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Introduction

Using IntelliCAD® is part of an integrated documentation set that includes this man-
ual and a comprehensive collection of help resources to give you the information you 
need to create drawings in IntelliCAD.

This manual is organized into chapters that parallel how you work in IntelliCAD, 
according to the tasks you might perform. The tasks are divided and organized into 
the following work-focused chapters:

Introduction: Chapter 1  An overview of the key features of IntelliCAD plus basic con-
cepts of computer-aided design (CAD) as they apply to IntelliCAD.

Getting started: Chapter 2  Installing IntelliCAD, starting and exiting IntelliCAD, 
working with toolbars, and selecting commands. 

Working with drawings: Chapter 3  Opening an existing drawing and starting a new 
drawing. Using drawing settings to establish paper size, scale factors, and text height. 
Using drawing aids such as entity snaps and orthogonal mode to draw accurately.

Creating entities: Chapters 4–5  Working with simple entities such as lines, circles, and 
arcs and with complex entities such as polygons and spline curves.

Viewing your drawing: Chapter 6  Moving around in the drawing, changing its magnifi-
cation, creating multiple views, and saving arrangements of windows of the drawing.

Working with coordinates: Chapter 7  Working with Cartesian coordinate systems, 
specifying two-dimensional and three-dimensional coordinates, and defining your 
own user coordinate systems.

Topics in this chapter
About IntelliCAD and other CAD software ............................................................ 2
Using AutoCAD commands with IntelliCAD..........................................................4
Comparing IntelliCAD and CAD to manual drafting ..............................................4
Using advanced CAD features ........................................................................... 13
Getting more information .................................................................................... 14
What’s new in IntelliCAD 4 ................................................................................. 14
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Working with the IntelliCAD Explorer: Chapter 8  Using the IntelliCAD Explorer to man-
age your drawings: controlling layers, linetypes, text styles, coordinate systems, 
views, and blocks and copying information between drawings.

Getting drawing information: Chapter 9  Working with the additional information in 
IntelliCAD drawings, calculating areas and distances, and displaying other drawing 
information.

Modifying entities: Chapter 10  Selecting, copying, rearranging, resizing, and editing 
entities.

Annotating and dimensioning your drawing: Chapters 11–12  Using text to annotate 
drawings; using dimensions to annotate the measurement of entities.

Working with blocks, attributes, and external references: Chapter 13  Using blocks and 
external references to combine entities and data for reuse; creating attribute informa-
tion to extract for use in other programs. 

Formatting and printing drawings: Chapter 14  Combining drawings into finished lay-
outs and printing copies.

Drawing in three dimensions: Chapter 15  Creating and editing three-dimensional enti-
ties. 

Working with other programs: Chapter 16  Sharing drawings and data with other users, 
documents, and programs.

Customizing IntelliCAD: Chapter 17  Customizing the appearance and operation of the 
program to suit your needs.

Understanding AutoCAD compatibility: Appendix  Describes similarities and differences 
between IntelliCAD and AutoCAD.

About IntelliCAD and other CAD software

IntelliCAD is designed for anyone who wants a fast and efficient CAD program with 
all the power and versatility of standard programs such as AutoCAD by Autodesk, 
Inc., or MicroStation by Bentley Systems, Inc., at an affordable price. Using today’s 
advanced technology, IntelliCAD integrates the Microsoft Windows interface with a 
powerful CAD engine. 

IntelliCAD provides unparalleled compatibility with AutoCAD, using most of the 
same file formats including those for drawings (.dwg files), commands, linetypes, 
hatch patterns, and text styles. You can also use AutoCAD menu files and run 
AutoLISP by Autodesk programs. If you have written your own ADS (AutoCAD 
Development System by Autodesk) programs, simply recompile them to link with the 
IntelliCAD libraries provided on your compact disc. Many third-party ADS programs 
already support IntelliCAD. If you have a program that is not already supported, ask 
your software vendor to provide an IntelliCAD-compatible version of the program.
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IntelliCAD is more compatible with the AutoCAD program than any other CAD 
product, delivers additional tools with advanced CAD features, and has a seamless 
Microsoft Windows integration. This powerful program provides a superb combina-
tion of features for CAD users like architects, engineers, and designers.

IntelliCAD incorporates all the standard features found in other CAD programs, 
along with features and capabilities you won’t find anywhere else. Its multiple-docu-
ment interface (MDI) lets you open and work with several drawings at the same time. 
You can easily copy drawing entities between drawings. In addition, the powerful 
IntelliCAD Explorer lets you manage information and settings and quickly copy lay-
ers, linetypes, and other information between drawings.

Using AutoCAD legacy drawings
IntelliCAD fully supports AutoCAD legacy drawings. IntelliCAD reads and writes 
DWG files in their native format without any loss of data, from AutoCAD Release 14 
back to version 2.5, including AutoCAD LT. Because IntelliCAD uses DWG as its 
native file format, no translation is required. 

IntelliCAD provides you with the appropriate tools for your experience level—
whether you are a beginner, intermediate, or advanced CAD user. If you are just start-
ing out with CAD, you may want to use the beginner level, which provides toolbars 
containing the basic tools such as lines, arcs, and circles. As you become more expe-
rienced, you can move to the intermediate level and then to the advanced level, which 
gives you access to more than 300 commands through toolbars, menus, and keyboard 
entries. When you install the program, the default setting is the intermediate level; 
you can change it to either beginner or advanced during installation, or you can 
change it from the Options dialog box on the Tools menu.

IntelliCAD supports three-dimensional wireframes and surfaces. Three-dimensional 
drawings can be displayed in wireframe, hidden-line view, and surface shading and 
rendering. When a drawing file contains an ACIS solid model, IntelliCAD does not 
display it, but the program does not harm any ACIS data in AutoCAD drawings. The 
program stores the ACIS data, so when you open the drawing later in AutoCAD, the 
solid model reappears.

When a drawing containing AutoCAD ACIS solids and proxy entities is loaded into 
IntelliCAD, the program displays the following message: “This drawing contains one 
or more entities that will not display. These entities WILL be stored and saved back 
into the drawing.” 

The following table identifies which AutoCAD objects are not displayed in 
IntelliCAD. 

AutoCAD objects not displayed in IntelliCAD
AutoCAD object Description
Proxy (zombie) Not displayed.

Images Do not display if inside blocks and externally referenced drawings 
(xrefs).
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It’s easy to customize IntelliCAD. You can modify menus and toolbars, create cus-
tom menus, dialog boxes, command aliases, and scripts, and add custom programs 
written in any of several programming languages, including LISP (the program’s 
Autodesk AutoLISP-compatible language), SDS™ (Solutions Development Sys-
tem™, the program’s Autodesk ADS-compatible language), and Microsoft Visual 
Basic for Applications (VBA).

You can run existing Autodesk AutoLISP applications in IntelliCAD with little or no 
modification. IntelliCAD uses the appload command so you can easily load LISP 
programs. IntelliCAD reads files that contain dialog control language (DCL) state-
ments as well, which makes IntelliCAD compatible with dialog boxes created for 
AutoCAD.

Using AutoCAD commands with IntelliCAD

Because IntelliCAD supports hundreds of AutoCAD Release 14 commands, you use 
the commands you already know. For example, to draw a circle, use the circle com-
mand. To copy a circle, use the copy command. 

When you press Enter or the spacebar, you activate the command—just like in 
AutoCAD. IntelliCAD accepts the special characters used by AutoCAD, such as 
point filters (for example, .xy), relative coordinates (the @ symbol), and the apostro-
phe (the ‘ prefix) for transparent commands. IntelliCAD function keys are also simi-
lar to those used in AutoCAD. 

Because you do not need to learn a new set of commands, you are immediately pro-
ductive with IntelliCAD. 

Comparing IntelliCAD and CAD to manual drafting

IntelliCAD greatly reduces the time and effort it takes to create and revise drawings. 
Not only can you produce accurate drawings faster, you can also reuse the informa-
tion in your drawings. These are the primary reasons for making the transition to 
CAD from traditional, manual drafting on paper.

As with any tool, however, to use it effectively, you need to be familiar with some of 
the special features, functions, and concepts of CAD. If you are familiar with manual 
drafting, you’ll find some conceptual similarities in CAD as well as some differences.
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Drawing to scale
In traditional, manual drafting, you usually determine the scale of the drawing before 
you even start to draw, because you are working with a sheet of paper of a fixed size. 
You may have to reduce or enlarge the entity you are drawing to fit within the con-
fines of the paper.

When you create a drawing in IntelliCAD, you draw everything full-size. You deter-
mine the type of units in which your drawing is measured. If you are drawing a build-
ing, 1 drawing unit might equal 1 inch. If you are drawing a map, 1 drawing unit 
might equal 1 mile. Your drawing environment and the CAD drawing file itself are 
not limited to the size of a particular sheet of paper. 

As you draw, you can use commands such as Pan and Zoom to work on different por-
tions of the drawing and to magnify the display of the drawing to view small details. 
These commands have no effect on the actual size of the entities in your drawing; 
they affect only the way the drawing is displayed on your screen. Only when you 
print or plot your drawing do you need to set the scale so that the printed drawing fits 
within a specific paper size.

Using tools
In manual drafting, you use tools such as pencils, rulers, T-squares, templates, eras-
ers, and so on. When you create a drawing in IntelliCAD, you use a mouse instead of 
a pencil, and you use the mouse to select other tools—commands you select from a 
menu or a toolbar.

You use some tools to create basic entities, such as lines, circles, and arcs, and other 
tools to modify existing entities (for example, to copy or move them or to change 
properties such as color and linetype).

1 drawing unit equals 1 inch. 1 drawing unit equals 1 foot.
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Organizing information
In traditional drafting, you often separate elements such as walls, dimensions, struc-
tural steel members, and electrical plans onto separate, translucent overlays. When 
you want to print the working drawings, you can create several different drawings by 
combining different overlays.

When you create a drawing in IntelliCAD, you use layers to organize elements in a 
similar manner. However, the layers feature in CAD offers numerous advantages 
over physical transparencies. The number of overlays you can combine to print a 
manually drafted drawing is limited by the printing process. There is no such limita-
tion in CAD. With IntelliCAD, you can define an unlimited number of layers, any of 
which can be visible or invisible at any time. You can name each layer and assign 
each its own color and linetype. You can also lock individual layers to ensure that 
information on those layers isn’t altered accidentally. 

Use layers to organize drawing information.
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Drawing accurately
When you create a manual drawing, ensuring accuracy typically requires a lot of 
measuring and rechecking. By contrast, IntelliCAD offers a number of drawing aids 
that ensure accuracy from the start. For example, you create and modify entities 
based on an underlying Cartesian coordinate system. Every location in the drawing 
has its own x,y,z-coordinates. You can also display a grid as a visual reference to 
your coordinate system.     

Settings such as snap and entity snap allow you to draw accurately without specifying 
coordinates. The snap setting forces the selected points to adhere to the grid incre-
ment or to any other increment you set. Entity snaps let you snap to precise geometric 
points on existing entities—for example, the endpoint of a line or the center of a cir-
cle. Another setting, orthogonal, constrains lines so that they are drawn parallel to the 
vertical and horizontal axes. 

Every location in the drawing has its own x,y,z-coordinates within the underlying Cartesian coordinate 
system. Point 5,2,0 is 5 units to the right (along the x-axis), 2 units up (along the y-axis), and 0 units (along 
the z-axis) from the origin (the 0,0,0 point).
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Drawing efficiently
In paper-based, manual drafting, you often have to redraw the same entity several 
times at different scales or from different vantage points. You may also need to 
redraw the border and title block on each new sheet.

One of the most powerful features of IntelliCAD is that when you create a drawing, 
you can reuse individual entities, borders, and title blocks as often as you want. You 
need draw an entity only once; the final printed drawing can show the entity at sev-
eral different scales and viewpoints.

IntelliCAD provides two drawing environments, or workspaces: model space and 
paper space. You usually begin working in model space, creating the drawing (a floor 
plan, a map, or a three-dimensional part) without regard to the final layout on paper. 
When you are ready to print your drawing, you have the option to switch to paper 
space, where you lay out the drawing as you want it to appear on a sheet of paper. For 
example, you can insert a drawing file that contains the standard border and title 
block that you created. You can define and arrange multiple views of the drawing at 
appropriate scales and with specific portions visible or invisible—again, without hav-
ing to redraw the border and title block for each view. 

Paper-based drawings lack the high degree of accuracy possible when using CAD. Lines often overlap or fail 
to meet adjacent lines.

Snap and entity snap force the cursor to adhere to a specified increment or attach to key geometric points on 
existing entities. You can also constrain lines to vertical and horizontal axes.
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You create the basic drawing in model space.

When you’re ready to print or plot your drawing, you can switch to paper space, where you arrange the 
drawing as you want it to appear on a sheet of paper.
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Reusing CAD drawings and entities
When you create a paper drawing manually, you can draw repetitive symbols by trac-
ing a plastic template. After you draw a symbol in IntelliCAD, you can reuse that 
symbol without having to redraw it. You simply save the symbol as a block. You can 
then insert copies of that block anywhere in your drawing. You can also save the 
symbol as a separate drawing for use in other drawings.  

In addition, you can reuse entire drawings and insert individual drawings into other 
drawings. You can also use an external reference, which acts as a pointer to another 
drawing rather than a copy of the entire drawing. Using an external reference has an 
added advantage: when you update the externally referenced drawing, each drawing 
that references it can be automatically updated.

You can draw a symbol one time, save it as a block, and then insert multiple copies of that symbol anywhere 
in your drawing.
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Making changes
To make changes to a paper drawing, you erase and then redraw. With IntelliCAD, 
you use commands to modify entities in the drawing. You can move, rotate, stretch, 
or change the scale of entities. When you want to remove an entity, you can delete it 
with a single click of the mouse. If you make a mistake while creating or modifying 
your drawing, you can easily reverse your actions.    

Working with other data and programs
Traditional paper drawings serve only as a means of communicating information 
between the person who created the drawing and the person viewing the drawing. The 
drawings contain no more information than what is visually imparted by the creator 
and seen by the viewer.

IntelliCAD offers rich possibilities for analyzing drawings and attaching additional 
data to them. For instance, although it may be impractical to count entities in a com-
plex paper drawing, this task is simple in CAD. IntelliCAD can calculate the number 
of entities in a drawing and compute area and distance.

You can easily change an entity using commands such as move, rotate, stretch, and scale instead of 
redrawing the entity.
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CAD drawings can also contain information in addition to visible entities. You can 
attach invisible database information to visible drawing entities and extract the infor-
mation for analysis in a database or spreadsheet. (Working with information in a data-
base requires a program from a third-party vendor, or you can create your own means 
of exporting the data in LISP, SDS, or VBA.) 

IntelliCAD provides in-place editing of Microsoft objects, such as those created in 
Microsoft Word and Microsoft Excel software programs. In-place editing makes it 
easy to share data with other users and programs. For example, you can include Intel-
liCAD drawings in files created using Microsoft Word, and you can insert files cre-
ated using Microsoft Word into your IntelliCAD drawings.

You can extract information stored in the drawing as 
visible or invisible attributes…

…and use that data for analysis in a database or 
spreadsheet.
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Using advanced CAD features

In addition to being compatible with AutoCAD, IntelliCAD goes several steps further 
by providing you with innovative features to increase your productivity.

Using the IntelliCAD Explorer
The IntelliCAD Explorer has an interface similar to the Windows Explorer, allowing 
you to view and manage the elements of multiple, open drawings, such as layers, 
blocks, linetypes, views, user coordinate systems, and text styles. 

Editing multiple documents simultaneously
With IntelliCAD, you can open and edit multiple drawings simultaneously. You can 
also copy and paste elements between open drawings. 

Editing multiple entities
IntelliCAD allows you to change most of the properties of all selected entities using a 
single, tabbed dialog box. 

Using the Customize dialog box
IntelliCAD has a single, tabbed dialog box for changing toolbars, menus, keyboard 
shortcuts, and command aliases. You can also use the drag-and-drop method to cus-
tomize toolbars, including flyouts. The simple, point-and-click action lets you easily 
create new menu items and keyboard shortcuts—no programming or manual text 
editing required.

Performing unlimited undo and redo
IntelliCAD increases your power with unlimited undo and redo of editing actions.
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Getting more information

In addition to this user’s guide, much of the assistance you need as you use Intelli-
CAD is specific to the commands you work with on the screen. To obtain immediate 
information as you work, use these additional sources of information:

ToolTips To find out what a specific tool on a toolbar does, pause the cursor over it for 
a moment. A ToolTip appears on the screen.

Status bar To find out more detailed information about a tool when you pause the cur-
sor over it, look on the status bar at the bottom of the screen.

Online help IntelliCAD online help is available on the screen when you press F1, 
choose a command from the Help menu, or click the question mark in a dialog box. 
The online help also presents information that does not appear in this manual, includ-
ing a programming reference that describes how to program in LISP and SDS.

What’s new in IntelliCAD 4

Multiple layouts
In paper space, you can use multiple layouts for different paper sizes and settings.

Unicode characters
IntelliCAD now supports the Unicode character encoding standard, which enables 
you to display and write text in different languages using different letters. 

New system variables
New system variables include: DIMFRAC, DIMLUNIT, DIMATFIT, 
DIMLDRBLK, DIMTMOVE, and MTEXTED. 

Enhanced block insertion
Using IntelliCAD Explorer, you can insert blocks from any open drawing into 
another open drawing. 
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Getting started

This chapter helps you get started using IntelliCAD® software by explaining how to 
install it and providing basic information about how to use it.

NOTE This user’s guide assumes that you have used other Microsoft Windows-based 
programs and are familiar with Windows terminology and techniques.

Topics in this chapter
System requirements.......................................................................................... 18
Installing IntelliCAD............................................................................................. 18
Starting IntelliCAD .............................................................................................. 19
Working in IntelliCAD.......................................................................................... 19
Selecting commands .......................................................................................... 24
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Customizing IntelliCAD....................................................................................... 27
Getting online Help ............................................................................................. 28
Saving your drawing ........................................................................................... 28
Exiting IntelliCAD................................................................................................ 28
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System requirements

You need the following software and hardware to install and run IntelliCAD: 

• Microsoft Windows 95, Windows 98, Windows ME, Windows 2000, Windows 
NT 4.0, or Windows XP

• Intel Pentium (or faster) processor
• 32 megabytes (MB) of RAM (minimum); 64 MB of RAM or more (recom-

mended)
• 60 MB of free hard disk space for a full installation, including sample files, elec-

tronic documentation, and online Help

• CD-ROM drive for installation, if installing from a CD

Installing IntelliCAD

A setup program guides you through the IntelliCAD installation process. The pro-
gram transfers files from the compact disc to a folder that it creates on your hard disk. 
The program also creates a menu item on the Windows 95, Windows 98, or Windows 
NT 4.0 Start menu.

During installation, a prompt is displayed for you to select your experience level. The 
default is intermediate. If this is the first time you have used a CAD program, you can 
change the experience level to beginner, which provides basic tools. If you are an 
experienced CAD user, you can change the level to advanced, which provides more 
than 300 commands. You can also change the experience level from within the pro-
gram after installation.

Installation starts automatically after you insert the IntelliCAD compact disc into 
your CD-ROM drive. If installation does not start, you can install IntelliCAD by 
using the following procedure.

Installing IntelliCAD
1 Insert the IntelliCAD compact disc into your CD-ROM drive.
2 Do one of the following:

• Wait for the autorun feature to start.

• Choose Start > Run and in the Open field, type d:\setup, where d is the letter 
assigned to your CD-ROM drive. Click OK.

3 Follow the instructions on your screen.
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Starting IntelliCAD

To start IntelliCAD, choose Start > Programs > IntelliCAD > IntelliCAD2001.

When you start IntelliCAD, the program opens a new, blank drawing based on a 
default template, icad.dwg. Using a template as the basis for a new drawing has sev-
eral advantages:  

• You can use predetermined units of measure, grid settings, text heights, and other 
settings appropriate for the type of drawing you’re creating.

• You can predefine special layers.

• You can include predefined title blocks and borders.

Each time you start IntelliCAD, a Tip of the Day appears on your screen. To display 
the Tip of the Day dialog box at any time, choose Help > Tip of the Day. To prevent 
the Tip of the Day dialog box from being displayed, click the check box for Show 
Tips On StartUp to clear it.

Working in IntelliCAD

You can work with the IntelliCAD window and its elements in a variety of ways. For 
example, you can display and rearrange the toolbars, display the command bar, and 
enable the status bar. The toolbars and command bar can also be floated anywhere on 
the screen or docked to the edges of the main IntelliCAD window.  
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A You can customize the menu bar at the top of the 
window.

B You can customize the toolbars, changing the 
appearance and arrangement of tools and 
adding your own commands and macros.

C You can type commands in the command bar. To 
reposition the command bar, drag it to another 
location on your screen.

D Your drawings are displayed in the drawing 
window.

E The user coordinate system (UCS) icon indicates 
the orientation of the drawing in three-
dimensional space. 

F The status bar displays information such as the 
name or purpose of a tool, the current cursor 
coordinates, layer name, and mode settings.

G You can move and dock the toolbars to any 
location on your screen. 

A

B

C

D E

F

G
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Displaying commands on a shortcut menu
Shortcut menus provide quick access to specific commands. A shortcut menu dis-
plays when you right-click an entity or a toolbar. The selections presented in the 
shortcut menu depend on whether you clicked a toolbar or an entity.      

When you right-click a toolbar or the status bar, the program displays a shortcut menu 
that lets you toggle the bars on and off. If you select one or more entities and then 
right-click, the program displays a shortcut menu from which you can choose a com-
mand to modify the selected entities. To display a shortcut menu from which you can 
choose an entity snap, press and hold down the Shift key, and then right-click any-
where within the drawing window.

Displaying and hiding toolbars
When you start IntelliCAD the first time, the Standard, Draw 2D, and Modify tool-
bars are displayed. IntelliCAD provides about a dozen toolbars, which you can cus-
tomize by adding and deleting tools. You can also move and resize toolbars, and you 
can create new toolbars. You can use a shortcut menu to display or hide toolbars. 

You can also choose whether toolbars are displayed large or small and in color. You 
can choose to display or hide ToolTips, which provide descriptions of tools that dis-
play when you pause the cursor over them. Go to View > Toolbars to make these 
selections.

Toolbars are either docked or floating. A floating toolbar has a title bar and a Close 
box, can be located anywhere on the screen, and can be resized. A docked toolbar 
does not display a title or Close box, cannot be resized, and is attached along one of 
the edges of the drawing window.

• To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it 
away from the perimeter.

• To position a toolbar in a docking area without docking it, press Ctrl while you 
drag it.

• To move a toolbar, drag it to a new location.

• To resize a toolbar, move your cursor to the edge until it changes to a resize arrow, 
and then drag.
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To choose which toolbars to display
1 Right-click anywhere on a docked toolbar or the status bar to display the toolbar 

shortcut menu.
2 Select the toolbars you want displayed.
3 If the toolbar does not appear in the shortcut menu, choose Toolbars.
4 In the Select Toolbars dialog box, choose the toolbars you want displayed, and 

then click OK.

Using the command bar
The command bar is a dockable window in which you type IntelliCAD commands 
and view prompts and other program messages. To display the command bar, choose 
View > Command Bar, or press F3. When initially displayed, the command bar is 
docked between the toolbars and the drawing. It displays the three most recent lines 
of prompts. You can move the command bar by dragging it.

When the command bar is floating, you can drag the top or bottom of the window to 
change the number of lines of text it displays. You can dock the command bar at the 
top or bottom of the drawing. 

Select the check boxes for the toolbars you want to display.
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Using the status bar
If you elect not to use the command bar, the status bar displays information about the 
selected command or tool. It also displays the current cursor coordinates, the name of 
the current layer, mode settings, and other information about current settings.          

Using prompt boxes
IntelliCAD commands often provide several options. These options appear in the sta-
tus bar or command bar and also in a prompt box (called a context menu in Autodesk 
AutoCAD) initially displayed in the upper right corner of the screen. You can move 
the prompt box by dragging it; future prompt boxes will appear where you last placed 
it. The options appear as menu selections. Choose the appropriate option by selecting 
it in the prompt box. To close a prompt box, click the Close box.   

A Information about the current command.
B Cursor coordinates (x,y,z).
C Layer name. Double-click to change layers.
D Drawing color. By default, the color is BYLAYER. 

Double-click to change colors.
E Linetype. By default, the linetype is BYLAYER. 

Double-click to change linetypes.
F Snap setting. Double-click to toggle on or off.

G Grid setting. Double-click to toggle on or off.
H Orthogonal setting. Double-click to select entity 

snaps.
I Entity snap setting. Double-click to select entity 

snaps.   
J Space mode setting. Double-click to select tile 

mode, model space, or paper space.
K Digitizer mode. Double-click to toggle on or off.

A B C D E F G H I J K

Command options appear in a prompt box.
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The prompt box is displayed by default. To turn off the display of prompt boxes, 
choose Tools > Options, click the Display tab, and then click the Display Prompt 
Boxes check box to clear it.   

 Selecting commands

Select commands using any of these methods:

• Choose a command from a menu.
• Click a tool in a toolbar.
• Type the command in the command bar.
Some commands remain active until you end them, so you can repeat an action with-
out having to select a command repeatedly. You can end a command by clicking 
Done in the prompt box or by pressing Esc.

The IntelliCAD user interface.        
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Using commands
You can use most commands while another command is active. For example, while 
drawing a line, you may want to use the Pan command to move the drawing across 
the screen to select the endpoint of the line. You can also change the settings of draw-
ing aids such as snap or grid while other commands are active.

Starting commands using toolbars
To start a command from a toolbar, click a tool and respond to the prompts. 

NOTE  The available toolbars depend on the experience level that is set. When you 
install IntelliCAD, you choose the experience level you want. The intermediate expe-
rience level is the default. Toolbar selections shown in this guide are based on the 
intermediate experience level unless otherwise noted. To change the current experi-
ence level, choose Tools > Options, and then click the General tab.

Some tools, such as Line or Arc, contain flyouts, which are options either for using 
the basic tool with different methods or that contain other, related tools. Flyouts are 
indicated by a small triangle in the lower right corner of a tool. To display a flyout, 
click the tool and hold down the mouse button. To select a tool from a flyout, point to 
the tool you want and then release the mouse button. The tool you select on the flyout 
becomes the default tool on the toolbar.

Starting commands using menus
To start a command from a menu, choose it from the list of menu options available.

The available menu options depend on the experience level that is set. When you 
install IntelliCAD, you choose the experience level you want. The intermediate expe-
rience level is the default. Menu selections shown in this guide are based on the inter-
mediate experience level unless otherwise noted. To change the current experience 
level, choose Tools > Options, and then click the General tab.

Starting commands using the command bar
Type a command, and then press Enter. If the command bar is displayed, the com-
mand you typed appears there. If the command bar is not displayed, the command 
you typed appears in the status bar.
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Repeating a command
You can repeat the command you just used without having to reselect it by pressing 
either the spacebar or Enter or by clicking the right mouse button.

TIP  If you are using the command bar to type commands, you can type multiple 
before starting some commands (Circle, Arc, and Rectangle, for example) to repeat a 
command indefinitely. When you are done with a command, press Esc.

Nesting a command
If you are working in the command bar, you can use another command from within a 
command, called nesting. To use a command inside an active command, type an 
apostrophe before you type the command, such as ‘circle, ‘line, or ‘pyramid. You can 
nest commands indefinitely in IntelliCAD. Many menu and toolbar macros work this 
way by default; for example, select color, reference grid, zoom, and snap. When you 
have finished with the nested command, the original command resumes. 

Using the Prompt History window
The Prompt History window displays a history of the commands and prompts issued 
since you started the current session of IntelliCAD. By default, the program tracks up 
to 256 command lines. There is no limit to the number of command lines you can 
track, but program performance may be degraded if you choose to track an exces-
sively high number of lines.

To change the number of command lines to track
1 Do one of the following:

• Choose Tools > Options > Display.

• Type options and then press Enter. Click the Display tab.

2 In the Command Lines To Track field, type the number of command lines you 
want to display, and then click OK.

TIP  To display the Prompt History window, press F2. To close the window, press F2 
again.

Using scripts
The IntelliCAD Script Recorder captures and saves many of your actions so you can 
play them back. After you enable the Script Recorder, all commands and options that 
you type in the command bar are recorded until you type a command to stop 
recording. When you run the script, the program carries out the recorded commands 
in succession.
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Correcting mistakes

IntelliCAD tracks the commands you use and the changes you make. If you change 
your mind or make a mistake, you can undo, or reverse, the last action or several pre-
vious actions. You can also redo any actions that you reversed.  

You can undo multiple actions by typing undo and specifying the number of actions 
to undo. 

Customizing IntelliCAD

You can tailor many aspects of IntelliCAD to better suit your needs. For example, 
you can easily create and modify toolbars by simply dragging and dropping icons. If 
you want to restore any area of the user interface back to its default state, click Reset. 
IntelliCAD stores your customized settings in the Windows registry rather than in a 
separate file.

IntelliCAD supports the most important AutoCAD customization files, including 
linetypes, hatch patterns, text fonts, the unit conversion file, menus, toolbars, and 
aliases. In addition, IntelliCAD unifies four AutoCAD customization functions with a 
single customize command: command aliases, keyboard shortcuts, menus, and 
toolbars.

You can also add custom programs written in any of several programming languages, 
including LISP (the program’s Autodesk AutoLISP-compatible language), SDS (the 
program’s Autodesk ADS-compatible language), and Microsoft Visual Basic for 
Applications (VBA).

A Click the Undo tool to reverse the last action.
B Click the Redo tool to reverse the previous 

undos.

A B
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Getting online Help

IntelliCAD includes online Help. It contains some information that does not appear in 
this book, including a programming language reference.

You can display online Help in any of these ways:

• On the Standard toolbar, click Help ( ).
• Press F1.
• Choose a command from the Help menu.
• Click the question mark in a dialog box.

• Type help in the command bar.

Saving your drawing

You can save your drawing at any time.

To save a drawing, use one of the following methods:

• On the Standard toolbar, click Save ( ).
• Choose File > Save.

• Type save and then press Enter.

TIP When you save a drawing the first time, the program displays the Save Drawing 
As dialog box so that you can choose a directory and type a name for the drawing. To 
save the drawing later using another name, choose File > Save As and type the new 
name.

Exiting IntelliCAD

When you have finished working in IntelliCAD, choose File > Exit. 
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Working with drawings

CAD drawings help you organize information for greater efficiency. With Intelli-
CAD®, you can draw entities representing different types of information on various 
layers and use those layers to control color, linetype, and visibility. IntelliCAD also 
includes drawing aids that help you draw accurately.

This chapter explains setting up drawings and using built-in drawing aids, including 
how to:

• Create new drawings, open existing drawings, and save changes to drawings.

• Use aids such as the grid, snap, and orthogonal settings to draw accurately.

Topics in this chapter
Creating a new drawing...................................................................................... 30
Opening an existing drawing .............................................................................. 30
Setting up a drawing........................................................................................... 32
Setting and changing the grid and snap alignment............................................. 43
Using the Draw Orthogonal option...................................................................... 48
Using entity snaps .............................................................................................. 49
Saving your drawing ........................................................................................... 58
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Creating a new drawing    

When you start IntelliCAD, the program automatically creates a new drawing based 
on a template drawing, icad.dwg. This template includes predefined settings such as 
drawing units, text size, and drawing area. You can either use these settings or change 
them according to your needs. There is nothing unique about a template drawing. 
You can use any drawing as a template for future drawings.              

You can save many steps by basing a new drawing on an existing template. By doing 
this, a new drawing will contain all the settings and entities you need. When you open 
a new drawing from your custom template, you can modify existing settings and 
delete any entities that you don’t need.

To create a new drawing based on a template    
1 Do one of the following:

• Choose File > New.

• Type newwiz and then press Enter.

2 Click Use A Template Drawing, and then click Next.
3 To display the Open Template dialog box, click Browse.
4 Select the drawing you want to use as the template, and then click Open.
5 Click Finish.

Opening an existing drawing    

You can open and use one of the sample drawings included in the program.       

To open an existing drawing
1 Use one of the following methods:

• Choose File > Open.

• On the Standard toolbar, click the Open tool ( ).

• Type open and then press Enter.

2 Choose the directory containing the drawing.
3 Choose the drawing you want to open.
4 Click Open.

TIP To quickly open a drawing file from the Open Drawing dialog box, double-click 
the drawing name.
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TIP To quickly open a drawing file that you recently used, choose File > <file name>. 
The program tracks the last four drawings.          

A Read a description of the file size, creation date, 
and other information about the drawing.

B Open the drawing as read-only to prevent 
making changes to the file.    

C Preview an image of the drawing before you 
open it.     

A

B

C
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Setting up a drawing    

You can specify individual settings when you create a new drawing or when you 
modify settings in a drawing created from a template.

Setting the current layer
Layers are like the overlays that you use in manual drafting. You use layers to orga-
nize different types of drawing information. Every drawing has at least one layer, the 
default layer, named “0.” Your drawing can also contain an unlimited number of 
additional layers. When you create an entity, it is created on the current layer.     

To set the current layer
1 Do one of the following:         

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

• Type la and then press Enter.

• On the status bar, right-click on the current layer, and from the list, select the 
layer you want to make current.

2 Double-click the layer name that you want to make current.
3 Close the IntelliCAD Explorer window.       

Double-click the layer name that you want to make current.
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Setting the current entity color     
An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color. There are 255 standard colors 
and two additional color properties that are often referred to as colors.             

You can use seven of the 255 standard colors by name: red, yellow, green, cyan, blue, 
magenta, and white. (Numbers eight and nine are not named.) Each color has a 
unique number from 1 to 255. The two additional color properties are BYLAYER 
and BYBLOCK. These color properties cause an entity to adopt the color either of the 
layer or of the block into which it is inserted. BYLAYER is color number 256, and 
BYBLOCK is color number 0. In all commands for which you would use a color, you 
can indicate BYLAYER and BYBLOCK as well as by numbers 256 and 0, respec-
tively.    

You can choose colors by selecting them from the Color dialog box. In the command 
bar or in some dialog boxes, you specify a color either by name or by number.    

When you open a new drawing, entities are created in the color BYLAYER, which 
adopts the color of the current layer. Initially, layer 0 is both the only layer and the 
current layer. Its default color is white, so your entities appear as white.      

To set the current entity color
1 Do one of the following:      

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.
3 Click Select Color.
4 In the Color dialog box, click BYBLOCK, BYLAYER, or the color of your 

choice, or type the color number in the edit field.
5 Click OK.
6 Click OK again.

TIP On the status bar, right-click on the word BYLAYER next to the current layer, 
click Properties, and then select a color for the current entity. 
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Setting the current linetype
Linetypes help convey information. You use different linetypes to differentiate the 
purpose of one line from another. A linetype consists of a repeating pattern of dots, 
dashes, or blank spaces. Linetypes determine the appearance of entities both on the 
screen and when printed. By default, every drawing has at least three linetypes: CON-
TINUOUS, BYLAYER, and BYBLOCK. Your drawing may also contain an unlim-
ited number of additional linetypes.           

When you create an entity, it is created using the current linetype. By default, the cur-
rent linetype is BYLAYER. IntelliCAD indicates that the entity linetype is deter-
mined by the current layer linetype by assigning the BYLAYER property as the 
default linetype setting. When you assign BYLAYER, changing the layer linetype 
changes the linetype of all the entities created on that layer if they were created using 
the linetype BYLAYER.     

You can also select a specific linetype as the current linetype, which overrides the 
layer’s linetype setting. Entities are then created using that linetype, and changing the 
layer linetype has no effect on them.

As a third option, you can use the linetype BYBLOCK property, in which case new 
entities are drawn using the CONTINUOUS linetype until you group them into a 
block. The entities then inherit the current linetype setting when you insert the block 
into a drawing.

A Click to set the color to one of 
the standard colors.

B Click to set the current color 
BYBLOCK.

C Click to set the current color 
BYLAYER.

D Indicates the current color.
E Displays the color number.
F Click to set the color to one of 

the gray shades.

A
B
C

E

F

D
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To set the current linetype
1 Do one of the following:          

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.
3 In the Entity Linetype list, choose the linetype that you want to make current.
4 Click OK.

TIP  On the status bar, right-click on the word BYLAYER next to the word SNAP, click 
Properties, and then choose the linetype that you want to make current.

Setting the linetype scale    
You can specify the linetype scale. The smaller the scale, the more repetitions of the 
linetype pattern are generated per drawing unit. For example, a linetype pattern is 
defined as a sequence of dashed lines and open spaces, each 0.25 units long. The line-
type scale uses the drawing scale factor to determine the length. A scale factor of 0.5 
would reduce the length of each line and space to 0.125 units; a scale factor of 2 
would increase the length of each to 0.5 units.         

NOTE  Setting the linetype scale too large or too small may result in a line pattern 
looking like a solid line, depending on what the scale view is or at what scale the 
drawing is plotted.

You can control a new entity’s individual linetype scale factor as well as the overall 
or global scale factor applied to all the entities in the drawing.

To set the current individual linetype scale
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.
3 In the Linetype Scale field, type or choose the linetype scale that you want to 

make current.
4 Click OK.
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To change the global linetype scale
1 Do one of the following:     

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.
3 In the Global Linetype Scale field, type or choose the global linetype scale that 

you want to change.
4 Click OK.

Setting drawing units    
With IntelliCAD, you typically draw at full-size (1:1 scale), and then set a scale fac-
tor when you print or plot your drawing. Before you begin drawing, however, you 
need to determine the relationship between drawing units and real-world units.            

For example, you can decide whether one linear drawing unit represents an inch, a 
foot, a meter, or a mile. In addition, you can specify the way the program measures 
angles. For both linear and angular units, you can also set the degree of display preci-
sion, such as the number of decimal places or smallest denominator used when dis-
playing fractions. The precision settings affect only the display of distances, angles, 
and coordinates. IntelliCAD always stores distances, angles, and coordinates using 
floating-point accuracy.     

To set the linear drawing units    
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Drawing Units tab.
3 Under Change Settings For, choose Linear Units.
4 Under Unit Types, select a unit type.
5 Under Display Precision, type the display precision according to the number of 

decimal places you want, or click the arrows to select it.
The field above this setting shows an example of the linear unit type at the current 
precision.

6 Click OK.
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To set the angular drawing units                   
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

To set the angular drawing units
1 Click the Drawing Units tab.
2 Under Change Settings For, choose Angular Units.
3 Under Unit Types, select a unit type.
4 Under Display Precision, type the display precision according to the number of 

decimal places you want, or click the arrows to select it.    
The field above this setting shows an example of the angular unit type at the cur-
rent precision.

5 Under Angle Direction, select the direction in which angles increase when you 
specify a positive angle value.    

6 Under Angle Base, specify the compass location for the zero angle.    
For example, by default, angle 0 is at the “three o’clock” or “east” position.
The adjacent icon shows the current location of the angle base.

7 Click OK. 

A Select the type of linear units.
B Choose the display precision 

for linear units.

A

B
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Understanding scale factors    
Instead of drawing to a particular scale, you draw everything in the program full-size. 
Although it’s a good idea to keep your scale factor in mind when setting up a draw-
ing, you don’t need to set the scale until you print it. For example, when you draw a 
mechanical part 40 inches in length with IntelliCAD, you actually draw it as 40 
inches, rather than applying a scale factor as you draw. When you print your drawing, 
you can assign the scale at which the drawing is to print.          

Scale, however, does affect the way a few elements such as text, arrows, or linetypes 
print or plot in your drawing. For these, you can make adjustments when you first set 
up your drawing so that they print or plot at the correct size. For example, when you 
draw text, you need to determine the text size so that when you plot it later at a partic-
ular scale, the text height is correct.     

After you determine the eventual scale of your finished drawing, you can calculate 
the scale factor for the drawing as a ratio of one drawing unit to the actual scale unit 
represented by each drawing unit. For example, if you plan to print your drawing at  
1/8” = 1’-0”, your scale factor ratio is 1:96 (1/8” = 12” is the same as 1 = 96). If you 
want your printed scale to be 1 inch = 100 feet, your scale factor ratio is 1:1200.        

A Determines the type of units you 
are controlling.

B Select the type of angular units.
C Choose the display precision for 

angular units.
D Select the direction in which 

angles increase.
E Select the angle base, the 

direction of the zero angle.

C

D

B

A

E
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The following table shows some standard architectural and engineering scale ratios 
and equivalent text heights required to create text that measures 1/8-inch high when 
you plot the drawing at the specified scale.           

You can use these scale factors to predetermine the size of your drawing to make sure 
that it fits on a specific size paper when you print it. You control the size of your 
drawing by the drawing limits. To calculate the drawing limits to match the size of 
your paper, multiply the dimensions of your paper size by your scale factor.        

For example, if the paper you use to print measures 36 inches x 24 inches and you 
plot your drawing at 1/8” = 1’-0” (in other words, using a scale factor of 96), the size 
of your drawing measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 
96 (or 2,304 units) high.

Keep in mind that you can print the finished drawing at any scale, regardless of the 
scale factor you calculate. You can also print on paper of a different size and use the 
IntelliCAD paper space feature to create different views of your drawing and to posi-
tion and scale those views differently. The scaling factor is not related to the size of 
the entities you draw; it simply provides a preliminary guide to help you establish the 
text height and drawing limits when you begin your drawing. You can change the text 
height and drawing limits at any time.

Standard scale ratios and equivalent text heights 
Scale Scale factor Text height
1/16” = 1’-0” 192 24”

1/8” = 1’-0” 96 12”

3/16” = 1’-0” 64 8”

1/4” = 1’-0” 48 6”

3/8” = 1’-0” 32 4”

1/2” = 1’-0” 24 3”

3/4” = 1’-0” 16 2”

1” = 1’-0” 12 1.5”

1 1/2” = 1’-0” 8 1”

3” = 1’-0” 4 0.5”

1” = 10’ 120 15”

1” = 20’ 240 30”

1” = 30’ 360 45”

1” = 40’ 480 60”

1” = 50’ 600 75”

1” = 60’ 720 90”

1” = 100’ 1200 150”
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Setting the text height            
The text height setting controls the height of text, measured in drawing units. Set this 
value initially so that text used for your most common annotations, when scaled to the 
size at which you will print a drawing, measures 1/8-inch high on the printed draw-
ing.              

For example, if you plan to print your drawing at 1/8” = 1’-0” and you want your text 
to be 1/8-inch high in the final drawing, create that text 1 foot high (in your real-
world drawing units) so that when you print it, it appears 1/8-inch high on the paper. 
You must create text 4 feet high that you want to print 1/2-inch high.

To set the text height
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.
3 Under Change Settings For, choose Text.
4 In the Default Text Height field, select the text height or type the text height value 

that you want.
5 Click OK.      

A Choose Text. B Specify the text height in drawing units.

A
B
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NOTE  The default text height applies only if the current text style height is 0.0. Other-
wise, the text height for the current style takes precedence.

Setting the drawing limits    
You can specify the drawing limits that form an invisible boundary around your 
drawing. You can use the drawing limits to make sure that you do not create a draw-
ing larger than can fit on a specific sheet of paper when printed at a specific scale.       

For example, if you plan to print your drawing at 1/8” = 1’-0” (in other words, using a 
scale factor of 96) on a sheet of paper measuring 36 inches x 24 inches, you can set 
drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 96), 
which allows a 1-inch margin around the edges of the printed image.

To set the drawing limits    
1 Do one of the following:         

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click either the Coordinate Input tab or the Display tab.
3 Under Change Settings For, choose Limits.
4 Specify the x-coordinate and y-coordinate of the upper right drawing limit and the 

lower left drawing limit.
You can also click Select to specify the drawing limits by selecting points in the 
drawing.

5 To constrain your drawing to these drawing limits, click the Disallow Input 
Beyond Limits check box.

6 Click OK.     
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A

B
C

D

E

A Choose limits.
B Specify the x-coordinate and 

y-coordinate of the upper 
right drawing limit.

C Specify the x-coordinate and 
y-coordinate of the lower left 
drawing limit.

D When you click this check 
box, the program prevents 
you from drawing outside the 
drawing limits.

E Specify the drawing limits by 
selecting points in the 
drawing.
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Setting and changing the grid and snap alignment

Grid and snap settings are effective tools to use in your drawing to ensure accuracy. 
Although many users find it convenient to match grid points to snap settings, they are 
independent of each other and should not be confused. Grid points are for visual 
reference only; they do not affect your drawing and they do not print. Snap points are, 
by themselves, not visible; however, when set, they constrain the creation of new 
entities.      

Setting a reference grid
A reference grid displays as a pattern of regularly spaced dots. You can turn the dis-
play on and off, and you can specify how far apart the dots are spaced.       

The reference grid extends only to the limits of the drawing, helping you to visualize 
the boundary of your drawing and to align entities and visualize distances between 
entities. You can turn the grid on and off as needed. You can also change the spacing 
of the grid at any time. 

To turn the grid on and set the grid spacing
1 Do one of the following:         

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.
3 Under Change Settings For, choose Snap And Grid.
4 Under Reference Grid, click the Show Grid check box.
5 Under Reference Grid Spacing, in the X field, choose the horizontal grid spacing.
6 Under Reference Grid Spacing, in the Y field, choose the vertical grid spacing.    
7 Click OK.

TIP To toggle the grid display on and off at any time, double-click the GRID setting 
on the status bar, click the Reference Grid tool ( ) on the Settings toolbar, or press 
F7.       
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Setting snap spacing 
Another way to ensure drawing accuracy is to turn on and set snap spacing. When 
snap is turned on, the program restricts the selection points to predetermined snap 
intervals. Although it is often helpful to match the grid spacing to the snap spacing or 
another related setting, the settings do not have to match.           

A Click the check box to enable orthogonal mode.    
B Click the check box to display the reference grid.
C Specify the x and y grid spacing.
D Click the check box to enable snap mode.
E Specify the x and y snap spacing.
F Click the check box to use an isometric snap and 

grid.     

G Click the current isometric plane.
H Specify the grid rotation angle.    
I Indicates the current grid rotation angle.
J Specify the x- and y-coordinates of the snap 

origin.
K Click to match the grid spacing to the snap 

spacing.

E

F

G

C

B

A

H

I

J

KD
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To turn snap settings on and set snap spacing
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.
3 Under Change Settings For, choose Snap And Grid.
4 Under Snap Settings, click the Snap check box to turn Snap on.
5 Under Snap Settings Spacing, in the X field, choose the horizontal snap spacing.
6 Under Snap Settings Spacing, in the Y field, choose the vertical snap spacing.
7 Click OK.

TIP To toggle snap settings on and off at any time, double-click the SNAP setting on 
the status bar, click the Snap tool ( ) on the Settings toolbar, or press F9.       

In addition to setting the snap spacing, you can change the snap and grid orientation. 
You can also rotate the alignment of the grid or set it to create isometric drawings.

Using entity snaps
One difference between IntelliCAD and AutoCAD (if you’re familiar with that pro-
gram) is that with IntelliCAD, you can type an entity snap directly, instead of having 
to precede it with the osnap command. For example, to turn on center snap, you type 
center instead of osnap center. IntelliCAD uses all the same snap settings as 
AutoCAD, plus one more: a plan view intersection snap. The planviewint command 
snaps to the point where entities would intersect if they were at the current elevation.



46   C H A P T E R  3
Changing the snap and grid angle and base point
The snap and grid are both normally based on the drawing origin, the 0,0 coordinate 
in the World Coordinate System (WCS). You can relocate the snap and grid origin, 
however, to help you draw entities in relation to a different location. You can also 
rotate the grid to a different angle to realign the crosshairs to the new grid angle. If the 
grid is on, and the grid spacing is 0,0, then the grid defaults to the snap spacing.                 

To change the snap angle and base point
1 Do one of the following:        

• Click Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.
3 Under Change Settings For, select Snap And Grid.
4 Under Snap Settings, click the Snap check box to turn Snap on.
5 Under Reference Grid, click the Show Grid check box to turn Show Grid on. 
6 Under Snap And Grid Settings, in the X Origin field, type the x-coordinate of the 

new snap origin.
7 Under Snap And Grid Settings, in the Y Origin field, type the y-coordinate of the 

new snap origin.
8 Under Snap And Grid Settings, in the Rotation field, type the grid rotation angle. 
9 Click OK.
  

Default grid and snap alignment. Rotated grid and snap alignment.
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Using isometric snap and grid
You can use the Isometric Snap And Grid option to create two-dimensional isometric 
drawings. With the isometric option, you are simply drawing a simulated three-
dimensional view on a two-dimensional plane, much the same as you might draw on 
a piece of paper. Do not confuse isometric drawings with three-dimensional draw-
ings. You create three-dimensional drawings in three-dimensional space.                       

The isometric option always uses three preset planes, which are denoted as left, right, 
and top. You cannot alter the arrangement of these planes. If the snap angle is 0, the 
three isometric axes are 30 degrees, 90 degrees, and 150 degrees.

When you check the Isometric Snap And Grid option and select an isometric plane, 
the snap intervals, grid, and crosshairs align with the current plane. The grid is always 
shown as isometric and uses y-coordinates to calculate the grid spacing. If you click 
the Draw Orthogonal check box, the program restricts the drawing of entities to the 
current isometric plane.

TIP  To toggle between isometric planes, press F5.

To turn the Isometric Snap And Grid option on
1 Do one of the following:        

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.
3 Under Change Settings For, select Snap And Grid.
4 Click the Isometric Snap And Grid check box.
5 Under Isometric Crosshairs, click the option for the isometric plane you want 

(Top, Left, or Right).
6 Click OK.
  

Isometric planes left (A), right (B), top (C).     

A B

C
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Using the Draw Orthogonal option    

You can restrict cursor movement to the current horizontal and vertical axes so that 
you can draw at right angles, or orthogonally. For example, with the default 0-degree 
orientation (angle 0 at the “three o’clock” or “east” position), when the Draw Orthog-
onal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 
270 degrees. As you draw lines, the rubber-banding line follows either the horizontal 
or vertical axis, depending on which axis is farthest from the cursor. When you 
enable the isometric snap and grid, cursor movement is restricted to orthogonal 
equivalents within the current isometric plane.            

NOTE  IntelliCAD ignores orthogonal drawing when you type coordinates in the com-
mand bar or when you use entity snaps.

To enable orthogonal drawing
1 Do one of the following:       

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.
3 Click the Draw Orthogonal check box.
4 Click OK.

TIP To toggle orthogonal drawing on and off at any time, double-click the ORTHO 
setting on the status bar, click the Draw Orthogonal tool ( ) on the Settings tool-
bar, or press F8.    
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Using entity snaps   

Entity snaps enable you to quickly select exact geometric points on existing entities 
without having to know the exact coordinates of those points. With entity snaps, you 
can select the endpoint of a line or arc, the center point of a circle, the intersection of 
any two entities, or any other geometrically significant position. You can also use 
entity snaps to draw entities that are tangent or perpendicular to an existing entity.              

You can use entity snaps any time the program prompts you to specify a point—for 
example, if you are drawing a line or other entity. You can work with entity snaps in 
one of two ways:

• Enable a running entity snap that remains in effect until you turn it off by choosing 
an entity snap when no other command is active.    

• Enable a one-time entity snap for a single selection by choosing an entity snap 
when another command is active. You can also use a one-time entity snap to over-
ride a running entity snap.    

When using entity snaps, the program recognizes only visible entities or visible por-
tions of entities. You cannot snap to entities on layers that have been turned off or to 
the blank portions of dashed lines.

When you specify one or more entity snaps, an entity snap target box is added to the 
crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active 
entity snap. When you select an entity, the program snaps to the snap point closest to 
the center of the target box.            

TIP  If you type the name of the entity snap, you need to type only the first three letters.    

To change the size of the entity snap target box      
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.
3 Under Change Settings For, choose Entity Selection.
4 Under Entity Snap Aperture, change the value in the Aperture field.
5 Click OK. 
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Setting entity snaps                                
You can set entity snaps using any of the following methods:        

• Choose Settings > Entity Snap, and choose the entity snap you want to set.
• On the Entity Snaps toolbar, click one of the entity snap tools.
• In the command bar, type an entity snap command.
• In the status bar, double-click ESNAP.     

• Press and hold down the Shift key while right-clicking anywhere within the draw-
ing window to display the entity snap shortcut menu, and then choose the entity 
snap you want to set.    

You can also set entity snaps using the Drawing Settings dialog box. To do this, 
choose Settings > Entity Snap > Entity Snap Settings. The Drawing Settings dialog 
box is displayed with the Coordinate Input tab active. In the Entity Snap Modes list, 
click the check box for each of the entity snaps that you want to set.

TIP When you select an entity snap, a check mark appears next to the entity snap in 
the menu, the associated tool in the Entity Snaps toolbar is active, and the corre-
sponding box is checked in the Coordinate tab of the Drawing Settings dialog box. 

A Choose Entity Selection. B Type or select the entity snap aperture size.

A

B
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Nearest Snap tool
Use the Nearest Snap tool to snap to the nearest point of another entity. You can snap 
to the nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline seg-
ment, ray, spline, or infinite line that is visually closest to the cursor.

To set the Nearest Snap    
Do one of the following:
• Choose Settings > Entity Snap > Nearest Snap.
• On the Entity Snaps toolbar, click the Set Nearest Snap tool ( ).

• Type nearest and then press Enter.

Endpoint Snap tool
Use the Endpoint Snap tool to snap to the endpoint of another entity. You can snap to 
the closest endpoint of an arc, line, polyline segment, ray, plane, or three-dimensional 
face. If an entity has thickness, the Endpoint Snap also snaps to the endpoints of the 
edges of the entity.       
To set the Endpoint Snap
Do one of the following:
• Choose Settings > Entity Snap > Endpoint Snap.
• On the Entity Snaps toolbar, click the Set Endpoint Snap tool ( ).

• Type endpoint and then press Enter.
 

 

A Sets the Nearest Snap.
B Sets the Endpoint Snap.
C Sets the Midpoint Snap.
D Sets the Center Snap.
E Sets the Perpendicular Snap.
F Sets the Tangent Snap.

G Sets the Quadrant Snap.
H Sets the Insertion Point Snap.
I Sets the Point Snap.
J Sets the Intersection Snap.
K Sets the Plan View Intersection Snap.
L Sets the Clear Entity Snaps.

A C E G I K

B D F H J L

To snap to the endpoint, select anywhere on the entity near its endpoint (A).

A



52   C H A P T E R  3
Midpoint Snap tool
Use the Midpoint Snap tool to snap to the midpoint of another entity. You can snap to 
the midpoint of an arc, line, polyline segment, plane, or infinite line. In the case of 
infinite lines, the midpoint snaps to the first defined point. If an entity has thickness, 
the midpoint entity snap also snaps to the midpoint of the edges of the entity.        

To set the Midpoint Snap
Do one of the following:
• Choose Settings > Entity Snap > Midpoint Snap.
• On the Entity Snaps toolbar, click the Set Midpoint Snap tool ( ).

• Type midpoint and then press Enter. 
  

Center Snap tool
Use the Center Snap tool to snap to the center point of another entity. You can snap to 
the center of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, 
you must select a visible portion of the entity.    

To set the Center Snap
Do one of the following:    
• Choose Settings > Entity Snap > Center Snap.
• On the Entity Snaps toolbar, click the Set Center Snap tool ( ).

• Type center and then press Enter.
  

To snap to the midpoint, select anywhere on the entity near its midpoint (A).

To snap to the center, select anywhere on the visible portion of the entity (A).

A

A
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Perpendicular Snap tool
Use the Perpendicular Snap tool to snap to the perpendicular point of another entity. 
You can snap to an arc, circle, line, polyline, infinite line, ray, or edge of a plane to 
form a perpendicular alignment with that entity or with an imaginary extension of 
that entity.    

To set the Perpendicular Snap    
Do one of the following:
• Choose Settings > Entity Snap > Perpendicular Snap.
• On the Entity Snaps toolbar, click the Set Perpendicular Snap tool ( ).

• Type perpendicular and then press Enter. 
  

Tangent Snap tool
Use the Tangent Snap tool to snap to the tangent point of another entity. You can snap 
to the point on an arc or circle that, when connected to the previous point, forms a line 
tangent to that entity.

To set the Tangent Snap       
Do one of the following:
• Choose Settings > Entity Snap > Tangent Snap.
• On the Entity Snaps toolbar, click the Set Tangent Snap tool ( ).

• Type tangent and then press Enter.
  

To form a perpendicular angle (A) to an entity (B), select anywhere on the entity.

To snap to a tangent, select the entity near the tangent point (A).

A

B

A
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Quadrant Snap tool
Use the Quadrant Snap tool to snap to the quadrant point of another entity. You can 
snap to the closest quadrant of an arc, circle, ellipse, or elliptical arc.    

To set the Quadrant Snap    
Do one of the following:
• Choose Settings > Entity Snap > Quadrant Snap.
• On the Entity Snaps toolbar, click the Set Quadrant Snap tool ( ).

• Type quadrant and then press Enter.
  

Insertion Point Snap tool
Use the Insertion Point Snap tool to snap to the insertion point of an attribute, block, 
or text entity.              

To set the Insertion Point Snap
Do one of the following:
• Choose Settings > Entity Snap > Insertion Point Snap.
• On the Entity Snaps toolbar, click the Set Insertion Point Snap tool ( ).

• Type insertion and then press Enter. 
  

To snap to a quadrant, select the entity near the quadrant point (A).

To snap to an insertion point, select anywhere on the entity (A).

A

A

A
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Point Snap tool
Use the Point Snap tool to snap to a point entity.        

To set the Point Snap
Do one of the following:
• Choose Settings > Entity Snap > Point Snap.
• On the Entity Snaps toolbar, click the Set Point Snap tool ( ).

• Type node and then press Enter. 
  

Intersection Snap tool
Use the Intersection Snap tool to snap to the actual intersection in three-dimensional 
space of any combination of entities. You can snap to the combination of an arc, cir-
cle, line, polyline, ray, or infinite line. If the target covers only one entity, the pro-
gram prompts you to select a second entity, and then snaps to the point at which the 
two entities would intersect if they were of infinite length. You can snap to the verti-
ces of three-dimensional entities and the corners of entities that have thickness.         

To set the Intersection Snap
Do one of the following:    
• Choose Settings > Entity Snap > Intersection Snap.
• On the Entity Snaps toolbar, click the Set Intersection Snap tool ( ).

• Type intersection and then press Enter.
  

To snap to a point entity, select the entity (A).

To snap to an intersection, select the intersection (A).

A

A

A
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Plan View Intersection Snap tool    
Use the Plan View Intersection Snap tool to snap to the location in the plan view of 
the current user coordinate system (UCS) where two entities would intersect if they 
were projected onto that plan view. The z-coordinates for the selected entities are 
ignored; the intersection point uses the current elevation as its z-coordinate. If the tar-
get covers only one entity, the program prompts you to select a second entity, and 
then snaps to the point at which the two would intersect in plan view if they were of 
infinite length.    

To set the Plan View Intersection Snap       
Do one of the following:
• Choose Settings > Entity Snap > Plan View Intersection Snap.
• On the Entity Snaps toolbar, click the Set Plan View Intersection Snap tool ( ).

• Type planviewint and then press Enter.
  

Quick Snap command
Normally, an entity snap searches all the entities crossing the target and selects the 
one closest to the center of the target. Use the Quick Snap command to modify the 
current entity snap so that the program stops searching for the snap point as soon as it 
finds one entity with at least one point of the current entity type.    

To set the Quick Snap    
• Type quick and then press Enter.

Select the two entities ([A] and [B]) to snap to a plan view intersection (C).

A

B
C C
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Clear Entity Snaps tool
Use the Clear Entity Snaps tool to turn off all entity snap settings, regardless of how 
they were set: by menu, tool, command, or in the Drawing Settings dialog box.

To set Clear Entity Snaps
Do one of the following:
• Choose Settings > Entity Snap > Clear Entity Snaps.
• On the Entity Snaps toolbar, click the Clear Entity Snaps tool ( ).

• Type none and then press Enter.

Using fly-over snapping 

Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently. 
When the Fly-over snapping option is set, IntelliCAD will display a colored marker at 
matching entity snap points as you move the crosshairs around the drawing. 

Each entity snap has its own type of marker:

1 Endpoint Snap 
2 Nearest Snap 
3 Midpoint Snap 
4 Center Snap 
5 Perpendicular Snap 
6 Tangent Snap 
7 Quadrant Snap 
8 Insertion Snap 
9 Node (point) Snap

10 Intersection Snap 
When Fly-over snapping is enabled and multiple entity snaps are on, you can press 
TAB to cycle through the available entity snap points of the entities covered by the 
target box. For example, when the Endpoint and Midpoint snaps are set and the aper-
ture box is on a line, pressing TAB will cycle between the line's closest endpoint and 
midpoint.
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To set the Fly-over snapping option 
1 Choose Settings > Entity Snap > Entity Snap Settings. The Drawing Settings dia-

log box opens to the Coordinate Input tab.
2 Click Fly-over. The Options dialog box opens to the Snapping tab. 
3 Turn on the Enable Fly-over Snapping option. 
4 Set the fly-over options. 
5 Define the color, size, and thickness of the snap marker. 
6 Click OK to close the Option dialog box. 
7 Click OK to close the Drawing Settings dialog box. 

TIP You can also set the Fly-over option using the Options dialog box. Choose Tools 
> Options and select the Snapping tab to choose the Fly-over settings. 

Saving your drawing    

To save a drawing, choose any of the following methods:

• Choose File > Save.
• On the Standard toolbar, click Save ( ).

• Type save and then press Enter.

TIP When you save a drawing the first time, the program displays the Save Drawing 
File As dialog box so that you can choose a directory and type a name for the draw-
ing. You can use any name when you first save the drawing. To save a drawing later 
using a different name, choose File > Save As, and then type the new name.
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Creating simple entities  

With IntelliCAD®, simple entities include lines (both finite and infinite), circles, arcs, 
ellipses, elliptical arcs, points, and rays. In addition, IntelliCAD includes a freehand 
sketch tool. Entities drawn freehand are also considered to be simple entities.

This chapter explains how to create simple entities using the different ways that you 
can start the drawing command for each, including how to:

• Use menu commands on the Insert menu.
• Use the tools on the Draw 2D toolbar.

• Type commands in the command bar.

In some cases, there are a number of different ways to create an entity. For the most 
part, one or two are given here. Refer to the online Help to learn how to create entities 
using other methods.

When you use a tool or a drawing command, the program prompts you to enter coor-
dinate points, such as endpoints or insertion points. You can enter the points or dis-
tances either using a mouse or by typing coordinate values at the command prompt. 
As you draw, IntelliCAD also displays a context-sensitive prompt box with appropri-
ate additional options for the type of entity you are drawing.

After you create entities, you can modify them using the entity modification tools.

Topics in this chapter
Drawing lines ...................................................................................................... 60
Drawing circles ................................................................................................... 61
Drawing arcs....................................................................................................... 63
Drawing ellipses.................................................................................................. 66
Drawing elliptical arcs ......................................................................................... 67
Creating point entities ......................................................................................... 68
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Drawing infinite lines........................................................................................... 71
Creating freehand sketches................................................................................ 73
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Drawing lines

A line consists of two points: a start point and an endpoint. You can connect a series 
of lines, but each line segment is considered a separate line entity.  

To draw a line
1 Do one of the following:

• Choose Insert > Line.

• On the Draw 2D toolbar, click the Line tool ( ).

• Type line and then press Enter.

2 Specify the start point.
3 Specify the endpoint.
4 In the prompt box, choose Done to complete the command.

The prompt box provides several options as you draw. For example, when you draw 
the first line segment, you can specify its length or orientation angle. After you draw 
at least one line segment, you can click Undo to remove the previous line segment. 
You can click Done to end the line command. After you draw two or more line seg-
ments, you can click Close to complete the line command by drawing a line segment 
that connects to the start point of the first line segment you drew.

If the last entity you drew was an arc, you can also draw a line tangent to and starting 
from the endpoint of the arc.

To draw a line as a continuation from the end of an arc 
1 Do one of the following:

• Choose Insert > Line.

• On the Draw 2D toolbar, click the Line tool ( ).

• Type line and then press Enter.

2 In the prompt box, choose Follow.
3 Specify the length of the line.

Start point (A) and endpoint (B).

A
B
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Drawing circles

The default method for drawing a circle is to specify a center point and radius. You 
can draw circles using any of the following methods:         

• Center-Radius ( )
• Center-Diameter ( ) 
• Two points ( ) 
• Three points ( )
• Radius-Tangent-Tangent ( ) 

• Convert Arc to Circle ( )

To draw a circle by specifying its center and radius 
1 Do one of the following: 

• Choose Insert > Circle.

• On the Draw 2D toolbar, click the Circle Center-Radius tool ( ).

• Type circle and then press Enter.

2 Specify the center point.
3 Specify the radius of the circle.

Endpoint of previous arc (A) and length of the line (B).

A

B

Center point (A) and radius (B).

A
B
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To draw a circle tangent to existing entities
1 Do one of the following: 

• Choose Insert > Circle.

• On the Draw 2D toolbar, click the Circle Radius-Tangent tool ( ).  
Go to step 3.

• Type circle and then press Enter.

2 In the prompt box, choose Radius-Tangent-Tangent.
3 Specify the radius of the circle.
4 Select the first entity to which to draw the circle tangent.
5 Select the second entity to which to draw the circle tangent.

To convert an arc to a circle
1 Do one of the following: 

• Choose Insert > Circle.

• On the Draw 2D toolbar, click the Convert Arc to Circle tool. ( ).  
Go to step 3.

• Type circle and then press Enter.

2 In the prompt box, choose Turn Arc Into Circle.
3 Select the arc you want to convert to a circle. 

Radius of circle (A) and tangent lines (B) and (C).

A

B

C

Select an arc (A) to convert to a circle.

A
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Drawing arcs

An arc is a portion of a circle. The default method for drawing an arc is to specify 
three points—the start point, a second point, and the endpoint. You can draw arcs 
using any of the following methods:                                                

• Three points on an arc ( ).
• Start point-center-endpoint ( ), or Start point-endpoint-center ( ), or Center-

start point-endpoint ( ).
• Start point-center-included angle ( ), or Start point-included angle-center 

( ), or Center-start point-included angle ( ).    
• Start point-center-chord length ( ), or Center-start point-chord length ( ).   
• Start point-endpoint-radius ( ), or Start point-radius-endpoint ( ). 
• Start point-endpoint-included angle ( ), or Start point-included angle-endpoint 

( ).
• Start point-endpoint-starting direction ( ), or Start point-starting direction-end-

point ( ).
• Start point-radius-angle ( ).

• As a tangent continuation of the previous arc or line ( ).

To draw an arc by specifying three points
1 Do one of the following:

• Choose Insert > Arc.

• On the Draw 2D toolbar, click the 3-Point Arc tool ( ).

• Type arc and then press Enter.

2 Specify the start point.
3 Specify a second point.
4 Specify the endpoint.

Start point (A), second point (B), and endpoint (C).

A

B
C
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The prompt box provides additional options for drawing arcs. For example, after you 
specify the start point of an arc, you can choose Angle, Center, Direction, Endpoint, 
or Radius. You can select the options in a different order as well. For instance, you 
can draw an arc by specifying its start point, endpoint, and radius, or you can specify 
the start point, radius, and then endpoint.

To draw an arc by specifying its start point, center point, and endpoint
1 Do one of the following: 

• Choose Insert > Arc.

• On the Draw 2D toolbar, click the Arc Start-Center-End tool ( ).

• Type arc and then press Enter.

2 Specify the start point.
3 In the prompt box, choose Center.
4 Specify the center point.
5 Specify the endpoint.

To draw an arc by specifying two points and an included angle     
1 Do one of the following:

• Choose Insert > Arc.

• On the Draw 2D toolbar, click the Arc Start-End-Angle tool ( ).

• Type arc and then press Enter.

2 Specify the start point.
3 In the prompt box, choose Angle or type angle.
4 To draw an arc in a counterclockwise direction, enter a positive value for the 

included angle.
To draw an arc in a clockwise direction, enter a negative value for the included 
angle.

5 Specify the endpoint.

Start point (A), center point (B), and endpoint (C).

A

B

C
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If the last entity you drew was an arc or a line, you can also draw an arc tangent to and 
starting from the endpoint of the arc or line.

To draw an arc tangent to an arc or line 
1 Do one of the following:

• Choose Insert > Arc.

• On the Draw 2D toolbar, click the Tangent Arc tool ( ). Go to step 3.

• Type arc and then press Enter.

2 In the prompt box, choose Follow.
3 Specify the endpoint.

TIP To convert an arc to a circle, on the Draw 2D toolbar, click the Convert Arc To 
Circle flyout tool ( ).

Start point (A), endpoint (B), and included angle (C).

A
B

C

Endpoint (A).

A
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Drawing ellipses

The default method for drawing an ellipse is to specify the endpoints of one axis of 
the ellipse, and then specify a distance representing half the length of the second axis. 
The endpoints of the first axis determine the orientation of the ellipse. The longer axis 
of the ellipse is called the major axis, and the shorter one is the minor axis. The order 
in which you define the axes does not matter. The program determines the major and 
minor axes based on their relative lengths. You can draw ellipses using any of the fol-
lowing methods:  

• Axis-axis ( )
• Axis-rotation ( )
• Center-axis ( ) 

• Center-rotation ( )

To draw an ellipse by specifying the axis endpoints
1 Do one of the following: 

• Choose Insert > Ellipse.

• On the Draw 2D toolbar, click the Ellipse Axis-Axis tool ( ).

• Type ellipse and then press Enter.

2 Specify the first endpoint.
3 Specify the second endpoint. 
4 Specify the half-length of the other axis.

First axis endpoint (A), second axis endpoint (B), and half-length of other axis (C).

A
C

B
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Drawing elliptical arcs

An elliptical arc is a portion of an ellipse. The default method for drawing an ellipti-
cal arc is to specify the endpoints of one axis of the ellipse, and then specify a dis-
tance representing half the length of the second axis. Then you specify the start and 
end angles for the arc, measured from the center of the ellipse in relation to its major 
axis. You can draw elliptical arcs using any of the following methods: 

• Axis-axis ( ) 
• Axis-rotation ( )
• Center-axis ( ) 

• Center-rotation ( )

To draw an elliptical arc by specifying the axis endpoints
1 Do one of the following:

• Choose Insert > Elliptical Arc.

• On the Draw 2D toolbar, click the Elliptical Arc Axis-Axis tool ( ).

• Type ellipse and then press Enter, and then type a (for Arc) and press Enter.

2 Specify the first endpoint.
3 Specify the second endpoint.
4 Specify the half-length of the other axis.
5 Specify the start angle of the arc.
6 Specify the end angle.

NOTE  IntelliCAD draws elliptical arcs in the direction you specify. Go to Settings > 
Drawing Settings > Drawing Units tab. Under Change Settings For, select Angular 
Units. The default setting is counterclockwise.

First axis endpoint (A), second axis endpoint (B), half-length of other axis (C), start angle of arc (D), and 
end angle (E).

A

D

C
E

B
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Creating point entities

You can draw a point entity formatted as either a single dot or as one of 19 other pos-
sible display styles.        

To draw a point
1 Do one of the following:

• Choose Insert > Draw Point.

• On the Draw 2D toolbar, click the Point tool ( ).

• Type point and then press Enter.

2 Specify the location of the point.

To draw several points
1 Do one of the following:

• Choose Insert > Draw Point.

• On the Draw 2D toolbar, click the Point tool ( ).

• Type point and then press Enter.

2 In the prompt box, choose Multiple Points.
3 Specify the location of each point.
4 In the prompt box, choose Done to complete the command.

Changing the size and appearance of point entities
Changing the size and appearance of point entities affects all point entities already in 
the drawing, as well as all points that you subsequently draw. Positive values repre-
sent the absolute size of the point entity measured in drawing units. Negative values 
represent a percentage relative to the drawing screen, so that points retain their visual 
size as you use the Zoom command to change the magnification of the drawing.

To change the size and appearance of point entities
1 Do one of the following: 

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.
3 Under Change Settings For, click Points.
4 Under Point Display Type, select the style you want.
5 Under Point Size, select the point size, or choose one of the options.
6 Click OK.
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When you regenerate the drawing, all point entities change to reflect the new size and 
appearance settings. 

A To increase or decrease the point size, type a 
value or click one of the point size arrows. 

B To use one of the preset point size options, click 
the one that you want.

C Select the button for the Point Display Type that 
you want.

A

B

C
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Drawing rays

A ray is a line in three-dimensional space that starts at a point and extends to infinity. 
Because rays extend to infinity, they are not calculated as part of the drawing extents. 
The default method for drawing a ray is to select the start point of the ray and then 
specify its direction. You can draw a ray in any of the following ways:

• Horizontal draws the ray parallel to the x-axis of the current user coordinate sys-
tem (UCS). 

• Vertical draws the ray parallel to the y-axis of the current UCS.
• Angle draws the ray parallel to a specified angle.
• Bisect draws the ray perpendicular to an existing entity.

• Parallel draws the ray parallel to an existing entity.

To draw a ray
1 Do one of the following:

• Choose Insert > Ray.

• On the Draw 2D toolbar, click the Ray tool ( ).

• Type ray and then press Enter.

2 Specify the start point.
3 Specify the direction.
4 To complete the command, press Enter.

Start point (A) and direction (B).

A B
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Drawing infinite lines
Infinite lines are sometimes referred to as construction lines. An infinite line is a line 
through a given point, oriented at a specified angle in three-dimensional space and 
extending to infinity in both directions. Because infinite lines extend to infinity, they 
are not calculated as part of the drawing extents.  

The default method for drawing an infinite line is to select a point along the line and 
then specify the direction of the line. You can draw an infinite line in any of the fol-
lowing ways:

• Horizontal draws the infinite line parallel to the x-axis of the current UCS. 
• Vertical draws the infinite line parallel to the y-axis of the current UCS.
• Angle draws the infinite line parallel to a specified angle.
• Bisect draws the infinite line perpendicular to an existing entity.

• Parallel draws the infinite line parallel to an existing entity.

To draw an infinite line
1 Do one of the following:   

• Choose Insert > Infinite Line.

• On the Draw 2D toolbar, click the Infinite Line tool ( ).

• Type infline and then press Enter.

2 Specify a point along the line.
3 Specify the direction.
4 To complete the command, press Enter.
.

You can also draw infinite lines at a specific angle or at an angle relative to an exist-
ing entity.

Point along the infinite line (A) and the direction (B).

A
B
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To draw an infinite line at a specified angle relative to another entity
1 Do one of the following:

• Choose Insert > Infinite Line.

• On the Draw 2D toolbar, click the Infinite Line tool ( ).

• Type infline and then press Enter.

2 In the prompt box, choose Angle.
3 In the prompt box, choose Reference.
4 Select the reference entity.
5 Specify the angle of the infinite line in relation to the selected entity.
6 Specify the location of the infinite line.
7 To complete the command, press Enter.

Reference entity (A) and angle in relation to entity (B).

A B
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Creating freehand sketches

A freehand sketch consists of many straight line segments, created either as individ-
ual line entities or as a polyline. Before you begin creating a freehand sketch, you 
must set the length, or increment, of each segment. The smaller the segments, the 
more accurate your sketch, but segments that are too small can greatly increase the 
file size.   

After you specify the length of the sketch segments, the crosshairs change to a Pencil 
tool. Your freehand sketch is not added to the drawing until you “write” the sketch 
into your drawing. This means that you temporarily save the segment that you’ve 
drawn and the segment length, and you can continue sketching. 

To create a freehand sketch
1 Do one of the following: 

• Choose Insert > Freehand.

• On the Draw 2D toolbar, click the Draw Freehand tool ( ).

• Type freehand and then press Enter.

2 Specify the length of the sketch segments.
3 Click the mouse button to place the Pencil tool ( ) on the drawing to begin 

sketching.
4 Move the pencil image to draw a temporary freehand sketch.
5 Click the mouse button to lift the pencil up to stop sketching.
6 In the prompt box, choose Write, Then Resume to write the temporary freehand 

sketch into the drawing.
7 Click the mouse button to put the pencil down again and resume sketching.
8 Click the mouse button again to lift the pencil up to stop sketching.
9 In the prompt box, choose Done to write the temporary freehand sketch into the 

drawing and end the command.

A freehand sketch consists of individual line entities or a polyline.
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Erasing freehand sketch lines
You can erase temporary freehand sketch lines that have not yet been written into the 
drawing by choosing the Delete On option in the prompt box. The pencil changes to 
an Eraser tool. You can erase portions of the line when you move the eraser over a 
temporary freehand line without clicking the mouse button.

To erase freehand sketch lines
1 Do one of the following:

• Choose Insert > Freehand.

• On the Draw 2D toolbar, click the Draw Freehand tool ( ).

• Type freehand and then press Enter.

2 Specify the length of the sketch segments.
3 Select a point on the drawing to display the Pencil tool and begin sketching.
4 Click the mouse button to lift the pencil up to stop sketching.
5 In the prompt box, choose Delete On.
6 Move the Eraser tool ( ) to the beginning or end of the freehand sketch line that 

you drew, and then move it as far along the line as you want to erase.
7 Click the mouse button to put the Pencil tool down to resume sketching.

Setting the sketch method and accuracy
Using polylines for freehand sketches makes it easier to go back and edit sketches. 
You control whether to create freehand sketches using line segments or polylines in 
the Drawing Settings dialog box. You can also control the length of sketch segments 
in this dialog box. 
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To specify lines or polylines when sketching
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Choose the Entity Creation tab.
3 Under Change Settings For, click Freehand Sketches.
4 Under Freehand Sketching Methods, click either Freehand Command Creates 

Lines or Freehand Command Creates A Polyline.
5 Click OK.
m

A Select the sketch method. B Specify the default length of sketch segments.

A

B



76   C H A P T E R  4



5

Creating complex entities

With IntelliCAD®, complex entities include polylines (including rectangles and poly-
gons), spline curves, donuts, and planes. In addition, IntelliCAD includes tools for 
adding hatching to your drawings.   

This chapter explains how to create complex entities using the different ways that you 
can start the drawing command for each, including how to:

• Use menu commands on the Insert menu.
• Use the tools on the Draw 2D toolbar.

• Type commands in the command bar.

When you type a drawing command or select a tool, the program prompts you to 
enter coordinate points, such as endpoints or insertion points. As you draw, the pro-
gram displays a context-sensitive prompt box with appropriate additional options for 
the type of entity you are drawing.

After you create complex entities, you can modify them using the entity-modification 
tools. Several of these entity types require special editing commands. 

Topics in this chapter
Drawing rectangles ............................................................................................. 78
Drawing polygons ............................................................................................... 80
Drawing polylines................................................................................................ 81
Drawing splines .................................................................................................. 84
Drawing donuts................................................................................................... 87
Creating planes................................................................................................... 89
Creating boundary polylines ............................................................................... 91
Adding hatching.................................................................................................. 94
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Drawing rectangles

With IntelliCAD, rectangles are closed polylines with four sides. You draw a rectan-
gle by specifying its opposite corners. The rectangle is normally aligned parallel to 
the current snap and grid alignment, but you can use the Rotated option to align the 
rectangle to any angle.    

To draw a rectangle
1 Do one of the following:

• Choose Insert > Rectangle.

• On the Draw 2D toolbar, click the Rectangle tool ( ).

• Type rectangle and then press Enter.

2 Specify one corner of the rectangle.
3 Specify the opposite corner of the rectangle.    

You can edit each side of a rectangle individually using the Edit Polyline tool ( ) 
on the Modify toolbar. You can convert the sides into individual line entities using 
the Explode tool ( ) on the Modify toolbar. You can control whether wide rectan-
gle lines are shown filled or as outlines using the Fill tool ( ) on the Settings tool-
bar. 

You can also use the Rectangle tool to draw a square. Instead of specifying the oppo-
site corners, you specify the length of one side and the alignment of the square. 

Opposite corners (A and B). Resulting rectangle.

A
B
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To draw a square     
1 Do one of the following:

• Choose Insert > Rectangle.

• On the Draw 2D toolbar, click the Rectangle tool ( ).

• Type rectangle and then press Enter.

2 In the prompt box, choose Square.
3 Specify one corner of the square.
4 Specify the length of one side of the square by selecting its other end.

The point you specify determines both the size and alignment of the square.       

TIP To control the width of the rectangle line, choose the Width Of Line option in the 
prompt box. After you change the width of the line, the new width setting remains in 
effect for subsequent rectangles until you change it again. 

Endpoints of one side of the square (A and B). Resulting square.

A

B
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Drawing polygons

Polygons are closed polylines composed of a minimum of three and a maximum of 
1,024 equal-length sides. The default method for drawing a polygon is to specify the 
center of the polygon and the distance from the center to each vertex. You can draw a 
polygon using any of the following methods: 

• Center - by vertex ( ) on the Draw 2D toolbar
• Center - by side ( ) on the Draw 2D toolbar

• Edge ( ) on the Draw 2D toolbar

The vertex polygon drawing method creates an equal-sided polygon defined by its 
center point and the distance to its vertices. You specify the number of sides, the cen-
ter point, and the location of one vertex, which determines both the size and orienta-
tion of the polygon.

To draw a polygon by vertex     
1 Do one of the following:

• Choose Insert > Polygon.

• On the Draw 2D toolbar, click the Polygon, Center-Vertex tool ( ).

• Type polygon and then press Enter.

2 Type 5 to specify five sides for the polygon.
3 Specify the center of the polygon.
4 Specify the vertex of the polygon.            

The center (A) and vertex (B). Resulting polygon.

A
B
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Drawing polygons by side
The side polygon drawing method creates an equal-sided polygon defined by its cen-
ter point and the distance to the midpoint of a side. You specify the number of sides, 
the center point, and the location of the midpoint of one side, which determines both 
the size and orientation of the polygon.

To draw a polygon by side    
1 Do one of the following:

• Choose Insert > Polygon.

• On the Draw 2D toolbar, click the Polygon, Center-Side tool ( ).

• Type polygon and then press Enter.

2 Type 3 to specify three sides for the polygon.
3 Specify the center of the polygon.
4 In the prompt box, choose Specify By Side, and then press Enter.
5 Specify the midpoint of the side.
 

You can edit each side of a polygon individually using the Edit Polyline tool ( ) on 
the Modify toolbar. You can convert the sides into individual line entities using the 
Explode tool ( ) on the Modify toolbar. You can control whether wide polygon 
lines are shown filled or as outlines using the Fill tool ( ) on the Settings toolbar.               

Drawing polylines    

With IntelliCAD, a polyline is a connected sequence of arcs and lines that is treated 
as a single entity. You can draw a polyline with any linetype and using a width that 
either remains constant or tapers over the length of any segment. When editing a 
polyline, you can modify the entire polyline or change individual segments.      

After you specify the start point of a polyline, a prompt box provides several options 
as you draw, such as Distance, Halfwidth, and Width. You can specify different start-
ing and ending widths to create a tapered polyline segment.      

The center (A) and midpoint of one side (B). Resulting polygon.

A
B
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After you draw at least one polyline segment, you can use the Undo tool ( ) to 
remove the previous segment. After you draw two or more polyline segments, you 
can use the Close option to complete the command by drawing a segment that ends at 
the start point of the first polyline segment you drew. Choose Done to complete the 
command without closing the polyline.               

To draw a polyline with straight segments
1 Do one of the following:

• Choose Insert > Polyline.

• On the Draw 2D toolbar, click the Polyline tool ( ).

• Type polyline and then press Enter.

2 Specify the start point.
3 Specify the endpoint of each segment.
4 To complete the command, choose Close or Done.

With the Draw Arcs option, you can continually draw arc segments until you select 
the Draw Lines option to go back to drawing line segments. When you draw arc seg-
ments, the first point of the arc is the endpoint of the previous segment. By default, 
you draw arc segments by specifying the endpoint of each segment. Each successive 
arc segment is drawn tangent to the previous arc or line segment. If you choose Close 
while in the Draw Arcs option, the closing segment is created as an arc. 

Curved polyline with tapered width. Polyline with straight  
segments.

Closed polyline.

Polyline start point (A) and segment endpoints (B).

A

B

B

B

B
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You can also specify the arc using any of the following methods: 
• Start point, included angle, center point
• Start point, included angle, radius
• Start point, center point, endpoint
• Start point, included angle, endpoint
• Start point, center point, included angle
• Start point, center point, chord length
• Start point, direction, endpoint
• Start point, radius, included angle

• Start point, second point, endpoint

To draw a line segment followed by an arc polyline segment
1 Do one of the following: 

• Choose Insert > Polyline.

• On the Draw 2D toolbar, click the Polyline tool ( ).

• Type polyline and then press Enter.

2 Specify the start point.
3 Specify the endpoint.
4 In the prompt box, choose Draw Arcs.
5 Specify the endpoint of the arc segment.
6 To complete the command, choose Done.

You can edit entire polylines and individual segments using the Edit Polyline tool 
( ) on the Modify toolbar. You can convert polylines into arc and line entities 
using the Explode tool ( ) on the Modify toolbar. You can control whether wide 
polylines are shown filled or as outlines using the Fill tool ( ) on the Settings 
toolbar. 

Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C).

A
B

C
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Drawing splines    

A spline is a smooth curve defined by a set of points. You can use splines to create 
sculptured shapes such as the cross section of a turbine blade or an airplane wing.            

To draw a spline      
1 Do one of the following:

• Choose Insert > Spline.

• On the Draw 2D toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.
3 Specify the second point of the spline.
4 Specify as many more points as you want.
5 When you have finished, press Enter.

You can add tangents to the spline, which are lines that give it shape.

To add tangents to a spline
1  Specify the starting tangent point.
2 Specify the ending tangent point.

Spline.                                                                      Spline with starting tangent point (A) and ending tangent 
point (B).

A B
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Specifying fit tolerance
By default, a spline passes through all of the control points. When you draw a spline, 
you can change this by specifying the fit tolerance. The fit tolerance value determines 
how closely the spline fits the set of points you specify. For example, a spline fit tol-
erance value of 0 causes the spline to pass through the control points. A value of 0.01 
creates a spline that passes through the start and endpoints and within 0.01 units of 
the intermediate control points. 

To specify the fit tolerance
1 Do one of the following:

• Choose Insert > Spline.

• On the Draw 2D toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.
3 Specify the second point of the spline.
4 In the prompt box, choose Fit Tolerance.
5 To accept the default of 0.0000, press Enter.

To specify a different fit tolerance, type the number, and then press Enter.
6 Specify the additional points you need to draw a spline or a closed spline.
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Drawing a closed spline
You can draw a closed spline, which is a spline for which the start point and endpoint 
are the same. Because the spline is closed, you specify only one tangent. 

To draw a closed spline
1 Do one of the following:

• Choose Insert > Spline.

• On the Draw 2D toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.
3 Specify the second point of the spline.
4 Specify as many more points as you want.
5 When you have finished, in the prompt box, choose Close.
6 To complete the command, specify the tangent point. 

The start point and endpoint (A) of a closed spline.

A
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Drawing donuts

Donuts are solid, filled circles or rings created as closed, wide polylines. You can 
draw a donut using one of several methods. The default method is to specify the 
inside and outside diameters of the donut, and then specify its center. You can then 
create multiple copies of the same donut by specifying different center points until 
you press Enter to complete the command.   

To draw a donut
1 Do one of the following:

• Choose Insert > Donut.

• On the Draw 2D toolbar, click the Donut tool ( ).

• Type donut and then press Enter.

2 Specify the inside diameter of the donut.
3 Specify the outside diameter of the donut.
4 Specify the center of the donut.
5 Specify the center point to draw another donut, or choose Done to complete the 

command.

The prompt box provides additional options for drawing donuts. For example, you 
can specify the width of the donut and two points on the diameter of the donut, or you 
can specify the width and three points on the donut. You can also draw a donut tan-
gent to existing entities.    

TIP A donut can be a completely filled circle by specifying an inside diameter of zero.

Inside diameter (A) and outside diameter (B).

A

B
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To draw a donut tangent to existing entities
1 Do one of the following: 

• Choose Insert > Donut.

• On the Draw 2D toolbar, click the Donut tool ( ).

• Type donut and then press Enter.

2 In the prompt box, choose Radius Tangent Tangent.
3 Specify the width of the donut.
4 Specify the diameter of the donut.
5 Select the first tangent entity to which to draw the donut.
6 Select the second tangent entity to which to draw the donut.

You can edit donuts using the Edit Polyline tool ( ) on the Modify toolbar. You 
can convert donuts into arc entities using the Explode tool ( ) on the Modify 
toolbar. You can control whether donuts are shown filled or as outlines using the Fill 
tool ( ) on the Settings toolbar. 

TIP You can control the default outside and inside diameter of donuts by choosing 
Settings > Drawing Settings, and then clicking the Entity Creation tab and choosing 
the options you want.

Width (A) and diameter (B) of the donut and tangent entities (C).

A

B

C

C
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Creating planes    

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled 
with a solid color. The default method is to specify the corners of the plane. After you 
specify the first two corners, the plane is displayed as you specify the remaining cor-
ners. Specify corner points in a triangular manner. The program prompts you for the 
third point and then the fourth point. If you continue specifying points, the third- and 
fourth-point prompts toggle until you press Enter to complete the command.    

To draw a quadrilateral plane
1 Do one of the following:

• Choose Insert > Plane.

• On the Draw 2D toolbar, click the Plane tool ( ).

• Type plane and then press Enter.

2 Specify the first point.
3 Specify the second point.
4 Specify the third point.
5 Specify the fourth point.
6 To complete the command, press Enter.

The prompt box provides additional options for drawing planes. For example, you 
can draw rectangular, square, or triangular planes.

After you select the first two points (A) and (B), the sequence in which you select the third (C) 
and fourth (D) points determines the shape of the resulting quadrilateral plane.

B

A
D

C

B

A D
C
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To draw a rectangular plane
1 Do one of the following:

• Choose Insert > Plane.

• On the Draw 2D toolbar, click the Plane tool ( ).

• Type plane and then press Enter.

2 Choose Rectangle.
3 Specify the first point.
4 Specify the opposite corner.
5 Specify the rotation angle.
6 To complete the command, specify the opposite corner to draw another rectangle, 

or press Enter.

You can control whether planes are shown filled or as outlines using the Fill tool 
( ) on the Settings toolbar. You can convert planes into individual line entities cor-
responding to the outline of the plane using the Explode tool ( ) on the Modify 
toolbar.                              

Opposite corners (A and B) and rotation angle (C). Resulting plane.

A BC
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Creating boundary polylines

With the Boundary command, you can designate a specific area of a drawing for 
operations such as hatching and dimensioning. You create a boundary polyline by 
selecting an area inside a closed loop. The area you select can be bounded by a single 
closed entity or by multiple entities that intersect.

NOTE You cannot use a spline or an ellipse to create a boundary polyline.

In cases where entities intersect, IntelliCAD interprets the boundary as the closed 
loop closest to the point specifying the area. In the following figure, for example, the 
area point selected in the rectangle results in a boundary consisting of the closed loop 
nearest the point selection, as opposed to the closed loop formed by the rectangle 
itself.         

To make boundaries more specific, you can create a boundary set. A boundary set 
specifies which entities are considered in determining the boundary path. 

In the following figure, the circle and triangle are the selected entities. If you select an 
area anywhere inside the circle or the triangle, the result is a polyline that bounds the 
shaded area.

Selected point (A). Resulting boundary (B).

A

B

Selected entities (A and B).                                                                    Point specified in the selected area (C), 
which results in a new boundary 
around the shaded area.

A

B
C
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Using islands and island detection
Islands are closed loops that reside inside other closed loops. IntelliCAD provides 
island-detection options so that you can specify which islands, if any, should be con-
sidered in the area selection for a boundary. 

The following figure shows a rectangular polyline with two islands. The circle is 
referred to as the outer island, and the octagon is referred to as a nested island.  

You can choose from three island-detection methods.

• Nested Islands The outer entity and all its islands are considered for the polyline.
• Outer Only Only the outer entity and its outer island are considered for the 

polyline.

• Ignore Islands Only the outer entity is considered for the polyline.

Rectangular polyline (A) with outer island (B), with point (C) specifying the area selection, and nested island 
(D).

A

B

C

D
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To draw a boundary polyline
Advanced experience level

1 Do one of the following:
• Choose Insert > Boundary Polyline.

• On the Draw 2D toolbar, click the Boundary tool ( ).

• Type boundary and then press Enter.

2 Specify the set of entities that you want to define the polyline. 
To use all entities in the drawing, select All Visible Entities. To select specific 
entities, click Select Boundary Set, and then select the entities.

3 To complete entity selection and return to the Boundary dialog box, press Enter.
4 Choose an island-detection option.
5 Click Select Area.
6 Specify a point in the area whose closed perimeter forms the boundary.
7 When you have finished, click OK.

A Specify the defining entities.
B Choose to use all visible entities as the boundary 

set.

C Select island-detection option.
D Specify the bounded area.

A

B

C

D
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Adding hatching

You can add hatching to an area enclosed by entities selected to form the hatch 
boundary. The entire hatch is treated as a single entity. After you draw a hatch, it is 
independent of the entity itself.     

You can also use an existing entity to define the area you want to hatch. You can 
associate the hatch with its boundary entities by selecting Associative from the Hatch 
Attributes area of the Hatch dialog box. 

To open the Boundary Hatch dialog box
Do one of the following:
• Choose Insert > Hatch.
• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

Specifying a hatch pattern
A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can 
select a hatch pattern from a set of predefined patterns, or you can define a pattern of 
your own. The hatch pattern you used most recently is the default pattern the next 
time you choose Hatch. 

The program supplies predefined standard hatch patterns, which are stored in the 
icad.pat and icadiso.pat hatch pattern library files. You can use other external hatch 
pattern libraries, such as an office standard library, customized patterns, and libraries 
available from vendors or standards organizations. 

NOTE The icad.pat hatch pattern library files are ANSI (American National Standards 
Institute)-compliant patterns; the icadiso.pat hatch pattern library files are ISO 
(International Standards Organization)-compliant.
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To specify a predefined hatch pattern     
1 Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Pattern Properties tab.
3 In the Pattern Type list, click Predefined.

With Predefined, you can apply a scale factor to make the pattern larger or smaller 
than the default size. 

4 For Scale, enter the scale factor as a percentage of the default.
5 For Angle, enter the angle of the pattern in degrees (1-360). 

The default angle is clockwise; you can change the angle of any hatch pattern by 
entering a numerical value.

6 For ISO Pen Width, enter the pen width.
If you choose a predefined, ISO standard pattern, you can scale the pattern based 
on the ISO pen width. 

7 To copy the pattern properties from an existing hatch, choose Copy Hatch Proper-
ties and select the hatch.

8 To associate the hatch pattern to its boundary entities, under Hatch Attributes, 
select the Associative check box. 

9 To continue, go to the next section, "Selecting an Area for Hatching," and begin 
with step 2.
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To specify a user-defined hatch pattern   
1 Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Pattern Properties tab.
3 In the Pattern Type list, click User Defined.
4 For Spacing, enter the line spacing for the pattern.
5 To crosshatch the pattern, select the Cross-Hatched check box.

You can choose to crosshatch the pattern. Cross-hatching imposes a copy of the 
specified user-defined pattern at a 90-degree angle over the first pattern you 
defined.

6 To copy the pattern properties from an existing hatch, choose Copy Hatch Proper-
ties, select a hatch pattern from a hatched entity in the drawing.

7 To associate the hatch pattern to its boundary entities, under Hatch Attributes, 
select the Associative check box. 

8 To continue, go to the next section, "Selecting an Area for Hatching," and begin 
with step 2.

    

A Determines how hatch will be defined.
B Determines density of hatching for Predefined 

hatch patterns.
C Sets angle of hatch in relation to entity (User 

Defined only).
D Determines density of hatching for User Defined 

hatch patterns.

E Sets pen width for ISO-standard pattern.
F Imposes another copy of the specified pattern at 

a 90-degree angle over the first.
G Opens drawing to allow selection and copying of 

existing hatch pattern.
H Associates hatching to its boundary.

A

B

C

D

E

F
G

H
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To use a predefined library pattern
1 Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Pattern tab.
3 For Hatch File, select the icad.pat or icadiso.pat hatch pattern library file.
4 To select a predefined pattern, do one of the following:

• In the Patterns list, click the pattern name.

• Click the graphical representation of the hatch pattern.

5 To continue, go to the next section, "Selecting an Area for Hatching," and begin 
with step 2.

NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing.        

A Hatch pattern library files.
B Hatch patterns listed by name.

C Hatch patterns shown graphically.

A

B C
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Selecting an area for hatching
You can select an area whose closed perimeter forms the boundary for hatching.
To select an area for hatching
1 Do one of the following:

• Choose Insert > Hatch.
• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).
• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Boundary tab.
3 Under Island Detection Options, choose one of the following:

• Nested Islands The outer entity and all its islands are considered for hatching.
• Outer Only Only the outer entity and its outer island are considered for hatching.
• Ignore Islands Only the outer entity is considered for hatching.

4 To keep the boundary, select the Retain Boundaries check box.
5 Click Select Boundary Set, select the entities either individually or by choosing a 

selection method from the prompt box.
6 To complete entity selection, press Enter.
7 Click Select Area, specify the area to be hatched, and then press Enter.
8 Click OK. 

NOTE When you specify an area to be hatched, you must click within the closed 
perimeter of the boundary, not on the boundary polyline itself.
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A Opens selection method prompt box.
B Sets all visible entities as the boundary set.
C Sets currently selected entities as the boundary 

set.
D When selected, retains boundary after hatch is 

applied.

E Indicates type of entity used as the boundary.
F Determine how hatching interacts with islands.
G Opens drawing area for selection of areas to be 

hatched.

A

B
C

D

E

G

F
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6

Viewing your drawing

IntelliCAD® provides many ways to display and view your drawing. You can also 
change various display settings to speed up the display or printing of a drawing. This 
chapter explains how to:

• Navigate within a drawing by scrolling and panning.
• Change the magnification of a drawing by zooming in and out.
• Work with multiple windows or views of a drawing.

• Control the display of elements to optimize performance when working with large 
or complex drawings.

Topics in this chapter
Redrawing and regenerating a drawing............................................................ 102
Moving around within a drawing ....................................................................... 102
Changing the magnification of your drawing ....................................................104
Displaying multiple views.................................................................................. 108
Controlling visual elements................................................................................113
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Redrawing and regenerating a drawing     

As you work on a drawing, visual elements may remain after the completion of a 
command. You can remove these elements by refreshing, or redrawing, the display.            

To redraw (refresh) the current window display
Do one of the following:
• Choose View > Redraw.
• On the View toolbar, click the Redraw tool ( ).

• Type redraw and then press Enter.

Information about drawing entities is stored in a database as floating point values, 
ensuring a high level of precision. Sometimes a drawing must be recalculated, or 
regenerated, from the floating-point database to convert those values to the appropri-
ate screen coordinates. This occurs automatically. You can also manually initiate a 
regeneration. When the drawing is regenerated, it is also redrawn.       

To regenerate the current window, type regen in the command bar. If more than one 
window is displayed, type regenall to regenerate all the windows.    

Moving around within a drawing  

You can move the view of a drawing displayed in the current viewport by scrolling or 
panning. Doing this changes the portion of the drawing you are viewing without 
changing the current magnification. Scrolling lets you move around in the drawing 
horizontally and vertically. Panning lets you move the drawing in any direction.          

Using scroll bars
To assist you in navigating within a drawing, horizontal and vertical scroll bars are 
available in each drawing window. The size of the scroll box in relation to the scroll 
bar indicates the current level of drawing magnification. The position of the scroll 
box in relation to the scroll bar indicates the location of the center of the drawing in 
relation to the extents of the drawing (the smallest rectangle containing all the entities 
in the drawing).       

To turn scroll bars on or off
Do one of the following:
• Choose View > Scroll Bars.

• Type scrollbar, press Enter, and then select On, Off, or Toggle.
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Using the Pan command
You can move the drawing in any direction using the Pan tool ( ) on the View 
toolbar. Panning shifts or slides the view of the drawing horizontally, vertically, or 
diagonally. The magnification of the drawing remains the same, as does its orienta-
tion in space. The only change is the portion of the drawing displayed.       

Panning methods   
To pan, you can use any of the following methods:

• For precise panning, specify two points defining the magnitude and direction of 
the pan. The first point, or base point, indicates the starting point of the pan. The 
second point indicates the amount of pan displacement relative to the first point.

• To pan in real time, use the right mouse button.
• If you have a mouse with a wheel, use the wheel to pan up or down.

• To pan in small increments, use the arrow keys.

To pan by specifying two points
1 Do one of the following:

• Choose View > Pan.

• On the View toolbar, click the Pan tool ( ).

• Type pan and then press Enter.

2 Specify the pan base point either by typing the coordinates or by specifying a point 
in the drawing window.

3 Specify the pan displacement point either by typing the coordinates or by specify-
ing a point in the drawing window. 

 

Select the pan base point (A), and then select a 
second point (B) to specify the pan displacement.

Result.

A
B
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To pan in real time    
1 Simultaneously press Ctrl+Shift and click and hold the right mouse button. 
2 Move the cursor in the direction you want to pan.
3 To stop panning, release the mouse button.

To pan using a mouse with a wheel    
• Rotate the wheel backward to pan up or forward to pan down.

NOTE  You must have the scroll bars displayed to use this feature. To display the 
scroll bars, choose View > Scroll Bars.

To pan using the arrow keys
• Press the up, down, right, or left arrow keys.

Changing the magnification of your drawing  

You can change the magnification of your drawing at any time by zooming. The 
cursor changes to a magnifying glass ( ) when a zoom tool is active. Zoom out to 
reduce the magnification so you can see more of the drawing, or zoom in to increase 
the magnification so you can see a portion of the drawing in greater detail. Changing 
the magnification of the drawing affects only the way the drawing is displayed; it has 
no effect on the dimensions of the entities in your drawing.             

Zooming in and out
One of the easiest ways to change the magnification of the drawing is to zoom in or 
out by a preset increment. On the View toolbar, the Zoom In tool ( )doubles the 
current magnification of the drawing. The Zoom Out tool ( ) reduces the magnifi-
cation of the drawing by half. The portion of the drawing located at the center of the 
current viewport remains centered on the screen as you zoom in and out.            

Zoom in. Zoom out.
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Zooming methods
To zoom, you can use any of the following methods:

• To define the portion of the drawing to zoom, create a window.
• To zoom in real time, use the mouse.

• If you have a mouse with a wheel, use the wheel button to zoom in and out.

To zoom in to an area using a window
1 Do one of the following:

• Choose View > Zoom > Window.

• On the View toolbar, click the Zoom Window tool ( ).

• Type zoom and then press Enter.

2 Select one corner of the window around the area you want to magnify.
3 Specify the opposite corner of the window around the area you want to magnify.

To zoom in real time    
1 Simultaneously press Ctrl+Shift and click and hold the left mouse button. 
2 To zoom in, move the cursor up the screen; to zoom out, move the cursor down the 

screen.
3 To stop zooming, release the mouse button.

To zoom using a mouse with a wheel    
• Rotate the wheel away from you to zoom in or toward you to zoom out.

Each rotation of the wheel away from you zooms out .8 times; each rotation 
toward you zooms in 1.25 times.

To specify a rectangular window around the 
area you want to magnify, select first one corner 
(A), and then select the opposite corner (B).

Result.

A

B
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Displaying the previous view of a drawing
After you zoom in or pan to view a portion of your drawing in greater detail, you may 
want to zoom back out to see the entire drawing. On the View menu, the Zoom Previ-
ous tool ( ) lets you restore the previous view. Selecting this tool repeatedly steps 
back through up to 25 successive zoomed or panned views.      

Zooming to a specific scale  
You can increase or decrease the magnification of your view by a precise scale factor 
measured relative to the overall size of the drawing or in relation to the current dis-
play. When you change the magnification factor, the portion of the drawing located at 
the center of the current viewport remains centered on the screen.    

To change the magnification of the view relative to the overall size of the drawing, 
type a number representing the magnification scale factor. For example, if you type a 
scale factor of 2, the drawing appears at twice its original size. If you type a magnifi-
cation factor of .5, the drawing appears at half its original size.

You can also change the magnification of the drawing relative to its current magnifi-
cation by adding an x after the magnification scale factor. For example, if you type a 
scale factor of 2x, the drawing changes to twice its current size. If you type a magnifi-
cation factor of .5x, the drawing changes to half its current size.

To zoom to a specific scale relative to the current display    
1 Do one of the following:

• Choose View > Zoom > Zoom In.

• On the View toolbar, click the Zoom In tool ( ).

• Type zoom and then press Enter.

2 Type the scale factor, followed by an x (such as 2x).
3 Press Enter.
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Combining zooming and panning  
You can specify the point you want at the center of the view when you change the 
drawing magnification. You can specify the point you want at the lower left of the 
view when you change the magnification of the drawing with the Zoom Left tool 
( ) on the View toolbar. With the exception of the Zoom Window tool, the other 
zoom tools zoom in or out from the center of the current view.        

To change the center of the current view
1 Do one of the following:    

• Choose View > Zoom > Center.

• On the Zoom toolbar, click the Zoom Center tool ( ).

• Type zoom, press Enter, and then in the prompt box, choose Center.

2 Select the point you want located at the center of the new view.
3 Specify the zoom scale factor or the height of the drawing in drawing units.     

Displaying the entire drawing
You can use the Zoom All tool ( ) on the View toolbar to display an entire draw-
ing. If you have drawn any entities outside the defined limits of the drawing, the 
extents of the drawing are displayed. If you drew all entities within the limits of the 
drawing, the drawing is displayed all the way to the drawing limits.                 

The Zoom Extents tool ( ) on the View toolbar displays the drawing to its extents, 
making the image fill the display to the greatest possible magnification. 
 

Current view showing the point to be centered in the new view (A), and the new view zoomed using a scale 
factor of 2x.

Zooming extents. Zooming entire drawing.

A
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Displaying multiple views

When you begin a new drawing, it is displayed in a single window. You can view the 
drawing in a second window, or you can divide one window into multiple windows. 
You can also open and display multiple drawings.          

Working with multiple views
You can open and work with several views of the same drawing simultaneously. 
There are two methods for dividing the current drawing into multiple views:

• Open a new window of the open drawing.
• Divide the current window into multiple views.
After you divide a single window into multiple windows, you can control each win-
dow separately. For example, you can zoom or pan in one window without affecting 
the display in any of the other windows. You can control the grid, snap, and view ori-
entation separately for each window. You can restore named views in individual win-
dows, draw from one window to another, and name window configurations 
individually so you can reuse them later.       

As you draw, any changes you make in one window are immediately visible in the 
others. You can switch from one window to another at any time, even in the middle of 
a command, by clicking the window’s title bar.

Opening a new window
You can open additional windows to create more than one view of a drawing. To 
open a new window, choose Window > New Window. After you open a new win-
dow, you can change its display without affecting any of the other windows.    

Working with multiple drawings
With the multiple-document interface (MDI) feature, you can open more than one 
drawing window at a time without using more memory. Because you can open and 
work on several drawings at one time, you can copy, cut, or paste an entity from one 
drawing to another.          
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Each drawing appears in a drawing window, which has the following advantages:

• You can see two or more drawings side by side.
• You can easily copy entities from one drawing to another.
• Using the IntelliCAD Explorer, you can copy such elements as layers, linetypes, 

and text styles from one drawing to another.
• Like paper space viewports, you can tile or overlap drawing windows; unlike 

paper space viewports, drawing windows maximize or reduce to an icon.

• It is more convenient to use drawing windows than to set up paper space 
viewports.   

One session of IntelliCAD with four drawings open.
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Each drawing window that you open and work on retains in the Prompt History log 
all the commands that you perform, but the command line does not indicate when you 
have switched windows.

If you move an entity from one window to another and then want to undo this action, 
you must undo it in both drawings for it to take effect. If you copy an entity from one 
window to another and then want to undo that action, you must undo it from the 
drawing into which you copied the entity. If you cut and paste an entity and then want 
to undo that action, you must undo it in both drawings.

Working with multiple windows  
When you open more than one window for a single drawing, each window is assigned 
a unique number (for example, mydrawing:1, mydrawing:2, and so on). If your cur-
rent window is maximized, you can switch to another open window by selecting its 
name from the bottom of the Window menu.              

The names of other open drawings appear at the bottom of the Window menu. You 
can also use the Cascade, Tile Horizontally, and Tile Vertically commands to arrange 
all the open windows and drawings. To arrange all the windows and drawings into a 
stack of identically sized windows, choose Window > Cascade. Arranging windows 
and drawings in this way makes it easy to see the title bar for each window.       

To arrange all the windows and drawings horizontally so they are placed in order 
from top to bottom, choose Window > Tile Horizontally. Arranging windows and 
drawings in this way displays each open window. The windows are resized to fit 
within the available space.    

To arrange all the windows and drawings vertically so they are placed side by side, 
choose Window > Tile Vertically. Arranging windows and drawings in this way dis-
plays each open window. The windows are resized to fit within the available space.

IntelliCAD uses the commands in the following table to control its windows.  

IntelliCAD window-control commands
Command Result
vports Splits the current window into two, three, or four tiled windows.

wcascade Cascades (overlaps) all open windows.

wclose Closes the current window.

wcloseall Closes all windows; also closes all drawings.

whtile Tiles all windows horizontally.

wiarrange Arranges window icons.

wopen Opens another window of the current drawing.

wvtile Tiles all windows vertically.
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Dividing the current window into multiple views
You can divide a drawing window into multiple tiled windows. You can control the 
number of windows created and the arrangement of the windows. The Viewports tool 
also lets you save and restore named window configurations and display a list of the 
current and saved window configurations.

To create multiple views   
1 Do one of the following:    

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Create 2 Viewports, Create 3 Viewports, or Create 4 
Viewports.

3 In the prompt box, choose the viewport orientation.    

You can divide a drawing window into two windows arranged vertically (A) or horizontally (B); three windows 
arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally (H); or four tiled windows (I).

A B C

D E F

G H I
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To join two views
1 Do one of the following:      

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Join.
3 Click anywhere inside the window you want to keep.
4 Click anywhere inside the adjacent window you want to join to the first window.
5 Press Enter.

Saving window configurations
You can save the current window arrangement as a named configuration so that you 
can recall it to the screen later. The number and placement of the windows are saved 
exactly as they are currently displayed. The settings for each window are also saved.  

To name and save a window configuration        
1 Do one of the following:

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Save.
3 Type a configuration name, and then press Enter.

The name can be up to 31 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.      

To restore a named window configuration    
1 Do one of the following:

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Restore.
3 Type the name of the window configuration you want to restore.
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Controlling visual elements  

The number of entities in your drawing and the complexity of the drawing affect how 
quickly IntelliCAD can process commands and display your drawing. You can 
improve overall program performance by turning off the display of certain visual ele-
ments, such as solid fills and text, while you work on the drawing. When you are 
ready to print your drawing, turn on the display of these elements so your drawing 
prints the way you want.       

You can also improve performance by turning off entity-selection highlighting and 
the display of marker blips created when you select locations in the drawing.

Turning Fill on and off
You can reduce the time it takes to display or print a drawing by turning off the dis-
play of solid fill. When Fill is turned off, all filled entities, such as wide polylines and 
planes, display and print as outlines. When you turn Fill on or off, you must redraw 
the drawing before the change is displayed.        

To turn Fill on or off
1 Do one of the following:

• Choose Settings > Fill.

• On the Settings toolbar, click the Fill tool ( ).

• Type fill and then press Enter.

2 Choose View > Redraw.    

TIP  On the Settings menu, a check mark appears next to the Fill command when it is 
turned on and the Fill tool on the Settings toolbar is activated. 

Fill on. Fill off.
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Turning Quick Text on and off   
Text entities require a considerable amount of time to display and print. You can 
reduce the time it takes to display or print a drawing by enabling Quick Text. For 
example, if you’re doing a preliminary check plot of a drawing, you may want to turn 
Quick Text on to speed up printing. When Quick Text is enabled, text entities are 
replaced by rectangular boxes that indicate the outline of the area occupied by the 
text. When you turn Quick Text on or off, you must regenerate the drawing before the 
change is displayed.          

To turn Quick Text on and off
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type qtext, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.
3 Under Change Settings For, click Display.
4 Select or clear the Enable Quick Text check box.
5 Click OK.
6 To regenerate your drawing, do one of the following:

• Choose View > Regen.

• On the View toolbar, click the Regen tool ( ).

• Type regen and then press Enter.

Quick Text off. Quick Text on.
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Turning highlighting on and off
You can improve overall program performance by turning highlighting off. When 
you select entities to modify, the program highlights them using a dashed linetype. 
This highlight disappears when you finish modifying the entities or when the entities 
are cleared. Sometimes highlighting entities can take a considerable amount of time. 

To turn highlighting on and off
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type highlight, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.
3 Under Change Settings For, click Display.
4 Select or clear the Highlight Item When Selected check box.
5 Click OK.



116   C H A P T E R  6
Turning Blips on and off
You can turn Blips off. They are the temporary markers that appear on the screen 
when you select an entity or location. Blips are visible only until you redraw the 
drawing. You cannot select Blips; they are used only for reference and never print.

To turn Blips on and off
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type blipmode, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.
3 Under Change Settings For, click Display.
4 Select or clear the Show Marker Blips check box.
5 Click OK.

Blips on. Blips off.
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Working with coordinates

For accuracy in a drawing, you can locate specific points by entering coordinates as 
you draw or modify entities. When you create two-dimensional entities, you enter 
two-dimensional coordinates; for three-dimensional entities, you specify three-
dimensional coordinates.

You can also specify coordinates in relation to other known locations or entities in a 
drawing. In particular, when you work in three-dimensional drawings, it is often eas-
ier to specify coordinates in relation to a two-dimensional working plane, called a 
user coordinate system (UCS).

This chapter explains how to work with coordinates, including how to:

• Use two-dimensional and three-dimensional coordinate systems.
• Specify absolute and relative coordinates.
• Specify polar, spherical, and cylindrical coordinates.

• Define and manipulate user coordinate systems.

Topics in this chapter
Using Cartesian coordinates..............................................................................118
Using two-dimensional coordinates .................................................................. 121
Using three-dimensional coordinates ............................................................... 125
Using xyz point filters........................................................................................ 128
Defining user coordinate systems..................................................................... 130
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Using Cartesian coordinates  

Many commands in IntelliCAD® require that you specify points as you draw or mod-
ify entities. You can do so by selecting points with the mouse or by typing coordinate 
values in the command bar. The program locates points in a drawing using a Carte-
sian coordinate system. 

Understanding how coordinate systems work  
The Cartesian coordinate system uses three perpendicular axes—x, y, and z—to spec-
ify points in three-dimensional space. Every location in a drawing can be represented 
as a point relative to a 0,0,0 coordinate point, referred to as the origin. To draw a two-
dimensional entity, you specify horizontal coordinate positions along the x-axis and 
vertical coordinate positions along the y-axis. Thus, every point on a plane can be 
represented as a coordinate pair composed of an x-coordinate and a y-coordinate. 
Positive coordinates are located above and to the right of the origin; negative coordi-
nates are located to the left and below the origin.               
     

When you work in two dimensions, you need enter only the x- and y-coordinates; the 
program assumes that the z-axis value is always the current elevation. When you 
work in three dimensions, however, you must also specify the z-axis value. When you 
look at a plan view of your drawing (a view from above, looking down), the z-axis 
extends straight up out of the screen at a 90-degree angle to the xy plane. Positive 
coordinates are located above the xy plane, and negative coordinates are below the 
plane.

The three perpendicular axes of the Cartesian coordinate system.
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All IntelliCAD drawings use a fixed coordinate system, called the World Coordinate 
System (WCS), and every point in a drawing has a specific x,y,z-coordinate in the 
WCS. You can also define arbitrary coordinate systems located anywhere in three-
dimensional space. These are called user coordinate systems and can be located any-
where in the WCS and oriented in any direction.           

You can create as many user coordinate systems as you want, saving or redefining 
them to help you construct three-dimensional entities. By defining a UCS within the 
WCS, you can simplify the creation of most three-dimensional entities into combina-
tions of two-dimensional entities.     

To help you keep your bearings in the current coordinate system, the program dis-
plays a coordinate system icon. When you begin a new drawing, you are automati-
cally in the WCS, indicated by the letter W in the icon. When you display a drawing 
in plan view, you see the coordinate system icon from the top, with the z-axis directed 
straight toward you. When you display a three-dimensional drawing in a view other 
than plan view, the coordinate system icon changes to reflect your new viewpoint.         

TIP The visible portions of the axes are the positive directions. 

    

The IntelliCAD UCS icon looks different from the UCS icon in AutoCAD, because it 
presents more information. Three colors represent the three axes, making it easier for 
you to recognize the orientation in three-dimensional space:

• x-axis: red
• y-axis: green

• z-axis: blue 

If you prefer a single color for the cursor and UCS icon, you can make that change 
with the config or options command.

WCS icon. Plan UCS icon. 3D View WCS icon.
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Understanding how coordinates are displayed
The current position of the cursor is displayed as x,y,z-coordinates in the status bar 
and, by default, updates dynamically as you move the cursor. You can toggle the 
coordinate display to static mode by pressing F6, so that it updates only when you 
select a point in the drawing.         

You can also change the coordinate display to a different dynamic mode that shows 
the distance and angle (rather than x,y,z-coordinates) when the program displays a 
rubber-band line. To do this, choose Settings > Drawing Settings and select the Dis-
play tab. Under Coordinate Display, select the option for Coordinates In Polar Form 
For Distance And Angle Selection.                
       

  
The coordinates display on the status bar shows the current cursor position.

You can control the coordinate display from the Drawing Settings dialog box.
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Finding the coordinates of a point
To find the x,y,z-coordinates for a point on an entity, such as the endpoint of a line, 
select an appropriate entity snap (such as Endpoint) before selecting the entity. If you 
have no entity snaps set, the x,y-coordinates of the point you specified is displayed, 
with the z-coordinate equal to the current elevation.   

To find the coordinate of a point in the drawing
1 Do one of the following: 

• Choose Tools > Inquiry > ID Coordinates.

• On the Inquiry toolbar, click the ID Coordinates tool ( ).

• Type idpoint and then press Enter.

2 Select the point for which you want to find the coordinates.
If the command bar is activated, the x,y,z-coordinates for the point you selected 
display in the command bar.
If the command bar is not activated, the Prompt History window displays, show-
ing the x,y,z-coordinates for the point you selected.

Using two-dimensional coordinates

When working in two dimensions, you specify points on the xy plane. You can spec-
ify any point as an absolute coordinate (or Cartesian coordinate), using the exact x-
coordinate and y-coordinate locations in relation to the origin (the 0,0 coordinate 
point at which the two axes intersect), or as a relative coordinate in relation to the pre-
vious point. You can also specify points using relative or absolute polar coordinates, 
which locate a point using a distance and an angle. 
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Entering absolute Cartesian coordinates
To enter absolute Cartesian coordinates, type the coordinate location of the point in 
the command bar. For example, to use absolute Cartesian coordinates to draw a line 
from the origin (0,0) to a point 3 units to the right and 1 unit above the origin, start the 
Line command and respond to the prompts as follows:     

Start of line: 0,0

Angle • Length • <Endpoint>: 3,1   

When using absolute Cartesian coordinates, you need to know the exact point loca-
tions for anything you draw. For instance, to use absolute Cartesian coordinates to 
draw an 8.5-unit square with its lower left corner at 4,5, you must determine that the 
upper left corner is at coordinate 4,13.5, the upper right corner at 12.5,13.5, and the 
lower right corner at 12.5,5.

Drawing a line using the absolute Cartesian coordinate method.

1
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(3, 1)
(0, 0)
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Entering relative Cartesian coordinates
Another, simpler method is to use relative Cartesian coordinates: you specify a 
location in the drawing by determining its position relative to the last coordinate you 
specified. To use relative Cartesian coordinates, type the coordinate values in the 
command bar, preceded by the at symbol (@). The coordinate pair following the @ 
symbol represents the distance along the x-axis and the y-axis to the next point. For 
example, to draw an 8.5-unit square with its lower left corner at 4,5 using relative 
Cartesian coordinates, start the Line command, and then respond to the prompts as 
follows:

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5,0

Angle • Length • Follow • Undo • <Endpoint>: @0,8.5

Angle • Length • Follow • Close • Undo • <Endpoint>: @-8.5,0

Angle • Length • Follow • Close • Undo • <Endpoint>: C

  

The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right 
(along the x-axis) from the previous point of 4,5; the second relative coordinate 
(@0,8.5) locates the next point 8.5 units above (along the y-axis) the previous point, 
and so on. Entering C (for Close) draws the final line segment back to the first point 
specified when you started the Line command.                      

Drawing a square using the relative Cartesian coordinates method; enter C to close.
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Entering polar coordinates
Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a 
simple task. Polar coordinates base the location of a point on a distance and angle 
from either the origin (absolute coordinate) or from the previous point (relative coor-
dinate).                                

To specify polar coordinates, type a distance and an angle, separated by the open 
angle bracket (<). For example, to use relative polar coordinates to specify a point 1 
unit away from the previous point and at an angle of 45 degrees, type @1<45.                 

To draw the square from the example in the previous section, “Entering relative Car-
tesian coordinates,” this time tilted at a 45-degree angle, start the Line command, and 
then respond to the prompts as follows:     

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5<45

Angle • Length • Follow • Undo • <Endpoint>: @8.5<315

Angle • Length • Follow • Close • Undo • <Endpoint>: @8.5<225

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

  

NOTE  This example, like all examples in this guide, assumes the program’s default 
settings: Angles increase counterclockwise and decrease clockwise. Thus, an angle of 
315 degrees is the same as -45 degrees.

Drawing a tilted square using the relative polar coordinates method; enter C to close.
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Using three-dimensional coordinates  

Specifying coordinates in three-dimensional space is similar to working in two 
dimensions, except that you also use the z-axis to locate coordinates. Three-dimen-
sional coordinates are represented in the format x,y,z (for example, 2,3,6). 

Using the right-hand rule   
To visualize how IntelliCAD works with three-dimensional space, use a technique 
known as the right-hand rule. Hold up your right hand in a loose fist with your palm 
facing you. Extend your thumb in the direction of the positive x-axis and your index 
finger upward in the direction of the positive y-axis. Then extend your middle finger 
straight toward you in the direction of the z-axis. These three fingers are now pointing 
in the positive x, y, and z directions, respectively.        

You can also use the right-hand rule to determine the positive rotation direction. Point 
your thumb in the positive direction of the axis about which you want to rotate, and 
then curl the rest of your fingers toward your palm. These fingers are curling in the 
positive rotation direction.       

Entering x,y,z-coordinates  
When working in three dimensions, you can specify x,y,z-coordinates as absolute dis-
tances in relation to the origin (the 0,0,0 coordinate point at which the three axes 
intersect) or as relative coordinates based on the last point selected. For example, to 
specify a point 3 units along the positive x-axis, 4 units along the positive y-axis, and 
2 units along the positive z-axis, specify the coordinate 3,4,2.    

The right-hand rule helps you determine the positive direction of the x-, y-, and z-axes and the 
positive rotation direction.

Y

Z

X
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Entering spherical coordinates

When working in three-dimensional space, you can use spherical coordinates to spec-
ify a three-dimensional point by entering its distance from either the origin (absolute 
distance) or the last point (relative distance), along with its angle in the xy plane and 
its angle up from the xy plane. In spherical format, you separate each angle with the 
open angle bracket (<).              

Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an 
angle of 45 degrees from the x-axis and 35 degrees from the xy plane, start the Line 
command, and then respond to the prompts as follows:

Start of line: 0,0,0

Angle • Length • <Endpoint>: 10.2500<45<35 

  

When you draw a line from a start point (A) to an endpoint (B) using spherical coordinates, you 
specify its length (C, in this case 10.2500 units), the angle in the xy plane (D, in this case 45 
degrees), and the angle from the xy plane (E, in this case 35 degrees).

A
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C
E

D
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Entering cylindrical coordinates  
When working in three-dimensional space, you can also use cylindrical coordinates 
to specify a three-dimensional point. You specify a point by entering its distance from 
either the origin (absolute distance) or the last point (relative distance), its angle in the 
xy plane, and its z-coordinate value.       

In cylindrical format, you separate the distance and angle with the open angle 
bracket (<) and separate the angle and z value with a comma. For example, to draw a 
line from the last point to a point 7.4750 units away, at an angle of 27 degrees from 
the x-axis in the xy plane and 3 units up in the z direction, start the Line command, 
and then respond to the prompts as follows: 

Start of line: (select point A)

Angle • Length • <Endpoint>: @7.4750<27,3 

 

When you draw a line from a start point (A) to an endpoint (B) using cylindrical coordinates, 
you specify its length (C, in this case 7.4750), the angle in the xy plane (D, in this case 27 
degrees), and the distance in the z direction (E, in this case 3 units).
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Using xyz point filters  

Point filters provide a method of locating a point in a drawing relative to another 
point without specifying the entire coordinate. Using a point filter, you can enter par-
tial coordinates, and then the program prompts you for the remaining coordinate 
information. To use xyz point filters, respond to the prompt for a coordinate with a 
filter in the following form:          

.coordinate

where coordinate is one or more of the letters x, y, and z. The program then prompts 
you for the filtered coordinate(s). For example, if you type .xy, the program prompts 
you to select a point whose xy-coordinate you want, and then prompts you for the z-
coordinate. The filters .x, .y, .z, .xy, .xz, and .yz are all valid filters.

Using point filters in two dimensions
You can use point filters when you work in two dimensions to locate points in rela-
tion to existing entities. For example, to draw a circle centered in a rectangle, start the 
Circle command, and then respond to the prompts as follows:

2Point • 3Point • RadTanTan • Arc • Multiple • <Center of circle>: .y

Select Y of: mid

Snap to midpoint of: (select the left side of the rectangle)

Still need XZ of: mid

Snap to midpoint of: (select top of the rectangle)

Diameter • <Radius>: (specify radius of circle) 

  

You can use point filters to center the circle by separately selecting the midpoints of 
two sides of the rectangle (A and B) and then specifying its radius.

A

B
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Using point filters in three dimensions
You can use point filters when you work in three-dimensional space to locate points 
in two dimensions and then specify the z-coordinate as the elevation above the xy 
plane. For example, to begin drawing a line from a point with a z-coordinate 3 units 
above the center of a circle, insert the circle, and then start the Line command and 
respond to the prompts as follows:       

ENTER to use last point • Follow • <Start of line>: .xy

Select XY of: cen

Snap to centerpoint of: (select a point on the circle)

Still need Z of: 3 (locates the starting point 3 units above the center of 

the circle)

Length of line: (specify the length of the line) 

  

You can use point filters to draw a line by first selecting a point in the xy plane (A), 
specifying the z-coordinate (B), and then specifying the length of the line (C).
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Defining user coordinate systems  

When working in three-dimensional space, you can define a UCS with its own 0,0,0 
origin and orientation separate from the WCS. You can create as many user coordi-
nate systems as you want, and then save and recall them as you need them to simplify 
construction of three-dimensional entities.               

For example, you can create a separate UCS for each side of a building. Then, by 
switching to the UCS for the east side of the building, you can draw the windows on 
that side by specifying only their x- and y-coordinates. When you create one or more 
user coordinate systems, the coordinate entry is based on the current UCS. 
  

Defining a user coordinate system
To define a UCS, you can use any of the following methods:

• Specify a new origin and points on the positive x- and y-axes.
• Specify a new origin and point on the positive z-axis.
• Align the UCS with an existing entity.    
• Rotate the current UCS around any of its axes.     
• Align the UCS with its z-axis parallel to the current viewing direction.

• Align the UCS xy plane perpendicular to the current view.

When you define a new UCS, the UCS icon changes to indicate the origin and orien-
tation of the new UCS.

UCS aligned with the front wall of the house.
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To define a UCS by specifying a new origin and points on the positive x- and y-
axes     
1 Do one of the following: 

• Choose Settings > User Coordinate Systems.

• On the Settings toolbar, click the User Coordinate Systems tool ( ).

• Type setucs and then press Enter.

2 In the User Coordinate Systems dialog box, click Explore UCSs.
3 In the IntelliCAD Explorer, be sure that Coordinate Systems is selected, and click 

the New Item tool ( ).     
4 In the prompt box, choose 3 Point.
5 Select the new origin.
6 Select a point on the positive x-axis.
7 Select a point in the positive y direction.
8 In the IntelliCAD Explorer - Coordinate Systems dialog box, type the name for the 

new UCS, and then close the dialog box.  

Using a preset user coordinate system
IntelliCAD lets you select a preset UCS. The six planes defined by looking along the 
x,y,z-axes align the UCS with the top, left, front, bottom, right, or back, based on 
either the WCS or the current UCS in effect when you select the tool. You can also 
select the previous UCS, align the UCS to the current view, or select the WCS.

When you select a UCS, the cursor orientation and UCS icon change to reflect the 
new UCS. The display does not change, however, unless you select the Change View 
To Plan View Of The Selected UCS check box.     

After you align the UCS to a preset UCS, you can use the IntelliCAD Explorer to 
save the UCS. To do this, in the IntelliCAD Explorer window, choose Edit > New > 
UCS, and then select Current.

Define the new UCS by selecting the origin (A), a point on the positive x-axis 
(B), and a point in the positive y direction (C).

A

B

C
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To select a preset UCS 
1 Do one of the following: 

• Choose Settings > User Coordinate Systems.

• On the Settings toolbar, click the User Coordinate Systems tool ( ).

• Type setucs and then press Enter.

2 Under Set The Selected UCS Relative To, select either Current UCS to change to 
the new UCS by reorienting relative to the current UCS or World Coordinate Sys-
tem (WCS) to base the new UCS orientation on the WCS.

3 Under Select UCS, click the button corresponding to the UCS you want as the new 
current UCS. 

  

A Specify whether to define the new UCS relative 
to the current UCS or to the World Coordinate 
System (WCS).

B Select to change the display to the plan view of 
the new UCS. 

C Click to select the previous UCS. 

D Click one of these buttons to select the view you 
want of a preset UCS.

E Click to select the WCS.
F Click to align the UCS with the current view.
G Click to display the IntelliCAD Explorer. 
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Working with the IntelliCAD Explorer

The IntelliCAD Explorer provides a powerful and convenient way to maintain and 
manage many of the features and settings of your drawings. You can use the Intelli-
CAD Explorer to work with layers, linetypes, text styles, coordinate systems, named 
views, blocks, and dimension styles within the current drawing or to copy this infor-
mation between drawings.

This section explains how to use the IntelliCAD Explorer to:

• Manage elements related to settings and entities in your drawings.
• Organize information on layers and manage layers.
• Create and use linetypes.
• Load text fonts and create text styles.
• Select and control coordinate systems.
• Save and restore named views.
• Save, insert, and manage blocks.

• Copy, cut, and paste dimension styles between DWG files.

Topics in this chapter
Using the IntelliCAD Explorer ........................................................................... 134
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Working with text fonts and styles .................................................................... 156
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Working with dimension styles.......................................................................... 174
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Using the IntelliCAD Explorer 

The IntelliCAD Explorer opens in its own, separate window, which you can move or 
resize. The IntelliCAD Explorer window has its own menu and tools. 

To display the IntelliCAD Explorer

Do one of the following:    
• Choose Tools > IntelliCAD Explorer.     
• On the Tools toolbar, click the IntelliCAD Explorer tool ( ).
• Type explayers and then press Enter.       
• Type la and then press Enter.

• On the status bar, right-click on the current layer, and from the list, select the layer 
you want to make current.

The IntelliCAD Explorer window has two panes, a left pane and a right pane. The 
elements are listed in the left pane, and the drawing settings are listed and described 
in the right pane.

TIP On the Settings menu, you can use the Explore Layers, Explore Blocks, Explore 
Views, Explore Coordinate Systems, Explore Linetypes, Explore Text Styles, and 
Explore Dimension Styles commands to display the layers, blocks, views, coordinate 
systems, linetypes, text styles, and dimension styles for the current drawing in the 
IntelliCAD Explorer window. Tools for these commands also appear on the Settings 
toolbar.        
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A Tools on the Standard toolbar provide controls common to all 
elements.

B The Elements pane shows an outline view containing the name of 
every drawing currently open and lists the elements you can control 
in each drawing.      

C  Click on a setting to change it.
D The named settings for the selected element.
E Other toolbars appear, depending on the selection in the Elements 

pane.
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Using the IntelliCAD Explorer, you can create, delete, or modify any of the settings 
for the currently selected element for a given drawing. You can also copy the contents 
of any element from one drawing to another. The tools and menu items on the Intelli-
CAD Explorer provide the following functions:         

Copying settings   
A particularly powerful feature of the IntelliCAD Explorer is its capability of copying 
many of the settings—layers, linetypes, text styles, coordinate systems, views, blocks, 
or dimension styles—from one drawing to another. If you have more than one draw-
ing open, the IntelliCAD Explorer makes it easy to reuse information. For example, 
when you copy layers from one drawing to another, the layer names as well as their 
linetypes, colors, and other settings are also copied, but not the entities on those lay-
ers.    

IntelliCAD Explorer tools    

Tool Function

( ) New Item Creates a new layer, linetype, style, coordinate system, view, block, or 
dimension style.

( ) Current Makes the selection current.

( ) Cut Cuts the selection to the Clipboard.

( ) Copy Copies the selection to the Clipboard.

( ) Paste Pastes the selection from the Clipboard into the appropriate list of a 
different drawing.

( ) Delete Deletes the selection from the list.

( ) Properties Displays the properties for the selection.

( ) World Sets the current coordinate system to the World Coordinate System 
(WCS).

( ) Purge Eliminates unreferenced elements from your drawing file.
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To copy layers from one open drawing to another open drawing
1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Elements pane, select the drawing from which you want to copy layers.
3 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 

and then click Layers.
4 In the Layers Settings In Drawing list (right pane), select the layers you want to 

copy.
5 Choose Edit > Copy, or click the Copy tool ( ).
6 In the Elements pane, select the drawing to which you want to copy the layers.
7 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 

and then click Layers.
8 Choose Edit > Paste, or click the Paste tool ( ).

Deleting settings   
You can use the IntelliCAD Explorer to delete many of the items that appear in the 
Elements list. You can delete a layer, linetype, text style, coordinate system, view, 
block, or dimension style.     

Because you may have already created entities on a particular layer or using a partic-
ular linetype or text style, deleting one of these elements requires that you make cer-
tain choices from options the program presents. For example, if you attempt to delete 
a layer, the program prompts you to specify whether you want to move any entities 
from that layer to another layer. Every drawing has at least one layer, the default 
layer, named “0.” You cannot delete or rename this layer. Your drawing can also con-
tain an unlimited number of additional layers, each of which you assign a unique 
name.    

If you try to delete a linetype, the program prompts you to specify whether you want 
to convert all entities drawn using that linetype to a different linetype. If you attempt 
to delete a text style, the program prompts you to specify whether you want to convert 
all text entities created using that style to a different style.    
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To delete a layer and relocate its entities to another layer
1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 From the Layer Name list, select the layer that you want to delete.
If that layer is the current layer, layer 0 automatically becomes the current layer.

3 Choose Edit > Delete, or click the Delete tool ( ).
4 From the dialog box, click Change.
5 In the drop-down list, double-click the layer to which you want to relocate entities.      

A Click to delete the layer and all entities on 
the layer.

B Click to delete the layer after first relocating all of 
its entities to a selected layer.

C Click to cancel the layer deletion.

A

B

C
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Purging elements    
From within the IntelliCAD Explorer, you can eliminate unused blocks, layers, line-
types, text styles, or dimension styles from your drawing file. Purging unused ele-
ments can significantly reduce the drawing file size.

To purge an element
1 Do one of the following:

• Choose Tools > IntelliCAD Explorer.

• On the Tools toolbar, click the IntelliCAD Explorer tool ( ).

• Type explayers and then press Enter.

2 Select the element from which you want to purge unreferenced elements.
3 From the Standard toolbar, select the Purge tool ( ). 

The main drawing window appears. 
4 From the prompt box, select Yes to purge the element listed in the command line, 

or select Yes To All to purge all unused elements.

Organizing information on layers 

Layers in IntelliCAD® 2001 are like the transparent overlays you use in manual draft-
ing. You use layers to organize different types of drawing information. In IntelliCAD, 
each entity in a drawing exists on a layer. When you draw an entity, it is created on 
the current layer.    

You can control the visibility of layers in individual viewports. When you turn a layer 
off, entities drawn on that layer are no longer visible, and they do not print. Although 
a layer may be invisible, you can still select it as the current layer, in which case new 
entities are also invisible until you turn the layer back on. Entities on invisible layers 
can also affect the display and printing of entities on other layers. For example, enti-
ties on invisible layers can hide other entities when you use the Hide command to 
remove hidden lines.    

You can also freeze and thaw layers. Entities drawn on frozen layers do not display, 
do not print, and do not regenerate. When you freeze a layer, its entities do not affect 
the display or printing of other entities. For example, entities on frozen layers do not 
hide other entities when you use the Hide command to remove hidden lines. In addi-
tion, you cannot draw on a frozen layer until you thaw it, and you cannot make a fro-
zen layer current.     

You cannot freeze the current layer. If you attempt to freeze the current layer, a dia-
log box appears prompting you to specify a different layer. You also cannot freeze or 
thaw a viewport layer. To set this property, you must set TILEMODE to Off.
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You can lock or unlock layers. The entities on a locked layer are still visible and will 
print, but you cannot edit them. Locking a layer prevents you from accidentally mod-
ifying entities.     

Each layer has its own color and linetype. Entities you draw on a particular layer are 
displayed in the color and linetype associated with that layer unless you override 
these settings. You control all of the associated settings for layers using the Layers 
elements in the IntelliCAD Explorer.    

To display layers in the IntelliCAD Explorer

Do one of the following:       
• Choose Settings > Explore Layers.
• Choose Tools > IntelliCAD Explorer.
• On the Tools toolbar, click the IntelliCAD Explorer tool ( ).
• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter. 
     

A Select Layers to display the Layers settings.     
B Lists named layers in the current drawing. A check mark 

indicates the current layer.
C Displays the color assigned to each layer.
D Displays the linetype assigned to each layer.
E Indicates the visibility status of each layer.     
F Indicates the locked or unlocked status of each layer. 

G Indicates the frozen or thawed status of each layer for all viewports.
H Indicates the frozen or thawed status of the layer in the current 

viewport.
I Indicates the frozen or thawed status of the layer for new viewports in 

paper space.
J Sorts the layers by that property when you click a column head.



W O R K I N G  W I T H  T H E  I N T E L L I C A D  E X P L O R E R    141
When Layers are displayed, three tools on the Layer toolbar provide the following 
functions:

( ) Layer On/OffToggles the selected layers on and off.     

( ) Freeze/ThawFreezes or thaws the selected layers.    

( ) Lock/UnlockLocks or unlocks the selected layers.

You can change any of these settings by clicking either the tool or its current condi-
tion. You can edit the color and linetype of a layer by clicking the color or linetype 
name and selecting the values you want in the dialog box.

Creating and naming layers 
You can create an unlimited number of layers in every drawing and use those layers 
for organizing information. When you create a new layer, it is initially assigned the 
color white (or black, depending on your system settings) and the linetype CONTIN-
UOUS. By default, a new layer is also visible. After you create and name a layer, you 
can change its color, linetype, visibility, and other properties.     

NOTE  Layer names created or renamed in IntelliCAD can have up to 31 characters 
and cannot include spaces. IntelliCAD will, however, display longer layer names and 
names containing spaces, such as layers created in AutoCAD 2000.

To create a new layer
1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 Choose Edit > New > Layer.
The program adds a new layer to the Layer Name list, with the default name 
NewLayer1.

3 Type a name for the new layer over the highlighted default name, and then press Enter.
4 To complete the command and return to your drawing, close the window.

TIP You can also create a new layer by selecting the Layers element for a drawing 
and clicking the New Item tool ( ).
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To change a layer name in the current drawing
1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layer you want to make current.
3 Do one of the following:

• Choose Edit > Rename, type a new name, and then press Enter.

• Highlight the layer name you want to change, type a new name, and then press 
Enter.

• Right-click the layer name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

4 To complete the command and return to your drawing, close the window.    

NOTE  You cannot rename the 0 layer.

Setting the current layer
When you create new entities, they are drawn on the current layer. To draw new enti-
ties on a different layer, you must first make that layer the current layer.   

To make a layer current 
1 Do one of the following:

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layer you want to make current.
3 Do one of the following:

• Choose Edit > Current.

• In the Layer Name list, select the name you want to make current, and then click 
the Current tool ( ).

• Double-click the layer name in the Layer Name list. 

• Right-click the layer name you want to change, and from the shortcut menu 
select Current. 

4 To complete the command and return to your drawing, close the window.
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To set the current layer to that of an existing entity
1 Do one of the following:      

• Choose Settings > Set Layer By Entity.

• On the Settings toolbar, click the Set Layer By Entity tool ( ).

• Type setlayer and then press Enter.

2 Select the entity to set the current layer.    

Controlling layer visibility   
A layer can be visible or invisible. Entities on invisible layers are not displayed and 
do not print. By controlling layer visibility, you can turn off unnecessary information, 
such as construction lines or notes. By changing layer visibility, you can put the same 
drawing to multiple uses.    

For example, if you are drawing a floor plan, you can draw the layout of light fixtures 
on one layer and the location of plumbing lines on another. By selectively turning 
layers on and off, you can print the electrical engineering drawings and the plumbing 
drawings from the same drawing file. For even more convenience, you can control 
the visibility of layers within individual viewports, so that layers that display in one 
viewport are invisible in other viewports in the same drawing.

When you turn a layer off, entities drawn on that layer are no longer visible. When 
you turn the layer back on, the entities on that layer are redisplayed.

To turn layers on or off
1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layer you want to turn on or off.
3 Do one of the following:

• Choose View > On/Off.

• Right-click the layer you want to change, and from the shortcut menu, select 
Properties and turn the layer on or off. 

• Click the setting in the On/Off column.

The On/Off column shows the new setting.
4 To complete the command and return to your drawing, close the window.

You can also freeze layers to improve the performance of operations such as zooming 
and panning or producing hidden lines or shaded images. When a layer is frozen, 
entities drawn on that layer are no longer visible.    

To control the visibility of external reference layers and save any changes made to 
them in the current drawing, turn on the XRef Layer Visibility system variable.



144   C H A P T E R  8
To turn on XRef Layer Visibility
1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter

2 Choose View > XRef Layer Visibility.

TIP  You can also turn on this variable by typing visretain.

To freeze or thaw layers
1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layers you want to freeze or thaw.
3 Do one of the following:

• Choose View > Freeze/Thaw.

• Right-click the layer you want to change, and from the shortcut menu, select 
Properties and freeze or thaw the layer.

• Click the setting in the All Viewports column.

The All Viewports column shows the new setting.
4 To complete the command and return to your drawing, close the window.
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Locking and unlocking layers 
Locking a layer makes it easy to refer to information contained on the layer, but pre-
vents you from accidentally modifying its entities. When a layer is locked (but visible 
and thawed), its entities remain visible, but you cannot edit them. If you lock the cur-
rent layer, you can still add new entities to it. You can also change the linetype and 
color associated with a locked layer. Unlocking a layer restores full editing capabili-
ties.    

To lock or unlock layers
1 Do one of the following:

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layers you want to lock or unlock.
3 Do one of the following:

• Choose View > Lock/Unlock.

• Right-click the layer name you want to change, and from the shortcut menu, 
select Properties and lock or unlock the layer.

• Click the setting in the Locked column.

The Locked column shows the new setting.
4 To complete the command and return to your drawing, close the window.

Setting the layer color   
Each layer in a drawing is assigned a color. IntelliCAD uses the BYLAYER color as 
the default color setting for entity creation so that new entities are drawn in the color 
of the layer on which they are inserted (set in the Drawing Settings dialog box).    

Using the IntelliCAD Explorer, you can set or change the color assigned to a layer. 
With the direct-editing feature, you can click on the color you want to change, and 
then select a new color from the dialog box that appears. Changing a layer’s color 
automatically changes the color of all entities on that layer with the BYLAYER color.
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To change the layer color
1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the right pane, click the color swatch for the layer you want to change.
3 Do one of the following:

• In the Color dialog box, select the color you want, and then click OK. 

• Right-click the layer you want to change, and from the shortcut menu, select 
Properties and change the layer color.

NOTE You can also assign a specific color to an entity, which overrides the layer’s 
color setting. When you create a new entity, use the Settings > Colors > Select Colors 
command to change the current color. For an existing entity, select the entity, right-
click for the shortcut menu, and choose Properties. You can then change the entity’s 
color in the Entity Properties dialog box.      

   

A Select to keep the dialog box on the screen 
when you switch back to the IntelliCAD Explorer.

B Displays the name of layer whose properties are 
being changed.

C Displays the current layer color.

D Click to display the Color dialog box to select a 
new color.   

E Choose the linetype assigned to the selected 
layer.

F Select or clear check boxes to control other 
properties of the selected layer.

A
B

C
D F

E
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Setting a layer’s linetype    
Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). 
Linetype determines the appearance of entities both on the screen and when printed.    

It’s a good idea to assign the BYLAYER linetype to any entities that you draw on that 
layer. IntelliCAD uses the BYLAYER linetype as the default linetype setting for 
Entity Creation (in the Drawing Settings dialog box).

Using the IntelliCAD Explorer, you can set or change the linetype assigned to a layer. 
With the direct-editing feature, you can click on the linetype you want to change, and 
then select a new linetype from the dialog box that appears. Changing the linetype 
assigned to a layer changes the linetype of all entities drawn on that layer with the 
BYLAYER linetype.

NOTE  Only those linetypes already set in the drawing can be assigned to layers. For 
more information about setting additional linetypes, see the next section, “Working 
with Linetypes.”

To change the linetype assigned to one or more layers
1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the right pane, click the linetype for the layer you want to change.
3 In the Linetype dialog box, select a new linetype for the layer, or click Browse to 

select your linetype file.

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the linetype assigned to a layer.

NOTE  You can also assign a specific linetype to an entity, which overrides the layer’s 
linetype setting. When you create a new entity, use the Settings > Explore Linetypes 
command to change the current linetype through the IntelliCAD Explorer. For an 
existing entity, select the entity, right-click for the shortcut menu, and choose Proper-
ties. You can then modify the entity’s linetype in the Entity Properties dialog box.    
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Working with linetypes 

IntelliCad provides simple and complex linetypes:

• A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces.
• A complex linetype contains embedded shape and text objects along with 

dots, dashes, and spaces.
You can use different linetypes to represent specific kinds of information. For exam-
ple, if you are drawing a site plan, you can draw roads using a continuous linetype, a 
fence using a using a linetype of dashes square posts, or a gas line using a complex 
linetype showing the text ’GAS’.

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, 
and BYBLOCK. You cannot rename or delete these linetypes. Your drawing may 
also contain an unlimited number of additional linetypes. You can load more line-
types into the program from a linetype library file or create and save linetypes you 
define. 

To display the IntelliCAD Explorer Linetypes element
Do one of the following:    
• Choose Settings > Explore Linetypes.
• On the Settings toolbar, click the Explore Linetypes tool ( ).
• Type expltypes and then press Enter.

• Choose Tools > IntelliCAD Explorer, and then click the Linetypes element.   



W O R K I N G  W I T H  T H E  I N T E L L I C A D  E X P L O R E R    149
 

Setting the current linetype
You normally draw an entity using the linetype assigned to the current layer, indi-
cated as BYLAYER. You can also assign linetypes on a per-entity basis, which over-
rides the layer’s linetype setting. A third option is to assign the BYBLOCK linetype, 
whereby you draw new entities using the default linetype until you group them into a 
block. The entities inherit the current linetype setting when you insert the block into 
the drawing.    

To make the linetype current
1 Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 In the Linetype Name list, select the linetype you want to make current.
3 Do one of the following:

• Choose Edit > Current.

• Select it in the Linetype Name list and click the Current tool ( ).

• Double-click the linetype name.

4 To complete the command and return to your drawing, close the window.

A Select Linetypes to display the Linetypes settings.
B Lists names of linetypes loaded in the current drawing. A check 

mark indicates the current linetype.
C Describes linetypes loaded in the current drawing.

D Shows how linetypes will appear in the drawing.
E Sorts the linetypes by that property when you click a column head.
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Loading additional linetypes 
Before you can select a new linetype to use in a drawing, you must either create the 
linetype definition or load a predefined linetype from a linetype library file (*.lin). 
IntelliCAD includes a linetype library file, icad.lin, which contains more than 100 
predefined linetypes.    

To load a new linetype from a linetype library
1 Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:
• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With the cursor in the right pane of the window, right-click to display the 
shortcut menu, and then choose New > Linetype.

3 Click Choose From File.
4 Click Browse. 
5 Select the linetype library file, and then click Open.
6 Select the linetype you want to load.
7 Click OK, and then close the window.
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Creating and naming linetypes 
In addition to loading predefined linetypes from a linetype library file, you can create 
new linetypes. You can save new linetypes you create to a linetype library file for use 
in other drawings.   

NOTE  Linetype names created or renamed in IntelliCAD can have up to 31 charac-
ters and cannot include spaces. IntelliCAD will, however, display longer linetype 
names and names containing spaces, such as linetypes created in AutoCAD 2000.

To create a new simple linetype   
1 Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:
• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose New > Linetype.

3 In the Linetype Description field, type the linetype description.
You can type anything in this field that will help you remember the purpose or 
appearance of this linetype. For example, it is helpful to type text or symbols such 
as __..__.. that approximate the appearance of the linetype.

4 In the Linetype Definition field, type the linetype definition.
The definition consists of positive and negative numbers separated by commas. A 
positive number draws a solid line segment for the specified number of drawing 
units; a negative number creates a gap for the specified number of units; a zero 
creates a dot.   

5 Click OK.
The program adds the new linetype to the linetypes list with the default name, 
NewLinetype1.

6 To enter a name for the new linetype, type over the highlighted default text, and 
press Enter.
Do not use spaces between words in the new linetype name.

7 To complete the command and return to your drawing, close the window.
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To create a new complex linetype
A complex linetype can denote utilities, boundaries, contours, and so on. As with 
simple linetypes, complex lines are dynamically drawn as the user specifies vertices. 
Shapes and text objects embedded in lines are always displayed completely; they are 
never trimmed.

1 Do one of the following: 
• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:
• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the shortcut 
menu, and choose New > Linetype.

3 In the Linetype Description field, type the linetype description.
You can type anything in this field that will help you remember the purpose or 
appearance of this linetype. For complex linetypes, it is helpful to type a text 
description of the linetype.

4 In the Linetype Definition field, type the linetype definition.
As for the simple linetypes, the syntax for a complex linetype is a comma delimi-
nated list of pattern descriptors. see “Syntax for a complex linetype definition” on 
page 157 in this chapter.

A Click to select a predefined linetype from a 
linetype library file.

B Type any description in this box that helps you 
remember the purpose or appearance of the 
linetype.

C Type the definition of the linetype, consisting of 
positive and negative numbers separated by 
commas.

A

B

C
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5 Click OK.
The program adds the new linetype to the linetypes list with the default name, 
NewLinetype1.

6 To enter a name for the new linetype, type over the highlighted default text, and 
press Enter.
Do not use spaces between words in the new linetype name.

7 To complete the command and return to your drawing, close the window.

Syntax for a complex linetype definition
Complex linetypes can include shape and text objects as pattern descriptors, as well 
as the dash and dot descriptors of simple linetypes.

The shape descriptor syntax 
You can add a shape object to a complex linetype using the following syntax:

[shape_name, shape_filename] or [shape_name, shape_filename, transform]

The definitions of the fields in the syntax are as follows.

shape_name The name of the shape to add to the linetype. The shape name must exist 
in the specified shape file (shape_filename).

shape_filename The name of a compiled shape definition file (extension *.shx). If no 
path is defined for the shape filename, the library path is searched for the file.

transform The transform argument is optional and can be any series of the following 
(each preceded by a comma):

R=value Relative rotation

A=value Absolute rotation

S=value Scale

X=value X offset

Y=value Y offset

In this syntax, value represents a signed decimal number. The rotation is expressed in 
degrees while the other options are in linetype scaled drawing units.

rotation R=value or A=value.

R= determines a relative or tangential rotation with respect to the line’s elaboration.

A= determines an absolute rotation of the shape with respect to the origin. All shapes 
have the same rotation regardless of their relative position to the line. The value can 
be appended with a d for degrees (default), r for radians, or g for grads. If rotation is 
omitted, 0 relative rotation is used.
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scale S=value.

Determines a factor by which the shape's internal scale is multiplied. If the shape's 
internal scale is 0, the scale value is used as the scale.

X offset X=value.

Determines a shift of the shape along the X axis of the linetype computed from the 
end of the linetype definition vertex. If X offset is omitted or is 0, the shape is elabo-
rated with no offset. Include this field if you want a continuous line with shapes. This 
value is not scaled by the scale factor defined by S.

Y offset Y=value.

Determines a shift of the shape along the Y axis of the linetype computed from the 
end of the linetype definition vertex. If Y offset is omitted or 0, the shape is elabo-
rated with no offset. This value is not scaled by the scale factor defined by S.

The text descriptor syntax 
You can add a text object to a complex linetype using the following syntax:

["string", style_name] or ["string", style_name, transform]

The definitions of the fields in the syntax are as follows.

string The text to be used in the complex linetype. You cannot use the ` or the " char-
acters in the text string. To use these characters, enter a control code (%%) with the 
ASCII value for the character instead.

style_name The name of the text style to be elaborated. The specified text style must 
be included. If it is omitted, use the currently defined style.

transform The transform argument is optional and can be any series of the following 
(each preceded by a comma):

R=value Relative rotation

A=value Absolute rotation

S=value Scale

X=value X offset

Y=value Y offset

In this syntax, value represents a signed decimal number. The rotation is expressed in 
degrees while the other options are in linetype scaled drawing units.
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rotation R=value or A=value.

R= determines a relative or tangential rotation with respect to the line’s elaboration.

A= determines an absolute rotation of the text with respect to the origin. All text has 
the same rotation regardless of its relative position to the line. The value can be 
appended with a d for degrees (default), r for radians, or g for grads. If rotation is 
omitted, 0 relative rotation is used.

Rotation is centered between the baseline and the nominal cap heights box.

scale S=value.

Determines a factor by which the style's height is multiplied. If the style's height is 0, 
the scale value is used as the scale.

Because the final height of the text is defined by both the scale value and the height 
assigned to the text style, you will achieve more predictable results by setting the text 
style height to 0. It is recommended that you create separate text styles for text in 
complex linetypes to avoid conflicts with other text in your drawing.

X offset X=value.

Determines a shift of the text along the X axis of the linetype computed from the end 
of the linetype definition vertex. If X offset is omitted or is 0, the text is elaborated by 
using the lower left corner of the text as the offset. Include this field if you want a 
continuous line with text. This value is not scaled by the scale factor that is defined by 
S.

Y offset Y=value.

Determines a shift of the text along the Y axis of the linetype computed from the end 
of the linetype definition vertex. If Y offset is omitted or is 0, the text is elaborated by 
using the lower left corner of the text as the offset. This value is not scaled by the 
scale factor that is defined by S.

Editing linetypes

To change a linetype name   
1 Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Do one of the following:
• Select the linetype, and then choose Edit > Rename. 

• Click the linetype name you want to change, and then type the new name.

• Right-click the linetype name you want to change, and from the shortcut menu, 
select Rename.

3 To complete the command and return to your drawing, close the window.
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To change a linetype definition
1 Do one of the following:

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Right-click on the linetype name for which you want to change the definition.
3 From the shortcut menu, select Properties.
4 In the Linetype Definition field, define the linetype using positive and negative 

numbers and zeros. 
A positive number draws a solid line segment for the specified number of drawing 
units. A negative number creates a gap for the specified number of drawing units. 
A zero creates a dot.

5 To complete the command and return to your drawing, close the Linetypes dialog 
box and the IntelliCAD Explorer window.

NOTE  You cannot rename the CONTINUOUS, BYBLOCK, or BYLAYER linetypes.

Working with text fonts and styles 

When you add text to a drawing, it is created using the current text style. The text 
style determines the font, size, angle, orientation, and other text characteristics.   

Every drawing has at least one text style, named Standard, which initially uses the txt 
font. You cannot delete the Standard style, but you can rename it or modify it. For 
example, you can change the font or the oblique angle applied to the font. You also 
can use an unlimited number of additional text styles in your drawing.    

From the IntelliCAD Explorer, you can directly edit any setting associated with a text 
style by using the single-click editing method to change the setting.   

To display the IntelliCAD Explorer Text Styles element

Do one of the following:    
• Choose Settings > Explore Text Styles.
• Choose Tools > IntelliCAD Explorer, and then click the Styles element.
• On the Settings toolbar, click the Explore Text Styles tool ( ).
• Type expstyles and then press Enter.
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Creating and naming text styles 
Fonts are character sets that consist of letters, numbers, punctuation marks, and sym-
bols. Each font is stored in its own font file. Text styles apply additional formatting to 
fonts. You can create multiple text styles based on the same font, changing the vari-
ous characteristics to alter the appearance of the font. To create a new text style, you 
assign formatting characteristics to a font.    

IntelliCAD uses *.shx font files and provides a selection of fonts. These fonts are 
located in the IntelliCAD/Fonts directory. You can also use any font designed to 
work with AutoCAD. Many fonts are available from third-party vendors.    

NOTE  Text style names created or renamed in IntelliCAD can have up to 31 charac-
ters and cannot include spaces. IntelliCAD will, however, display longer text style 
names and names containing spaces, such as text styles created in AutoCAD 2000.

A Select Styles to display the Styles settings.
B Lists names of text styles defined in the current drawing. A check 

mark indicates the current style.    
C Displays the height assigned to the text style.
D Displays the width factor assigned to the text style.    
E Displays the oblique angle assigned to the text style.    

F Displays the font on which the style is based, including the path 
and font file name.

G Indicates whether text will appear backward.    
H Indicates whether text will appear upside down.
I Indicates whether text will appear vertically.
J Click any column head to sort the styles by that property.
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To create a new text style
1 Do one of the following:     

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Choose Edit > New > Style.
3 Select the font on which you want to base the new style, and then click Open.

The program adds a new style to the text styles list with the default name, 
NewStyle1.

4 Type the name for the new style by typing over the highlighted default text, and 
then press Enter.

5 To complete the command, close the window.

TIP You can also create a new text style by selecting the Styles element and clicking 
the New Item tool ( ).

To change a text style name in the current drawing
1 Do one of the following: 

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Do one of the following:
• Select the text style, choose Edit > Rename, type a new name, and then press 

Enter.

• Click the text style name you want to change, type a new name, and then press 
Enter. 

• Right-click the text style name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.

Modifying text styles
A new text style is initially assigned default values for height, width factor, oblique 
angle, and other characteristics. You can change these values for both new and exist-
ing text styles. You can also change the font assigned to the text style. If you change 
the font or orientation properties of a text style assigned to text previously inserted in 
the drawing, all text using that style is regenerated to reflect the changes. Oblique 
angle and height, if specified, are given by the style definition when text is created, 
but are not updated for existing text when the style is changed.    
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A fixed text height value of 0 allows you to specify the text height at the time you 
insert text into the drawing. Any other value sets height of the text to that value; the 
program does not prompt for the text height when you insert text into the drawing. 
The width factor determines the horizontal scaling of text. A value less than 1 com-
presses the text (for example, 0.75 compresses the text 25 percent); a value greater 
than 1 expands the text (for example, 1.50 expands the text 50 percent). The oblique 
angle determines the forward or backward slant of text as an angle offset from 90 
degrees. Negative values slant text to the left; positive values slant text to the right.

To modify a text style   
1 Do one of the following:     

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Select the text characteristic of a style that you want to modify. 
The text characteristic either toggles its value or a dialog box appears, allowing 
you to make the modifications you want.

3 To complete the command, close the IntelliCAD Explorer window.    

A Select to keep the dialog box on the screen 
when you switch back to the IntelliCAD Explorer 
or another element.

B Displays the name of the style whose properties 
are being changed.

C Type the fixed text height. 
D Type the width factor.
E Type the oblique angle.

F Select to create text that displays backward.
G Select to create text that displays upside 

down.    
H Select to create text that displays vertically.    
I Displays a text preview of the text font.
J Select the font style.
K Select the font name.   

B

C
D
E

F
IG

J
K

H

A
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Setting the current text style
When you insert text in a drawing, the text is created using the current text style. You 
can also select a different text style when you create text.    

To make the text style current
1 Do one of the following:     

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 In the Text Style Name list, click the style you want to make current.
3 Use one of the following methods to make the style the current style:

• Choose Edit > Current.

• Click the Current tool ( ).

• With the cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose Current.

4 To complete the command and return to your drawing, close the IntelliCAD 
Explorer window.

TIP You can also make a text style current by selecting it in the Text Style Name list 
and clicking the Current tool ( ) or by double-clicking the text style name in the 
Text Style Name list.    

Working with coordinate systems 

When you create entities in a drawing, they are located in relation to the drawing’s 
underlying Cartesian coordinate system. Every drawing has a fixed coordinate system 
called the World Coordinate System (WCS). You cannot delete or modify the WCS.   

Your drawing may contain additional coordinate systems, however, each with its own 
0,0,0 origin and orientation. You can create as many user coordinate systems as you 
want, and then save and recall them as you need them. You can edit the origin of a 
coordinate system from within the IntelliCAD Explorer by single-clicking the origin 
coordinates and then typing new coordinates.

For example, you can create a separate user coordinate system (UCS) for each side of 
a building. Then, by switching to the UCS for the east side of the building, you can 
draw the windows on that side by specifying only their x- and y-coordinates.

You can create and then switch between various user coordinate systems by selecting 
Coordinate Systems in the IntelliCAD Explorer.
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To display the Coordinate Systems element
Do one of the following:    
• Choose Settings > Explore Coordinate Systems.
• Choose Tools > IntelliCAD Explorer, and then click the Coordinate Systems 

element.
• Choose Settings > User Coordinate Systems, and then click Explore UCSs.
• On the Settings toolbar, click the Explore Coordinate Systems tool ( ).
• Type expucs and then press Enter.    

A Select Coordinate Systems to display the Coordinate 
Systems settings.

B Lists names of coordinate systems defined in the current 
drawing. A check mark indicates the current coordinate 
system.

C Displays the origin of the coordinate system in relation to 
the WCS.

D Displays the x-axis direction of the coordinate system in 
relation to the WCS.

E Displays the y-axis direction of the coordinate system in 
relation to the WCS.

F Click any column head to sort the coordinate systems by 
that property.
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Defining and naming user coordinate systems 
A drawing can contain as many coordinate systems as you want and can be named 
appropriate names so you can remember how they are used in your drawing for 
recalling them later.

NOTE  Coordinate system names created or renamed in IntelliCAD can have up to 31 
characters and cannot include spaces. IntelliCAD will, however, display longer coor-
dinate system names and names containing spaces, such as coordinate systems cre-
ated in AutoCAD 2000.

To define new user coordinate systems in the IntelliCAD Explorer
1 Do one of the following:   

• Choose Settings > Explore Coordinate Systems.

• On the Settings toolbar, click the Explore Coordinate Systems tool ( ).

• Type expucs and then press Enter.

2 Do one of the following:   
• Choose Edit > New > UCS.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose New > UCS.

3 Select a method from the prompt box or command bar by which to define the UCS 
in the drawing window. 
For example, select 3 Point and then specify three points in the drawing window 
to define the x, y, and z axes for your coordinate system.

4 Type the name for the new user coordinate system by typing over the highlighted 
default text, and then press Enter.

5 To complete the command, close the window.
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To change a user coordinate system name in the current drawing
1 Do one of the following:

• Choose Settings > Explore Coordinate Systems.

• On the Settings toolbar, click the Explore Coordinate Systems tool ( ).

• Type expucs and then press Enter.

2 Do one of the following:
• Select the user coordinate system, and then choose Edit > Rename, type a new 

name, and then press Enter.

• Click the user coordinate system name you want to change, type a new name, 
and then press Enter.

• Right-click the user coordinate system name you want to change, and from the 
shortcut menu, select Rename, type a new name, and then press Enter.

3 Type the new user coordinate system name, and then press Enter.
4 To complete the command and return to your drawing, close the window.

Setting the current user coordinate system
When you draw new entities, they are created in relation to the current coordinate 
system. You can set the current UCS from the IntelliCAD Explorer.    

To set the current UCS from the IntelliCAD Explorer
Do one of the following:
• Double-click the UCS name in the UCS Name list.
• Select the UCS in the UCS Name list, and then choose Edit > Current.

• Select the UCS in the UCS Name list, and then click the Current tool ( ).     
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Using named views 

As you work on a drawing, you may find that you frequently switch among different 
portions of it. For example, if you are drawing the floor plan of a house, you may 
zoom in to particular rooms of the house and then zoom out to display the entire 
house. Although you can repeat the Pan and Zoom commands to do this, it is much 
easier to save various views of the drawing as named views. You can then quickly 
switch among these views. You can save and later restore named views using either 
the View command or the Views element in the IntelliCAD Explorer.    

To display Views in the IntelliCAD Explorer
Do one of the following:    
• Choose Settings > Explore Views.
• On the Settings toolbar, click the Explore Views tool ( ).
• Type expviews and then press Enter.

• Choose Tools > IntelliCAD Explorer, and then click the Views element.
  

A To display the Views settings, select Views.
B Lists names of views defined in the current drawing. 

A check mark indicates the current view.    
C Displays the height of the view in drawing units.    

D Displays the width of the view in drawing units.
E Displays the direction of the view, expressed as a three-

dimensional coordinate in the WCS.
F Click any column head to sort the views by that property.



W O R K I N G  W I T H  T H E  I N T E L L I C A D  E X P L O R E R    165
Saving and naming views 
You can save the view displayed in the current window as a named view. After you 
save a named view, you can restore that view in the current window at any time.    

NOTE  View names created or renamed in IntelliCAD can have up to 31 characters 
and cannot include spaces. IntelliCAD will, however, display longer view names and 
names containing spaces, such as views created in AutoCAD 2000.

To save the current view as a named view
1 Do one of the following:     

• Choose View > Save/Restore View.

• On the View toolbar, click the Save/Restore View tool ( ).

• Type view and then press Enter.

2 In the prompt box, choose Save.
3 Type a name for the view, and then press Enter.
4 To complete the command and return to your drawing, close the window.

To save a portion of the current view as a named view
1 Do one of the following:     

• Choose Settings > Explore Views.

• On the Settings toolbar, click the Explore Views tool ( ).

• Type expviews and then press Enter.

2 Do one of the following:
• Choose Edit > New > View.

• On the IntelliCAD Explorer toolbar, click the New Item tool ( ).

3 In the prompt box, choose Window.
4 Specify the first corner of the view window.
5 Specify the opposite corner of the view window.
6 Rename the new view, and then press Enter.

Do not use spaces between words in the new view name.
7 To complete the command and return to your drawing, close the window.

TIP You can also create a new view by selecting the Views element in the IntelliCAD 
Explorer and clicking the New Item tool ( ).
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To change a saved view name in the current drawing
1 Do one of the following:

• Choose Settings > Explore Views.

• On the Settings toolbar, click the Explore Views tool ( ).

• Type expviews and then press Enter.

2 Do one of the following:
• Select the view, choose Edit > Rename, type a new name, and then press Enter.

• Click the view name you want to change, type a new name, and then press Enter.

• Right-click the view name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 Type the new view name, and then press Enter.
4 To complete the command and return to your drawing, close the window.

Restoring named views   
After you save one or more named views, you can restore any of those views in the 
current window using either the View command or the IntelliCAD Explorer.    

To restore a named view using the View command
1 Do one of the following:

• Choose View > Save/Restore View.

• On the View toolbar, click the Save/Restore View tool ( ).

• Type view and then press Enter.

2 In the prompt box, choose Restore.
3 Type the name of the view you want to restore, and then press Enter.

To restore a named view from the IntelliCAD Explorer
Do one of the following:
• Select the view name in the list of View settings, and then choose Edit > Current.
• Select the view name in the list of View settings, and then click the Current tool 

( ).

• Double-click the view name in the View list.

Changing named view properties   
Once you create a named view you can modify its properties, such as the target direc-
tion and twist angle. This gives you access to many of the view settings after a view 
has been defined.   
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To change the view options
1 Do one of the following:

• Choose Settings > Explore Views.

• On the Settings toolbar, click the Explore Views tool ( ).

• Type expviews and then press Enter.

2 Select the view whose properties you want to change.
3 Choose Edit > Properties.

You can also right-click the view you want to change, and from the shortcut menu, 
select Properties. 

4 Change the values of the settings on any of the tabs and close the dialog box.
5 To complete the command and return to your drawing, close the window.

Working with blocks and external references 

Blocks represent a special type of entity that, once saved, can be inserted and manip-
ulated in the drawing as a single entity. A block can consist of visible entities such as 
lines, arcs, and circles as well as visible or invisible data called attributes. You can 
use attributes to track things such as part numbers and prices and to export attribute 
information to an external database. You can also track the number of parts by count-
ing the number of times a block has been inserted into the drawing. Blocks are stored 
as part of the drawing file.    

External references have similar uses to blocks. Using external references, you can 
attach entire drawings to your current drawing. Unlike a block, however, an external 
reference does not become part of the current drawing.    

You can save blocks in the IntelliCAD Explorer. You can also use the IntelliCAD 
Explorer to manage and insert copies of blocks. The IntelliCAD Explorer lists the 
names of all blocks contained in the current drawing, along with other information 
about each block or external reference.    

You can also rename a block, modify its insertion point, and change the path of an 
externally referenced drawing by single-clicking on the property and making your 
edits within the IntelliCAD Explorer.
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To display blocks in the IntelliCAD Explorer
Do one of the following:    
• Choose Settings > Explore Blocks.
• Choose Tools > IntelliCAD Explorer, and then click the Blocks element.
• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

The Blocks element in the IntelliCAD Explorer defaults with images on. The Images 
view shows you a small image of each block or external reference.       

When blocks are displayed, additional tools on the Block toolbar provide the func-
tions described in the following table: 
    

 The Images view shows an image of each block in the selected drawing. Click an image to select it.

Additional tools on the Block toolbar   

Tool Function

( ) Images Displays a small image of each block.

( ) Details Displays information about each block.

( ) Insert Inserts a block.
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To see more information about each block, click the Details tool ( ). In the Details 
view, you can edit the path and the insertion point by clicking the setting and typing 
your changes.     

( ) Insert External File Blocks Inserts a drawing available from disk as a block.

( ) Save Block Saves selected block as independent.dwg file.

( ) Attach Drawing Attaches drawing as an external reference.

Additional tools on the Block toolbar   

Tool Function

A To display the Blocks settings, select Blocks.
B Lists names of blocks and external references defined in the current 

drawing.    
C Displays the number of occurrences of the block in the current drawing.     

D Displays the insertion point of the block in the current drawing.
E Displays the name and path for externally referenced drawings.
F Click any column head to sort the blocks by that property.
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Creating and naming blocks
You can combine any number of entities into a single block. After you create a block, 
you can insert copies of it into a drawing. Each block insertion is treated as a single 
entity; for example, you can rotate or scale each block when you insert it. The program 
adds the name of the new block you insert to the Block Name list in the IntelliCAD 
Explorer.    

NOTE  Block names created or renamed in IntelliCAD can have up to 31 characters 
and cannot include spaces. IntelliCAD will, however, display longer block names and 
names containing spaces, such as blocks created in AutoCAD 2000.

To create a block
1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 Do one of the following:
• Choose Edit > New > Block.

• On the IntelliCAD Explorer toolbar, click the New Item tool ( ).

3 Enter a name for the new block.    
4 Specify the insertion point for the block.
5 Select the entities to be combined into the block, and then press Enter.

The program adds a new block to the blocks list, with the name you entered for it.
6 To complete the command and return to your drawing, close the window.

To change a block name in the current drawing
1 Do one of the following:

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 Do one of the following:
• Select the block, choose Edit > Rename, type a new name, and then press Enter.

• Click the block name you want to change, type a new name, and then press 
Enter.

• Right-click the block name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.
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Inserting a block
You can insert into a drawing any block listed in the Block Name list in the Intelli-
CAD Explorer. 

To insert a block
1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 If you wish to insert a block from another open drawing, select the drawing in the 
Elements pane. (If the block is contained within the same drawing, you can skip 
this step.)

3 In either the Details or Images view, select the block to be inserted.
4 On the IntelliCAD Explorer toolbar, click the Insert tool ( ).
5 In the drawing, specify the insertion point.    
6 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 

select Done.   
7 To complete the command and return to your drawing, close the window.

TIP  You also can insert a block by choosing Tools > IntelliCAD Explorer, and then 
double-clicking the name of the block you want to insert in the Block Name list.

TIP  You can also insert a block from the Insert menu. (See Chapter 13, " Working 
with blocks, attributes, and external references.")

Inserting a drawing as a block      
You can insert as a block another drawing into the current drawing. After you do this, 
the block name is added to the Block Name list in the IntelliCAD Explorer. Changes 
made later to the inserted drawing will not be reflected in this drawing.    
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To insert a drawing as a block
1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 On the IntelliCAD Explorer toolbar, click the Insert External File Blocks tool 
( ).    

3 In the Insert Block dialog box, select the drawing you want to insert, and then 
click Open.   

4 In the drawing, specify the insertion point.
5 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 

select Done.
6 To complete the command and return to your drawing, close the window.

Attaching a drawing as an external reference
You can attach another drawing to the current drawing as an external reference and 
insert a copy of the drawing into the current drawing. The name of the external refer-
ence drawing is added to the Block Name list. Changes made later to the referenced 
drawing will appear in this drawing when you reload the external reference.    

To attach an external reference
1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 On the IntelliCAD Explorer toolbar, click the Attach Drawing tool ( ).    
3 In the Select File To Attach dialog box, select the drawing you want to attach, and 

then click Open.
4 In the drawing, specify the insertion point.     
5 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 

select Done.    
6 To complete the command and return to your drawing, close the window.
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To edit the path of an external reference
1 Do one of the following:    

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 Click the path you want to change.
3 From the Insert Block dialog box, select the new drawing you want as the external 

reference.
4 Click Open.
5 To complete the command and return to your drawing, close the window.
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Saving a block as a separate drawing
You can save a block as a separate drawing, and then you can open and modify that 
drawing as you would any other drawing.     

To save a block as a separate drawing file
1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 In either the Details or Images view, select the block you want to save.
3 On the IntelliCAD Explorer toolbar, click the Save Block To Disk tool ( ).
4 In the Save Block dialog box, select the folder in which you want to save the 

block.
5 In the File Name field, type a name for the new drawing file (or accept the default, 

in which case the new drawing name is the same as the name of the block), and 
then click Save.    

Working with dimension styles    

From the IntelliCAD Explorer, you can use the Dimension Styles element to cut, 
copy, and paste dimension styles from one drawing to another.     

TIP You can select the dimension style and use the Microsoft Windows shortcut keys 
(Ctrl+A to select all, Ctrl+X to cut, Ctrl+C to copy, Ctrl+V to paste) to accomplish 
the same results. You can use these shortcut keys with all other IntelliCAD Explorer 
elements 
as well.

A dimension style contains the settings that control the appearance of a dimension. 
Although you cannot control these settings from within the IntelliCAD Explorer, you 
can use the Dimension Settings dialog box to control settings related to the appear-
ance of arrows, lines, text, units, and other formatting characteristics. 
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To display the IntelliCAD Explorer Dimension Styles element
Do one of the following:    
• Choose Settings > Explore Dimension Styles.
• Choose Tools > IntelliCAD Explorer, and then click the Dimension Styles ele-

ment.
• On the Settings toolbar, click the Dimension Settings tool ( ).
• Type setdim and then press Enter. 
    

Creating and naming dimension styles 
By using the Dimension Styles element in combination with the Dimension Settings 
dialog box, you can create new dimension styles, modify them, and copy them into a 
different drawing. 

NOTE  Dimension style names created or renamed in IntelliCAD can have up to 31 
characters and cannot include spaces. IntelliCAD will, however, display longer 
dimension style names and names containing spaces, such as dimension styles cre-
ated in AutoCAD 2000.

A To display the Dimension Styles settings, select Dimension 
Styles.

B Lists the names of dimension styles defined in the current 
drawing.

C Click the Dimension Style Name column head to sort by 
name.
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To create a dimension style
1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click New.
3 Type the name of the new dimension style.
4 Click Create.
5 In the Dimension Settings dialog box, click one of the other tabs, and then change 

the dimension settings as necessary.
Repeat this step for each tab, as needed.

6 To end the command, click OK.

To change a dimension style name in the current drawing
1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 Do one of the following:
• Select the dimension style, choose Edit > Rename, type a new name, and then 

press Enter.

• Click the dimension style name you want to change, type a new name, and then 
press Enter.

• Right-click the dimension style name you want to change, and from the shortcut 
menu, select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.
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To copy a dimension style from one drawing to another
1 Do one of the following:

• Choose Settings > Explore Dimension Styles.

• On the Settings toolbar, click the Explore Dimension Settings tool ( ).

• Type expdimstyles and then press Enter. 

2 Right-click the dimension style name you want to copy.
3 From the shortcut menu, select Copy.
4 In the left pane, select the drawing to which you want to copy the dimension style.
5 Click the Dimension Styles element for that drawing.
6 In the right pane, right-click, and then from the shortcut menu, select Paste.

NOTE  Each drawing contains a dimension style named Standard. You cannot delete 
this dimension style, but you can rename it from within the IntelliCAD Explorer or 
modify its properties in the Dimension Settings dialog box.    
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Getting drawing information

IntelliCAD® stores accurate, detailed information about all the entities in a drawing. 
You can get details about an existing drawing and its entities using the tools for mea-
suring distances and calculating areas. You can also track the amount of time you 
spend editing a drawing. This chapter explains how to:

• Measure distances along an entity.
• Measure distances and angles.
• Divide an entity into a number of equal segments.
• Calculate areas.
• Display information about entities in a drawing.

• Track the amount of time spent editing a drawing.

Many of the functions described in this chapter require that you set IntelliCAD to the 
Advanced experience level.

Topics in this chapter
Specifying measurements and divisions........................................................... 180
Calculating areas.............................................................................................. 183
Calculating distances and angles ..................................................................... 187
Displaying information about your drawing.......................................................188
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Specifying measurements and divisions      

You can divide a line, arc, circle, or polyline into a number of equal segments or mark 
off intervals of a specific length along an entity. (Note that divide is not the same as 
break.) For example, you may want to place station-point markers every 50 feet along 
the centerline of a roadway or divide the plan view of a window into three equal-
width sections of glass, placing a mullion at each division point.    

To specify measurements and divisions, use these commands:

• For the length of the segments, use the Measure command.

• For the number of equal-length segments, use the Divide command.

You can measure or divide arcs, circles, lines, and polylines. With either command, 
you can identify the segments by placing either a block or point entity at the end of 
each interval. If you use points, you can snap to the ends of intervals using the point 
entity snap. The appearance of the point entities is determined by the current point 
display type, which you control in the Drawing Settings dialog box.    

To use a block as the marker, the block must already be defined in the current draw-
ing. You can further indicate whether to rotate the block to align perpendicularly to 
the entity you are measuring or dividing.   

IntelliCAD begins measuring or dividing based on the point at which you select the 
entity and the type of entity with which you are working. For most entities, measuring 
starts from the endpoint closest to the point you used to select the entity. If you select 
the entity to be measured or divided using a method other than pointing (for example, 
using a window or fence selection), the program prompts you to specify the end from 
which you want to begin measuring.

Measuring intervals on entities
You can mark specified length increments along a selected entity using either a point 
entity or a block.    

Block not aligned with entity. Block aligned with entity.
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To measure intervals along an entity and mark them using point entities
Advanced experience level

1 Do one of the following:
• Choose Modify > Measure.

• On the Modify toolbar, click the Measure tool ( ).

• Type measure and then press Enter.

2 Select the entity.
3 Specify the segment length, and then press Enter.    

To measure intervals along an entity and mark them using blocks 
Advanced experience level

1 Do one of the following:    
• Choose Modify > Measure.

• On the Modify toolbar, click the Measure tool ( ).

• Type measure and then press Enter.

2 Select the entity.
3 In the prompt box, choose Insert Blocks.
4 Type the name of the block you want to insert as the marker.
5 In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the 

block so that its vertical alignment is always perpendicular to the entity or No-Do 
Not Align to insert each copy of the block with a zero rotation angle.

6 Specify the segment length, and then press Enter.

When you select the entity by pointing, intervals are measured from the end 
closest to the point at which you select the entity (A). Blocks or point entities (B) 
are placed along the entity at the specified interval.

A B
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Dividing entities into segments
You can place markers along a selected entity, dividing that entity into a specified 
number of equal-length segments. You can use either a point entity or a block to mark 
the segments.    

To divide an entity into segments and mark them using point entities
Advanced experience level

1 Do one of the following:    
• Choose Modify > Divide.

• On the Modify toolbar, click the Divide tool ( ).

• Type divide and then press Enter.

2 Select the entity.
3 Specify the number of segments, and then press Enter.    

To divide an entity into segments and mark them using blocks    
Advanced experience level

1 Do one of the following:
• Choose Modify > Divide.

• On the Modify toolbar, click the Divide tool ( ).

• Type divide and then press Enter.

2 Select the entity.
3 In the prompt box, choose Insert Blocks.
4 Type the name of the block you want to insert as the marker.
5 In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the 

block so that its vertical alignment is always perpendicular to the entity or No-Do 
Not Align to insert each copy of the block with a zero rotation angle.

6 Specify the number of segments, and then press Enter.

When you select the entity by pointing, divisions are marked beginning from the end closest to the 
point at which you select the entity (A). Blocks or point entities (B) are placed along the entity to 
mark it in equal intervals.

A

B
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Calculating areas       

You can calculate the area and perimeter of a polygon based on a series of points you 
specify or enclose with a circle or closed polyline. You can also determine the area of 
several combined entities and add or subtract the area of one or more entities from a 
total combined area.   

Calculating areas defined by points
You can find the area and perimeter of any closed region by specifying a series of 
points. The program calculates the area and perimeter of the space that is enclosed by 
an imaginary polygon consisting of straight-line segments connecting each point.

To calculate the area defined by points you specify
1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 Specify the first point.
3 Specify the second point.
4 Continue specifying points in sequence to define the perimeter of the area you 

want to measure.
As you select each successive point, the resulting polygon is displayed on the 
screen.

5 To complete the calculation, press Enter.
The area and perimeter of the region you defined are displayed. For example, the 
following type of information is displayed:
Area = 11.0583, Perimeter = 15.3092    

Select the points (A, B, C) that form a polygon. The area and 
perimeter of the region are then calculated.

A

C

B



184   C H A P T E R  9
Calculating areas of closed entities
You can find the area of any closed entity. In addition, the program calculates either the 
circumference or the perimeter of the entity, depending on the type of entity you select.

To calculate the area of a closed entity
1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Find Area Of One Entity.
3 Select the entity.

The following type of information is displayed:
Area = 62.3837, Circumference = 27.9989

Calculating combined areas  
You can find the total area of several combined regions by specifying points or by 
selecting entities. You can also subtract the areas of entities or polygons from a 
running total.    

To add areas to calculate a combined area    
1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Add Areas Together.
3 Using one of the following methods, identify the first area:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Add Entities To Area, select the entities you want to 
add, and then press Enter to complete the calculations.

4 To complete the command, choose Done in the prompt box.
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To subtract areas when calculating a combined area    
1 Do one of the following:    

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Add Areas Together.
3 Using one of the following methods, identify the first area:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Add Entities To Area, select the entities you want to 
add, and then press Enter to complete the calculations.

4 In the prompt box, choose Subtract Areas.
5 Using one of the following methods, identify the area to be subtracted:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Subtract Entities From Area, select the entities you 
want to subtract, and then press Enter to complete the calculations.

6 To complete the command, choose Done in the prompt box.

To calculate the area of the gasket using the Area command, first add 
the area of the entire gasket (A), and then subtract the areas of the two 
circles (B and C).

A
B

C
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As you select entities, the program displays the calculations. If the command bar is 
displayed, the information appears there. If the command bar is not displayed, the 
program opens the Prompt History window and displays the calculations. The follow-
ing type of information is an example of what is displayed:

Entity • Add • Subtract • <First point>: Choose Add Areas Together

Adding: Entity • Subtract • <First point>: Choose Add Entities to Area

Adding area: <Select entities>: Select the first entity

Area = 64.6259, Perimeter = 33.3049

Total length = 33.3049

Total area = 64.6259

Adding area: <Select entities>: press Enter

Adding: Entity • Subtract • <First point>: Choose Subtract Areas

Subtracting: Entity • Add • <First point>: Choose Subtract Entities from 

Area

Subtracting area: <Select entities>: Select the first entity to subtract

Area = 3.1597, Circumference = 6.3012

Total length = 27.0036

Total area = 61.4662

Subtracting area: <Select entities>: Select the second entity to subtract

Area = 3.1597, Circumference = 6.3012

Total length = 20.7024

Total area = 58.3066

Subtracting area: <Select entities>: Press Enter

Subtracting: Entity • Add • <First point>: Choose Done
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Calculating distances and angles            

You can calculate the distance between any two points you select. The following 
information is displayed:          

• The distance between the points, measured in drawing units.
• Their angle in the xy plane.
• Their angle measured from the xy plane.

• The change (delta) in the x, y, and z distances between the two points.       

To calculate the distance between two points and their angle
1 Do one of the following:    

• Choose Tools > Inquiry > Distance.

• On the Inquiry toolbar, click the Distance tool ( ).

• Type distance and then press Enter.

2 Specify the first point.
3 Specify the second point.

The following type of information is displayed:

Distance = 13.2850, Angle in XY Plane = 31º, Angle from XY Plane = 0º

Delta X = 11.3878, Delta Y = 6.8418, Delta Z = 0.0000  

TIP  To use specific points on selected entities, use entity snaps to select the precise 
points on the entities.     

Use the Distance command to calculate the distance (A) between two points (B 
and C), the angle in the xy plane (D), the angle from the xy plane, and the delta 
x (E), delta y (F), and delta z distances between the two points.

A

B D

E

F

C



188   C H A P T E R  9
Displaying information about your drawing      

You can display a variety of information about a drawing and the entities it contains, 
including:    

• Information in the drawing database about selected entities.
• The current drawing status.

• The time spent working on the drawing.

This information is displayed in the Prompt History window and in the command bar.    

Displaying information about entities
You can display information about the selected entities. The information varies, 
depending on the type of entities you select. All of the listings display the following 
information:    

• Entity type.     
• Layer.
• Color.
• Linetype.   
• The location of the entity (its xyz-coordinates relative to the current user 

coordinate system [UCS]).     
• The current space (model space or paper space).     

• The size of the entity (the information varies, depending on the entity type).    

To display information about an entity
Advanced experience level     

1 Do one of the following:
• Choose Tools > Inquiry > List Entity Info.

• On the Inquiry toolbar, click the List Entity Info tool ( ).

• Type list and then press Enter.

2 Select one or more entities.
3 Press Enter.

TIP  To return to the drawing window, press F2.
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The following type of information is displayed:

------ Circle ---------------------------------------------------

Handle: 2C

Current space: Model

Layer: 0

Color: BYLAYER

Linetype: CONTINUOUS

Handle: 4C

Current space: Model

Center point: X= -5.8583 Y= 7.2752 Z= 0.0000

Radius: 4.4562

Circumference: 27.9989

Area: 62.3837

Displaying the drawing status
You can display information about the current status of a drawing, including:    
• Drawing name.
• Limits.     
• Insertion base point.     
• Snap and grid settings.
• Current layer, color, and linetype.     

• Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on).    

To display the drawing status
Advanced experience level

Do one of the following:    
• Choose Tools > Inquiry > Drawing Status.

• Type status and then press Enter.
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The following type of information is displayed:    
Current drawing name: Site Plan

Drawing limits are: X=0.0000 Y=0.0000 Z=0.0000

X=12.0000 Y=9.0000 Z=0.0000

Paper space limits are: X=0.0000 Y=0.0000 Z=0.0000

X=12.0000 Y=9.0000 Z=0.0000

Screen width (pixels): 971

Screen height (pixels): 569

Insertion base is: X=0.0000 Y=0.0000 Z=0.0000

Snap resolution is: X=0.5000 Y=0.5000 Z=0.0000

Grid spacing is: X:0.5000 Y:0.5000 Z=0.0000

Current layer: 0

Current color: BYLAYER

Current linetype: BYLAYER

Current elevation: 0.0000

Current thickness: 0.0000

Fill: on

Grid: off

Ortho: off

Snap: off

Blips: off

Drag: on

Command echo: on

Positive angle direction: Counterclockwise

Angular units: Decimal degrees

Dimension units: Decimal

Pick box height: 3

Entities in drawing: 288

Tracking time spent working on a drawing
You can display information about the amount of time you have spent working on a 
drawing, including:    

• The date and time the drawing was created.
• The date and time the drawing was most recently saved.    
• The total amount of time spent working on the drawing.

• The time spent working on the drawing during the current editing session.    

You can turn the elapsed-time timer on and off or reset it to zero.   
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To display the timer information
Advanced experience level    

1 Do one of the following:
• Choose Tools > Inquiry > Time Variables.

• On the Inquiry toolbar, click the Time Variables tool ( ).

• Type time and then press Enter.

2 Select any of the prompt box options:
• Choose Timer On to turn the elapsed timer on.

• Choose Timer Off to turn the elapsed timer off.

• Choose Display Timer to redisplay the timer information.

• Choose Reset Timer to reset the elapsed timer to zero.

3 In the prompt box, choose Cancel to exit the command.

Each time you display the timer information, the following type of information is 
displayed:

The current time is Fri Dec 19 09:58:43 1997

Drawing was created on: Wed 17 Dec 1997 at 16:17:59.8090

Drawing was last updated on: Thur 18 Dec 1997 at 09:58:43.3040

Total editing time: 1  2: 35:4.2345

Elapsed timer (on): 0  1: 21:5.6324    
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Modifying entities

IntelliCAD® provides many editing tools for modifying a drawing. You can easily 
move, rotate, or stretch drawing entities, or change their scale. When you want to 
remove an entity, you can delete it with a few clicks of the mouse. You can also make 
multiple copies of any entity and copy entities from one drawing to another. 

You can modify most entities using general-purpose editing commands. Some com-
plex entities require special commands to modify specific properties. Most of these 
tools and commands are located on the Modify toolbar and the Modify menu. This 
chapter explains how to:

• Select entities using entity-selection methods and grips.
• Change the properties of entities.
• Rearrange entities by moving or rotating.
• Resize entities by stretching, scaling, extending, trimming, or editing their lengths.
• Break and join entities.
• Group entities.
• Edit polylines.
• Explode entities.

• Create chamfers and fillets.
Topics in this chapter
Selecting entities............................................................................................... 194
Modifying the properties of entities ................................................................... 200
Deleting entities ................................................................................................ 202
Copying entities ................................................................................................ 202
Rearranging entities.......................................................................................... 209
Resizing entities................................................................................................ 212
Breaking and joining entities............................................................................. 220
Grouping entities............................................................................................... 222
Editing polylines................................................................................................ 225
Exploding entities.............................................................................................. 231
Chamfering and filleting entities........................................................................ 232
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Selecting entities       

You can create a selection set that consists of one or more entities before you modify 
them. Use any of the following methods to create a selection set:    

• Choose a command or tool first, and then select entities.
• Select entities first, and then choose a command or tool (most entities).

• Select entities by pointing, and then use grips to modify them.

Displaying selected entities highlighted
You can specify whether to display selected entities highlighted, which makes the 
selection set easier to see. By default, the highlighting feature is turned on.    

To turn the highlighting feature on or off
1 Do one of the following:     

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Display tab.
3 In the Change Settings For box, select Display.
4 Select or clear the Highlight Item When Selected check box.
5 Click OK. 

Entity-selection methods    
When you choose a command that requires you to select entities (when you’re delet-
ing or changing entity properties, for example), you can use any of the following 
selection methods, which are displayed in a prompt box:    

• Select all entities Selects all entities in the current drawing.    
• Add to set Adds one or more entities to the selection set.    
• Subtract from set Removes one or more entities from the selection set.    
• Previous selection Selects entities included in the previous selection set.    
• Last entity in drawing Selects the entity most recently added to the drawing.    
• Window-Inside Selects entities contained entirely within a rectangular selection 

window.    
• Crossing window Selects entities contained within or crossing the boundary of a 

rectangular selection window.    
• Outside window Selects entities falling completely outside a rectangular selection 

window.    
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• Window polygon Selects entities contained entirely within a polygon selection 
window.    

• Crossing polygon Selects entities contained within or crossing the boundary of a 
polygon selection window.    

• Outside polygon Selects entities falling completely outside a polygon selection 
window.    

• Window circle Selects entities contained entirely within a circular selection 
window.    

• Crossing circle Selects entities contained within or crossing the boundary of a cir-
cular selection window.    

• Outside circle Selects entities falling completely outside a circular selection 
window.    

• Point Selects any closed entities that surround the selected point.    

• Fence Selects entities crossing a line or line segments.    

In addition to these methods, you can select entities that match a particular set of 
properties—for example, all entities on a particular layer or drawn in a certain color.    

You can also use a few selection methods automatically, without displaying the 
prompt box. For example, you can simply click to select entities, or you can use a 
Window-Inside or Crossing Window by defining the opposite corners of a rectangu-
lar selection window. The direction in which you define the points of the rectangle 
(left-to-right or right-to-left) determines which type of window you create.
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To create a Window-Inside
1 Click to select a point in the drawing.    
2 Click to the right of the first point to select a second point in the drawing. 
 

This method is most commonly referred to as simply a window or selection window.

To create a Crossing Window
1 Click to select a point in the drawing.    
2 Click to the left of the first point to select a second point in the drawing.    

In addition to a rectangular window, you can define a selection window using other 
shapes such as a polygon, circle, or fence (a multisegmented line that selects entities 
it crosses).

Window-Inside by selecting the first (A) and second (B) 
points.

Resulting selection.

A

B

Crossing Window by selecting the first (A) and second 
(B) points.

Resulting selection.

A

B
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To select entities using Window Polygon 
1 Activate an entity-modification command.    
2 In the prompt box, choose Window Polygon.
3 Specify the vertices of the polygon.
4 To complete the selection polygon, press Enter. 
  

To select entities using Fence 
1 Activate an entity-modification command.
2 In the prompt box, choose Fence.
3 Specify the endpoints of the Fence segments.
4 To complete the Fence, press Enter.    

Window Polygon by specifying the vertices of the 
polygon (A, B, and C).

Resulting selection.

A

C

B

Fence by specifying the endpoints of the fence segments 
(A, B, and C).

Resulting selection.

A

B

C
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Choosing the command first    
When you choose an entity-modification tool or command, the program prompts you 
to select entities and displays a prompt box from which you can choose a selection 
method. You can select individual entities or use other techniques such as selection 
windows to select multiple entities.

When you select entities, you add them to the selection set. After you select at least 
one entity, you can remove entities from the selection set. To finish adding entities to 
the selection set, press Enter. Most entity-modification commands then act on the 
entire selection set.    

Selecting entities first    
You can select entities first and then choose how to modify them. As you select each 
entity, it is highlighted with small squares called grips, which appear at strategic 
points on the entity.    

The locations of the grips depend on the type of entity selected. For example, grips 
appear at the endpoints and midpoint of a line, at the quadrant points and center point 
of a circle, and at the endpoints, midpoint, and center of an arc.    

After you select one or more entities, you can choose an entity-modification com-
mand, such as Copy or Move, from the Modify menu or toolbar. You can also click 
the right mouse button to display a shortcut menu containing the entity-modification 
commands appropriate for the selected entities, and then choose the command from 
the menu.

When you select entities and then issue a command, the program immediately acts on 
the entities you’ve selected. In many cases, a command-specific prompt box provides 
additional options for that editing operation. If you want to modify the selection set at 
that point, right-click to display the prompt box with the selection options and choose 
the option you want. To redisplay the command-specific prompt box, right-click 
again.

You remove an individual entity from the selection set by selecting it again. To 
remove all the entities from the selection set, press Escape.

Turning grips on and off
You can turn the use of grips on and off and control the size and color of grips.

Examples of grip locations.
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To change grip settings
1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type ddgrips and then press Enter.

2 In the Drawing Settings dialog box, click the Display tab.
3 In the Change Settings For list, click Grips.
4 Change the desired settings, and then click OK.    

Editing with grips
To use grips for editing, you select an entity to display the grips, and then click a grip 
to make it active. The grip you select depends on the type of entity you’re modifying 
and the editing operation you’re performing. For example, to move a line entity, drag 
it by its midpoint grip. To stretch the line, drag one of the endpoint grips. You do not 
need to enter a command when using grips.    

A Click to activate grips for all selected entities.
B Click to assign the color for grips.

C Specify the grip size.
D Displays the current grip size.

A
D

C

B
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Modifying the properties of entities    

You can change the layer, thickness, linetype, color, and linetype scale of one or 
more entities. Depending on the type of entity or entities you select, you can also 
change other properties, such as the start point and endpoint of lines, the center point 
and radius of circles, and the vertices of polylines.    

You can modify all the properties of all entities simultaneously. For example, using 
the entprop command, select all entities on a particular layer, and then move the enti-
ties to another layer by simply selecting a name from the Layer text box.

In the Entity Properties dialog box, changes that you make in the Layer, Thickness, 
Linetype, Color, and Entity Linetype Scale fields affect all selected entities. If you 
select several entities that all have different properties, the default value initially is 
Varies. Changes that you make in the entity tabs, such as Circle, Line, and Arc, affect 
all selected entities of that type. You can select the entities to be changed using any 
entity-selection method.    

To modify the properties of multiple entities 
1 Do one of the following:

• Choose Modify > Properties.    

• On the Modify toolbar, click the Properties tool ( ).

• Type entprop and then press Enter.

2 Select the entities, and then press Enter.
3 Make changes to the properties you want to change, and then click OK.
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The Entity Properties dialog box, shown in the following illustration, has two sec-
tions. The All Selected Entities section (the upper part of the dialog box) displays 
properties common to all selected entities, such as Layer, Color, and Thickness. This 
portion of the dialog box is equivalent to the dialog box displayed by the AutoCAD 
ddchprop command. 

The lower section of the Entity Properties dialog box contains options specific to the 
selected entities. Each tab displays the properties appropriate for the entity. This fea-
ture is equivalent to repeatedly applying the AutoCAD ddmodify command to one 
entity at a time.  

The IntelliCAD Entity Properties dialog box.
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Deleting entities

You can remove entities from a drawing. You can delete entities using any of the 
entity-selection methods.    

To delete a selection set    
1 Do one of the following:

• Choose Edit > Delete.

• On the Standard toolbar, click the Delete tool ( ).

• Type delete and then press Enter.

2 Select the entities, and then press Enter.

TIP  Typing the Undelete command restores the most recently deleted selection set. If 
you have made additional modifications since deleting the entities, use Undelete 
rather than Undo to restore those entities without reversing those modifications.    

Copying entities    

You can copy one or more entities, making one copy or multiple copies within the 
current drawing. You can also copy entities between drawings.    

Use any of the following methods to copy entities within the current drawing:

• Create a copy at a location referenced from the original.
• Create a copy aligned parallel to the original.
• Create a copy as a mirror image of the original.

• Create several copies in a rectangular or circular pattern.

Copying entities within a drawing
You can duplicate entities within the current drawing. The default method is to create 
a selection set and then specify a starting point, or base point, and an endpoint, or dis-
placement point, for the copy. You can also make multiple copies or copy the selec-
tion set to a location you specify, using a direction vector.     
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To copy a selection set once    
1 Do one of the following:

• Choose Modify > Copy.

• On the Modify toolbar, click the Copy tool ( ).

• Type copy and then press Enter.

2 Select the entities, and then press Enter.
3 Specify the base point.
4 Specify the displacement point.    

Entity to copy (A), base point (B), and 
displacement point (C).

Result.

A B
C
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To make multiple copies of a selection set
1 Do one of the following:     

• Choose Modify > Copy.

• On the Modify toolbar, click the Copy tool ( ).

• Type copy and then press Enter.

2 Select the entities, and then press Enter.
3 In the prompt box, choose Multiple Copies.
4 Specify the base point.
5 Specify the displacement point of the first copy.
6 Specify the displacement point of the next copy.
7 Continue specifying displacement points to place additional copies.
8 To complete the command, press Enter.   

Copying between drawings
You can use the Clipboard to cut or copy entities from one drawing to another. 
Cutting removes the selected entities from a drawing and stores them on the 
Clipboard. Copying duplicates the selected entities from a drawing and places them 
on the Clipboard.     

To cut entities to the Clipboard
1 Select the entities you want to cut.
2 Do one of the following:   

• Choose Edit > Cut.

• On the Standard toolbar, click the Cut tool ( ).

• Type cutclip and then press Enter.

To make multiple copies of an entity, select the 
entity to copy (A), specify the base point (B), and 
then specify the displacement points (C, D, and 
E).

Result.

A

B
C

D
E
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To copy entities to the Clipboard
1 Select the entities you want to copy.
2 Do one of the following:

• Choose Edit > Copy.

• On the Standard toolbar, click the Copy tool ( ).

• Type copyclip and then press Enter.

Anything that you can copy to the Clipboard can be pasted into a drawing. The format 
in which the program adds the Clipboard contents to the drawing depends on the type 
of information in the Clipboard. For example, if you copy IntelliCAD drawing enti-
ties to the Clipboard, the program pastes them into the drawing as IntelliCAD enti-
ties. If you copy objects to the Clipboard from other programs, they are pasted into 
the current drawing as embedded ActiveX objects. 

To paste entities from the Clipboard
1 Do one of the following:     

• Choose Edit > Paste.

• On the Standard toolbar, click the Paste tool ( ).

• Type pasteclip and then press Enter.

Making parallel copies
You can use the parallel feature to copy selected entities and align them parallel to the 
original entities at a specified distance. You can make parallel entities using arcs, cir-
cles, ellipses, elliptical arcs, lines, two-dimensional polylines, rays, and infinite lines.    

Making parallel copies of curved entities creates larger or smaller curves, depending 
on which side of the original entity you place the copy. For example, placing a paral-
lel copy of a circle outside the circle creates a larger concentric circle; positioning the 
copy inside the circle creates a smaller concentric circle.
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To make a parallel copy by specifying the distance 
1 Do one of the following:

• Choose Modify > Parallel.

• On the Modify toolbar, click the Parallel tool ( ).

• Type parallel and then press Enter.

2 Specify the distance by selecting two points or by entering a distance.
3 Select the entity to copy.
4 Specify on which side of the entity to place the parallel copy.
5 Select another entity to copy, or press Enter to complete the command. 
  

To make a parallel copy passing through a point
1 Do one of the following:     

• Choose Modify > Parallel.

• On the Modify toolbar, click the Parallel tool ( ).

• Type parallel and then press Enter.

2 In the prompt box, choose Through Point.
3 Select the entity to copy.
4 Specify the point for the entity to pass through.
5 Repeat steps 3 and 4, or press Enter to complete the command.    

To make a parallel copy, specify the distance between copies 
by entering a distance or selecting two points (A and B), select 
the entity to copy (C), and specify on which side to place the 
copy (D).

Result.

A

B

C

D

To make a parallel copy passing through a point, select the entity to copy (A) and then specify the through 
point (B).

A

B
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Mirroring entities    
You can create a mirror image of an entity. You mirror the entity about a mirror line, 
which you define by specifying two points in a drawing. You can delete or retain the 
original entities.    

To mirror entities
1 Do one of the following:     

• Choose Modify > Mirror.

• On the Modify toolbar, click the Mirror tool ( ).

• Type mirror and then press Enter.

2 Select the entity, and then press Enter.
3 Specify the first point of the mirror line.
4 Specify the second point of the mirror line.
5 In the prompt box, choose one of the following:

• Yes-Delete Entities to delete the original entities.

• No-Keep Entities to retain the original entities.    

Arraying entities   
You can copy an entity in a rectangular or polar (circular) pattern, creating an array. 
For a rectangular array, you control the number of copies in the array by specifying 
the number of rows and columns. You also specify the distance between each row 
and column. For a polar array, you control the number of copies that compose the 
array and whether to rotate the copies.      

To mirror an entity, select it (A), and then specify the 
first point (B) and second point (C) of the mirror line.

Result.

A B

C
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To create a polar array    
1 Do one of the following:

• Choose Modify > Array.

• On the Modify toolbar, click the Array tool ( ).

• Type array and then press Enter.

2 Select the entities, and then press Enter.
3 In the prompt box, choose Polar.
4 Specify the center point of the array.
5 Specify the number of items to array, including the original selection set.
6 Specify the angle the array is to fill, from 0 to 360 degrees.

The default setting for the angle is 360 degrees. Positive values create the array in a 
counterclockwise direction; negative values create the array in a clockwise direc-
tion.

7 In the prompt box, choose one of the following:
• Yes-Rotate Entities, to rotate entities as they are arrayed.

• No-Do Not Rotate, to retain the original orientation of each copy as it is arrayed.   

To create a rectangular array
1 Do one of the following:     

• Choose Modify > Array.

• On the Modify toolbar, click the Array tool ( ).

• Type array and then press Enter.

2 Select the entities, and then press Enter.
3 In the prompt box, choose Rectangular.
4 Type the number of rows.
5 Type the number of columns.
6 Specify the distance between the rows.
7 Specify the distance between the columns. 

To create a polar array, select the entity to copy (A), specify the center point of the array (B), and then 
specify the number of items to array, the angle the array is to fill, and whether to rotate the items.

A

B
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Rearranging entities    

You can move one or more entities, and you can also rotate entities about a specified point.  

Moving entities    
You can move entities around within the current drawing or from one drawing to 
another. The default method is to create a selection set and then specify a starting 
point, or base point, and an endpoint, or displacement point, to define the relocation 
of the entities. You can also relocate the entities using a direction vector.    

To move a selection set
1 Do one of the following:     

• Choose Modify > Move.

• On the Modify toolbar, click the Move tool ( ).

• Type move and then press Enter.

2 Select the entities, and then press Enter.
3 Specify the base point.
4 Specify the displacement point.    

To create a rectangular array, select the entity to copy (A), type the number of rows and columns, and then 
specify the distance between each row (B) and column (C).

A

B

C

To move an entity, select it (A), and then specify the 
base point (B) and the displacement point (C).

Result.

A

B

C
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You can also move entities using grips. To move an entity using grips, select the 
entity to display its grips, and then click a grip and drag it. The grip you select 
depends on the type of entity you’re modifying. For example, to move a line entity, 
select the midpoint grip. To move a curved entity, such as an arc, circle, or ellipse, 
select the center point grip. Not all entities can be moved using grips.    

To move an entity using grips
1 Select the entity.
2 Click a grip to select it.
3 Drag the entity to where you want to relocate it.
4 Click to release.

Rotating entities    
You can rotate entities about a specified point at a specified rotation angle or by an 
angle referenced to a base angle. The default method rotates the entities using a rela-
tive rotation angle from their current orientation.    

To rotate a selection set
1 Do one of the following:     

• Choose Modify > Rotate.

• On the Modify toolbar, click the Rotate tool ( ).

• Type rotate and then press Enter.

2 Select the entities, and then press Enter.
3 Specify the rotation point.
4 Specify the rotation angle.    

To rotate an entity, select the entity to rotate (A), and then specify the rotation point (B) and the rotation 
angle (C).

A
B

C
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To rotate a selection set in reference to a base angle
1 Do one of the following:

• Choose Modify > Rotate.

• On the Modify toolbar, click the Rotate tool ( ).

• Type rotate and then press Enter.

2 Select the entities, and then press Enter.
3 Specify the rotation point.
4 In the prompt box, choose Base Angle.
5 Specify the base angle.
6 Specify the new angle.    

To rotate an entity in reference to a base angle, select the entity (A), specify the rotation point (B), select the 
base angle and pick point (B) again (or type the @ symbol), specify the second point (C), and then specify 
the point representing the new angle (D).

A

B C

D
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Resizing entities    

You can change the size of an entity or set of entities by stretching, scaling, extend-
ing, trimming, or editing their lengths.     

Stretching entities    
You can change the size of entities by stretching them. When you stretch entities, you 
must select the entities using either a crossing window or a crossing polygon. You 
then specify a displacement distance or select a base point and a displacement point. 
Entities that cross the window or polygon boundary are stretched; those completely 
within the crossing window or crossing polygon are simply moved.    

To stretch an entity
1 Do one of the following:

• Choose Modify > Stretch.    

• On the Modify toolbar, click the Stretch tool ( ).

• Type stretch and then press Enter.

2 In the prompt box, choose Crossing Window or Crossing Polygon.
3 Select the entities, and then press Enter.
4 Specify the base point.
5 Specify the second point of displacement.    

To stretch an entity using grips, you select it to display its grips and then select a grip 
to make it the active grip. This becomes the base point. Then you move the active 
grip to a new location. The grip you select depends on the type of entity you’re modi-
fying. For example, to stretch one corner of a rectangle, select the corner point grip. 
To stretch a line, select an endpoint grip. Not all entities can be stretched using grips.     

To stretch entities, select them using a crossing window (A) or crossing polygon, and then specify the base 
point (B) and displacement point (C).

A

B

C
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To stretch an entity using grips
1 Select the entity.
2 Click a grip to activate it.
3 Drag the grip.
4 Click to release.    

Scaling entities
You can change the size of a selected entity by scaling it in relation to a base point. 
You can change the size of an entity by specifying a base point and a length, which is 
used as a scale factor based on the current drawing units, or by specifying a scale fac-
tor. You can also use a scale factor referenced to a base scale factor, for example, by 
specifying the current length and a new length for the entity.    

To scale a selection set by a scale factor
1 Do one of the following: 

• Choose Modify > Scale.

• On the Modify toolbar, click the Scale tool ( ).

• Type scale and then press Enter.

2 Select the entities, and then press Enter.
3 Specify the base point.
4 Specify the scale factor.    

To stretch an entity using grips, select the entity 
(A), select a grip (B), and drag the grip to its new 
location (C).

Result.

A
B

C

To scale an entity by a scale factor, select the entity (A),  
and then specify the base point (B) and the scale factor.

Result.

A
B
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You can also scale some entities using grips. To scale an entity, you select the entity, 
and then click a grip. You then change the size of the entity by moving the grip. The 
grip you select depends on the type of entity you’re modifying. For example, to scale 
a circle, select a quadrant point grip.

To scale an entity using grips
1 Select the entity.
2 Click a grip to select it.
3 Drag the grip.
4 Click to release.  

Extending entities    
You can extend entities so that they end at a boundary defined by other entities. You 
can also extend entities to the point at which they would intersect an implied bound-
ary edge. When extending entities, you first select the boundary edges, and then spec-
ify the entities to extend, selecting them either one at a time or using the fence 
selection method.    

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, 
ellipses, lines, splines, polylines, rays, infinite lines, and viewports in paper space can 
act as boundary edges.

To extend an entity
1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more entities as boundary edges, and then press Enter.
3 Select the entity to extend.
4 Select another entity to extend, or press Enter to complete the command.

To scale using grips, select the entity (A), click a grip (B), and 
scale the entity by dragging the grip to its new 
location (C).

Result.

A

B

C
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To extend an entity to an implied boundary    
1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more boundary edges, and then press Enter.
3 In the prompt box, choose Edge Mode.
4 In the prompt box, choose Extend.
5 Select the entity to extend.
6 Select another entity to extend, or press Enter to complete the command.    

To extend entities, select the boundary edge (A), and then 
select the entities to extend (B).

Result.

A

B
B

Select the boundary edge (A), and then select the entities to 
extend (B).

Result.

A
B

B
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To extend several entities using the fence selection method    
1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more boundary edges, and then press Enter.
3 In the prompt box, choose Fence.
4 Specify the first point of the fence.
5 Specify the second point of the fence.
6 Specify the next fence point, or press Enter to complete the command.
  

When you extend a wide polyline, its centerline intersects the boundary edge. 
Because the end of the polyline is always cut at a 90-degree angle, part of the polyline 
may extend past the boundary edge. A tapered polyline continues to taper until it 
intersects the boundary edge. If this would result in a negative polyline width, the 
ending width changes to 0.        

Select the boundary edge (A), and then specify the  
first point (B) and second point (C) of the fence. 

Result.

A

B

C

A tapered polyline (A) continues to taper until  
it intersects the boundary edge (B).

Result.

A

A

B
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Trimming entities    
You can clip, or trim, entities so they end at one or more implied cutting edges 
defined by other entities. You can also trim entities to the point at which they would 
intersect an implied cutting edge. When trimming entities, you first select the cutting 
edges and then specify the entities to trim, selecting them either one at a time or using 
the fence selection method.    

You can trim arcs, circles, lines, open two-dimensional and three-dimensional 
polylines, and rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports 
in paper space can act as cutting edges. An entity can be both a cutting edge and one 
of the entities being trimmed.

To trim an entity
1 Do one of the following:

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.
3 Select the entity to trim.
4 Select another entity to trim, or press Enter to complete the command.    

To trim an entity to an implied boundary
1 Do one of the following:     

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.
3 In the prompt box, choose Edge Mode.
4 In the prompt box, choose Extend.
5 Select the entity to trim.

To trim entities, select the cutting edge (A), and then select 
the entities to trim (B).

Result.

A

B
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6 Select another entity to trim, or press Enter to complete the command.    

To trim several entities using the fence selection method
1 Do one of the following:     

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.
3 In the prompt box, choose Fence.
4 Specify the first point of the fence.
5 Specify the second point of the fence.
6 Specify the next fence point, or press Enter to complete the command.     

Editing the length of entities   
You can change the length of entities or the included angle of arcs. Use any of the fol-
lowing methods to change the length of an entity:    

• Dynamically drag the endpoint or angle.
• Specify an incremental length or angle measured from an endpoint.
• Specify the new length as a percentage of the total length or angle.

• Specify a new length or included angle.

You can change the length of arcs, lines, and open polylines.

Select the implied boundary edge (A), and then select 
the entities to trim (B).

Result.

A

B

Select the boundary edge (A), and then specify the first 
point (B) and second point (C) of the fence.

Result.

A B

C
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To change the length of an entity by dragging
1 Do one of the following:     

• Choose Modify > Edit Length.

• On the Modify toolbar, click the Edit Length tool ( ).

• Type editlen and then press Enter.

2 In the prompt box, choose Dynamic.
3 Select the entity you want to change.
4 Specify the new endpoint or included angle. 
  

Select the entity (A), and then select the new 
endpoint (B).

Result.

A
B

A B
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Breaking and joining entities    

You can break an entity into two parts, removing a portion of the entity in the pro-
cess. You can also join two entities into a single entity.    

Breaking entities
You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When 
breaking entities, you must specify two points for the break. By default, the point you 
use to select the entity becomes the first break point; however, you can use the First 
option to select a break point different from the one that selects the entity.    

To break an entity
1 Do one of the following:     

• Choose Modify > Break.

• On the Modify toolbar, click the Break tool ( ).

• Type break and then press Enter.

2 Select the entity.
3 Specify the second break point.    

To select an entity and then specify the two break points
1 Do one of the following:

• Choose Modify > Break.

• On the Modify toolbar, click the Break tool ( ).

• Type break and then press Enter.

2 Select the entity.
3 In the prompt box, choose First.
4 Specify the first break point.
5 Specify the second break point.

Select the entity (A), and then specify the second break 
point (B).

Result.

A

B
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TIP  To break an entity in two without removing a portion of the entity, specify the 
same point for the first and second break points by typing the at sign (@) and press-
ing Enter instead of specifying the second break point.    

Joining entities
You can join two entities into a single entity. You can join either two lines or two arcs. 
The two lines must be parallel; the two arcs must share the same center point and radius.    

When you join two lines, the farthest endpoints remain at their existing locations; the 
program draws a new line between these points. Arcs are joined counterclockwise, 
from the first arc you select to the second.

To join two entities
1 Do one of the following:

• Choose Modify > Join.

• On the Modify toolbar, click the Join tool ( ).

• Type join and then press Enter.

2 Select the first arc or line.
3 Select the second arc or line.  

Select the entity (A), and then specify the first (B) and 
second (C) break points.

Result.

A
B

C

Select the first arc or line (A), and then select the 
second arc or line (B).

Result.

A

A

B

B
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Grouping entities   

A group is a collection of entities saved together as one unit. After you select the enti-
ties that belong in the group, you can later add more entities, remove entities, and re-
order the entities. If necessary, you can also ungroup the entities at any time to work 
with the entities separately.

The Group dialog box controls the settings for all groups in a drawing. 

Creating groups 
When you create a group, you enter a group name and description, and then select the 
entities for the group. 

To create a group
1 Do one of the following:

• Choose Tools > Group.

• On the Tools toolbar, click the Group tool ( ).

• Type group and then press Enter.

2 Under Create New Group, enter the name and description of the group.
3 Click Selectable if you want all entities in the group to be selected when you select 

one entity of the group in the drawing.
4 Click Select Entities and Create Group.
5 Select the entities for the group, and then press Enter.
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6 In the Group dialog box, click OK.

TIP You can enter the name of a group when selecting objects at the command 
prompt.

Modifying groups

To modify a group and its entities
1 Do one of the following:

• Choose Tools > Group.

• On the Tools toolbar, click the Group tool ( ).

• Type group and then press Enter.

2 In the Group dialog box, select the group you want to modify.
3 Under Modify Selected Group, do one or more of the following:

• Enter a new name, and then click Rename Group.

• Enter a new description, and then click Change Group Description.

• Select whether you want the group to be selectable in the drawing.

• Click Add Entities to Group, select the entities to add to the group, and then 
press Enter.

• Click Remove Entities from Group, select the entities to remove from the group, 
and then press Enter.

4 In the Group dialog box, click OK.
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To change the order of entities in a group 
1 Do one of the following:

• Choose Tools > Group.

• On the Tools toolbar, click the Group tool ( ).

• Type group and then press Enter.

2 In the Group dialog box under Modify Selected Group, click Re-order Entities.
3 In the Re-Order Grouped Entities dialog box, select the group you want to re-

order.
4 To see the order of entities in the group, click Highlight. Follow the prompts that 

display to view the entities, one by one.
5 To reverse the order of all entities in the group, click Reverse Order.
6 To change the order of specific entities or a range of entities:

• In Remove from Position, enter the current position of the entity. 

• In Place to Position, enter the new position of the entity. 

• In Number of Entities, enter the number of entities or range of entities to re-
order. For example, if you are changing the order of only one entity, enter 1. 

• Click Re-Order.

NOTE The entities in a group are numbered 0, 1, 2, 3, and so on.

7 Click OK, and then click OK again.
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Ungrouping entities
When you ungroup entities, the entities remain in the drawing but the group is deleted 
from the drawing.

To ungroup entities
1 Do one of the following:

• Choose Tools > Group.

• On the Tools toolbar, click the Group tool ( ).

• Type group and then press Enter.

2 In the Group dialog box, select the group to delete.
3 Under Modify Selected Group, click Ungroup Entities.
4 Click OK.

Editing polylines    

You can modify any type of two-dimensional or three-dimensional polyline. Entities 
such as rectangles, polygons, and donuts, as well as three-dimensional entities such as 
pyramids, cylinders, and spheres, are all variations of polylines that you can edit.    

You can edit a polyline by opening or closing it, by changing its overall width or the 
widths of individual segments, and by converting a polyline with straight line seg-
ments into a flowing curve or an approximation of a spline. In addition, you can use 
the Edit Polyline tool to edit individual vertices, adding, removing, or moving verti-
ces. You can also add new segments to an existing polyline, change the linetypes of a 
polyline, and reverse the direction or order of the vertices.    

To modify a polyline, you first select the polyline, and then select a polyline editing 
option. The available options vary depending on whether the selected polyline is a 
two-dimensional or three-dimensional entity. If the selected entity is not a polyline, 
the Edit Polyline tool provides the option of turning it into one. You can convert only 
arcs and lines into polylines. If several arcs or lines are joined endpoint to endpoint, 
they can all be selected and turned into one polyline.    

To convert an entity into a polyline
1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the entity.
3 In the prompt box, choose Yes-Turn Into Polyline.
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4 In the prompt box, choose another option, or choose Done to complete the 
command.

Opening and closing polylines
When you close a polyline, the program draws a straight polyline segment from the 
last vertex of the polyline to the first vertex. Opening a polyline removes the closing 
segment. When you select a polyline for editing, the prompt box displays either the 
Open or Close option, depending on whether the polyline you select is closed or 
open.    

To close an open polyline
1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.
3 In the prompt box, choose Close.
4 In the prompt box, choose another option, or choose Done to complete the 

command.    

Curving and decurving polylines   
You can convert a multisegment polyline into a smooth curve using either the Fit or 
Spline option. The Fit option creates a smooth curve connecting all the vertices. The 
Spline option computes a smooth curve that is pulled toward the vertices but passes 
through only the first and last vertices. The Decurve option removes Fit or Spline 
curves and arcs, leaving straight segments between the vertices.    

Closing an open polyline adds a straight 
polyline segment between the first (A) and last 
(B) vertices.

Result.

A B
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To fit a curve to a polyline
1 Do one of the following:    

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.
3 In the prompt box, choose Fit.
4 In the prompt box, choose another option, or choose Done to complete the 

command.
  

Joining polylines    
You can add an arc, line, or polyline entity to an existing open polyline, forming one 
continuous polyline entity. To join an entity to a polyline, that entity must already 
share an endpoint with an end vertex of the selected polyline.    

When you join an entity to a polyline, the width of the new polyline segment depends 
on the width of the original polyline and the type of entity you are joining to it:

• A line or an arc assumes the same width as the polyline segment for the end vertex 
to which it is joined.

• A polyline joined to a tapered polyline retains its own width values.

• A polyline joined to a uniform-width polyline assumes the width of the polyline to 
which it is joined.    

Original polyline. After applying Fit curve. After applying Spline.
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To join an arc, line, or polyline to an existing polyline 
1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.
3 In the prompt box, choose Join.
4 Select the arc, line, or polyline to join.
5 In the prompt box, choose another option, or choose Done to complete the 

command.

Changing the polyline width    
You can change the width of an entire polyline, applying a uniform width to the entire 
entity or tapering the polyline uniformly along its entire length.    

To apply a uniform width to an entire polyline    
1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.
3 In the prompt box, choose Width.
4 Specify the new polyline width.
5 In the prompt box, choose another option, or choose Done to complete the 

command.

To taper a polyline uniformly along its length
1 Do one of the following:     

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.
3 In the prompt box, choose Taper.
4 Specify the starting width.
5 Specify the ending width.
6 In the prompt box, choose another option, or choose Done to complete the 

command.
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Editing polyline vertices    
You can use the Edit Vertices option to modify individual polyline vertices. When 
you select this option, the program switches into a special vertex editing mode and 
places an x on the first vertex. The x indicates the vertex you are editing. The Next 
and Previous options move the x to the next or previous vertex. You can edit only one 
vertex at a time.    

When editing vertices, you can modify the polyline in the following ways:

• Convert a polyline segment into a curve by specifying a new tangent angle.
• Break a polyline into two separate polylines.
• Insert a new vertex after the current vertex.
• Move the current vertex.
• Straighten the polyline segment between two vertices.

• Change the width of the polyline segment between two vertices.

To move a polyline vertex    
1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.
3 In the prompt box, choose Edit Vertices.
4 In the prompt box, choose Next Vertex.

Repeat until the x reaches the vertex you want to move.
5 In the prompt box, choose Move.
6 Specify the new location for the vertex.
7 In the prompt box, choose another option, or choose Exit to stop editing vertices.
8 In the prompt box, choose another option, or choose Done to complete the 

command.    

Select the polyline (A), move the current vertex 
marker to the vertex you want to move (B), and then 
specify the new vertex location (C).

Result.

A

B

C
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To taper the width of an individual polyline segment
1 Do one of the following:     

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.
3 In the prompt box, choose Edit Vertices.
4 In the prompt box, choose Next Vertex.

Repeat until the x reaches the first vertex of the segment you want to taper.
5 In the prompt box, choose Width.
6 Specify the starting width.
7 Specify the ending width.
8 In the prompt box, choose another option, or choose Exit to stop editing vertices 

and update the display.
9 In the prompt box, choose another option, or choose Done to complete the 

command.    

Select the polyline (A), move the current vertex 
marker to the first vertex of the segment you want to 
taper (B), and then specify the new starting and 
ending widths for that segment.

Result.

A B
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Exploding entities    

You can convert a complex entity, such as a block or polyline, from a single entity 
into its component parts. Exploding a polyline, rectangle, donut, polygon, dimension, 
or leader reduces it to a collection of individual line and arc entities that you can then 
modify individually. Blocks are converted to the individual entities, possibly includ-
ing other, nested blocks that composed the original entity.                                               

With the following exceptions, exploding an entity usually has no visible effect on a 
drawing:

• If the original polyline had a width, the width information is lost when you explode 
it. The resulting lines and arcs follow the centerline of the original polyline.    

• If you explode a block containing attributes, the attributes are lost, but the original 
attribute definitions remain.    

• Colors and linetypes assigned BYBLOCK may appear different after exploding an 
entity, because they will adopt the default color and linetype until inserted into 
another block.    

To explode an entity
1 Do one of the following:

• Choose Modify > Explode.

• On the Modify toolbar, click the Explode tool ( ).

• Type explode and then press Enter.

2 Select the entities to explode.
3 Press Enter.
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Chamfering and filleting entities             

You can chamfer or fillet entities. A chamfer connects two nonparallel entities with a 
line to create a beveled edge. A fillet connects two entities with an arc of a specified 
radius to create a rounded edge. If both entities you are working with are on the same 
layer, the chamfer or fillet is drawn on that layer. If they are on different layers, the 
chamfer or fillet is drawn on the current layer.                                     

The Chamfer/Fillet settings in the Drawing Settings dialog box control the chamfer 
and fillet settings. The portions of the entities that extend beyond the chamfer or fillet 
are normally deleted when you create the chamfer or fillet. You can retain these 
original entities, however, by changing the settings in the dialog box.    

A Click to remove or retain portions of entities that 
extend beyond the chamfer or fillet.

B Click to create a chamfer using two chamfer 
distances (distance-distance method).

C Specify the first and second chamfer distances 
when using the distance-distance method.

D Specify the chamfer length and angle when 
using the distance-angle method.

E Click to create a chamfer using the chamfer 
length and angle (distance-angle method).

F Click to specify the fillet radius by selecting two 
points in the drawing.    

G Specify the fillet radius.

A

D

B
E
F

G

C
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Chamfering entities    
You can connect two nonparallel entities by extending or trimming them and then 
joining them with a line to create a beveled edge. You can chamfer lines, polylines, 
rays, and infinite lines. When creating a chamfer, you can specify how far to trim the 
entities back from their intersection (distance-distance method), or you can specify 
the length of the chamfer and the angle it forms along the first entity (distance-angle 
method).    

When chamfering a polyline, you can chamfer multiple segments between two 
selected polyline segments, or you can chamfer the entire polyline.

To chamfer two entities using the distance-distance method
1 Do one of the following:     

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Chamfer Settings.
3 In the Drawing Settings dialog box, click the Entity Modification tab.
4 Under Chamfer Distances And Angles, click Distance-Distance.
5 Under Chamfer Distances And Angles, specify the first and second chamfer 

distances.
6 Click OK.
7 Select the first entity.
8 Select the second entity.    

Select the first (A) and second (B) entities. The chamfer is drawn, based on the first (C) and second (D) 
chamfer distances.

A

B

C

D
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To chamfer two entities using the distance-angle method
1 Do one of the following:

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Chamfer Settings.
3 In the Drawing Settings dialog box, click the Entity Modification tab.
4 Under Chamfer Distances And Angles, click Distance-Angle.
5 Under Chamfer Distances And Angles, specify the chamfer distance and angle.
6 Click OK.
7 Select the first entity.
8 Select the second entity.
  

To chamfer all vertices in a polyline
1 Do one of the following:     

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Polyline.
3 Select the polyline.    

Select the first (A) and second (B) entities. The chamfer is drawn, based on the distance measured along 
the first entity (C) and the angle (D) formed with the first entity.

A

B

C

D

Original polyline. Result after chamfering.
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To chamfer selected vertices in a polyline
1 Do one of the following:

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 Select the polyline along the segment where you want to begin the chamfer.
3 Select the polyline along the segment where you want to end the chamfer.    

Filleting entities    
You can connect two entities with an arc of a specified radius to create a rounded 
edge. You can fillet pairs of line segments, straight polyline segments, arcs, circles, 
rays, and infinite lines. You can also fillet parallel lines, rays, and infinite lines. When 
filleting a polyline, you can fillet multiple segments between two selected segments, 
or you can fillet the entire polyline.    

To fillet two entities
1 Do one of the following:

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 In the prompt box, choose Fillet Settings.
3 In the Drawing Settings dialog box, specify the fillet radius.
4 Click OK.
5 Select the first entity.
6 Select the second entity.    

Select the polyline along the (A) and (B) 
segments.

Result after chamfering.

A B

Select the first (A) and second (B) entities. Result after filleting.

A

B
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To fillet an entire polyline
1 Do one of the following:

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 In the prompt box, choose Polyline.
3 Select the polyline.    

To fillet selected vertices in a polyline
1 Do one of the following:    

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 Select the polyline along the segment where you want to begin the fillet.
3 Select the polyline along the segment where you want to end the fillet.    

Select the polyline (A). Result after filleting.

A

Select the polyline along the (A) and (B) 
segments.

Result after filleting.

A B
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When you fillet circles and arcs, more than one fillet can exist between the entities. 
The point at which you select the entities determines the fillet.    

You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or 
ray; the second entity can be a line, ray, or infinite line. The diameter of the fillet arc 
is always equal to the distance between the parallel entities. The current fillet radius is 
ignored.         

Select entities (A and B). Results after filleting.

B

A

B

A

B

A

B

A

Original entities. Result after filleting.
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11

Working with text

You can insert text into your drawing and control its appearance, allowing you to pro-
vide additional information for your IntelliCAD® drawings. This chapter explains 
how to:

• Create line text.
• Create paragraphs.
• Create text styles.
• Format text.
• Change text.

• Change paragraph text.

• Use an alternate text editor.

Topics in this chapter
Creating line text ...............................................................................................240
Creating paragraph text ....................................................................................241
Working with text styles.....................................................................................243
Formatting text ..................................................................................................244
Changing text ....................................................................................................248
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Creating line text       

When you create text, you end each line of text by pressing Enter. Each line of text is 
created as a separate entity that you can modify.

To create text 
1 Do one of the following:           

• Choose Insert > Text.

• On the Draw 2D toolbar, click the Text tool ( ).

• Type dtext and then press Enter.    

2 Specify the insertion point for the first character.    
3 Specify the height of the text.
4 Specify the text rotation angle.     
5 Type the text, and then press Enter at the end of each new line.
6 To complete the command, press Enter again.

TIP  If you’ve already created text and want new text to appear immediately below the 
previous text, choose Insert > Text. When prompted for an insertion point, press 
Enter. The new text will keep the same height and rotation angle as the previous text.
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Creating paragraph text    

Paragraph text consists of one or more lines of text or paragraphs that fit within a 
boundary width that you specify. Each paragraph text entity you create is treated as a 
single entity regardless of the number of individual paragraphs or lines of text it 
contains.    

When you create paragraph text, you first determine the paragraph’s boundary width 
by specifying the opposite corners of a rectangle. The paragraph text automatically 
wraps so that it fits within this rectangle. The first corner of the rectangle determines 
the default attachment point of the paragraph text. You can change the location of the 
attachment point in reference to the rectangle, and you can determine the direction in 
which text flows within the rectangle. You can also select the text style, text height, 
and the rotation angle of the entire paragraph text entity.    

To create paragraph text 
1 Do one of the following:

• Choose Insert > Multiline Text.

• On the Draw 2D toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter.    

2 Select the first corner of the text area.
3 In the MTEXT prompt box, select the properties you want to change, or proceed 

directly to step 4. 
You can select these properties in steps 7 and 8.

4 Select the second corner of the text area.
5 In the Multiline Text dialog box, click the Text tab.
6 In the window, type the text you want. 

To create paragraphs, press Enter and continue typing.
7 Make any selections or changes you want to the font, height, and text variations 

for bold, italic, and underline. 
8 Click the Properties tab, and make selections or changes you want to the text 

Style, Justification, Width, and Rotation.           
9 Click OK.

TIP You can paste text from the Clipboard into the Multiline Text dialog box.     
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A Text attributes tab.
B Font selections.
C Text area.

D Undoes last action.
E Changes font attributes of highlighted text.
F Text height selections.

A Properties tab.
B Text style selections.
C Text area.

D Angle of text box selections.
E Width of text box selections.
F Justification of text box selections.

A

B

C

EF D

A
B

C

F E D



W O R K I N G  W I T H  T E X T    243
Working with text styles    

When you add text to a drawing, it uses the current text style. Text style determines 
the font, size, angle, orientation, and other characteristics.           

Every drawing has a default text style, named Standard, which initially uses the 
icad.fnt font. You cannot delete the Standard style, but you can rename it or modify 
it. You can change the font, the size of the font, and the obliquing angle applied to it. 
If you change the font or orientation of an existing style, all existing text entities cre-
ated using that style are automatically updated to reflect the new font or orientation. 
Changing any other characteristic has no effect on existing text. You also can create 
and use an unlimited number of additional text styles.        

The text style determines the characteristics shown in the following table.                   

Style characteristics 
Characteristic Default Description
Style name Standard The name of the style, up to 31 characters.

Font file icad.fnt The font file on which the style is based.

Text height 0 The character height. A value of 0 prompts for text height upon insertion. 

Width factor 1 The horizontal expansion or compression of the text. Values less than 1 compress the text; 
values greater than 1 expand the text.

Obliquing angle 0 The slant of the text, in degrees. Negative values slant the text to the left; positive values slant 
the text to the right.

Backward No Determines whether text appears backward.

Upside down No Determines whether text appears upside down.

Vertical No Determines whether text has a vertical orientation.
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To create a text style     
1 Do one of the following:     

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Choose Edit > New > Style.
3 Type a new text style name, or press Enter to accept the default name.
4 Choose Edit > Properties to open the Styles dialog box.
5 Under Text Font, select the name, style, and language of the font you want to use.      
6 Under Text Measurements, enter the Fixed Text Height, Width Factor, and 

Oblique Angle measurement.    
7 Under Text Generation, select the check boxes you want to indicate the direction 

for printed text to appear.
8 Close the Styles dialog box, then close the IntelliCAD Explorer dialog box.
9 To begin using the new style, choose Insert > Text. 

10 In the prompt box, select Use Defined Style.

Formatting text    

When you create text, you choose the text style and set the alignment. The style deter-
mines the font characteristics for the text. For line text, the alignment determines how 
the text aligns with the text insertion point. For paragraph text, the alignment deter-
mines the location of the attachment point in relation to the paragraph text boundary 
and the direction in which text flows within the boundary.         

Setting the line text style
You can set the text style before you specify the insertion point. You select the text 
style by typing the name of a previously defined style.       
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To specify a line text style
1 Do one of the following:     

• Choose Insert > Text.

• On the Draw 2D toolbar, click the Text tool ( ).

• Type dtext and then press Enter.

2 In the prompt box, choose Use Defined Style.
3 Type the name of a previously defined text style, and then press Enter.        

To display a list of available text styles, type a question mark (?), and then press 
Enter.    

4 Specify the text insertion point.     
5 Specify the text height.     
6 Specify the rotation angle.    
7 Type the text line, and then press Enter.
8 To complete the command, press Enter again.

Setting the paragraph text style
You can set the paragraph text style before you specify the insertion point. You select 
the text style by typing the name of a previously defined style.

To specify a paragraph text style
1 Do one of the following:

• Choose Insert > Multiline Text.

• On the Draw 2D toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter.

2 Specify the first point of the Multiline Text box.
3 In the prompt box, choose Text Style.
4 Type the name of a previously defined text style, and then press Enter.
5 Specify the text height.
6 Specify the rotation angle.
7 Specify the opposite corner of the Multiline Text box.
8 Type the text, and then press Enter.
9 To complete the command, press Enter again.
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Setting the line text alignment    
When you create text, you can set the text alignment before you specify the insertion 
point. You set the alignment by choosing it in the prompt box. By default, text is left 
justified. You can align text at the left, center, or right and at the top, middle, or base-
line of the text or at the bottom of descending letters.                  

You can also align text so that it fits or aligns between two points. The Align option 
creates text that scales up or down while maintaining a constant height/width ratio; 
the Fit option expands or compresses the text to fit between the two points.        

A Top left
B Middle left
C Left
D Bottom left
E Center
F Bottom center
G Bottom right

H Baseline
I Right
J Middle right
K Top right
L Middle
M Middle center
N Top center

J

KL

GD

A

B

C

M

H
FE

I

N

Text aligned between two points maintains a 
constant height/width ratio.

Text fit between two points expands or compresses 
to fit.
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To specify the line text alignment
1 Do one of the following:       

• Choose Insert > Text.

• On the Draw 2D toolbar, click the Text tool( ).

• Type dtext and then press Enter.    

2 In the prompt box, choose an alignment option, or choose Justification Options to 
display all the justification options.

3 Specify the text insertion point, and then continue creating the line text.

Setting the paragraph text alignment
When you create paragraph text, you can set the text alignment by specifying the 
attachment point location in relation to the paragraph text boundary and the direction 
in which text flows within the boundary. You can set the paragraph text alignment 
either in the prompt box displayed after you specify the first corner of the paragraph 
text boundary or from the Multiline Text dialog box. You can specify the attachment 
point at the top left, top center, top right, middle left, middle center, middle right, bot-
tom left, bottom center, or bottom right. The paragraph text can flow left to right, 
right to left, top to bottom, or bottom to top.

Including special text characters    
You can use control codes to overscore or underscore text or to include special char-
acters. Both overscore and underscore can be active at the same time. To include con-
trol codes, as you type text, type two percent symbols (%%) followed by the special 
control code or character. A single percent sign is treated as a normal text character. 
A triple-percent control code is provided for those instances where a control-code 
sequence must follow a percent sign in the text.                         

Special text characters   
Control code Function
%%o Toggles overscore mode on and off.

%%u Toggles underscore mode on and off.

%%d Draws a degree symbol (º).

%%p Draws the plus-or-minus symbol (±).

%%c Draws the circle diameter symbol (Ø).

%%% Forces a single percent sign.

%%nnn Draws special character number nnn.

Text created using special text characters: Ut wisi %%uenim%%d ad%%p%%u minim %%c %%oveniam.
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Changing text    

Changing line text
You can edit and modify the text as you would any other drawing entity. That is, you 
can delete, move, rotate, and scale text.                      

To edit text     
1 Do one of the following:     

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool ( ).

• Type ddedit and then press Enter.

2 Select the text entity.
3 In the Text field, edit the text, and then click OK.

To change text properties
1 Do one of the following:           

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool( ).

• Type ddedit and then press Enter.

2 Select the text entity.
3 Under Text Settings, change the text properties you want.
4 Click OK.        
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Changing paragraph text
You can modify the text as you would any other drawing entity. That is, you can 
delete, move, rotate, and scale text.

To edit paragraph text
1 Do one of the following:

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool ( ).

2 Select the text entity.
3 Edit the text in the Contents field of the Entity Properties dialog box.
4 To apply font style changes to the text, click Full Editor.
5 Click OK.

A Click to change layer.
B Click to change color.
C Specify new text insertion point.
D Specify text height.
E Specify text rotation angle.
F Edit the existing text.
G Specify the width factor.

H Specify the obliquing angle.
I Select to insert backward text.
J Select to insert upside-down text.
K Click to change text style.
L Click to change text justification.
M Click to select a new text insertion point.

A

C

D

E

F

GH I

J

K
L

M

B
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To change paragraph text properties
1 Do one of the following:

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool ( ).

2 Select the text entity.
3 Change the text properties you want under the Text section of the Entity Properties 

dialog box.
4 To apply font style changes to the text, click Full Editor.
5 Click OK.

A Click to change layer.
B Click to change color.
C Specify new attachment point.
D Specify text height.
E Specify width of text boundary rectangle.
F Specify text rotation angle.

G Edit the existing text.
H Click to change font styles.
I Click to change text style.
J Click to change direction in which text flows.
K Click to change attachment point in relation to text 

boundary rectangle.
L Click to select a new attachment point.

C

B

A

D
E

L

F I

G

J
K

H
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Using an alternate text editor    

IntelliCAD includes a built-in text editor for creating paragraph text using the 
MTEXT command described earlier in this chapter (See Creating paragraph text
241. You can also specify an alternate text editor for the MTEXT command. 

Selecting an alternate text editor    
Before you can use an alternate text editor, you must specify the editor by setting the 
MTEXTED system variable.                      

To select an alternate text editor     
1 Type mtexted and then press Enter. 

2 Enter the path and name of the executable file for the text editor you want to use to 
create or edit multiline text. For example, to use Microsoft Wordpad, you would 
type something similar to the following (adjusting the path name as necessary):
C:\Program Files\Windows NT\Accessories\Wordpad.exe

Creating paragraph text in an alternate text editor    
                      

To use an alternate text editor     
1 Do one of the following:     

• Choose Insert > Multiline Text.

• On the Draw 2D toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter.    

2 Select the first and second corners of the text area, as described earlier in this 
chapter.

3 In the Multiline Text dialog box, click the Text tab.
4 In the window, type the text you want, using the special characters from the table 

shown below to achieve special formatting. Enter \P to end a paragraph and start a 
new paragraph on the next line. For example, to use an alignment value of 1 and 
stack two numbers to display them as a fraction:

{\A1;\S1/2;}\P 
5 When your text is complete, save the changes and exit the text editor. 
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Using Unicode characters
IntelliCAD supports the Unicode character encoding standard, which enables you to 
display and write text in different languages using different letters. Unicode fonts 
contain many more characters than typically defined in a system. See "Including spe-
cial text characters" and "Using an alternate text editor" earlier in this chapter for 
more information.

Special formatting characters   
Format characters Function
\0...\o Toggles overscore mode on and off.

\L...\l Toggles underscore mode on and off.

\~ Inserts a nonbreaking space.

\\ Inserts a backslash.

\{...\} Inserts an opening and closing brace.

\Cvalue; Sets the color to a specified value.

\File name; Sets the font based on a specified font file name.

\Hvalue; Sets the text height to a specified value.

\Hvaluex; Sets the text height to a multiple of the current text height.

\S...^...; Stacks the subsequent text at the /, #, or ^ symbol.

\Tvalue; Adjusts the space between characters, from 0.75 to 4 times.
\Qangle; Changes obliquing angle.

\Wvalue; Changes width factor to produce wide text.

\A Sets the alignment value.

\P Ends paragraph.
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Dimensioning your drawing

The IntelliCAD® dimensioning tools let you add measurements to a drawing. You 
can quickly add dimensions by simply pointing to entities. You can also add tolerance 
symbols to your drawings. 

The program’s many dimensioning variables let you control the appearance of the 
dimensions. With dimension styles, you can save dimension variable settings so you 
can reuse them without having to re-create them.

This chapter explains how to:

• Create dimensions as linear, angular, diametral, radial, and ordinate.
• Create leaders and annotations.
• Edit dimensions.
• Use dimension styles and variables.
• Add geometric tolerances.
• Control dimension tolerance.
• Control alternate dimension units.

Topics in this chapter
Understanding dimensioning concepts............................................................. 254
Creating dimensions ......................................................................................... 256
Editing dimensions............................................................................................ 266
Understanding dimension styles and variables ................................................ 269
Adding geometric tolerances ............................................................................ 280
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Understanding dimensioning concepts  

You can create five basic types of dimensions: linear, angular, radial, 
diametral, and ordinate. You can create dimensions for existing entities by 
selecting them, or you can create dimensions by selecting points within a 
drawing. For example, you can create a linear dimension either by selecting 
the entity to be dimensioned or by specifying the first and second extension 
line origins.             

When you create a dimension, the program draws it on the current layer, using the 
current dimension style. Each dimension has an associated dimension style, which 
controls the appearance of the dimension, such as the types of arrowheads, text style, 
and colors of various components. You can modify existing dimension styles by 
changing one of the dimension variable settings and then updating the dimension 
style to reflect the new settings.    

Each dimension you create consists of several parts. A dimension line shows where a 
dimension begins and ends. When you create an angular dimension, the dimension 
line is a dimension line arc that subtends the measured angle.    

A Radial dimension.
B Vertical linear dimension.
C Angular dimension.
D Linear continued dimensions.

E Aligned dimension.
F Diametral dimension.
G Horizontal linear dimension.
H Linear baseline dimension.

A

B

C

D

E
F

H

G
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Extension lines, also called projection lines, are lines that extend away from the entity 
for which you are creating a dimension, so that you can place the dimension line 
away from the entity. Arrowheads form the termination at each end of the dimension 
line.   

Dimension text contains the measured dimension and can also include prefixes, suf-
fixes, tolerances, and other optional text. As you insert dimensions, you can control 
the dimension text and specify its position and orientation.        

Dimensions can also contain other optional components. A leader is a line leading 
from a feature of the drawing to an annotation. Leaders begin with an arrowhead, and 
you can use them to place a dimension away from the dimension line or to add notes. 
When you create a radial dimension, you can add a center mark, which is a small 
cross that marks the center of a circle or an arc, or you can add centerlines, which are 
crossing lines that extend out from the center of a circle or an arc.      

A Extension line.
B Arrowhead.

C Dimension line.
D Dimension text.

A
B

C D

Leader. Center mark. Centerlines.
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Creating dimensions  

You can create dimensions by:    

• Selecting the entity to dimension and specifying the dimension line location.

• Specifying the extension line origins and the dimension line location.

When you create dimensions by selecting an entity, the program automatically places 
the extension line origins at the appropriate definition points based on the type of 
entity you select. For example, the definition points are located at the endpoints of 
arcs, lines, and polyline segments. When you create dimensions by specifying the 
extension line origins, the points you specify determine the definition points. To 
establish these points precisely, use entity snaps.    

Creating linear dimensions  
Linear dimensions annotate linear distances or lengths and can be oriented horizon-
tally, vertically, or aligned parallel to an existing entity or to the selected extension 
origin points. After you create a linear dimension, you can add a baseline dimension 
or a continued dimension. A linear baseline dimension inserts an additional dimen-
sion from a common first extension line origin of a previous linear dimension. A lin-
ear continued dimension continues a linear dimension from the second extension line 
of a previous linear dimension.    

TIP  To select precise ordinate points, use entity snaps.
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To create a horizontal or vertical dimension
1 Do one of the following:     

• Choose Insert > Dimensions > Linear.

• On the Dimensioning toolbar, click the Linear tool ( ).

• Type dimlinear and then press Enter.    

2 Press Enter, and then select the entity to dimension.    
Or, you can insert the dimension by specifying the first and second extension line 
origins.

3 Specify the dimension line location.            

To insert a linear dimension by selecting the entity, select the 
entity (A) to dimension, and then specify the dimension line 
location (B).

Result.

To insert a linear dimension by selecting the extension line 
origins, select the first extension origin (A), select the second 
extension origin (B), and then specify the dimension line 
location (C).

Result.

A
B

A

BC
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To create an aligned dimension    
1 Do one of the following:     

• Choose Insert > Dimensions > Aligned.

• On the Dimensioning toolbar, click the Aligned tool ( ).

• Type dimaligned and then press Enter.    

2 Press Enter, and then select the entity to dimension.
Or, you can insert the dimension by specifying the first and second extension line 
origins.

3 Specify the dimension line location.        

To insert an aligned dimension by selecting the entity, select 
the entity (A) to dimension, and then select the dimension line 
location (B).

Result.

To insert an aligned dimension by selecting the extension line 
origins, select the first extension origin (A), select the second 
extension origin (B), and then specify the dimension line 
location (C).

Result.

A
B

A

C B
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To create a linear baseline dimension

NOTE  Before you can use this procedure, you must first create a dimension.

1 Do one of the following:    
• Choose Insert > Dimensions > Baseline.

• On the Dimensioning toolbar, click the Baseline tool ( ).

• Type dimbaseline and then press Enter.    

2 To select a starting dimension, press Enter.
3 Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension for the baseline. Select the 
origin of the next extension line, and then press Enter.

The program automatically places the new baseline dimension above or below the 
previous dimension line. The distance between the two dimension lines is determined 
by the Baseline Offset value in the Dimension Settings dialog box.         

To add a baseline dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select as many additional points as you want (C).

A B

C

Result.
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To create a linear continued dimension

NOTE  Before you can use this procedure, you must first create a dimension.

1 Do one of the following:    
• Choose Insert > Dimensions > Continue.

• On the Dimensioning toolbar, click the Continue tool ( ).

• Type dimcontinue and then press Enter.     

2 To select a starting dimension, press Enter.
3 Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension to continue.
4 To add continued dimensions, continue selecting extension line origins.
5 To end the command, press Enter twice.        

To add a continued dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select another extension line origin (C).

Result.

A B

C
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Creating angular dimensions   
Angular dimensions annotate the angle measured between two lines. You can also 
dimension an angle by selecting an angle vertex and two endpoints. After you create 
an angular dimension, you can add a baseline dimension or a continued dimension. 
An angular baseline dimension inserts an additional dimension from a common first 
extension line origin of a previous angular dimension. An angular continued dimen-
sion continues an angular dimension from the second extension line of a previous 
angular dimension.       

To dimension an angle encompassed by an arc    
1 Do one of the following:     

• Choose Insert > Dimensions > Angular.

• On the Dimensioning toolbar, click the Angular tool ( ).

• Type dimangular and then press Enter.    

2 Select the arc.
3 Specify the dimension arc location.          

To dimension the angle subtended by an arc, select 
the arc (A), and then specify the dimension arc 
location (B).

Result.

A

B



262   C H A P T E R  1 2
To dimension an angle between two lines
1 Do one of the following:    

• Choose Insert > Dimensions > Angular.

• On the Dimensioning toolbar, click the Angular tool ( ).

• Type dimangular and then press Enter.

2 Select one line.
3 Select the other line.
4 Specify the dimension line location.    

Creating diametral and radial dimensions  
Diameter and radius dimensions annotate the radii and diameters of arcs and circles. 
You can optionally include centerlines or center marks.    

To create a diametral dimension    
1 Do one of the following:    

• Choose Insert > Dimensions > Diameter.

• On the Dimensioning toolbar, click the Diameter tool ( ).    

• Type dimdiameter and then press Enter.    

2 Select the arc or circle.
3 Specify the dimension line location.     

Select one line (A), select the other line (B), and then specify 
the dimension line location (C).

Result.

A

B
C

Select the circle (A), and then specify the  
dimension line location (B).

Result.

A B
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To create a radial dimension
1 Do one of the following:     

• Choose Insert > Dimensions > Radius.

• On the Dimensioning toolbar, click the Radius tool ( ).

• Type dimradius and then press Enter.    

2 Select the arc or circle.
3 Specify the dimension line location.     

Creating ordinate dimensions
An ordinate dimension annotates the perpendicular distance from an origin or base 
point (the origin of the current user coordinate system [UCS]). Ordinate dimensions 
consist of an x- or y-coordinate and a leader. An x-ordinate dimension measures dis-
tances along the x-axis; a y-ordinate dimension measures distances along the y-axis.    

As you select ordinate points, the program automatically determines whether the 
point is an x- or y-ordinate based on which direction you drag the second point. You 
can also specify whether the ordinate represents an x- or y-ordinate. Ordinate dimen-
sion text is always aligned with the ordinate leader lines, regardless of the text orien-
tation specified by the current dimension style.     

Select the circle (A), and then specify the  
dimension line location (B).

Result.

A B

Ordinate dimensions measure the distance along the x- or y-axis from an origin to a selected ordinate point.
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To create an ordinate dimension
1 Do one of the following:     

• Choose Insert > Dimensions > Ordinate.

• On the Dimensioning toolbar, click the Ordinate tool ( ).

• Type dimordinate and then press Enter.    

2 Select the point for ordinate dimension.
3 Specify the ordinate leader endpoint.     

TIP  To select precise ordinate points, use entity snaps.

Select the ordinate point (A), and then specify the ordinate leader endpoint (B).

A B
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Creating leaders and annotations
Leaders consist of a line or series of lines that connects a feature in a drawing to an 
annotation. Generally, you place an arrowhead at the first point. An annotation, cre-
ated as dimension text, is placed immediately adjacent to the last point. By default, 
the text placed at the end of the leader line consists of the most recent dimension. You 
can also type an annotation as a single line of text.    

To create a leader and an annotation
1 Do one of the following:     

• Choose Insert > Dimensions > Leader.

• On the Dimensioning toolbar, click the Leader tool ( ).

• Type dimleader and then press Enter.    

2 Specify the starting point of the leader.
3 Specify the endpoint of the leader line segment.
4 Specify additional leader line segment endpoints.
5 After you specify the last endpoint, press Enter.
6 Type the annotation, or press Enter to accept the most recent dimension as the 

default annotation.     

Specify the starting point of the leader (A) 
and the endpoint of the leader line segment 
(B).

Result.

A

B
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Editing dimensions  

You can use grips to edit entity dimensions. You can also edit the dimension text. 
You can rotate dimension lines and dimension text at any angle, and you can reposi-
tion the dimension text anywhere along the dimension line.   

Making dimensions oblique    
Extension lines are normally created at a perpendicular angle to the dimension line. 
You can change the angle of the extension lines, however, so that they tilt relative to 
the dimension line.    

To make oblique extension lines
1 Do one of the following:     

• Choose Insert > Dimensions > Make Oblique.

• On the Dimensioning toolbar, click the Make Oblique tool ( ).

• Type dimedit, press Enter, and then in the prompt box, choose Oblique Lines.    

2 Select the linear dimension, and then press Enter.
3 Type the obliquing angle, and then press Enter.        

TIP  To align the oblique angle if you don’t know the exact measurement, use snaps to 
pick two points on the entity.

Editing dimension text
You can rotate the text of an existing dimension, move the dimension text to a new 
position, or replace selected dimension text with new text. You can also restore 
dimension text to its original position as defined by the current dimension style.        

When you rotate or replace selected text, you specify the change first, and then select 
one or more dimensions to which to apply the change. All the selected dimensions are 
updated simultaneously.

Select the dimension to be made oblique (A), and then type 
the obliquing angle.

Result.

A
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To rotate dimension text
Advanced experience level      

1 Do one of the following:
• Choose Insert > Dimensions > Rotate Dimension Text.

• On the Dimensioning toolbar, click the Rotate Dimension Text tool ( ).

• Type dimedit, press Enter, and then in the prompt box, choose Rotate Text.

2 Type the new dimension text angle, and then press Enter.
3 Select the dimension to be rotated, and then press Enter.    

To move dimension text
Advanced experience level    

1 Do one of the following:
• Choose Insert > Dimensions > Reposition Dimension Text.

• On the Dimensioning toolbar, click the Reposition Dimension Text tool ( ).

• Type dimtedit and then press Enter.

2 Select the dimension to reposition text.
3 Select the new text position.      

Select the dimension to be rotated (A), and then  
type the rotation angle.

Result.

A

Select the dimension to be moved (A), and then 
select the new text position (B).

Result.

A
B
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To restore dimension text to its home position    
Advanced experience level     

1 Do one of the following:
• Choose Insert > Dimensions > Restore Text Position.

• On the Dimensioning toolbar, click the Restore Text Position tool ( ).

• Type dimedit, press Enter, and then in the prompt box, choose Restore Text.

2 Select the dimension text to restore, and then press Enter.

To replace existing dimension text with new text    
Advanced experience level    

1 Do one of the following:
• Choose Insert > Dimensions > Edit Dimension Text.

• On the Dimensioning toolbar, click the Edit Dimension Text tool ( ).

• Type dimedit and then in the prompt box, choose Edit Text.

2 Type the new dimension text, and then press Enter.
3 Select the dimension to be replaced, and then press Enter.
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Understanding dimension styles and variables  

Dimensions that you insert are created using the current dimension style. You can 
create, save, restore, and delete named dimension styles.    

To display information about the current dimension style and compare it with other 
style names, you can use the dimstyle command.

Dimension styles provide a way for you to change various settings that control the 
appearance of dimensions. You can then save those settings for reuse. If you don’t 
define a dimension style before creating dimensions, the program uses the Standard 
dimension style, which stores the default dimension variable settings. Each option in 
the Dimension Settings dialog box relates to a variable that you can set manually.    

To create a dimension style
1 Do one of the following:    

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click New.
3 Type the name of the new dimension style.
4 Click Create.
5 In the Dimension Settings dialog box, click one of the other tabs, and then change 

the dimension settings as necessary.
Repeat this step for each tab, as needed.

6 To end the command, click OK.

To rename a dimension style
1 Do one of the following:    

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click Rename.
3 In the Rename list, click the dimension style to be renamed.
4 In the To box, type the new dimension style name.
5 Click Rename.
6 Click OK.
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To delete a named dimension style
1 Do one of the following:    

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click Delete.
3 Select the dimension style to delete.
4 Click Delete.
5 Click OK.

To display information about the current style
1 Type dimstyle and then press Enter.   
2 Type v and then press Enter to display information about the variables.
3 Type the dimension style name, and press Enter.

Controlling dimension arrows   
You can control the appearance and size of arrowheads or tick marks placed at the 
ends of dimension lines. Any changes you make affect the current dimension style. 
The arrowheads you choose display both below the User-Defined Arrowheads check 
box and in the image tile on the right side of the Dimension Settings dialog box.    

You can choose from a number of arrowhead types. You can specify different arrow-
heads for each end of a dimension line. The Start arrow corresponds to the first exten-
sion line; the End arrow corresponds to the second extension line. The Arrow Size 
value determines the size of the arrowhead, measured in drawing units. You can also 
use tick marks instead of arrowheads.    

To choose an arrowhead
1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.    

2 Click the Arrows tab.   
3 Select the check box for User-Defined Arrowhead.
4 In the Start or End list, click to select the Start or End arrowhead, respectively.
5 Click OK.

NOTE  You can also specify leader arrow types using the DIMLDRBLK system vari-
able.
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A Click to select user-defined arrowheads.
B Click to toggle Start and End arrowheads.
C Click to select Start and End arrowheads.
D Type or select arrowhead size.

E Select to enable tick marks instead of 
arrowheads.

F Type or select tick mark size.
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Controlling dimension format  
You can control the way dimension text and arrowheads are placed in relation to the 
dimension lines. Any changes you make affect the current dimension style. The 
image tile on the right side of the Dimension Settings dialog box shows the appear-
ance of dimensions based on the current dimension style settings.       

The program determines whether both dimension text and arrowheads will fit 
between the extension lines by comparing the distance between the extension lines to 
the size of the dimension text, the size of the arrowheads, and the amount of space 
required around dimension text. The program applies the best fit method based on the 
available space. If possible, both the dimension text and arrowheads are placed 
between the extension lines. If both will not fit between the extension lines, you can 
determine how text and arrowheads are placed using the Fit Method settings on the 
Dimension Settings dialog box.     

To format dimensions     
1 Do one of the following:    

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.    

2 Click the Format tab.
3 Click the Fit option that you want.
4 Click OK. 

NOTE You can also specify how dimension text and arrows are arranged using the 
DIMATFIT system variable. You can specify how dimension text is moved using the 
DIMTMOVE system variable.

Text and arrowheads placed 
outside extension lines.

Text placed between extension 
lines and arrowheads outside 
extension lines.

Text placed above 
dimension line with a leader 
connecting the text to the 
dimension line.
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A Click to place both text and arrowheads inside 
the extension lines when both do not 
automatically fit between them.

B Click to place text only between extension lines 
and arrowheads outside extension lines when 
both do not fit between them.

C Click to fit either text or arrowheads between 
extension lines when both do not fit between 
them.

D Click to automatically determine the best fit 
method.

E Click to place text above the dimension line with 
a leader connecting the text to the dimension line 
when both text and arrowheads do not fit 
between the extension lines.

F Click to place text above the dimension line 
without a leader when both text and arrowheads 
do not fit between the extension lines.

G Type or select the distance around the 
dimension text.

C
B
A

D
E
F

G
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Controlling line settings  
You can control settings affecting dimension lines, extension lines, and center marks. 
Any changes you make affect the current dimension style. The image tile on the right 
side of the Dimension Settings dialog box shows the appearance of the dimensions 
based on the current dimension style settings.        

To set the color for dimension lines    
1 Do one of the following:     

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 Click the Lines tab.
3 Under Dimension Lines, click Select Color.
4 In the Color dialog box, click the dimension line color, and then click OK.
5 Click OK. 

A Extend past dimension.
B Baseline offset.

C Offset from origin.

A

B

C
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A Type or select center mark size. Positive values 
create a center mark. Negative values create 
centerlines.

B Type or select the baseline offset distance, the 
distance to offset successive dimension lines 
when creating baseline dimensions.

C Type or select the offset from origin, the distance 
extension lines are offset from their origin points.

D Type or select the distance dimension lines 
extend beyond extension lines.

E Type or select the distance extension lines 
extend beyond dimension lines.

F Select to prevent the creation of the first and 
second dimension lines.

G Select to prevent the creation of the first and 
second extension lines.

H Select to prevent the creation of dimension lines 
outside extension lines.

I Select to draw dimension lines between 
extension lines when text and arrows are placed 
outside extension lines.

J Click to select the extension line color.
K Click to select the dimension line color.

A
B
C
D
E

F
G
H

J K

I
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Controlling dimension text  
You can control the settings affecting the appearance of dimension text. Any changes 
you make affect the current dimension style. The image tile on the right side of the 
Dimension Settings dialog box shows the appearance of the dimensions based on the 
current dimension style settings.         

To align dimension text with the dimension line    
1 Do one of the following:     

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.     

2 Click the Text tab.     
3 Select the Align Inside Text With Dimension Line check box.
4 Click OK. 
  

Text between extension lines aligned  
horizontally.

Text between extension lines 
aligned with dimension line.
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A Click to select the text style used for dimension 
text.

B Type or select the text height, measured in 
drawing units.

C Type a prefix or suffix to be appended to 
dimension text.

D Select to align text placed between the extension 
lines with the dimension line.

E Select to align text placed outside the extension 
lines with the dimension line.

F Select to force text between the extension lines.
G Type or select the vertical text offset distance.
H Click to select the horizontal or vertical justification 

of dimension text.
I Click to select the dimension text color.
J Click to display the IntelliCAD Explorer, Styles 

element.

A
B

C

E
F

D

H
G

J
I
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Controlling dimension units  
You can determine the appearance and format of the primary and alternate dimension 
units. The image tile on the right side of the Dimension Settings dialog box shows the 
appearance of the dimensions based on the current dimension style settings.         

To round off dimensions        
1 Do one of the following:     

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.    

2 Click the Units tab.
3 In the Round Linear Distances To field, type or select the nearest value to which 

you want to round off dimensions.
4 Click OK. 

NOTE You can also specify units for linear dimensions using the DIMLUNIT system 
variable. You can specify fraction formats using the DIMFRAC system variable.

  

Round off distance set to .0100 
(original dimension before 
rounding).

Round off distance set to 0.2500. Round off distance set  
to 1.0000.
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A Type or select the number of decimal places you 
want displayed in dimension text.

B Type or select the nearest value to which you 
want to round off linear distances.

C Select to prevent the inclusion of leading zeros 
or the inclusion of feet in dimension text when 
the dimension is less than one foot.

D Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in dimension text when 
the number of inches is zero.

E Type or select the scale factor applied to all 
dimensions.

F Type or select the linear scale factor applied to 
all lengths measured by dimensioning 
commands.

G Click to select the format for linear dimensions.
H Click to select the format for angular dimensions.

A
B
C
D

E
F

G
H
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Adding geometric tolerances    

Geometric tolerances indicate the maximum allowable variations in the geometry 
defined by a drawing. IntelliCAD draws geometric tolerances using a feature control 
frame, which is a rectangle divided into compartments.    

Each feature control frame consists of at least two compartments. The first compart-
ment contains a geometric tolerance symbol that indicates the geometric characteris-
tic to which the tolerance is applied, such as location, orientation, or form. For 
example, a form tolerance may indicate the flatness or roundness of a surface. The 
geometric tolerance symbols and their characteristics are shown in the following 
table.                                                                   

Geometric tolerance symbols
Symbol Characteristic Type

Position Location

 Concentricity or coaxiality Location

 Symmetry Location

 Parallelism Orientation

 Perpendicularity Orientation

 Angularity Orientation

 Cylindricity Form

 Flatness Form

 Circularity or roundness Form

 Straightness Form

 Profile of a surface Profile

 Profile of a line Profile

 Circular runout Runout

 Total runout Runout
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The second compartment contains the tolerance value. When appropriate, the toler-
ance value is preceded by a diameter symbol and followed by a material condition 
symbol. The material conditions apply to features that can vary in size. The material 
condition symbols and their meanings are shown in the following table.      

The tolerance value can then be followed by primary, secondary, and tertiary datum 
reference letters, along with the material conditions of each datum. Datum reference 
letters are generally used as reference tolerances to one of up to three perpendicular 
planes from which a measurement is made, although datum reference letters can also 
indicate an exact point or axis.       

When two tolerances apply to the same geometry, you can also add a composite toler-
ance consisting of a primary tolerance value followed by a secondary tolerance value. 
To make a tolerance even more specific, it can also contain a projected tolerance con-
sisting of a height value followed by a projected tolerance symbol. For example, you 
can use a projected tolerance to indicate the perpendicularity of an embedded part.       

Material conditions
Symbol Definition

At maximum material condition (MMC), a feature contains the maximum amount of 
material stated in the limits.

At least material condition (LMC), a feature contains the minimum amount of 
material stated in the limits.

Regardless of feature size (RFS) indicates that the feature can be any size within 
the stated limits.

A Geometric characteristic symbol.
B Diameter symbol.
C Tolerance value.

D Material condition symbol.
E Datum reference.

A B C D E
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To add a geometric tolerance
1 Do one of the following:     

• Choose Insert > Dimensions > Tolerance.

• On the Dimensions toolbar, click the Tolerance tool ( ).

• Type tolerance and then press Enter.    

2 To display the geometric tolerance symbols, on the first line, click the Sym box.
3 Click to select a geometric tolerance symbol.
4 Under Tolerance 1, click the Dia box to add a diameter symbol.
5 In the field, type the first tolerance value.
6 To display the material condition symbols, click the M.C. box.
7 Click to select a material condition.
8 Under Tolerance 2, repeat steps 4 through 7 to add a secondary tolerance value, if 

appropriate.
9 Under Datum 1, type the primary datum reference letter.    

10 To display the material condition symbols, click the M.C. box.
11 Click to select a material condition.
12 Repeat steps 9 through 11 to add secondary and tertiary datum, if appropriate.
13 In the second row, repeat steps 2 through 12 to add composite tolerances, if 

appropriate.
14 In the Height box, type a projected tolerance zone height value, if appropriate.
15 To insert a projected tolerance zone symbol, click the Projected Tolerance Zone 

box, if appropriate.
16 Click OK.
17 In the drawing, specify the location of the feature frame.
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Controlling dimension tolerance   
You can create dimensions as either tolerance or limits dimensions. When creating a 
tolerance dimension, you can control the upper and lower tolerance limits as well as 
the number of decimal places of the dimension text. The image tile on the right side 
of the Dimension Settings dialog box shows the appearance of tolerance and limits 
dimensions based on the current dimension style settings.    

A Use this row to include composite tolerances.
B Type a projected tolerance height value.
C Type a datum identifier.
D Click to include a projected tolerance symbol.
E Click to select the material condition symbol for tertiary 

data.
F Type the tertiary datum reference letter.
G Click to select the material condition symbol for 

secondary datum.
H Type the secondary datum reference letter.
I Click to select the material condition symbol for primary 

datum.

J Type the primary datum reference letter.
K Click to select the material condition symbol for the 

second tolerance value.
L Type the second tolerance value.
M Click to include a diameter symbol for the second 

tolerance value.
N Click to select the material condition symbol for the first 

tolerance value.
O Type the first tolerance value.
P Click to include a diameter symbol for the first tolerance 

value.
Q Click to select a geometric tolerance symbol.

A

Q P O LM J H FI G E

DB
C

N K

Tolerance dimension. Limits dimension.
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To create a tolerance dimension
1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 Click the Tolerance tab.
3 Select the Append Dimension Tolerances check box.
4 Type or select the lower tolerance limit.
5 Type or select the upper tolerance limit.
6 Click OK.
7 Insert the dimension.    

A Select to insert dimensions as upper and lower 
tolerance limits.

B Select to include plus and minus tolerance 
values with the dimension text.

C Type or select the minimum tolerance or lower 
limit value.

D Type or select the maximum tolerance or upper 
limit value.

E Type or select the number of decimal places 
displayed in limits or tolerance dimensions.

F Select to prevent the inclusion of leading zeros 
or the inclusion of feet in dimension limits when 
the dimension is less than one foot.

G Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in dimension limits when 
the number of inches is zero.

A
B

C
D

E

F
G
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Controlling alternate dimension units   
You can include alternate dimensions in addition to the primary dimension text. You 
can also determine the appearance and format of the alternate dimensions, including 
the scale factor applied to generate alternate dimensions. The image tile on the right 
side of the Dimension Settings dialog box shows the appearance of the dimensions 
based on the current dimension style settings.    

To create an alternate dimension
1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 Click the Alternate Units tab.
3 Select the Enable Alternate Units check box.
4 Type or select the scale factor.
5 In the Suffix field, type a suffix to be appended to the alternate dimension.
6 Click OK.
7 Insert the dimension.

Alternate dimension created using a scale factor of 25.4, with an appended suffix.
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A Select to include alternate dimensions.
B Select to prevent the inclusion of leading zeros 

or the inclusion of feet in alternate dimensions 
when the dimension is less than one foot.

C Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in alternate dimensions 
when the number of inches is zero.

D Type or select the number of decimal places 
displayed in alternate dimensions.

E Type or select the scale factor applied to 
measured dimensions to generate the alternate 
dimensions.

F Click to select the format for alternate 
dimensions.

G Type a prefix to be appended to alternate 
dimensions.

H Type a suffix to be appended to alternate 
dimensions.

I Type or select the number of decimal places 
displayed in limits or tolerances included as part 
of alternate dimensions.

J Select to prevent the inclusion of leading zeros 
or the inclusion of feet in limits or tolerances 
included as part of alternate dimensions.

K Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in limits or tolerances 
included as part of alternate dimensions. 

A
B
C
D
E
F

I

G
H

J
K
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Working with blocks, attributes, and 
external references

Blocks, attributes, and external references provide mechanisms for managing entities 
in your drawings and for including additional information with the standard drawing 
entities. With blocks, you can combine numerous entities into a single entity, and 
then reuse it, inserting multiple copies. With attributes, you can associate text, such as 
part numbers or prices, with blocks, and then extract the text-attribute information to 
a separate file, such as a database, for further analysis. With external references, you 
can link separate reference drawing files to a drawing to combine information without 
adding the contents of the reference drawings to the current drawing. If you make 
changes to the referenced file, all references are updated automatically.

This chapter explains how to:

• Create, insert, and redefine blocks.
• Create, edit, and insert attributes.
• Extract attribute data to a separate file.

• Attach and work with external references.

Topics in this chapter
Working with blocks .......................................................................................... 288
Working with attributes ..................................................................................... 294
Working with external references ..................................................................... 301
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Working with blocks    

Usually, blocks are several entities combined into one that you can insert into a draw-
ing and manipulate as a single entity. A block can consist of visible entities such as 
lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks are 
stored as part of the drawing file.        

Blocks can help you better organize your work, quickly create and revise drawings, 
and reduce drawing file size. Using blocks, you can create a library of frequently used 
symbols. Then you can insert a symbol as a block rather than redraw the symbol from 
scratch.    

After you create a block from multiple entities, you save it once, which also saves 
disk space. You insert only multiple references to a single block definition. You can 
change the block definition to quickly revise a drawing, and then update all instances 
of the block.    

If you insert a block that contains entities originally drawn on layer 0 and assigned 
color and linetype BYLAYER, it is placed on the current layer and assumes the color 
and linetype of that layer. If you insert a block that contains entities originally drawn 
on other layers or with explicitly specified colors or linetypes, the block retains the 
original settings.    

If you insert a block that contains entities originally assigned color and linetype 
BYBLOCK, and the block itself has the color and linetype BYLAYER, those entities 
adopt the color and linetype of the layer onto which they are inserted. If the block is 
assigned an explicit color or linetype, such as red or dashed, those entities adopt those 
qualities.    

A procedure called nesting occurs when you include other blocks in a new block that 
you are creating. Nesting is useful when you want to combine and include small com-
ponents, such as nuts and bolts, into a larger assembly and you need to insert multiple 
instances of that assembly into an even larger drawing.    

Creating blocks 
The tools and commands for creating blocks appear on the Tools toolbar and the 
Tools menu, respectively, when you set the program to the Advanced experience 
level. You can also use the IntelliCAD Explorer to create blocks.    

You can create blocks in two ways:

• By saving a block for use within the current drawing only.        

• By saving the block as a separate drawing file that you can insert into other draw-
ings.

When you create a block, you specify its name, its insertion point, and the entities that 
compose the block. The insertion point is the base point for the block and serves as 
the reference point when you later insert the block into a drawing.    
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To create a block for use within a current drawing
Advanced experience level    

1 Do one of the following:
• Choose Tools > Create Block.

• On the Tools toolbar, click the Create Block tool ( ).

• Type block and then press Enter.

2 Type a name for the block, and then press Enter.
3 Specify the insertion point for the block.
4 Select the entities that you want in the block, and then press Enter.

The block is created and exists only in the current drawing. The entities you select 
are removed from the display, because they are now part of the block.

5 To restore the original entities to the drawing while retaining the new block, type 
undelete or oops.     

NOTE If you frequently restore original entities after you define a block, you can cus-
tomize the program to add the Undelete command to a menu or toolbar.

You can create a block as a separate drawing file that you can insert into other drawings.

To save a block as a separate drawing file    
Advanced experience level    

1 Do one of the following:
• Choose Tools > Save Block To Disk.

• On the Tools toolbar, click the Save Block To Disk tool ( ).

• Type wblock and then press Enter.

2 In the File Name field, type the name of the drawing file you want to create.
3 Click Save.
4 In the prompt box, choose one of the following:

• Multiple Blocks This option saves one or more existing block entities to a 
separate drawing file. When prompted, type the name of the block(s).

• All Entities This option immediately saves the entire drawing to a separate 
drawing file.

• Select Entities This option saves those entities you select to a separate drawing 
file. When prompted, specify the insertion point for the block, select the entities 
for the block, and then press Enter.
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NOTE When saving multiple blocks or saving the entire drawing as a separate draw-
ing file, the program assigns the 0,0,0 coordinate as the insertion base point. You can 
change the base point by opening the drawing and redefining the block.

Inserting blocks   
You can insert blocks and other drawings into the current drawing. When you insert a 
block, it is treated as a single entity. When you insert a drawing, it is added to the cur-
rent drawing as a block. You can then insert multiple instances of the block without 
reloading the original drawing file. If you change the original drawing file, those 
changes have no effect on the current drawing unless you redefine the block by rein-
serting the changed drawing.        

You can also insert blocks from another drawing into the current drawing, using the 
IntelliCAD Explorer. Both drawings must be open at the same time to do this. (See 
Chapter 8, "Working with the IntelliCAD Explorer.")  

When you insert a block or drawing, you must specify the insertion point, scale, and 
rotation angle. The block’s insertion point is the reference point specified when you 
created the block. When you insert a drawing as a block, the program takes the speci-
fied insertion point as the block insertion point. You can change the insertion point, 
however, by first opening the original drawing and redefining the block.        

To insert a block    
1 Display the Insert Block dialog box by doing one of the following:    

• Choose Insert > Block.

• On the Draw 2D toolbar, click the Block tool ( ).

• Type ddinsert and then press Enter.

2 In the Insert Block dialog box, under Insert, click Block Name.
3 In the Block Name box, select the name of the block you want to insert.
4 Click Insert.
5 Specify the insertion point for the block.
6 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 

the default values.
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To insert an entire drawing into the current drawing
1 Do one of the following:     

• Choose Insert > Block.

• On the Draw 2D toolbar, click the Block tool ( ).

• Type ddinsert and then press Enter.

2 In the Insert Block dialog box, under Insert, click From File.
3 Type the path and the drawing file name, or click Browse to specify the file from 

the Insert Drawing dialog box, and click Open.
4 Click Insert.
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5 Specify the insertion point for the block.
6 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 

the default values.

NOTE You can specify the insertion point, scale factors, and rotation angle in the 
Insert Block dialog box before inserting the block. You can also control whether the 
block is exploded back into its original component entities after insertion. Under 
Positioning, clear the Position Block When Inserting check box, and specify the 
appropriate coordinates. If you want to explode the block immediately, select the 
Explode Upon Insertion check box.        

    

A Click and then enter the path and drawing file 
name to insert the entire drawing file as a block.

B Click to position the block when inserting.
C Specify the insertion point, scale factors, and 

rotation angle before you insert the block 
(available only when Position Block When 
Inserting is cleared).

D Click to explode the block on insertion. 

E Specify columns, column spacing, rows, and row 
spacing.

F Click to insert the block.
G Click to select the block insertion point in the 

drawing before inserting the block (available only 
when the Position Block When Inserting check 
box is cleared).

A

B

C

E

F

G

D
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Redefining blocks    
You can redefine all instances of a block within the current drawing. To redefine a 
block that was created in the current drawing, you create a new block using the same 
name. You can update all the blocks in the current drawing by redefining the block. If 
the block was inserted from a separate drawing file that was subsequently updated, 
reinsert that block to update all other instances in the current drawing.    

To redefine a block in the current drawing
Advanced experience level    

1 Do one of the following:
• Choose Tools > Create Block.

• On the Tools toolbar, click the Create Block tool ( ).

• Type block and then press Enter.

2 Type the name of the block you want to redefine, and then press Enter.
3 In the prompt box, choose Yes-Redefine Block.
4 Specify the insertion point for the block.
5 Select the entities for the block, and then press Enter.

The block is immediately redefined, and all instances of the block in the drawing 
are updated. The entities you select for inclusion in the block are removed from 
the drawing, because they are now part of the block.

TIP To restore the original entities to the drawing while retaining the new block, type 
undelete or oops.    

You can update all instances of a block inserted from a separate drawing by reinsert-
ing the drawing.
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Exploding blocks
You can explode an inserted block to its original component entities. When you 
explode a block, only that single instance of the block is affected. The original block 
definition remains in the drawing, and you can still insert additional copies of the 
original block. If you explode a block that contains attributes, the attributes are lost, 
but the original attribute definitions remain.    

Exploding dissociates component entities to their next simplest level of complexity; 
blocks or polylines in a block become blocks or polylines again.

To explode a block
1 Do one of the following:

• Choose Modify > Explode.

• On the Modify toolbar, click the Explode tool ( ).

• Type explode and then press Enter.

2 Select the block.
3 Press Enter.

Working with attributes    

An attribute is a particular entity that you can save as part of a block definition. 
Attributes consist of text-based data. You can use attributes to track such things as 
part numbers and prices. Attributes have either fixed or variable values. When you 
insert a block containing attributes, the program adds the fixed values to the drawing 
along with the block, and you are prompted to supply any variable values.        

After you insert blocks containing attributes, you can extract the attribute information 
to a separate file and then use that information in a spreadsheet or database to produce 
a parts list or bill of materials. You can also use attribute information to track the 
number of times a particular block is inserted into a drawing.    

Attributes can be visible or hidden. Hidden attributes are neither displayed nor plot-
ted, but the information is still stored in the drawing and written to a file when you 
extract it.        
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Defining attributes    
You add an attribute to a drawing by first defining it and then saving it as part of a 
block definition. To define an attribute, you specify the characteristics of the 
attribute, including its name, prompt, and default value; the location and text format-
ting; and optional modes (hidden, fixed, validate, and predefined).        

To define an attribute          
Advanced experience level

1 Do one of the following:
• Choose Tools > Define Attributes.

• On the Tools toolbar, click the Define Attributes tool ( ).

• Type ddattdef and then press Enter.

2 In the Define Attribute dialog box, type the name, prompt, and default value.
3 Under Insert Coordinates, specify the location of the attribute, or click Select to 

select a point in the drawing.
4 Under Attribute Flags, select the optional attribute modes.
5 Under Text, specify the text characteristics.
6 To add the attribute to the drawing, do one of the following:

• Click Define to add the attribute and keep the dialog box active so you can 
define another attribute.

• Click Define And Exit to add the attribute and end the command.
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A Type the name you want to assign to the 
attribute.         

B Enter the identifying prompt information 
displayed when you insert a block containing the 
attribute.

C Enter the default or constant value. For variable 
attributes, the default value is replaced by the 
actual value when you later insert a block 
containing the attribute.

D Specify the x-, y-, and z-coordinates for the 
attribute insertion point.

E Select to create a hidden attribute.
F Select to create a fixed-value attribute.
G Select to create an attribute whose value must 

be validated when you later insert a block 
containing the attribute.    

H Select to create an attribute whose value is 
defined and not requested when you later insert 
a block containing the attribute, but that you can 
edit after the block is inserted. 

I Click to add the attribute and keep the dialog box 
active so you can define another attribute.

J Click to add the attribute and end the command.
K Specify the text rotation angle, or click to specify 

the rotation angle by selecting two points in the 
drawing.    

L Specify the text height, or click to specify the 
height by selecting two points in the drawing.

M Choose the text justification.
N Choose the text style from those styles already 

defined in the drawing.
O Click to specify the attribute insertion point by 

selecting a point in the drawing.

A

J

O

D

N
M
L
K

I

B
C

E
F
G
H
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Editing attribute definitions    
You can edit an attribute definition before you associate it with a block and before it 
is saved as part of a block definition.         

To edit an attribute definition           
Advanced experience level

1 Do one of the following:
• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool ( ).

• Type ddedit and then press Enter.

2 Select the attribute definition text to edit.
3 Modify the attribute name, prompt string, default value, and other attribute defini-

tion characteristics.
4 Click OK.  

A Modify the name assigned to the attribute.    
B Modify the identifying prompt information displayed 

when you insert a block containing the attribute.
C Modify the attribute insertion point.

D Modify the attribute text style and appearance.
E Modify the attribute insertion flags to create hidden, 

fixed-value, validated, or defined attributes.

A
B

C

D

E
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Attaching attributes to blocks
You can attach attributes to a block after you define it and select it as one of the enti-
ties to include. Include the attributes when the program prompts you for the entities to 
include in the selection set for a block. After the attribute is incorporated into a block, 
the program prompts you each time you insert the block, so you can specify different 
values for the attributes each time you insert it into a new drawing.    

Editing attributes attached to blocks
You can edit the attribute values of a block that has been inserted into a drawing.           

To edit an attribute attached to a block     
Advanced experience level
1 Do one of the following:

• Choose Tools > Edit Block Attributes.

• On the Tools toolbar, click the Edit Block Attributes tool ( ).

• Type ddatte and then press Enter.

2 Select the block to edit.
The Edit Block Attributes dialog box displays all the attributes attached to the 
block you select.

3 Edit the attribute values as necessary.
4 Click OK. 
    

A Identifies the name of the block.
B Displays the names of all 

attributes attached to the block.
C Click to select attribute.
D Type the new value for the 

selected attribute.
E Click to update the attribute 

values and exit.
F Displays the value of each 

attribute attached to the block.
G Displays the prompt for each 

attribute attached to the block.

A
B

C

D

G
F

E
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Extracting attribute information    
You can extract attribute information from a drawing and save it to a separate text file 
for use with a database program. You can save the file in any of the following for-
mats:      

• Comma Delimited Format (CDF) Contains one line for each instance of a block, 
with individual attribute fields separated by commas. Character string fields are 
enclosed with single quotation marks. You must specify a template file when 
extracting to a CDF file.       

• Space Delimited Format (SDF) Contains one line for each instance of a block. 
Each attribute field has a fixed length; there are no separators or character string 
delimiters. You must specify a template file when extracting to a SDF file.       

• Drawing Exchange Format (DXF) Creates a subset of a standard DXF file (a *.dxx 
file) containing all the information about each block, including the insertion 
points, rotation angles, and attribute values. No template file is required.       

Before extracting attributes to a CDF or SDF file, you must create a template file. The 
template file is an ASCII text file that specifies the attribute data fields to be written 
in the extract file. Each line of the template file specifies one attribute field. 
IntelliCAD® recognizes 15 different fields, which contain elements such as the block 
name, the x-, y-, and z-coordinates of its insertion point, the layer on which it is 
inserted, and so on. You can include any of these fields. The template file must 
include at least one attribute name.        

Each line in the template file must start with the field name. Block name and inser-
tion-point values must begin with BL:. The next nonblank character must be either a 
C (indicating a character string field) or an N (indicating a numeric field). This char-
acter is then followed by three digits indicating the width of the field (in characters). 
The final three digits indicate the number of decimal places (for numeric fields). In 
the case of character fields, the last three digits must be zeros (000). A typical tem-
plate file is similar to the one shown here:              
    

A Field name.
B Block name. Block names must 

begin with BL:.
C Insertion point. Insertion-point 

values must begin with BL:.
D Attribute tags.
E Number of decimal places for 

numeric fields or 000 for 
character fields.

F Field width for character or 
numeric fields.

G C for character fields; N for 
numeric fields.

A

B

C

D

E
F
G
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To create a template file
1 Create a template file using any ASCII text editor (such as Microsoft Notepad or 

Microsoft WordPad) or a word-processing program such as Microsoft Word.
2 Include the necessary fields in the template file.
3 Save the template file in ASCII text format.

To extract attribute information 
1 Do one of the following:

• Choose Tools > Extract Attributes.

• On the Tools toolbar, click the Extract Attributes tool ( ).

• Type ddattext and then press Enter.

2 Click Select, specify the entities from which to extract attributes, and then press 
Enter.

3 Specify the format of the extracted file.
4 For CDF and SDF formats, specify the template file.
5 Specify the extract output file. 
6 Click Extract.
  

A Click to select blocks in the drawing containing 
attributes you want to extract.

B Click to specify the format of the extracted file.
C Specify the template file for CDF and SDF 

extracts.
D Specify the extract output file.

E Click to extract attributes.
F Click to specify the output file using a file dialog 

box.
G Click to specify the template file using a file 

dialog box.
H Indicates the number of blocks with attributes 

selected for extraction.

A

F

B

C
D

E

G

H
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Working with external references           

You can link entire drawings to the current drawing as external references. Unlike 
inserting a drawing as a block, in which you add all the entities from the separate 
drawing into the current drawing, external references attach a pointer to the external 
file. The entities in the external reference appear in the current drawing, but the enti-
ties themselves are not added to the drawing. Thus, attaching an external reference 
does not significantly increase the size of the current drawing file.        

External references provide additional capabilities not available when you insert a 
drawing as a block. When you insert a drawing as a block, the entities are stored in 
the drawing. Any changes you make to the original drawing are not reflected in the 
drawing in which you inserted it. When you attach an external reference, however, 
any changes you make to the original drawing file are reflected in the drawings that 
reference it. These changes appear automatically each time you open the drawing 
containing the external reference. If you know that the original drawing was modi-
fied, you can reload the external reference anytime you’re working on the drawing.    

External references are useful for assembling master drawings from component draw-
ings. Use external references to coordinate your work with others in a group. External 
references help reduce drawing file size and ensure that you are always working with 
the most recent version of a drawing.     

Attaching external references
Attaching a separate drawing to the current one creates an external reference. The 
external reference appears in the drawing as a block definition, but the drawing enti-
ties are linked rather than added to the current drawing. If you modify the linked 
drawing, you can reload the external reference so that the current drawing reflects the 
latest version of the external reference.            

When you attach an external reference, its layers, linetypes, text styles, and other ele-
ments are not added to the current drawing. Rather, these elements are also loaded 
from the referenced file each time you reload the external reference. Attached refer-
ence files can themselves contain other, nested reference files. When you attach an 
external reference, any nested references contained in the file also appear in the cur-
rent drawing.    

You can attach as many copies of an external reference file as you want. Each copy 
can have a different position, scale, and rotation angle.      
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To attach an external reference      
Advanced experience level

1 Do one of the following:
• Choose Tools > External Reference.

• On the Tools toolbar, click the External Reference tool ( ).

• Type xref and then press Enter.

2 In the prompt box, choose Attach.
3 Specify the drawing file to attach as an external reference, and then click Open.
4 Specify the insertion point for the external reference.
5 Specify the x, y, and z scale factors and the rotation angle, or choose Done to 

accept the default values.       

Detaching external references    
To remove an external reference from your drawing, you must detach the reference 
file. Deleting the external reference does not remove elements such as layers and line-
types added to the current drawing.    

To detach an external reference
Advanced experience level

1 Do one of the following:     
• Choose Tools > External Reference.

• On the Tools toolbar, click the External Reference tool ( ).

• Type xref and then press Enter.

2 In the prompt box, choose Detach.
3 Type the name of the external reference you want to detach from the drawing, and 

then press Enter.
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Reloading external references
If you modify a drawing that is attached to the current drawing as an external refer-
ence, you can update the current drawing to display the latest version of the external 
reference drawing.    

To reload an external reference
Advanced experience level
1 Do one of the following:     

• Choose Tools > External Reference.

• On the Tools toolbar, click the External Reference tool ( ).

• Type xref and then press Enter.

2 In the prompt box, choose Reload.
3 Type the name of the external reference you want to reload, and then press Enter.

NOTE The program automatically reloads all external references each time you open 
a drawing containing external references and each time you print or plot a drawing 
containing external references.     

Overlaying external references
When a drawing that contains overlaid external references is itself attached or over-
laid as an external reference in another drawing, the overlays do not appear as part of 
the external reference. Use overlaying when you want to see reference geometry in a 
drawing but you do not need to include that geometry in drawings that will be used by 
others.         

To overlay an external reference    
Advanced experience level

1 Do one of the following:        
• Choose Tools > External Reference.

• On the Tools toolbar, click the External Reference tool ( ).

• Type xref and then press Enter.

2 In the prompt box, choose Overlay.
3 In the Select File To Overlay dialog box, specify the drawing file to be overlaid as 

an external reference, and then click Open.
4 Specify the insertion point for the external reference.
5 Specify the x, y, and z scale factors and the rotation angle, or choose Done to 

accept the default values.       
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Changing the path for external references
If the file associated with an external reference is moved to a different directory or 
renamed, the program displays a message indicating that it cannot load the external 
reference. You can reestablish the link to the file by changing the path for the external 
reference.          

To change the external reference path
Advanced experience level

1 Do one of the following:     
• Choose Tools > External Reference.

• On the Tools toolbar, click the External Reference tool ( ).

• Type xref and then press Enter.

2 In the prompt box, choose Path.
3 Type the name of the external reference whose path you want to change.
4 Type the new path, and then press Enter.

Inserting and binding external references to drawings
External references are not part of the drawing. Rather, they are links to an externally 
referenced file. To provide a copy of a drawing containing external references to 
someone else, you must also provide all the external reference files. In addition, the 
person receiving the drawings must either re-create the same paths you used when 
linking the external references or change the paths for the external references.            

The Insert command in the External Reference feature lets you insert an externally 
referenced drawing as a block. To provide a copy of a drawing that contains an exter-
nal reference, it is best to insert the external reference as a block.

To insert an external reference as a block    
Advanced experience level

1 Do one of the following:     
• Choose Tools > External Reference.

• On the Tools toolbar, click the External Reference tool ( ).

• Type xref and then press Enter.

2 In the prompt box, choose Insert.
3 Type the name of the external reference you want to insert into the drawing, and 

then press Enter.
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To provide a copy of a drawing that contains external references, it is often easier to 
first bind the external references to the drawing. Binding the external references 
makes them a permanent part of the drawing, which is the same as inserting a sepa-
rate drawing as a block.

To bind an external reference to a drawing
Advanced experience level

1 Do one of the following: 
• Choose Tools > External Reference.

• On the Tools toolbar, click the External Reference tool ( ).

• Type xref and then press Enter.

2 In the prompt box, choose Bind.
3 Type the name of the external reference you want to bind to the drawing, and then 

press Enter.       

Clipping external references using boundaries
After attaching a drawing as an external reference, you can define a clipping bound-
ary using the XCLIP command. Defining a clipping boundary enables you to display 
only a portion of an external reference and to suppress the display of geometry out-
side the boundary. Clipping applies to an individual instance of an external reference, 
not the external reference definition itself. The portion of the external reference 
within the clipped boundary remains visible, and the remainder of the external refer-
ence becomes invisible. The referenced geometry is not altered, only the display of 
the external reference is edited.

You can use the xclip command to do the following:

• Create a new clipping boundary
• Delete an existing boundary

• Generate a polyline object coincident with vertices of the clipping boundary

You can turn xref clipping on or off. When a clipping boundary is turned off, the 
boundary does not display and the entire external reference is visible, provided that 
the geometry is on a layer that is on and thawed. When a clipping boundary is turned 
off, it still exists and can be turned on. However, deleting a clipping boundary is per-
manent.

After an external reference has been clipped, it can be edited, moved, or copied just as 
an unclipped external reference. The boundary moves with the reference. If an exter-
nal reference contains nested clipped external references, they appear clipped in the 
drawing. If the parent external reference is clipped, the nested external reference is 
also clipped.

TIP You can also partially hide blocks using the xclip command.
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Clipping boundaries are moved, rotated and scaled along with the object.  

To define a rectangular clipping boundary
1 Type xclip and then press Enter.
2 Select the xrefs and/or blocks you want to be affected by the clipping boundary. 

All of the selected xrefs and blocks become highlighted.
3 Press Enter to complete the selection.

4 Press Enter to create a new boundary (the default option).
5 If prompted, press Enter to delete the existing boundary.
6 Choose Rectangular.
7 Define the first corner of the clipping rectangle.
8 Define the second corner of the clipping rectangle.

The selected external reference(s) and/or block(s) are clipped by the rectangle.

TIP You can first select all blocks and/or external references, then right-click and 
select Xref Clip from the shortcut menu.

Example of an external reference clipped by a clipping boundary. The clipping boundary is the rectangle in 
the top view.
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To define a clipping boundary using a polyline
1 Type xclip and then press Enter.
2 Select the xrefs and/or blocks you want to be affected by the clipping boundary. 

All of the selected xrefs and blocks become highlighted.
3 Press Enter to complete the selection.
4 Press Enter to create a new boundary (the default option).
5 If prompted, press Enter to delete the existing boundary.
6 Choose Select Polyline.
7 Select the polyline to use as clipping boundary.
 

If you want to see the clipping boundaries, you can turn on the xclipframe system 
variable. The xclipframe system variable determines whether the clipping boundary 
frame displays. When the clipping frame is on (set to 1), it can be selected as part of 
the object and plotted. 

To control the display of the clipping boundaries
1 Type xclipframe and then press Enter.
2 Choose On or Off from the context menu to toggle the display of the clipping 

boundaries.

Xclip options
Option Effect

On Activates all clipping boundaries in the drawing.

Off Switches off all clipping boundaries.

ClipDepth (3D only) Defines the clipping depth.

Delete Deletes the clipping boundary for the selected objects.

Generate Polyline Creates a polyline from the current clipping boundaries.

New Boundary Defines a new boundary. If a boundary already exists for 
the selected objects you are prompted to delete the current 
boundary.
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14

Formatting and printing drawings

To print a copy of your drawing, you can use workspaces to organize different views. 
You can print a copy of the drawing exactly as you created it, or you can switch to 
paper space and create multiple views. You can then control which portion of your 
drawing prints and at what scale.

This chapter explains how to:

• Switch between paper space and model space.
• Create floating viewports.

• Print or plot your drawing.

Topics in this chapter
Using paper space and model space ................................................................310
Preparing a layout .............................................................................................314
Printing or plotting your drawing........................................................................317
Selecting a printer or plotter ..............................................................................328
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Using paper space and model space

When you start a drawing session, your initial working area is called model space. 
Model space is an area in which you create two-dimensional and three-dimensional 
entities based on either the World Coordinate System (WCS) or a user coordinate 
system (UCS). Your view of this area is a single viewport that fills the screen. You 
can add viewports, each showing the same or different two-dimensional or three-
dimensional views, all of which are displayed in a tiled manner. You can work in 
only one of these viewports at a time, and you can print only the current viewport.                         
  

IntelliCAD® provides an additional workspace, called paper space. Paper space 
represents the paper layout of your drawing. In this working area, you can create and 
arrange different views of your drawing similar to the way you arrange detail 
drawings or orthogonal views on a sheet of paper. You can also add annotations, 
create a border, and create a title block.              

Model space with tiled viewports (tilemode = 1).
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The paper space views that you create are floating rather than tiled. In paper space, 
you can place the viewports anywhere on the screen; their edges can be touching or 
not; and you can print them all at the same time. You do not need to use paper space 
to print your drawing, but it offers several advantages.         
     

Paper space with floating viewports (tilemode = 0).
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After you switch from model space to paper space and arrange different views of 
your drawing, each view is created as a floating viewport, and each viewport is 
treated as a separate entity that you can move, copy, or delete. In paper space, you 
cannot modify the individual entities within the viewport, and zooming or panning 
the drawing affects the entire drawing.    

To edit the entities rather than the layout, you can switch to a third workspace, called 
model space with floating viewports. In this workspace, each viewport functions as a 
window into your model space drawing. You can click any floating viewport to make 
it the current viewport, and then add or modify entities in that viewport. Any changes 
you make in one viewport are immediately visible in the other viewports. Zooming or 
panning in the current viewport affects only that viewport.                       

To switch to paper space    
1 Do one of the following:    

• Choose View > Workspaces.

• On the View toolbar, click the Workspaces tool ( ).

• On the status bar, double-click the workspace indicator.

• Type pmspace and then press Enter.

2 Click Paper Space.
3 Click the Active Paper Space layout drop-down list to select a layout.
4 Click OK.

The first time you switch to paper space, your drawing seems to disappear. This is 
normal. When you switch to paper space, you must create at least one floating model 
space viewport to see your work.       

To switch to model space with floating viewports 
1 Do one of the following:     

• Choose View > Workspaces.

• On the View toolbar, click the Workspaces tool ( ).

• On the status bar, double-click the workspace indicator.

• Type pmspace and then press Enter.

2 Click Model Space, With Floating Viewports.
3 Click OK.    

Status bar workspace indicators
Indicator Workspace
TILE Model space, with tiled viewports

MODEL Model space, with floating viewports

PAPER Paper space
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To switch to model space with tiled viewports 
1 Do one of the following:     

• Choose View > Workspaces.

• On the View toolbar, click the Workspaces tool ( ).

• On the status bar, double-click the workspace indicator.

• Type pmspace and then press Enter.

2 Click Model Space, With Tiled Viewports.
3 Click OK.

When you switch from model space with floating viewports to model space with tiled 
viewports, your floating viewports seem to disappear. This is normal. Floating view-
ports do not display when you switch to this workspace. They are retained, however, 
and display normally when you switch back to model space with floating viewports.            
  

A Click to display model space with floating 
viewports.

B Click to display model space with tiled viewports.

C Click to display paper space.
D Click to create a floating viewport in paper 

space.
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Preparing a layout      

When you begin working on a drawing, it consists of a single view of your model in a 
tiled model space viewport. You may have created additional tiled viewports by 
dividing the drawing space into multiple windows, but each is a separate tiled model 
space viewport.       

In paper space, you can create floating viewports and arrange them on the screen to 
simulate the paper on which you will print a copy of your drawing. You can sepa-
rately control the view, scale, and contents of each floating viewport.

When you switch to paper space, all of your model space viewports disappear. You 
must create at least one floating viewport to see your work. 

Creating floating viewports
You can create floating viewports anywhere inside the drawing area. You can control 
the number of viewports created and the arrangement of the viewports.             

To create floating viewports
1 Make sure that tilemode is set to OFF. 

• In the command bar, type tilemode and then press Enter.

• In the Setvar prompt box, choose Off.

2 Do one of the following:
• Choose View > Paper Space Views.

• On the Views toolbar, click the Paper Space Views tool ( ).

• Type mview and then press Enter.

3 In the prompt box, choose Fit To View, Create 2 Viewports, Create 3 Viewports, 
or Create 4 Viewports, or specify two opposing corners to create a custom view-
port.

4 In the prompt box, choose the viewport orientation.
5 Do one of the following:

• To arrange the viewports to fill the current graphic area, in the prompt box, 
choose Fit To Screen.

• To fit the viewports within a bounding rectangle, specify the corners of a 
rectangle.

TIP When you create a floating viewport, the program creates the viewport border on 
the current layer. You can make viewport borders invisible by creating a new layer 
before you create floating viewports and then turning off that layer after you create 
the viewports. To select the viewport borders, you must turn that layer back on before 
you can rearrange or modify the viewports.
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To name and save a viewport configuration 
1 Do one of the following: 

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type vports and then press Enter.

2 In the prompt box, choose Save.
3 Type a configuration name, and then press Enter.

The name can be up to 31 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.

Modifying floating viewports
After you create floating viewports, you can modify them as needed. In paper space, 
you can snap to the viewport borders using entity snap. You can also copy, delete, 
move, scale, and stretch viewports as you would any other drawing entity. Modifying 
a viewport while in paper space does not affect the entities within the viewport.

You can create a single floating viewport, or you can divide the graphic area into two viewports arranged 
vertically (A) or horizontally (B); three viewports arranged left (C), right (D), above (E),  
below (F), vertically (G), or horizontally (H); or four viewports (I).

A B C

D E F

G H I
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Modifying the contents of floating viewports
After you create floating viewports, you can modify the entities in a viewport by 
switching to model space with floating viewports. Select one of the viewports to 
make it the current viewport, and then modify the entities in the viewport using any 
entity modification command. Changes you make are immediately reflected in all the 
viewports. Changes you make to the grid, snap settings, zoom magnification, or 
viewpoint orientation, however, affect only the current viewport.

To edit the contents of a floating viewport 
1 Switch to model space with floating viewports.
2 Click a floating viewport to make it current.
3 Edit the drawing.

The tools that affect the drawing display and viewpoint orientation operate the same 
within floating model space viewports as within tiled model space windows with the 
exception of the zoom tools. When you work in paper space, you can control the scale 
of views in floating viewports by specifying a scale factor relative to paper space 
units by appending the suffix xp to the scale factor. For example, to increase the scale 
of the entities in the viewport to twice the size of paper space units, type 2xp. To 
decrease the scale to half the size of paper space units, type .5xp.

To change the scale of a floating viewport relative to paper space 
1 Switch to model space with floating viewports. 
2 Click a floating viewport to make it current.
3 Choose View > Zoom > Zoom.
4 Type the zoom scale factor relative to paper space, and then press Enter.
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Working with multiple layouts
In paper space, you can use multiple layouts for different paper sizes and plot set-
tings. By default, the first layout is called Layout1. You can create new layouts, 
delete layouts, rename layouts, set a layout as the current layout, and list all layouts.  

To create a new layout 
1 Type layout and then press Enter.    
2 In the prompt box, choose New.
3 Type a name for your new layout and then press Enter.

To delete a layout 
1 Type layout and then press Enter.    
2 In the prompt box, choose Delete.
3 Type a name for the layout to be deleted and then press Enter.

To rename a layout 
1 Type layout and then press Enter.    
2 In the prompt box, choose Rename.
3 Type the name of the layout you wish to rename and then press Enter.

4 Type a new name for the layout and then press Enter.

When you have multiple layouts, you may wish to change which layout is current.  

To make a layout current 
1 Type layout and then press Enter.   
2 In the prompt box, choose Set.
3 Type a name for the layout you wish to make currentand then press Enter.

To list all layouts 
1 Type layout and then press Enter.    
2 In the prompt box, choose ? to list all layouts.
3 Type s or press Enter to scroll through layouts.

Printing or plotting your drawing

You can print or plot your drawing on any Microsoft Windows-compatible printer or 
plotter. With IntelliCAD, you can control many aspects of printing, including:                

• Selecting which portion of a drawing to print.
• Scaling the drawing for print.
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• Mapping screen colors to colors and line widths in your output device.
• Opening plot configuration (PCP) files.
• Creating and saving printer configuration files.
• Specifying header and footer information such as a date and time stamp, your 

name and company name, or other information you want to appear at the top or 
bottom of the printed page.

• Specifying the origin of the print area.
• Previewing the printed page.
• Changing default printer settings such as paper size and orientation.

To preview the drawing before printing 
1 Do one of the following:

• Choose File > Print Preview.

• On the Standard toolbar, click the Print Preview tool( ).

• Type ppreview and then press Enter.

2 After checking the preview image, do one of the following:
• To print the drawing, click Print Settings to display the Print dialog box.

• To return to the drawing, click Close.
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Printing a drawing       
The Print dialog box is organized by tabs into three functional areas: scaling and 
viewing; color and width mapping; and advanced printing options. The print setting 
options available under each tab are described in the sections that follow. 

NOTE You cannot print a rendered image directly to a printer. To print a rendered 
image, you must first export the drawing to a different format—either a bitmap 
(.bmp), Postscript (.ps), or TIFF (.tif) file—and then print it from another graphics 
program. For more information, see Chapter 15, Drawing in Three Dimensions, Cre-
ating Rendered Images. 

A Click to zoom in.
B Click to zoom out. If you have zoomed in 

several times, click multiple times to restore 
the entire preview image. 

C Click to display the Print Settings dialog box.
D  Click to print the drawing.
E Click to close the preview and return to the 

drawing.

A B C D E
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To print a drawing
1 Do one of the following:

• Choose File > Print.

• On the Standard toolbar, click the Print tool ( ).

If you click the Print tool, the Print dialog box does not display. Your drawing 
will be sent directly to the selected printer.

• Type print and then press Enter.

2 From the Print dialog box, choose the settings you want.
3 Click Print.

NOTE  IntelliCAD saves your print settings each time you print. To restore the Intelli-
CAD default print settings, click Reset in the Print dialog box.

Setting the scale and view
You can print or plot the entire drawing or a selected portion, depending on which 
options you select in the Scale/View tab of the Print dialog box. You can choose to 
print what is visible on the screen, or you can specify to print an area of the drawing.

You can control the position of the drawing on the paper by specifying the origin of 
the print area, the location of the lower left corner of the plot area, in relation to the 
lower left corner of the paper. The origin is normally set to 0,0, which places the 
lower left corner of the print area as close to the lower left corner of the paper as the 
printer or plotter will allow. You can specify a different origin, however, by 
specifying different coordinates.
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When you create a drawing, you generally draw entities full-size. When you plot the 
drawing, you can specify the scale of the resulting print or let the program adjust the 
size of the drawing to fit the paper. To plot the drawing at a specific scale, specify the 
scale as a ratio of drawing units to printed units.

To automatically scale the drawing for printing
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 From the Print dialog box, click the Scale/View tab.
3 To scale the drawing to fit on one printed page, select the check box under Print 

Scale.

To specify the scale factor yourself
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 From the Print dialog box, click the Scale/View tab.
3 Under Print Scale, clear the check box.
4 Under User Defined Scale, type the ratio of printed units of measure (inches or 

millimeters) to drawing units.
5 To specify the printed units of measure, click Inches or Millimeters.
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To specify a portion of the drawing to print 
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 From the Print dialog box, click the Scale/View tab.
3 Under Print Area, click one of the following:

• Current View – prints the view on the screen.

• Saved View – prints the selected saved view.

• Extents – prints to the full extents of the entities in the drawing.

• Limits – prints to the limits defined for the drawing.

• Window – prints the portion of the drawing contained in the specified window, 
maintaining the aspect ratio of the windowed area to the drawing.

If you clicked Window, you must specify the window. Under Windowed Print 
Area, enter the diagonal x- and y-coordinates of the window, or select the area on 
the screen. 
To print only the area in the window without considering whether there is extra 
space on the screen, select the Print Only Area Within Specified Window check 
box.

4 Under Entities To Print, click one of the following:
• All Entities Within Print Area – prints all drawing entities contained within the 

specified print area.

• Selected Entities Within Print Area – prints only the entities you select from 
within the specified print area. 



F O R M A T T I N G  A N D  P R I N T I N G  D R A W I N G S    323
  

To specify a header and footer
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 Click the Advanced tab.
3 Under Header And Footer, type or select header and footer content.

A Click to select the area of the drawing that you want 
to print.

B Type the x- and y-coordinates of the two opposing 
corners of the rectangular area of the drawing that 
you want to print; or, to specify coordinates in the 
drawing window, click Select Print Area.

C Select to specify the rectangular area of the drawing 
that you want to plot by specifying points within the 
drawing.

D Click to specify drawing units and paper size in 
millimeters or inches.

E Specify the scale for the print area by typing the 
ratio of drawing units to printed inches or printed 
millimeters.

F Select to fit the specified print area to the current 
paper size.

G Click to print selected entities within the specified 
print area.

H Click to print all entities within the specified print 
area.



324   C H A P T E R  1 4
To specify the print area origin
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 Click the Advanced tab.
3 Under Origin Of Print Area, do one of the following:

• To center the specified print area on the printed page, select the Center On Page 
check box.

• To specify an origin for the print area, type the x- and y-coordinates, or click 
Select Origin and then specify a point on the drawing.

Using printer configuration files
Printer configuration files store the printer information you create for specific 
drawings, which eliminates the need to completely reconfigure your print settings 
each time you print a drawing. IntelliCAD supports the plot configuration (PCP) file 
format used by Autodesk AutoCAD. This feature makes it possible to use existing 
PCP files saved in AutoCAD, as well as to save your IntelliCAD print configuration 
settings to a PCP format.

TIP  You can convert an AutoCAD PC2 file to PCP format using the Device And 
Default selection feature in the AutoCAD Print dialog box.

To open or save a PCP file
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 From the Print dialog box, click the Advanced tab.
3 Under Configuration File, click Open to open a saved PCP file, or click Save to 

save the current print configuration settings to a new PCP file.
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Mapping color and width
You can map the colors that display on your screen to the colors that you want sent to 
your output device. For example, you can map a screen color of yellow to an output 
color of purple, so that all entities that display on the screen as yellow will print as 
purple, in whatever line width you specify. 

Rather than focusing on actual pens in specific plotters, IntelliCAD supports mapping 
to any Windows output device, including raster printers. 

A Type the content for the header and footer, or 
select it from the lists.

B Click to open a PCP file.
C Click to save the current configuration as a PCP 

file.

D Click to specify the print area origin by selecting a 
point within the drawing.

E Type x- and y-coordinates to specify the origin of 
the print area.

F Select to center the print area on the page.

A
E

B
C

D

F
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To change an output color
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 From the Print dialog box, click the Color/Width Map tab.
3 From the Output Color column, click the output color you want to change. 

The output color corresponds to the screen color in the same row.
4 From the Color selection palette, select the new output color, and then click OK.
5 Verify or change your selections under Map Properties.

NOTE  To change multiple screen colors to the same output color, first select the 
screen colors from the Screen Color column, and then select the output color.

To change a line width
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 From the Print dialog box, click the Color/Width Map tab.
3 In the Line Width column, select the line width you want to change.

The line width corresponds to the output color in the same row.
4 Type the new line width value.
5 Verify or change your selections under Map Properties.

NOTE  When specifying line width, be sure to consider the limitations of your output 
device.
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To map all colors to black
1 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

2 From the Print dialog box, click the Color/Width Map tab.
3 From the Screen Color column, select all the colors in the column.

To select all the colors, under Screen Color, click the first color, then scroll to the 
bottom of the column, and on the last color, press Shift+click.

4 Under Map Properties, click the swatch for Output Color, and then click OK.
Alternatively, from the Output Color column, select black (screen color 250).

5 Verify or change your selections under Map Properties.

NOTE  IntelliCAD saves your print settings each time you print. To restore the Intelli-
CAD default print settings, click Reset in the Print dialog box. 

A The color as it appears on the screen  
(read-only).

B Click an output color to change.

C Click a line width to change.
D Verify or change your selections.

A B C

D
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Selecting a printer or plotter

Before printing or plotting your drawing, make sure that the correct printer or plotter 
is selected.

To select a printer or plotter 
1 Do one of the following:

• Choose File > Print Setup.

• Type print and press Enter, and then click Print Setup.

2 From the Name list, select a printer or plotter.
 

NOTE Select the page orientation you want from the Print Setup dialog box.

Select a printer or plotter from the Name list.
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Drawing in three dimensions

Paper drawings typically represent two-dimensional views of three-dimensional enti-
ties. With IntelliCAD®, you can create three-dimensional models of three-dimen-
sional entities.

This chapter explains how to:

• View entities in three dimensions.
• Create three-dimensional entities.

• Edit entities in three-dimensional space.

The tools and commands for many of the functions described in this chapter appear 
on the Draw 3D toolbar and the Insert menu, respectively, when you set the program 
to the Advanced experience level.

Topics in this chapter
Viewing entities in three dimensions .................................................................330
Creating three-dimensional entities...................................................................333
Editing in three dimensions ...............................................................................351
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Viewing entities in three dimensions 

You can view an IntelliCAD drawing from any position in three-dimensional space. 
From any selected viewing position, you can add new entities, modify existing enti-
ties, and generate hidden-line and shaded views. The tools for these methods are on 
the View toolbar.    

Setting the viewing direction 
You view three-dimensional drawings by setting the viewing direction. The viewing 
direction establishes the viewing position, the Cartesian coordinate corresponding to 
the viewpoint looking back at the origin point, the 0,0,0 coordinate. When you view a 
drawing from the default viewpoint (0,0,1), you see a plan view of the drawing.    

On the View toolbar, you can view a three-dimensional drawing using any of the fol-
lowing methods:

• Preset Viewpoints ( )    
• Dynamic View Control ( )

• Plan View ( )

You can change the viewing direction to look at the drawing from a different vantage 
point or to work on a three-dimensional model from a different orientation.

To set a new viewing direction    
1 Do one of the following:

• Choose View > Preset Viewpoints.

• On the View toolbar, click the Preset Viewpoints tool ( ).

• Type setvpoint and then press Enter.

2 Click the preset view you want to use. 
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You can dynamically rotate the viewpoint within the xy plane and relative to the xy 
plane, and you can pan and zoom the drawing. As you change the viewpoint settings, 
the drawing display automatically updates.    

To dynamically set a view direction    
1 Do one of the following:

• Choose View > Dynamic View Control.

• On the View toolbar, click the Dynamic View Control tool ( ).

• Type viewctl and then press Enter.

2 Click the appropriate tools to dynamically change the viewpoint.
3 To complete the command, click OK.

A Click to select a non-axis viewpoint.
B Click to select the previous viewpoint.

C Click to select a viewpoint aligned with an axis.

A

C

B
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You can set the current viewing direction to the plan view of the current user coordi-
nate system (UCS), a previously saved UCS, or the World Coordinate System 
(WCS).

To display a plan view of the current drawing
1 Do one of the following:    

• Choose View > Plan View.

• On the View toolbar, click the Plan View tool ( ).

• Type plan and then press Enter.

2 In the prompt box, choose one of the following:
• Current displays the plan view of the current UCS.

• UCS displays the plan view of a saved UCS. The program prompts you for the 
name of the UCS.

• World displays the plan view of the WCS.

A Indicates the current viewpoint.
B Click to pan the drawing.
C Click to display the Preset Viewpoints dialog box.
D Click to update the drawing display whenever 

you click a tool.
E Click to zoom extents.

F Click to zoom out.
G Click to zoom in.
H Shows the current viewpoint orientation.
I Type or select the rotation angle increment.
J Click to rotate the view about a predefined axis.

A

B

C

D

F
G

E

H

I

J
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Creating three-dimensional entities   

IntelliCAD supports the following types of three-dimensional models:   

• Wire-frame models, which consist of lines and curves that define the edges of a 
three-dimensional entity. You can create a wire-frame model by drawing lines, 
arcs, polylines, and other two-dimensional entities anywhere in three-dimensional 
space. Wire-frame models have no surfaces; they always appear as outlines. 
Because you must individually draw and position each entity that makes up a 
wire-frame model, creating one can be exacting and time-consuming.       

• Surface models, which consist of both edges and the surfaces between those 
edges. You can create a surface model by applying elevation and thickness to two-
dimensional planar entities or by using specific three-dimensional entity-creation 
commands. Surface models consist of individual planes forming a faceted, polyg-
onal mesh.

Applying elevation and thickness
By default, the program creates new two-dimensional entities with a zero elevation 
and thickness. The easiest way to create a three-dimensional entity is to change the 
elevation or thickness property of an existing two-dimensional entity.        

The elevation of an entity is its z-coordinate position in relation to the xy plane in 
which the entity is drawn. An elevation of 0 indicates that the entity is drawn on the 
xy plane of the current UCS. Positive elevations are above this plane; negative eleva-
tions are below it.    

The thickness of an entity is the distance it is extruded above or below its elevation. A 
positive thickness extrudes the entity upward in the positive z direction of the entity; 
a negative thickness extrudes it downward in the negative z direction. The thickness 
is applied uniformly to the entire entity. You can extrude any two-dimensional entity 
into a three-dimensional entity by changing the thickness of the entity to a nonzero 
value. For example, a circle becomes a cylinder, a line becomes a three-dimensional 
plane, and a rectangle becomes a box.      

Two-dimensional entities. Two-dimensional entities with thickness added.
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You can create three-dimensional entities using any of the following methods:

• Draw two-dimensional entities in three-dimensional space.    
• Convert two-dimensional planar entities into three-dimensional entities by apply-

ing elevation and thickness.
• Convert two-dimensional planar entities into three-dimensional entities by revolv-

ing or extruding.

• Create three-dimensional entities such as boxes, cylinders, cones, domes, spheres, 
and wedges. 

You can change the default elevation and thickness values to create new entities with 
an elevation and thickness already applied.

To set the current elevation    
1 Display the current elevation setting by doing one of the following:

• Choose Settings > Elevation.

• On the Settings toolbar, click the Elevation tool ( ).

• Type elev and then press Enter.

2 Specify the New Current Value For Elevation, and then press Enter. 

To set the current thickness    
1 Display the current thickness setting by doing one of the following:

• Choose Settings > Thickness.

• On the Settings toolbar, click the Thickness tool ( ).

• Type thickness and then press Enter.

2 Specify the New Current Value For Thickness, and then press Enter.
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To set the current elevation and thickness using a dialog box    
1 Display the Drawing Settings dialog box by doing one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the 3D Settings tab.
3 In the Change Settings For list, click Surfaces.
4 To change the current thickness, in the Current 3D Thickness box, type a new 

thickness value or click the arrows to select a new thickness.
5 To change the current elevation, in the Current 3D Elevation box, type a new ele-

vation value or click the arrows to select a new elevation.
6 Click OK.
  

A Type or select the current three-dimensional 
thickness.

B Type or select the current three-dimensional 
elevation.

A
B
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To change the thickness and elevation of an existing entity    
1 Do one of the following:

• Choose Modify > Properties.

• On the Modify toolbar, click the Properties tool ( ).

• Type entprop and then press Enter.

2 Select the entity, and then press Enter.
IntelliCAD displays the Entity Properties dialog box. The exact appearance of the 
dialog box depends on the type of entity you select.

3 To change the thickness, in the Thickness box, type a new thickness value or click 
the arrows to select the new thickness.

4 To change the elevation, in the Z coordinate box, type a new elevation value or 
click the arrows to select the new elevation.    

5 Click OK.

A Type or select the new thickness. B Type or select the new elevation.   

A

B
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Creating three-dimensional faces 
You can create a three-dimensional face, which consists of a section of a plane in 
three-dimensional space. You define a three-dimensional face by specifying the x,y,z 
coordinates of three or more corners. After you specify the fourth point, the program 
continues to prompt you for additional faces by alternating prompts for the third point 
and fourth point to allow you to build a complex three-dimensional entity. Each 
three- or four-sided plane is created as a separate three-dimensional face entity.    

To create a three-dimensional face    
Advanced experience level

1 Do one of the following:
• Choose Insert > 3D Entities > Face.

• On the Draw 3D toolbar, click the Face tool ( ).

• Type face and then press Enter.

2 Specify the first point of the three-dimensional face.
3 Specify the second, third, and fourth points.
4 Specify the third and fourth points for additional faces. 
5 To complete the command, press Enter.

TIP Any or all edges of a three-dimensional face can be invisible to allow you to more 
accurately model entities with holes in them. As the program prompts you for the cor-
ner points, in the prompt box, choose Invisible Edge to make the next edge invisible.      

An example of a three-dimensional model created using three-dimensional faces.
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Creating rectangular meshes
You can create a three-dimensional rectangular mesh consisting of four-sided poly-
gons. You determine the size of the mesh by specifying the number of vertices along 
the primary (M-direction) and secondary (N-direction) mesh axes and then specifying 
the coordinates for each vertex.    

To create a rectangular mesh    
Advanced experience level

1 Do one of the following:
• Choose Insert > 3D Entities > Mesh.

• On the Draw 3D toolbar, click the Mesh tool ( ).

• Type mesh and then press Enter.

2 Specify the number of vertices along the primary mesh axis.
3 Specify the number of vertices along the secondary mesh axis.
4 Specify the coordinates for each vertex.

Specifying the coordinates for the last vertex completes the mesh and ends the 
command. 

TIP Although creating rectangular meshes manually can be exacting, they are useful 
for representing complex surfaces such as three-dimensional terrain models. The 
Mesh tool is most useful when combined with scripts or LISP programs that mathe-
matically calculate the coordinates of the vertices.      

An example of a three-dimensional terrain model created using rectangular meshes.
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Creating polyface meshes
You can create a polygon mesh consisting of faces connecting three or more vertices. 
You first determine the coordinates of each vertex and then define each face by enter-
ing the vertex numbers for all the vertices of that face. As you create each face, you 
can control the visibility and color of each edge and assign each edge to specific lay-
ers.    

To create a polyface mesh    
Advanced experience level

1 Do one of the following:    
• Choose Insert > 3D Entities > Polyface Mesh.

• On the Draw 3D toolbar, click the Polyface Mesh tool ( ).

• Type pface and then press Enter.

2 Specify the coordinates of each vertex.
After each vertex that you specify, the next vertex number is displayed, and you 
are prompted for the coordinates of the vertex. Specify the coordinates, and then 
press Enter. Continue to specify the coordinates for each numbered vertex.

3 To finish specifying vertex coordinates, press Enter.
4 Specify the vertex numbers that define the first face. 

You specify the face by entering the vertex numbers that were defined when you 
specified coordinates in step 2. Each face can be composed of three or more num-
bered vertices.

5 To finish defining the first face, press Enter.
6 Specify the next face by entering its vertex numbers.
7 To complete the command, press Enter.

TIP To make an edge invisible, type the vertex number as a negative value.    
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Creating boxes     
You can create rectangular boxes, or cubes. A box consists of six rectangular surface 
planes. The base of the box is always parallel to the xy plane of the current UCS. You 
position the box by specifying either a corner or the center of the box. You determine 
the size of the box by either specifying a second corner and the height; defining the 
box to be a cube and then providing its length; or specifying the length, width, and 
height.   

To create a box    
1 Do one of the following:

• Choose Insert > 3D Entities > Box.

• On the Draw 3D toolbar, click the Box tool ( ).

• Type box and then press Enter.

2 Specify the first corner of the base.
3 Specify the opposite corner of the base.
4 Specify the height.  

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A
B

C
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Creating wedges 
You can create three-dimensional wedges consisting of five surface planes. The base 
of the wedge is always parallel to the xy plane of the current UCS with the sloped 
face opposite the first corner. The height is always parallel to the z-axis. You position 
the wedge by specifying either a corner or the center of the wedge. You determine the 
size of the wedge by either specifying a second corner and the height; defining the 
wedge based on a cube having a given length; or specifying the length, width, and 
height.    

To create a wedge    
1 Do one of the following:

• Choose Insert > 3D Entities > Wedge.

• On the Draw 3D toolbar, click the Wedge tool ( ).

• Type wedge and then press Enter.

2 Specify the first corner of the base.
3 Specify the opposite corner of the base.
4 Specify the height. 
  

Creating cones
You can create three-dimensional cones defined by a circular base and tapering to a 
point perpendicular to the base. The base of the cone is always parallel to the xy plane 
of the current UCS; the height of the cone is always parallel to the z-axis. You posi-
tion the cone by specifying the center of the base. You determine the size of the cone 
by specifying either the radius or the diameter of the base and the height.    

To create a cone   
1 Do one of the following:

• Choose Insert > 3D Entities > Cone.

• On the Draw 3D toolbar, click the Cone tool ( ).

• Type cone and then press Enter.

2 Specify the center of the base of the cone.
3 Specify the radius or diameter.

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A

BC
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4 Specify the height.  

Creating pyramids
You can create tetrahedrons (three-sided pyramids) or four-sided pyramids. The sides 
of the resulting pyramid can meet at a point (the apex) or can form a three- or four-
edged top. The sides of a four-sided pyramid can also meet along a ridge defined by 
two points. The base of the pyramid is always parallel to the xy plane of the current 
UCS. You position the pyramid by specifying a corner of the base. You determine the 
size of the pyramid by specifying the base points and either the apex, the corners of 
the top surface, or the endpoints of the ridge.       

To create a tetrahedron    
1 Do one of the following:

• Choose Insert > 3D Entities > Pyramid.

• On the Draw 3D toolbar, click the Pyramid tool ( ).

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.
3 Specify the second and third points.
4 In the prompt box, choose Tetrahedron.
5 Specify the apex of the tetrahedron.

Center of the base (A), the radius of the base (B), and the height (C).

A

C

B

The first point (A), second point (B), and third point (C) of the base, and the apex (D).

A

B

C

D
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To create a pyramid with a planar top 
1 Do one of the following: 

• Choose Insert > 3D Entities > Pyramid.

• On the Draw 3D toolbar, click the Pyramid tool ( ).

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.
3 Specify the second, third, and fourth points.
4 In the prompt box, choose Top Surface.
5 Specify the first point on the top surface of the pyramid.
6 Specify the second, third, and fourth points.
.

Creating cylinders
You can create cylinders defined by a circular base. The base of a cylinder is always 
parallel to the xy plane of the current UCS; the height of a cylinder is always parallel 
to the z-axis. You position a cylinder by specifying the center of the base. You deter-
mine the size of a cylinder by specifying either the radius or diameter of the base and 
the height.

To create a cylinder   
1 Do one of the following:

• Choose Insert > 3D Entities > Cylinder.

• On the Draw 3D toolbar, click the Cylinder tool ( ).

• Type cylinder and then press Enter.

2 Specify the center of the base of the cylinder.
3 Specify the radius or diameter.

The first point (A), second point (B), third point (C), and fourth point (D) of the base, and the first point (E), 
second point (F), third point (G), and fourth point (H) of the top surface.

A

B

C

D

E

F
G

H
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4 Specify the height.

Creating spheres
You can create spheres. The latitude lines of a sphere are always parallel to the xy 
plane of the current UCS; the central axis is always parallel to the z-axis. You posi-
tion a sphere by specifying its center point. You determine the size of a sphere by 
specifying either its radius or its diameter.

To create a sphere    
1 Do one of the following:

• Choose Insert > 3D Entities > Sphere.

• On the Draw 3D toolbar, click the Sphere tool ( ).

• Type sphere and then press Enter.

2 Specify the center of the sphere.
3 Specify the radius or diameter.

Center of the base (A), radius of the base (B), and the height (C).

A

B

C

Center (A) and radius (B) of the sphere. The resulting sphere.

A

B
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Creating dishes
You can create a three-dimensional dish. The latitude lines of a dish are always paral-
lel to the xy plane of the current UCS; the central axis is always parallel to the z-axis. 
You position a dish by specifying its center point. You determine the size of a dish by 
specifying either its radius or its diameter.

To create a dish      
1 Do one of the following:

• Choose Insert > 3D Entities > Dish.

• On the Draw 3D toolbar, click the Dish tool ( ).

• Type dish and then press Enter.

2 Specify the center of the dish.
3 Specify the radius or diameter.
.

Creating domes
You can create a three-dimensional dome. The latitude lines of a dome are always 
parallel to the xy plane of the current UCS; the central axis is always parallel to the z-
axis. You position a dome by specifying its center point. You determine the size of a 
dome by specifying either its radius or its diameter.

To create a dome    
1 Do one of the following:

• Choose Insert > 3D Entities > Dome.

• On the Draw 3D toolbar, click the Dome tool ( ).

• Type dome and then press Enter.

2 Specify the center of the dome.

Center (A) and radius (B) of the dish.

A

B
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3 Specify the radius or diameter.

Creating tori
You can create a three-dimensional donut or ring-shaped entity known as a torus. The 
diameter of a ring is always parallel to the xy plane of the current UCS. A torus is 
constructed by revolving a circle about a line drawn in the plane of the circle and par-
allel to the z-axis of the current UCS. You position a torus by specifying its center 
point. You determine the size of a torus by specifying its overall diameter or radius 
and the diameter or radius of the tube (the circle being revolved).

To create a torus    
1 Do one of the following:

• Choose Insert > 3D Entities > Torus.

• On the Draw 3D toolbar, click the Torus tool ( ).

• Type torus and then press Enter.

2 Specify the center of the whole torus.
3 Specify the radius or diameter of the whole torus.
4 Specify the radius or diameter of the body of the torus.

Center (A) and radius (B) of the dome.

A

B

Center (A) and radius of the whole torus (B), and the radius of the body (C).

A

B C
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Creating ruled surface meshes
You can create a ruled surface, which is a three-dimensional polygon mesh that 
approximates the surface between two existing entities. You select the two entities 
that define the ruled surface. These entities can be arcs, circles, lines, points, or 
polylines.

To create a ruled surface mesh   
Advanced experience level

1 Do one of the following:
• Choose Insert > 3D Entities > Ruled Surface.

• On the Draw 3D toolbar, click the Ruled Surface tool ( ).

• Type rulesurf and then press Enter.

2 Select the first defining entity.
3 Select the second defining entity.
.

TIP To control the density of the mesh, change the values for the Number of M-Direc-
tion Surfaces. Choose Settings > Drawing Settings, and then click the 3D Settings 
tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the 
Number Of M-Direction Surfaces value. Or, on the Settings toolbar, use the Drawing 
Settings tool ( ) to display that dialog box.

Creating extruded surface meshes
You can create an extruded surface, which is a three-dimensional polygon mesh that 
approximates the surface generated by extruding a path curve along a direction vec-
tor. You select the two entities that define the path curve and direction vector. The 
length of the direction vector determines the distance the path curve is moved along 
the direction vector. The extruded entity can be an arc, circle, line, or polyline. You 
can choose a line or open polyline as the direction vector. The resulting mesh consists 
of a series of parallel polygonal planes running along the specified path.

Select the first (A) and second (B) defining entities. The resulting ruled surface mesh.

A

B
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To create an extruded surface mesh      
Advanced experience level

1 Do one of the following:
• Choose Insert > 3D Entities > Extruded Surface.

• On the Draw 3D toolbar, click the Extruded Surface tool ( ).

• Type tabsurf and then press Enter.

2 Select the entity to extrude.
3 Select the extrusion path.

TIP To control the density of the mesh, change the values for the Number of M-Direc-
tion Surfaces. Choose Settings > Drawing Settings, and then click the 3D Settings 
tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the 
Number Of M-Direction Surfaces. Or, on the Settings toolbar, use the Drawing Set-
tings tool ( ) to display that dialog box.

Creating revolved surface meshes
You can create a surface of revolution, which is a three-dimensional polygon mesh 
that approximates the surface generated by rotating a two-dimensional profile around 
an axis. You select the two entities that define the profile and the axis. You also spec-
ify the starting angle and the number of degrees to revolve the profile.

Revolving the profile 360 degrees creates a closed three-dimensional mesh. The 
Number Of M-Direction Surfaces value determines the mesh density (the number of 
mesh segments) in the M-direction (around the axis of revolution). The N-Direction 
Mesh Density value determines the mesh density (the number of mesh segments) in 
the N-direction (along the axis of revolution).

Select the entity to extrude (A) and the  
extrusion path (B).

The resulting extruded  
surface mesh.

A B
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To create a revolved surface mesh    
Advanced experience level

1 Do one of the following:
• Choose Insert > 3D Entities > Revolved Surface.

• On the Draw 3D toolbar, click the Revolved Surface tool ( ).

• Type revsurf and then press Enter.

2 Select the entity to revolve.
3 Select the entity to be used as the axis of revolution.
4 Specify the starting angle.
5 Specify the number of degrees to revolve the entity.

TIP To control the density of the mesh, change the values for the Number Of M-Direc-
tion Surfaces and N-Direction Mesh Density. Choose Settings > Drawing Settings, 
and then click the 3D Settings tab. Under Change Settings For, select Surfaces. 
Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direc-
tion Mesh Density values. Or on the Settings toolbar, use the Drawing Settings tool 
( ) to display that dialog box. 

Select the entity to be revolved (A) and the 
axis of revolution (B).

The resulting revolved surface  
mesh.

A

B
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Creating edge-defined Coons surface patch meshes
You can create a surface called a Coons surface patch, a mesh connecting four edges. 
You select the entities that define the edges. Edge entities can be arcs, lines, or 
polylines. The four edge entities must form a closed loop and share endpoints. A 
patch is a bicubic surface (one curve extends in the M-direction and the other in the 
N-direction) interpolated between the four adjoining edges. You can select the edges 
in any order. The first edge you select determines the M-direction of the mesh.

To create an edge-defined Coons surface patch mesh    
Advanced experience level

1 Do one of the following:
• Choose Insert > 3D Entities > Coons Surface.

• On the Draw 3D toolbar, click the Coons Surface tool ( ).

• Type edgesurf and then press Enter.

2 Select the first edge.
3 Select the second, third, and fourth edges.

TIP To control the density of the mesh, change the value for the Number of M-Direc-
tion Surfaces and N-Direction Mesh Density. Choose Settings > Drawing Settings, 
and then click the 3D Settings tab. Under Change Settings For, select Surfaces. 
Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direc-
tion Mesh Density values. Or on the Settings toolbar, use the Drawing Settings tool 
( ) to display that dialog box.

Select the entities to be used as the four 
edges (A, B, C, and D).

The resulting Coons surface patch mesh.

A
B

C

D
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Editing in three dimensions

You can copy, move, rotate, mirror, array, change, and edit properties of two-dimen-
sional and three-dimensional entities in both two-dimensional and three-dimensional 
space. When you modify three-dimensional entities in two-dimensional space, you 
modify the entity in relation to the current UCS. 

Rotating in three dimensions
You can rotate selected entities about a specified axis in three-dimensional space. 
You select the entities to rotate and then define the axis of rotation either by specify-
ing two points; selecting an existing entity; aligning the axis with the x-, y-, or z-axis 
of the current UCS; or aligning the axis with the current view.

To rotate an entity about an axis in three dimensions          
1 Do one of the following:

• Choose Modify > 3D Rotate.

• On the Modify toolbar, click the 3D Rotate tool ( ).

• Type rotate3D and then press Enter.

2 Select the entities to rotate, and then press Enter.
3 Choose from one of the following options: Entity, Last, View, Xaxis, Yaxis, 

Zaxis.
4 Specify the rotation angle.
5 Specify the reference angle.

Select the entities to rotate (A), specify the endpoints 
of the axis of rotation (B and C), and then specify the 
rotation angle (D).

Result after rotating the entities.

B

D
CA
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Arraying in three dimensions
You can copy selected entities and arrange them in a three-dimensional rectangular or 
polar (circular) pattern. For a rectangular array, you control the number of copies in 
the array by specifying the number of rows and columns and the number of levels. 
You also specify the distance between each. For a polar array, you specify the axis 
around which to array the entities, the number of copies of the entities to create, and 
the angle subtended by the resulting array.

To create a three-dimensional rectangular array   
1 Do one of the following:

• Choose Modify > 3D Array.

• On the Modify toolbar, click the 3D Array tool ( ).

• Type 3Darray and then press Enter.

2 Select the entities, and then press Enter.
3 In the prompt box, choose Rectangular.
4 Type the number of rows in the array.
5 Type the number of columns.
6 Type the number of levels.
7 Specify the vertical distance between the rows.
8 Specify the horizontal distance between the columns.
9 Specify the depth between the levels.

To create a three-dimensional rectangular array, select the entity to copy (A), type the 
number of rows, columns, and levels, and then specify the distance between each row (B), 
column (C), and level (D).

AB
C

D
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To create a three-dimensional polar array         
1 Do one of the following: 

• Choose Modify > 3D Array.

• On the Modify toolbar, click the 3D Array tool ( ).

• Type 3Darray and then press Enter.

2 Select the entities, and then press Enter.
3 In the prompt box, choose Polar.
4 Type the number of copies to make, including the original selection set.
5 Specify the angle the array is to fill, from 0 to 360 degrees.

The default setting for the angle is 360 degrees. Positive values create the array in 
a counterclockwise direction; negative values create the array in a clockwise 
direction.

6 In the prompt box, choose one of the following:
• Yes-Rotate Entities to rotate entities as they are arrayed.

• No-Do Not Rotate to retain the original orientation of each copy as it is arrayed.

7 Specify the center point of the array.
8 Specify a second point along the central axis of the array.

To create a three-dimensional polar array, select the entity to copy (A), type the number of copies to make, 
specify the angle the array is to fill (B), and then specify the center point of the array (C) and a second point 
along the central axis of the array (D).

A
B

C

D
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Mirroring in three dimensions
You can create a mirror image of selected entities in three-dimensional space. You 
mirror the entities about a mirror plane that you define by either specifying three 
points; selecting an existing two-dimensional planar entity; aligning the plane parallel 
to the xy, yz, or xz plane of the current UCS; or aligning the plane with the current 
view. You can delete or retain the original entities.

To mirror an entity about a three-dimensional plane     
1 Do one of the following:

• Choose Modify > 3D Mirror.

• On the Modify toolbar, click the 3D Mirror tool ( ).

• Type mirror3D and then press Enter.

2 Select the entities, and then press Enter.
3 In the prompt box, choose 3 Points, or press Enter to select the default.
4 Specify the first point on the mirror plane.
5 Specify the second and third points on the plane.
6 In the prompt box, choose one of the following:

• Yes-Delete Entities to delete the original entities.

• No-Keep Entities to retain the original entities.

 

Select the entity to mirror (A), and then specify 
the first point (B), second point (C), and third 
point (D) defining the mirror plane.

The resulting mirrored entity.

A
D C

B
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Working with other programs

IntelliCAD® offers great flexibility in its capability to be used with other programs. 
You can include an IntelliCAD drawing in a Microsoft Word document or insert a 
Microsoft Excel spreadsheet containing a parts list into an IntelliCAD drawing. To 
include IntelliCAD drawings in other programs and documents from other programs 
in IntelliCAD drawings, you either link or embed them. You can also save Intelli-
CAD drawings in other file formats that can be used directly with other programs or 
send IntelliCAD drawings to coworkers via e-mail.

This chapter explains how to:

• Save and view snapshots.
• Use object linking and embedding.
• Export IntelliCAD drawings to other file formats.
• Send drawing files via e-mail.

Topics in this chapter
Saving and viewing snapshots ......................................................................... 356
Using data from other programs in IntelliCAD drawings................................... 357
Using IntelliCAD data in other programs .......................................................... 361
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Saving and viewing snapshots

You can save snapshots of a drawing to view later. A snapshot saves the current 
drawing in either *.emf, *.wmf, or *.sld format exactly as it appears on the screen. A 
snapshot is not a drawing file. You cannot edit or print the snapshot; you can only 
view it.

You can use snapshots in the following ways:

• Make presentations by showing snapshots of your drawings.
• Reference a snapshot of a drawing while working on a different drawing.

• Present a number of snapshots as a slide show by using scripts.

When you view a snapshot, it temporarily replaces the current drawing. When you 
refresh the display of the current drawing (by redrawing, panning, zooming, minimiz-
ing, maximizing, or tiling), the snapshot image disappears, and you are returned to 
the current drawing.

You create a snapshot by saving the current view as a snapshot. A snapshot does not 
include any entities on layers that are not currently visible. The contents of the snap-
shot also depend on the current drawing space. In model space, the snapshot shows 
only the current viewport. In paper space, the snapshot contains all visible viewports.

To create a snapshot 
1 Display the drawing exactly as you want to capture it as a snapshot.

• Choose Tools > Make Snapshot.

• On the Tools toolbar, click the Make Snapshot tool ( ).

• Type msnapshot and then press Enter.

2 In the Create Snapshot dialog box, specify the name of the snapshot file you want 
to create.

3 From the Files Of Types list, choose either *.emf, *.wmf, or *.sld.
4 Click Save.

The current drawing remains on the screen, and the snapshot is saved to the directory 
that you specify. You can view previously saved snapshots, and you can also view 
snapshots created using AutoCAD.
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To view a snapshot
1 Do one of the following: 

• Choose Tools > View Snapshot.

• On the Tools toolbar, click the View Snapshot tool ( ).

• Type vsnapshot and then press Enter.

2 In the View Snapshot dialog box, specify the name of the snapshot file you want 
to view.

3 Click Open.
IntelliCAD displays the snapshot in the current drawing window.

Using data from other programs in IntelliCAD drawings

You can include data from other programs in IntelliCAD drawings by using either 
embedding or linking. The method you choose depends on the type of object or file 
you want to include in your IntelliCAD drawing and what you want to do with it after 
it is there.

Embedding objects into drawings
Embed an object into your IntelliCAD drawing when you want to keep all the data 
you work with in one file or if you want to transfer the file to other computers. You 
can embed data from programs that support object linking and embedding.

For example, if you want to distribute data about a department’s computer equipment 
along with an IntelliCAD drawing of the department’s floor plan, you can embed a 
Microsoft Excel spreadsheet into the floor plan.

When you embed data from another program, IntelliCAD becomes the container for 
that data. The object embedded in the IntelliCAD drawing becomes part of the 
IntelliCAD file. When you edit the data, you open its program from within the 
IntelliCAD drawing.

Any changes you make to the embedded data exist only in the IntelliCAD drawing, so 
it is not necessary to keep that data in a separate file. If the data does exist in a sepa-
rate file, the original file does not change when you modify the embedded object in 
IntelliCAD. Also, changes to the original file do not affect the embedded object in the 
IntelliCAD drawing.
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To embed another program’s object into an IntelliCAD drawing
1 Open the file that contains the data you want.
2 In the file, select the data you want to embed in the IntelliCAD drawing.
3 Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.
4 In the IntelliCAD window, display the drawing in which you want to embed the 

object.
5 Choose Edit > Paste, or click the Paste tool ( ) on the Standard toolbar.

The data on the Clipboard is pasted into the drawing as an embedded object. The 
object appears in the center of the view, but you can select and move it by moving 
the cursor.

To embed an object from an existing file within IntelliCAD      
1 Do one of the following:

• Choose Insert > Object.

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create From File.
3 Specify the file by doing one of the following:

• Type a path and file name in the File box.

• Click Browse to select a file.

4 Select Display As Icon if you want that program’s icon to appear in the drawing 
instead of the data.

5 Click OK.
The first page of the file appears in the IntelliCAD drawing, unless you chose to 
display it as an icon. You can select the object and drag to reposition it.
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To create a new embedded object from within IntelliCAD
1 Do one of the following:

• Choose Insert > Object.

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create New.
3 From the Object Type list, select the type of object you want to create, and then 

click OK.
The program for creating that object opens within IntelliCAD. If the program is 
compatible with ActiveX, it opens in place (within the other program) in the 
IntelliCAD drawing; otherwise, the program opens in its full window.

4 Create the object in the other program.
5 If the program is running within the other document (in place), click anywhere 

outside the embedded object to close the program.
If the program is running in its full window, choose File > Exit.

Linking objects to drawings
If another program supports ActiveX, you can link its data to IntelliCAD drawings. 
Use linking when you want to include the same data in many files. When you update 
the data, all links to other files reflect the changes.

For example, if you created your company logo in an ActiveX-compatible drawing 
program, and you want to include it in the title block of every drawing you create 
with IntelliCAD, you can link it to each IntelliCAD drawing. When you change the 
original logo in the drawing program, the IntelliCAD drawing updates automatically.

When you link data from another program, the IntelliCAD drawing stores only a ref-
erence to the location of the file in which you created the data. You link data from a 
saved file, so IntelliCAD can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly 
increase the file size of the IntelliCAD drawing. However, links require some mainte-
nance. If you move any of the linked files, you need to update the links. In addition, if 
you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing, or 
you can do so only when you specify. Anytime a link is updated, changes made to the 
object in its original file also appear in the IntelliCAD drawing, and the changes also 
appear in the original file if they were made through IntelliCAD.
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To link a file to an IntelliCAD drawing
1 Save the original file. 

Because a link consists of a reference to the original file, you must save the file 
before you can link to it.

2 In the original file, select the data you want in the IntelliCAD drawing.
3 Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.
4 Display the IntelliCAD drawing to which you want to link the file.
5 In IntelliCAD, choose Edit > Paste Special.
6 In the Paste Special dialog box, select Paste Link.
7 Click OK.

To create a linked object from within IntelliCAD   
1 Display the IntelliCAD drawing in which you want to display the linked object.

• Choose Insert > Object

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create From File.
3 Specify the file by doing one of the following:

• Type a path and file name in the File box.

• Click Browse to select the file using a file dialog box.

4 Select the Link check box.
5 Select Display As Icon if you want that program’s icon to appear in the drawing 

instead of the data.
6 Click OK.

The first page appears in the IntelliCAD drawing, unless you chose to display it as 
an icon. To reposition the object, select and drag it.

Editing an embedded or linked object from within IntelliCAD
You can modify an embedded or linked object in its original program from within 
IntelliCAD. When you modify an embedded object, you change the object only in 
IntelliCAD, not its original file (if you pasted the object from an existing file). When 
you modify a linked file, however, you open and change the original file.

Most programs include a submenu of actions you can perform on an embedded or 
linked ActiveX object. Usually, the commands for editing ActiveX objects are Edit 
and Open. If the object is embedded and its program supports in-place editing, the 
Edit command opens the object in place. The Open command opens the object in the 
full program window. In IntelliCAD, this command appears at the bottom of the Edit 
menu.
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To edit an embedded or linked object 
• In the IntelliCAD drawing, double-click the object.
If the object is embedded and the program in which you created the object supports 
in-place editing, the object opens in place.

If the object is linked, or if its program does not support in-place editing, the other 
program opens in its full window and displays the object.

Using IntelliCAD data in other programs

You can use any of the following methods to include IntelliCAD data in a document 
created in another program:

• Embedding
• Linking

• Exporting

The method you choose depends on the capabilities of the other program and how 
you want to work with the IntelliCAD data after you’ve placed it in the other 
document.

NOTE Each method except exporting uses ActiveX to integrate data from different 
programs. With ActiveX, you can open IntelliCAD drawings from within the other 
program to modify the IntelliCAD drawings.

Embedding drawings
When you embed an IntelliCAD drawing, it becomes part of the other program’s doc-
ument file. When you edit the drawing, you edit only the version that is embedded in 
the other document.

Embedding is useful when you don’t want to maintain a link to the IntelliCAD draw-
ing for the data you include in the other document. Edits made to the new drawing do 
not affect the original drawing. To transfer the file to other computers, you can trans-
fer all the data in one file, but embedded objects increase the file size.

From within a document in a program that supports ActiveX, such as Microsoft 
Word, you can either create a new embedded IntelliCAD drawing or embed an exist-
ing IntelliCAD drawing.
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To create an IntelliCAD drawing in another document
1 In the document, choose Insert > Object (or the equivalent command for that 

program).
2 In the dialog box, click the options for creating a new file. 
3 Under Object Type, choose IntelliCAD Drawing, and then click OK.
4 Create the IntelliCAD drawing.
5 If IntelliCAD is running in its own window, choose File > Exit.

If IntelliCAD is running within the other document (in place), click somewhere in 
the document outside the IntelliCAD drawing to close IntelliCAD.

6 To edit the IntelliCAD drawing from within the document, double-click the 
drawing.

TIP You can also embed an existing IntelliCAD drawing from within another docu-
ment. Follow step 1 in the preceding procedure, and then click the option for creating 
an object from an existing file.

To embed selected IntelliCAD entities
1 In IntelliCAD, select the entities you want to embed.
2 Choose Edit > Copy (or press Ctrl+C).
3 Open the document in which you want to embed the entities. 
4 Choose Edit > Paste (or the equivalent command).

To embed an entire IntelliCAD drawing
1 Open the document in which you want to embed the drawing.
2 Choose Insert > Object.
3 Click Create From File.
4 Click Browse, and then choose the file you want to embed.
5 Click Insert, and then click OK.

Editing an embedded IntelliCAD object in place
In many ActiveX-compatible programs you can edit an embedded IntelliCAD object 
without leaving the program (or container application). This is called in-place editing. 
A different set of IntelliCAD menus and toolbars temporarily replaces most of the 
menus and controls in the active window while you edit the IntelliCAD object.       

To edit an embedded IntelliCAD object in place
1 In the container application, double-click the embedded IntelliCAD object.

A different set of IntelliCAD menus and controls appears.
2 Edit the IntelliCAD drawing.
3 Click anywhere outside the drawing window to exit the in-place editing controls.
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Linking drawings
When you link an IntelliCAD drawing to another document, the other document con-
tains only a reference to the IntelliCAD drawing file, rather than the actual drawing. 
You link data in a saved IntelliCAD file so that the other program can find the data 
and display it.     

Linking works well when you want to include the same IntelliCAD data in more than 
one document. When you update the data, you need update it in only one location. 
The versions that are linked to other documents reflect the changes automatically.

Linking an IntelliCAD file to another document does not increase the file size the 
way embedding an IntelliCAD object does. However, links require more 
maintenance. To transport the data, you must make sure to transfer all linked files to 
the other computer.

To link an IntelliCAD file to another document
1 Open the drawing you want to link.

NOTE Because a link is a reference to a file, you can link only files that are saved to a 
location on a disk. If you haven’t saved the drawing you want to link, choose  
File > Save.

2 In the other program, open the document in which you want to include the 
IntelliCAD drawing.

3 Choose that program’s command for inserting objects.
In Microsoft Office programs, choose Insert > Object. In the Object dialog box, 
click the Create From File tab. Specify the name of the drawing file you want to 
link. Select the Link To File check box, and then click OK.
The drawing appears in the document, with a link to the original IntelliCAD file.

Dragging IntelliCAD drawings into other programs
If the other program in which you want to include IntelliCAD drawings is compatible 
with ActiveX, an alternative to pasting drawings with menu commands is to drag 
drawing file icons from Windows Explorer into the other document. Dragging and 
dropping drawings does not use the Clipboard, so data on the Clipboard is not 
affected. 
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When you drag an IntelliCAD drawing file from Windows Explorer, you link or 
embed the entire drawing in the other document. When you drag the file, the cursor 
changes in response to the action you take.

TIP Before you drag a drawing, position the Windows Explorer window and the other 
program’s window so you can see the file icon and the document in which you want 
to drop it.

To drag and embed drawings into another document
• Select the icon for the drawing file, and then drag the drawing into the document.

Exporting drawings
You can save or export IntelliCAD drawings in a number of different formats for use 
with other programs. When you save a drawing in a different format, the program 
saves all the entities in the drawing to the new file. When you export a drawing, you 
choose which entities are included in the new file. 

You can export a drawing in any of the following formats:

• As an AutoCAD Drawing file (*.dwg). You choose the specific AutoCAD version 
(R2000, R14, R13, R11/12, R10, R9, R2.6, or R2.5).

• As an ASCII AutoCAD Drawing Exchange Format file (*.dxf). You choose the 
specific AutoCAD version (2000, R14, R13, R11/12, R10, R9, R2.6, or R2.5).

• As a binary AutoCAD Drawing Exchange Format file (*.dxf). You choose the 
specific AutoCAD version (2000, R14, R13, R11/12, R10, R9, R2.6, or R2.5).   

• As a bitmap (*.bmp).
• As an Enhanced Windows Metafile (*.emf).

• As a Windows Metafile (*.wmf).

How the cursor changes
Cursor appearance Action

Drag to embed the selected file to the other 
document. 

Cannot drop drawings in that document.
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To export a drawing to a file 
1 Do one of the following:

• Choose File > Export To File.

• Type export and then press Enter.

2 In the Export Drawing As File dialog box, under Save As Type, choose the file 
format.

3 Specify the name of the file you want to create.
4 Click Save.

Sending drawings through e-mail
You can send an IntelliCAD drawing to another user via e-mail. IntelliCAD is com-
patible with e-mail programs that support the Messaging Application Program Inter-
face (MAPI) protocol.

To include a drawing file in an e-mail message
1 While the drawing file is open, choose File > Send Mail.

If your mail program is not already running, it starts; a new e-mail message con-
taining the IntelliCAD icon and file name appears.

2 Address the e-mail, type a message, and send the e-mail message as you would 
any other message.

To view an IntelliCAD file sent by e-mail 
• Open the e-mail message, and then double-click the IntelliCAD icon.

NOTE IntelliCAD software must be installed on the computer used to open drawings 
in e-mail.

Using IntelliCAD with the Internet

You can use IntelliCAD to access the Internet and exchange drawing information and 
perform other tasks, including:

• Add hyperlinks to a drawing
• Publish drawings to the Internet

• Access the Internet during a drawing session

NOTE You will need Microsoft Internet Explorer Version 5.0 or later and access to 
the Internet to fully use these features.
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Add hyperlinks to a drawing 
In your IntelliCAD drawings, you can include hyperlinks, which are pointers that take 
you to another location--such as a Web address or a file on a particular computer. 
You can attach a hyperlink to any entity in your drawing. Then, when you select that 
entity, you can open the link and jump to the specific Web address or file location. 
You can create absolute hyperlinks, which store the full path to a file, or relative 
hyperlinks, which store a partial path relative to a base folder or URL.

NOTE To open files associated with hyperlinks, the PICKFIRST system variable must 
be set to On. 

To create a hyperlink
1 Type hyperlink and then press Enter.
2 Select an entity or entities that you would like to associate with a hyperlink; then 

press Enter to display the Edit Hyperlink dialog box.
3 Do one of the following: 

• Click Browse to specify a file.

• In the Link to File or URL box, type a Web address.

4 If you wish to use a common path for all hyperlinks in the drawing, check the Use 
relative path for hyperlinks box. Relative paths provide flexibility if you move 
files to a different folder, since you can change multiple hyperlink paths at once, 
rather than change them all individually. 

5 Click OK to close the Edit Hyperlink dialog box.
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NOTE The HYPERLINKBASE system variable specifies the path used for all relative 
hyperlinks in the drawing. If no value is specified, the drawing path is used for all rel-
ative hyperlinks.

To remove a hyperlink
1 Type hyperlink and then press Enter.
2 Select an entity or entities with a hyperlink; then press Enter to display the Edit 

Hyperlink dialog box.
3 Click Remove Link. 
4 Click OK to close the Edit Hyperlink dialog box.

To access a hyperlink
1 Select an entity with a hyperlink.
2 Right-click anywhere in the drawing area.
3 In the pop-up menu, choose Open Link.

Publishing drawings to the Internet
You can publish IntelliCAD drawing to an Internet-compatible format using the 
VMLOUT command, which generates a file that can be viewed in a Web browser. 
The file will be created in Vector Markup Language (VML) format with an extension 
of HTM.

To publish a drawing to the Internet
1 Type vmlout and then press Enter.
2 Specify a file name.

Accessing the IntelliCAD Web site during a drawing session
In addition to using hyperlinks to access the Internet, you can access the IntelliCAD 
Web site at any time using the Onweb command. At the Web site, you can obtain 
information about the IntelliCAD Technology Consortium as well as product infor-
mation and news. 

To access the IntelliCAD Web site
1 Do one of the following: 

• Choose Help > IntelliCAD on the Web.

• Type onweb and then press Enter.

2 Navigate to the section of your choice on the IntelliCAD Web site.
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Customizing IntelliCAD

You can customize IntelliCAD® in a number of ways. For example, you can change 
the appearance of many aspects of the program and modify the existing menus and 
toolbars or create new ones. This chapter explains how to: 

• Set the program’s preferences.
• Customize menus and toolbars.
• Customize the keyboard.
• Create aliases for frequently used commands.
• Create and use scripts.
• Use add-on programs with IntelliCAD.

• Use a digitizer tablet for menu selection and calibrated drawing.

Topics in this chapter
Setting and changing options............................................................................370
Customizing menus...........................................................................................379
Customizing toolbars.........................................................................................387
Customizing the keyboard.................................................................................397
Creating aliases ................................................................................................400
Creating and replaying scripts...........................................................................403
Setting and changing options............................................................................370
Programming IntelliCAD....................................................................................405
Using a digitizer tablet .......................................................................................409
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Setting and changing options

You can change many of the options that control the program’s behavior and appear-
ance, such as setting the experience level, specifying file paths and default files, and 
configuring display features.

Changing the options on the General tab
In the Options dialog box, the General tab contains settings for experience level, save 
options, and VBA security.

Setting the experience level
You can control which menus and tools are available by setting the experience level. 
During installation, the default setting is for the Intermediate experience level. You 
can choose from the following experience levels: 

• Beginner Menus and toolbars display only basic commands. 
• Intermediate Menus and toolbars display most two-dimensional entity creation 

and modification commands.

• Advanced Menus and toolbars display all available commands. 

Saving your drawings automatically
To avoid losing data in the event of a power failure or other system error, save your 
drawing files often. You can configure the program to periodically save your draw-
ings automatically. The Minutes setting determines the interval between automatic 
saves. The program restarts this interval timer whenever you save the drawing file.        

When AutoSave is enabled, the program creates a copy of your drawing. The file is 
saved to the same directory as the drawing file, with the file extension specified in the 
AutoSave Drawing Extension box (by default, .SV$). 

Disabling VBA CommonProject macros
Each time you start IntelliCAD, macros are automatically loaded for the Visual Basic 
Application (VBA) CommonProject. If you do not plan to use VBA, disabling the 
macros may improve performance. In addition, disabling the macros can enhance 
security if you are running IntelliCAD at a low security level.
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To change the options on the General tab 
1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the General tab.
3 Under Experience level, select Beginner, Intermediate, or Advanced.
4 Under AutoSave, select the check box to enable the AutoSave feature, and select 

the frequency.
If you want to change the default extension assigned to your AutoSave files, type 
the new extension in AutoSave Drawing Extension.

5 If you do not want the CommonProject macros to be loaded when you start Intelli-
CAD, under VBA Security, click the check box for Disable VBA CommonProject 
Macros On Startup.

6 When you have finished, click OK.   
                             

A Click to enable AutoSave feature. 
B Click to disable VBA CommonProject macros on 

startup.
C Type the file extension for AutoSaved files.

D Enter frequency of AutoSave in minutes.
E Select the experience level.
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Changing the options on the Paths/Files tab 
You can specify locations for various file types such as those used for drawings, 
fonts, and menus in the Options dialog box on the Paths/Files tab. You can even 
specify multiple paths for the same file type. In addition, you can change the names 
of the default system files that are used for functions such as font mapping and error 
logging.

Specifying the user paths 
You can enter paths to your IntelliCAD directories by typing them into a Location 
field in the Options dialog box. This feature includes directories for drawings, fonts, 
help, external references, menus, and hatch patterns. If you don’t know the location, 
use the Browse button. 

You can enter multiple paths for each item. If, for example, the Drawings item has 
more than one directory associated with it, you can specify multiple paths by separat-
ing them with a semicolon. IntelliCAD searches the directories in the order in which 
they are listed.

To set up a user path
1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Paths/Files tab.
3 Under Location, click the item in the User Paths list whose path you want to spec-

ify, and type the path.
If you do not know the path or directory name, click Browse, and then browse to 
the location of the directory you want.

4 When you have finished, click OK.

Changing the default system files 
You can change the default system files, including the log file, default template, alter-
nate font, and font mapping file.
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To change a default system file
1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Paths/Files tab.
3 In the lower half of the dialog box, under File, click the file name for the default 

system file you want to change, and type in a new file name. 
If you don’t know the file name, click Browse, and then browse to the location of 
the file you want.

4 Type a new name.
5 When you have finished, click OK.

The following figure shows the Options dialog box with the User Paths and Sys-
tem Files sections identified.    

A Click to select new default file.
B Select the default file to change.

C Click to select new default folder.
D Directory path specified by user.
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Changing the options on the Display tab
In the Options dialog box, the Display tab contains settings for the number of 
command lines to track, screen color, display of prompt boxes, and automatic menu 
loading.

Setting the command lines to track
IntelliCAD tracks the commands and command prompts you used most recently. You 
can control the number of lines that the program keeps in memory as you work. The 
default value is 256. You can display the commands in the Prompt History window. 
To display the Prompt History window, press F2. To close the window, press F2 
again. 

Setting the graphics screen color
By default, drawings are displayed on a black background. You can change this color 
and specify the background screen color that you want. 

Displaying prompt boxes
When a command offers several options, a prompt box is displayed with those 
options. If you prefer to select options by typing, you can turn off the prompt boxes 
by clearing the Display Prompt Boxes check box. 

Automatic Menu Loading
The first time you start IntelliCAD, a default menu is loaded, and the Automatic 
Menu Loading check box in the Options dialog box is checked. The Automatic Menu 
Loading feature allows you to load drawings with associated menus without 
overwriting the default menu. You can turn off the Automatic Menu Loading option.
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To change the options on the Display tab
1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Display tab.
3 For Command Lines To Track, type the maximum number you want to track, or 

use the up and down arrows to scroll to the number.
4 For Graphics Screen Color, click Color, then select the color you want from the 

color palette that displays, and then click OK.
5 To disable the display of prompt boxes, clear the Display Prompt Boxes check 

box.
6 To disable automatic menu loading, clear the Automatic Menu Loading check 

box.
7 When you have finished, click OK.
   

A Click to clear prompt box display.
B Click to clear automatic menu loading.

C Click to select screen color.
D Type or select the number of command lines to 

track.
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Changing the options on the Crosshairs tab
In the Options dialog box, on the Crosshairs tab, you can control how the crosshairs 
display. To help you differentiate the x-, y-, and z-axes, a different color is assigned 
to each. You can change the default axes colors to any color you want. In addition, 
you can specify the size of the crosshairs display, and you can elect to use crosshairs 
as the default pointer shape.   

To change the options on the Crosshairs tab
1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Crosshairs tab.
3 Under Axis Color, for each axis, click Color and select a color from the palette, 

and then click OK.
4 If you want the pointer to always display as the crosshairs (instead of the small 

box), click the Pointer Defaults To Crosshairs check box.
5 Under Cursor Size, enter a number for the percentage of the screen to be used by 

the crosshairs cursor, or use the up and down arrows to scroll to the number.
6 When you have finished, click OK. 

The Options dialog box with the Crosshairs tab displayed.
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Changing the options on the Snapping tab
In the Options dialog box, on the Snapping tab, you can control the Fly-over snapping 
feature. Fly-over snapping is a visual aid to help you see and use entity snaps 
more efficiently. 

To change the options on the Snapping tab
1 Do one of the following: 

• Choose Tools > Options. 

• Type config and then press Enter.

• Choose Settings > Entity Snap > Entity Snap Settings and click Fly-over.

2 Click the Snapping tab.
3 Select the options you want.
4 When you have finished, click OK. 

The Options dialog box with the Snapping tab displayed.
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 Using shape files

Shapes are objects that you define for use as drawing symbols and text fonts. You can 
specify the scale and rotation to use for each shape as you add it. 

To use shape files, you first use the Load command to load the compiled shape file 
that defines the shape. Then you use the Shape command to insert shapes from the 
file into your drawing. 

To load a shape file
1 Type load and then press Enter.
2 In the Load Shape File dialog box, select a shape file.
3 Click OK to close the Load Shape File dialog box.

To use a shape file
1 Type shape and then press Enter.
2 Type a shape name and press Enter.
3 Specify an insertion point.
4 Specify a height.
5 Specify a rotation angle.
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 Customizing menus

You can customize a current menu and save your changes as an IntelliCAD menu 
file. You can also load both existing IntelliCAD (*.icm) and AutoCAD (*.mnu, 
*.mns) menu files. You customize menus using the Customize dialog box.     

To display the Customize dialog box
1 Do one of the following: 

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.
  

A To make a menu item current, choose it from the 
list.

B Contains the command string assigned to the 
current menu item.

C Contains the text displayed in the status bar for 
the current menu item.

D Click to import an existing menu file from another 
source.

E Click to save the current menu to a different 
location.

F Click to reset the current menu, rejecting any 
changes you have made.         

G Click to display the Options dialog box for further 
customization options.

H Click to add the selected command to the current 
menu item.

I Click to rename the current menu item.
J Click to insert a Menu Item, a Menu Sub-Item, a 

Spacer, or Context Menu Item, or a Context 
Menu Sub-Item.

G

H

I

JA

B
C

D E F
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Understanding menu compatibility
MNU files are menu files created by all AutoCAD releases, and MNS files are 
included in AutoCAD Releases 13, 14, and 2000. IntelliCAD reads both file formats, 
even when menu macros include AutoLISP code. This feature allows you to continue 
using your existing AutoCAD menus. 
 

To see how IntelliCAD reads AutoCAD menu source files
1 Type menu and then press Enter. 
2 Under Files Of Type, select AutoCAD Menu File (mnu).
3 In the Open Menu dialog box, go to the AutoCAD Support folder and select the 

Acad.mnu file (or Acad.mns for Releases 13, 14, and 2000).
4 To load the AutoCAD menu file into IntelliCAD, click Open.

The IntelliCAD menu bar now looks identical to the AutoCAD menu bar.
5 To see how it works, choose a few commands from the menu bar, such as File > 

Open or Draw > Line.
6 To restore IntelliCAD to its default menu, choose Tools > Customize, and then 

click the Menus tab and click Reset. 
7 To restore the IntelliCAD default toolbars, choose Tools > Customize, and then 

click the Toolbars tab and click Reset. 

IntelliCAD support of specific sections in AutoCAD MNU and MNS files
Menu section Definition IntelliCAD support
***POP0 Cursor menu Supported

***POPn Pull-down menus Supported

***AUXn Auxiliary menus Not supported

***BUTTONn Button menus Not supported

***ICON Icon menus Not supported

***SCREEN Screen menus Not supported

***TABLETn Tablet menus Not supported
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Creating new menus and commands
You can create a new menu by inserting a menu item at the top level of the Menu 
Tree. Then you can add commands to the new menu item. You can also add sub-
menus and modify existing menu names and commands by adding, deleting, and 
rearranging them. 

NOTE A green bullet in front of a menu item or command indicates that the menu item 
or command is available for you to use at the experience level you have set. A red 
bullet in front of a menu item or command indicates that the menu item or command 
is not available for you to use at the experience level you have set. To change your 
experience level, choose Tools > Options.

To create a new menu 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.
3 In the Menu Tree, select the menu name above which you want to add a new 

menu.
4 Choose Insert > Menu Item.
5 Type a name for the new pull-down menu, and then press Enter.
6 Click Close.

The IntelliCAD default menu bar.

The IntelliCAD menu bar customized to reflect the AutoCAD menu bar.
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To see the new menu, you must perform the following steps for adding a command to 
the menu.

To add a command to a menu 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.
3 In the Menu Tree, select the menu to which you want to add the new command.
4 Choose Insert > Menu Sub-Item.
5 Type a name for the new command, and then press Enter.
6 Assign a command string to the command you added by doing one of the 

following:
• In the Available Commands list, choose the command, and then click Add 

Command.

• In the Command box, type the command string, and then click Add Command.

7 In the Help String box, type the text to be displayed in the status bar when the cur-
sor is positioned over the new command.

8 To add another command, repeat steps 3 through 7.
9 When you have finished, click Close.

TIP When you type a name for a new command, you can specify an access key by 
including an ampersand (&) immediately preceding the letter you want to use as the 
access key. Be sure not to assign the same access key to more than one menu or com-
mand within a menu. For example, if you add a command named Quick Line to the 
Insert menu, including an ampersand immediately preceding the letter Q causes that 
letter to appear underlined in the menu. You can then select that command by dis-
playing the menu and pressing the Q key. 

To rename a menu item 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.
3 In the Menu Tree, select the menu item you want to rename.
4 Click Rename.
5 Type a new name for the menu item by typing over the highlighted name, and then 

press Enter.
6 Click Close.
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To delete a menu item 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.
3 In the Menu Tree, select the menu item you want to delete.
4 Click Delete.
5 In the Confirmation dialog box, click Yes to delete the menu item.
6 Click Close.

NOTE Deleting a menu item that has sub-items below it in the Menu Tree also deletes 
all those sub-items.

Setting the experience levels for menus
You can set the experience levels for menu items you create, and you can change the 
experience levels for existing commands.

To set the experience levels for a command 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.
3 In the Menu Tree, select the command.
4 Click Options.
5 In the Menu Customization Options dialog box, under Experience Level, select 

the experience levels that you want for the command.
6 Click OK.
7 Click Close.

NOTE Select all the experience levels above the lowest level you want to use. Com-
mands appear in the menu only at the experience levels you specify. If you select 
Intermediate without also selecting Advanced, the commands will appear only when 
you set the experience level to Intermediate.
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Saving menu files
IntelliCAD automatically saves any changes you make to the current menu. You can 
also create and save your custom menus. The program automatically saves all menu 
files with the *.icm file extension. 

To save the current menu to a file
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.
3 Click Export.
4 In the Select Menu File dialog box, specify the directory and file name you want 

to use to save the menu file.
5 Click Save.
6 Click Close.

NOTE Saving a menu does not save any toolbars that you created or modified.

Loading menu files
You can replace the current menu file with other custom menus. The program loads 
both AutoCAD (*.mnu, *.mns) and IntelliCAD (*.icm) menu files. 

To load a menu file
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.
3 Click Import.
4 From the Files Of Type list, choose either *.icm, *.mnu, or *.mns.
5 Select the menu to load.
6 Click Open.
7 Click Close.

NOTE Loading a new menu replaces only the menu. It does not replace any custom 
toolbars you may have defined.
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Creating custom shortcut menus
With IntelliCAD, you can create a custom shortcut menu for commands you want to 
use frequently. You access the shortcut menu by holding down the Shift key and 
clicking the right mouse button or by clicking the mouse wheel (if you have one). 
Using any ASCII text editor, you construct the menu to conform to the Custom short-
cut menu syntax and definitions as shown here:

***MENUGROUP=group_name 
***POP0 
**menu_name 
[menu_name] 
ID_item_name [item_string]command

***HELPSTRINGS 
ID_item_name[help_string]

To create a custom shortcut menu 
The following example describes how to build a custom menu that includes line, 
hatch, dtext, circle, and erase commands.

1 Open any ASCII text editor.
2 Type the following characters exactly as shown here:

***MENUGROUP=example 
***POP0 
**IntelliCAD 
[IntelliCAD] 
ID_Line [Line]^C^C_line 
ID_Hatch [Hatch]^C^C_hatch 

Shortcut menu syntax and explanations

Item Explanation
group_name Menu group name.

menu_name Shortcut menu name.

item_name Menu item name.

item_string Menu item string (typically, the command name). The menu item string 
appears in the shortcut menu. To specify an access key for a command, insert 
an ampersand (&) immediately before the letter you want to use as the access 
key. Do not assign the same access key to more than one command.

command Command string. Begin the command string with "^C^C" (e.g., ̂ C^C_LINE) 
unless the command is transparent.

help_string Help string. The text in the help string appears in the status bar when you 
place the cursor over the menu item.
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ID_Dtext [Dtext]^C^C_dtext 
ID_0 [Circle Rad]^C^C_circle 
ID_Erase [erase]^C^C_erase

***HELPSTRINGS 
ID_LINE [Draws a line] 
ID_HATCH [Fills an enclosed area with a nonassociative hatch pattern] 
ID_DTEXT [Displays text on screen as it is entered] 
ID_CIRCLE [Creates a circle] 
ID_ERASE [Removes objects from a drawing]

3 Save the file as example.mnu to the IntelliCAD2001 folder.

To use the custom shortcut menu
1 Open IntelliCAD.
2 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

3 Click the Menus tab.
4 Click Import.
5 Select the custom shortcut menu file.
6 Select the Append To Current Menu check box, and then click Open. 

If you don’t select this box, the custom shortcut menu deletes all current menus.
7 Click Close.
8 Select an entity in your drawing, and then hold down Shift and click the right 

mouse button.
9 Click the shortcut command that you want.

To restore the shortcut menu defaults
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

2 Click Reset.
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Customizing toolbars

IntelliCAD provides toolbars so that you can access frequently used commands. You 
can customize these toolbars by adding or removing tools or by rearranging the orga-
nization of tools. You can also create custom toolbars. Toolbars are saved as integral 
parts of the program. Although you cannot export custom toolbars for use by others, 
you can load toolbars created as part of AutoCAD menus. You customize toolbars 
using the Customize dialog box and clicking the Toolbars tab.  

To display the Customize dialog box
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter. 

2 Click the Toolbars tab.
3 Customize the toolbars using the procedures that follow the illustration here. 

A  The Categories list shows available toolbar 
categories.

B Contains the string displayed as a ToolTip for the 
current tool.

C Contains the text displayed in the status bar for 
the current tool.

D Contains the command string assigned to the 
current tool.

E  Displays the available tools for the selected 
category.

A

B
C
D

E
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Creating a new toolbar
You can create a new toolbar by dragging a tool from the Customize dialog box and 
dropping it anywhere except on another toolbar. IntelliCAD immediately creates a 
new toolbar and assigns it a default name. Then you can add tools to the new toolbar. 
You can also add, delete, or modify tools on any existing toolbar. 

When you create a toolbar using tools from the Buttons area of the Customize dialog 
box, the ToolTip, Help String, and Command fields are filled in automatically with 
default information. You can edit this information for each tool. 

To create a new toolbar
1 Do one of the following: 

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.
3 In the Categories list, choose a category to display its associated tools.
4 Click and drag a tool outside the Customize dialog box and onto an open area of 

the screen.
5 Modify the ToolTip, Help String, and Command fields as needed.
6 Click Close.

To add a tool to a toolbar 
1 Make sure the toolbar you want to modify is visible.
2 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

3 Click the Toolbars tab.
4 In the Categories list, choose a category to display its associated tools.
5 Click and drag a tool onto the toolbar.
6 Modify the ToolTip, Help String, and Command fields as needed.
7 To add another tool, repeat steps 3 through 5.
8 Click Close.
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To delete a tool from a toolbar
Make sure the toolbar you want to modify is visible.
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.
3 Drag the tool you want to delete off of the toolbar.
4 Click Close.

To add space between tools on a toolbar 
Make sure the toolbar you want to modify is visible.
1 Do one of the following: 

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.
3 On the toolbar, drag the tool away from the tool beside it.

To avoid accidentally deleting a tool, do not drag a tool more than halfway past 
the edge of the toolbar.

4 Click Close.

Naming toolbars
When you create a toolbar, the program assigns it an arbitrary name, such as 
ToolBar1, ToolBar2, and so on. The toolbar name is displayed on the title bar when 
the toolbar is floating. You can rename a toolbar at any time.

In the Select Toolbars dialog box, you can rename toolbars, turn the display of tool-
bars on and off, choose to display large or small tools, choose to display toolbar tools 
in color or black and white, and control the display of ToolTips. 
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To rename a toolbar 
1 Do one of the following:

• Choose View > Toolbars.

• Type tbconfig and then press Enter.

2 From the Toolbars list, choose the toolbar that you want to rename. 
3 In the Toolbar Name field, replace the current name with the new toolbar name.
4 Click OK.
  

Creating flyouts
A flyout displays a set of additional tools under a single toolbar tool. IntelliCAD uses 
flyouts to organize related tools and to conserve space on toolbars. A flyout is indi-
cated by a small triangle in the lower right corner of a tool. When you click a flyout 
tool, the other tools on the flyout extend from the original tool so you can select one 
of them. The flyout tool you select then becomes the default tool on the toolbar. You 
can add your own flyouts to toolbars. 

A Select to display a toolbar. 
B Choose the toolbar that you want to rename.
C Type a new name.
D Select to display large tools; clear to display 

small tools. 

E Select to display color tools; clear to display 
black and white tools.

F Select to display ToolTips; clear to not display 
ToolTips.

G Click to customize the toolbars.

A

B

C
D
E
F

G
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To add a flyout to a toolbar
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.
3 Select the Insert As Flyout check box.
4 In the Categories list, choose a toolbar name to display its associated tools in the 

Buttons area.
5 From the Buttons area, click and drag a tool onto a toolbar outside the Customize 

dialog box.
6 Modify the ToolTip, Help String, and Command fields as needed.
7 To add another flyout tool, repeat steps 4 through 6.
8 Click Close. 

Setting the experience levels for tools
You can set the experience levels for toolbar tools you create, and you can change the 
experience levels for existing tools.

To set the experience levels for a tool 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.
3 Go outside the Customize dialog box to a toolbar, and click a tool to select it.
4 Go back to the Customize dialog box, and click Options.
5 Under User Level, select the experience levels you want for that tool.
6 Click OK.
7 Click Close.

NOTE Select all the experience levels above the lowest level you want to use. Tools 
appear in toolbars only at the experience levels you specify. If you select Intermediate 
without also selecting Advanced, the tool will appear only when you set the 
experience level to Intermediate.
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Creating custom toolbar tools
IntelliCAD provides tools for most of the available IntelliCAD commands. These 
tools appear on the Toolbars tab of the Customize dialog box. You can also create 
your own custom tools and incorporate them into your custom toolbars. To add a cus-
tom tool to a toolbar, you must first add one of the program’s standard tools and then 
replace it on the toolbar with your custom tool. 

You create custom tools as bitmap (*.bmp) files using any paint or illustration pro-
gram capable of saving to a bitmap. Because you can configure toolbars to display 
either large or small tools and to display tools either in color or monochrome, create 
four different versions of each custom tool. Create custom tools using the following 
dimensions: 

• Small tools: 16 x 15 pixels. 

• Large tools: 24 x 22 pixels. 

NOTE If you attempt to use bitmaps that do not match these dimensions, the program 
will stretch or shrink (rather than crop) the bitmaps to fit the specified size. The 
resulting tools may not appear as originally intended.

To add a custom tool to a toolbar
Make sure the toolbar you want to modify is visible.
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.
3 Go outside the Customize dialog box to a toolbar, and click a tool in the toolbar to 

select it.
4 Go back to the Customize dialog box, and click Options.
5 In the Toolbar Customization Options dialog box, under Button Bitmaps, click the 

browse tool (indicated by an ellipsis) adjacent to the Small, Color Button list to 
display the Select Bitmap dialog box.

6 Select the bitmap you want to use for the small color tool.
7 Click Open.
8 Repeat steps 5 through 7 for the Large Color Button, Small Black and White But-

ton, and Large Black and White Button versions of your custom tool.
9 When you have finished, click OK.

10 Click Close.
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Importing toolbars
Toolbars are saved as integral parts of IntelliCAD. In IntelliCAD, you can load tool-
bars created as part of AutoCAD (*.mnu, *.mns) menus. Importing an AutoCAD 
menu file from the Toolbars tab of the Customize dialog box loads only the toolbar 
section of the menu file. 

To import a menu file
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.
3 Click Import.
4 Select the menu you want to load.
5 Click Open.
6 Click Close.

NOTE Importing an AutoCAD menu file from the Toolbars tab of the Customize dia-
log box replaces any custom toolbars you may have defined. Importing the menu file 
in this way, however, does not affect the current menu.

The Toolbar Customization Options dialog box.
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Creating toolbars that you can share as files
With IntelliCAD, you can manually create toolbars that you can share as files with 
other IntelliCAD users. You create the toolbar files using any ASCII text editor and 
the toolbar syntax and definitions shown here:

***MENUGROUP=group_name 
 
***TOOLBARS 
**toolbar_name 
ID_toolbar_name [_Toolbar ("toolbar_name", orient, visible, xval, yval, 

rows)] 
ID_button_name [_Button ("button_name", id_small, id_large)]command 
 
***HELPSTRINGS 
ID_button_name [help_string]

Toolbar syntax and explanations

Item Explanation
group_name Menu group name.

toolbar_name Toolbar name.

orient Orientation. Select Floating, Top, Bottom, Left, and Right (not case 
sensitive).

visible Visibility. Select Show or Hide (not case sensitive).

xval x coordinate, designated in pixels from left edge of screen. Suggested 
value: 200.

yval y coordinate, designated in pixels from top edge of screen. Suggested 
value: 200.

rows Number of rows

button_name Tool name. Appears as a ToolTip when user places cursor over button.

id_small Name of small (16 x 15 pixels) icon bitmap (BMP) file. This file must be 
located in the IntelliCAD2001 folder.

id_large Name of large (24 x 22 pixels) icon bitmap (BMP) file. This file must be 
located in the IntelliCAD2001 folder.

command Command string (Example: ^C^C_LINE).

help_string Help string. Appears in the status bar when cursor passes over the button.
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To create a toolbar that you can share
1 Open any ASCII text editor.
2 Type the following characters exactly as shown here:

***MENUGROUP=example 
 
***TOOLBARS 
**NewDraw 
ID_ NewDraw [_Toolbar("NewDraw ", _Bottom, _Show, 200, 200, 1)] 
ID_Line_0 [_Button("Line", Iline.bmp, IL_line.bmp)]^C^C_line 
ID_Hatch [_Button("Hatch", Ihatch.bmp, IL_hatch.bmp)]^C^C_hatch 
ID_Dtext [_Button("Dtext", Idtext.bmp, IL_dtext.bmp)]^C^C_dtext 
ID__0 [_Button("Circle Rad", Icirad.bmp, IL_cirad.bmp)]^C^Ccircle; 
ID_Erase [_Button("Erase", Ierase.bmp, IL_erase.bmp)]^C^Cerase; 
 
***HELPSTRINGS 
ID_Line_0 [Creates straight line segments] 
ID_Hatch [Fills an enclosed area with a nonassociative hatch pattern] 
ID_Dtext [Displays text on screen as it is entered] 
ID__0 [Allows user to draw a circle with a radius value] 
ID_Erase [Removes objects from a drawing]

3 Save the file to the IntelliCAD folder with a *.mnu extension.

To copy an existing toolbar
Make sure the toolbar you want to copy is visible.
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

2 Click the Toolbars tab.
3 Go outside the Customize dialog box and select a tool on the existing toolbar that 

you want to copy. 
4 Copy the information from the ToolTip, Help String, and Command boxes and 

paste it into the corresponding lines in the text file. 
5 Save the file to the IntelliCAD folder with a *.mnu extension.
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To open the toolbar file on another computer
1 Copy the toolbar (MNU) file and all related custom bitmap (*.bmp) files to the 

IntelliCAD folder on the other computer.
2 Open IntelliCAD.
3 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

4 Click the Toolbars tab.
5 Click Import.
6 Select the new toolbar file.
7 Select the Append To Current Menu check box, and then click Open.

If you don’t select this box, the custom shortcut menu deletes all current menus. 
8 Click Close. 

To restore the toolbar defaults
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

2 Click Reset.
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Customizing the keyboard

IntelliCAD provides keyboard shortcuts so you can access frequently used com-
mands. You can customize these shortcuts and add new shortcuts using the Custom-
ize dialog box. 

To customize the keyboard
1 Do one of the following: 

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.
3 To define a new shortcut key, enter the shortcut in the Press New Shortcut Key 

box.
4 To define a new command string, enter the command string in the Command box.
5 To import an existing keyboard shortcut file, click Import.
6 To save a keyboard shortcut to a file, click Export.
7 To add a command selected in the Available Commands pane to the shortcuts, 

click Add Command.
8 To insert a new keyboard shortcut, click New.
 

A Shows shortcuts already defined.
B Displays the shortcut key combination when 

adding a new shortcut.

C Contains the command string assigned to the 
shortcut.

A

B

C
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Creating a keyboard shortcut
You can assign macros to special keys and certain combinations of keys to create a 
keyboard shortcut. A macro consists of one or more commands that are displayed on 
the status bar as follows: 

• A single command, such as QSAVE.

• A command with options, such as ARC;\A;\\.

• More than one command, such as ^C^C^CZOOM;E;QSAVE;QPRINT.

Keyboard shortcuts are more powerful than aliases. An alias lets you abbreviate a sin-
gle command name; a keyboard shortcut contains one or more macros. To activate a 
macro, you press the shortcut key; you do not need to press Enter as you do with an 
alias. A shortcut consists of the following keys:

• The function and the cursor control keys, as well as alphanumeric keys pressed in 
combination with the Ctrl, Alt, and Shift keys. The Shift key must be used in con-
junction with the Ctrl, Alt, and/or function keys. 

• Alphanumeric keys are those labeled A through Z and 1 though 0. 
• The cursor keys are the up, down, left, and right arrows and the Page Up, Page 

Down, Home, End, Insert, and Delete keys. 

• The function keys are those labeled F1 through F12.

To create a keyboard shortcut 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.
3 Click New.
4 In the Press New Shortcut Key field, press Alt+A.

The program adds Alt+A to its list of Defined Keys.
5 In the Available Commands list, select Arc Center-Start-Angle.
6 Click Add Command.

The program adds the command to the Command field and enters the complete 
syntax for you:
^C^C^_CARC;C;\ \A; 

7 To save your changes and close the dialog box, click Close. 
8 To activate the Arc command with the center, start, and angle options, press 

Alt+A.
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To redefine an existing keyboard shortcut
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.
3 In the Defined Keys list, select the shortcut you want to change.
4 In the Command field, change the command string assigned to the keyboard short-

cut by doing one of the following:
• Use the text cursor to delete the current command string, choose a new 

command in the Available Commands list, and then click Add Command.

• Edit the command string in the Command field.

5 Click Close.

To delete an existing keyboard shortcut 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.
3 In the Defined Keys list, select the shortcut you want to delete.
4 Click Delete.
5 Click Close.

Saving keyboard shortcut files
IntelliCAD automatically saves any changes you make to the current keyboard short-
cuts. You can also create and save your own keyboard shortcut files. The program 
saves keyboard shortcut files with the *.ick file extension. 

To save the current keyboard shortcuts to a file
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.
3 Click Export.
4 Specify the directory and file name you want to use to save the keyboard shortcut 

file.
5 Click Save.
6 Click Close.
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Loading keyboard shortcut files
You can replace the current keyboard shortcut file with other custom keyboard short-
cut files.

To load a keyboard shortcut file
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.
3 Click Import.
4 Select the file to load.
5 Click Open.
6 Click Close.

Creating aliases

IntelliCAD provides aliases for many commands. You can use aliases to issue fre-
quently used commands by entering one or two letters rather than the entire command 
name. 

The program also uses aliases to maintain command-name compatibility with 
AutoCAD. You can use the same aliases and keyboard shortcuts used by AutoCAD. 
In addition, IntelliCAD has enhanced several AutoCAD commands. For example, 
IntelliCAD added two useful options to the rectangle command: you can draw a 
rectangle as a square, and you can rotate a rectangle at an angle.

You can customize aliases, and you can add new aliases. You customize aliases using 
the Customize dialog box.

To display the Customize dialog box
1 Do one of the following: 

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.
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Creating, redefining, and deleting aliases
To create a new command alias, you first define the alias and then assign it one of the 
available IntelliCAD commands. 

To create a new alias 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.
3 Click New.
4 In the Alias field, type the new alias.
5 In the Available Commands list, select the command you want to assign to the 

alias.
6 Click Assign.
7 Click Close.

A Shows aliases already defined.
B Contains the current alias.

C Displays the command assigned to the current 
alias. 

B

A

C
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To redefine an existing alias 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.
3 In the Aliases list, select the alias you want to change.
4 In the Available Commands list, select the command you want to assign to the 

alias.
5 Click Assign.
6 Click Close.

To delete an existing alias 
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.
3 In the Aliases list, select the alias you want to delete.
4 Click Delete.
5 Click Close.

Saving alias files
IntelliCAD automatically saves any changes you make to the current aliases. You can 
also create and save your own alias files. The program saves alias files with the *.ica 
file extension. You can also save alias files for use with AutoCAD by saving the files 
with the *.pgp file extension. 

To save the current aliases to a file
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.
3 Click Export.
4 From the Save As Type list, choose either *.ica or *.pgp.
5 Specify the directory and file name you want to use to save the alias file.
6 Click Save.
7 Click Close.
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Loading alias files
You can replace the current alias file with other custom alias files. The program loads 
both AutoCAD (*.pgp) and IntelliCAD (*.ica) alias files.

To load an alias file
1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.
3 Click Import.
4 From the Files Of Type list, choose either *.ica or *.pgp.
5 Select the alias file to load.
6 Click Open.
7 Click Close.

Creating and replaying scripts

IntelliCAD can record anything you type on the keyboard and any points you select 
in a drawing. You can save all of these actions to a script file (with the *.scr exten-
sion) and then repeat them by replaying the script. You can use scripts for succes-
sively repeating commands, showing snapshots in a slide show, or batch plotting. 
You can also load and run script files created for use with AutoCAD. 

IntelliCAD supports most AutoCAD customization files, including menus, script 
files, and LISP routines. IntelliCAD uses compatible linetypes, hatch patterns, units 
translation, and command aliases, but you can also substitute your own files for these. 
This feature allows you to continue to work with your favorite customized drafting 
environment. 

A script is a form of text file. A script file contains one line of text or other data for 
each action. For example, when you type a command and press Enter, it is recorded 
on a line in the script file. When you select a point in a drawing, the coordinate of that 
point is recorded on a line in the script file. You can also create script files outside 
IntelliCAD using a text editor (such as Microsoft Notepad or Microsoft WordPad) or 
a word-processing program (such as Microsoft Word) that saves the file in ASCII for-
mat. The file type must be .scr.

Script files can contain comments. Any line that begins with a semicolon is consid-
ered a comment. The program ignores these lines when replaying the script. The 
Undo feature reverses the last command performed by the script. 
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IntelliCAD improves on scripts, AutoLISP, and ADS by providing additional func-
tions. For scripts, IntelliCAD includes a Script Recorder that records both command 
line entries and screen picks you make with your mouse. 

After you activate the Script Recorder, every keyboard entry you make and any 
points you select in a drawing are recorded until you stop the Script Recorder. You 
can play back your script at any time.

CAUTION The Script Recorder does not record your use of toolbars, menus, or dialog 
boxes. Using these elements while recording a script causes unpredictable results.

To record a script 
1 Do one of the following:

• Choose Tools > Record Script.

• On the Tools toolbar, click the Record Script tool ( ).

• Type recscript and then press Enter.

2 Specify the name of the script file you want to create.
3 Click Save.
4 Type commands on the keyboard.

The Script Recorder records all keyboard entries and all points you select in the 
drawing, saving everything to the script file.

To stop recording 
Do one of the following: 
• Choose Tools > Stop Recording.
• On the Tools toolbar, click the Stop Recording tool ( ).

• Type stopscript and then press Enter.

To replay a script
1 Do one of the following:

• Choose Tools > Run Script.

• On the Tools toolbar, click the Run Script tool ( ).

• Type script and then press Enter.

2 In the Run Script dialog box, specify the name of the script file you want to run.
3 Click Open.

The program immediately runs the script, performing all the actions originally 
recorded.
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To append to a script 
1 Do one of the following:

• Choose Tools > Record Script.

• On the Tools toolbar, click the Record Script tool ( ).

• Type rescript and then press Enter.

2 In the Record Script dialog box, select the Append To Script check box.
3 Select the existing script file to append.
4 Click Save.
5 Click Yes to the prompt asking whether you want to replace the existing script.
6 Repeat the procedure to enter additional commands and steps.

TIP To invoke a script automatically when you load IntelliCAD, in Windows Explorer, 
double-click a script file. 

Programming IntelliCAD

Another way you can customize IntelliCAD is to add custom programs written in any 
of several programming languages that run within IntelliCAD, including the follow-
ing:

• LISP

• ADS

In IntelliCAD, you can run many programs originally created for use with AutoCAD. 
Specifically, you can use programs written entirely in AutoLISP with no modifica-
tion. In addition, you can run many ADS programs originally written for use with 
AutoCAD after first recompiling them using the IntelliCAD run-time libraries. Many 
AutoCAD third-party programs are compatible with IntelliCAD. 

NOTE Creating custom programs for use with IntelliCAD is beyond the scope of this 
manual. For information about programming for IntelliCAD, see the online Help for 
the IntelliCAD Developer’s Reference.Creating custom programs for use with Intelli-
CAD is beyond the scope of this manual. For information about programming for 
IntelliCAD, see the online Help for the IntelliCAD Developer’s Reference.
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Using LISP routines 
IntelliCAD supports the LISP programming language and is compatible with 
AutoLISP, the implementation of the LISP language in AutoCAD. This means that 
you can load and run any AutoLISP program written for use with AutoCAD.

To load a LISP routine 
Advanced experience level

1 Do one of the following:
• Choose Tools > Load LISP or SDS Application.

• Type appload and then press Enter.

• Drag and drop the LISP file into IntelliCAD.

2 In the Load Application Files dialog box, click Add File.
3 Select the LISP file that you want to load, and then click Open.
4 Click OK.The LISP file ICAD.LSP is automatically loaded whenever IntelliCAD 

is started. If you have files you want loaded every time you use IntelliCAD, add 
them to ICAD.LSP.       

 

TIP You can also load a LISP routine by typing (load “d:/path/routine.lsp”) in the 
command bar (you must include the parentheses and the quotation marks), where d:/
path is the drive and path where the LISP routine is located on your computer, and 
routine.lsp is the LISP routine file name. 

A Lists the names of LISP and SDS files already 
loaded. 

B Click to add a LISP or SDS file.
C Click to remove the highlighted file.
D Click to load the highlighted file.

E Click to unload the highlighted file.
F Select to save the current list to the icadload.dfs 

file when you click Load, Unload, or OK. 

A

B

C D

E

F
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To run a LISP routine 
Advanced experience level

1 Do one of the following:
• Choose Tools > Load LISP or SDS Application.

• Type appload and then press Enter.

2 In the Load Application Files dialog box, choose the routine you want to run 
(make sure that it is the only one selected), and then click Load.

Some LISP routines are created in such a way that you can run them by simply typing 
the name of the routine, or by typing a keyword, directly in the command bar. If noth-
ing happens when you attempt to run the LISP routine from within the Load Applica-
tion Files dialog box, turn on the display of the command bar or Prompt History 
window by choosing View > Command Bar or View > Prompt History Window, and 
look for an entry that is similar to the following: 

Loading D:\path\routine.lsp

C:KEYWORD

where D:\path\routine.lsp is the complete drive, path, and file name of the LISP rou-
tine. You may need to scroll back several lines in the command bar or Prompt History 
window to find the lines indicating where the LISP routine was loaded. You can run 
the LISP routine by typing the name of the routine or keyword appearing after the C 
drive designation. 

For example, if you loaded a LISP routine named drawbox.lsp and see the designa-
tion C:DRAWBOX in the command bar or Prompt History window, you can run the 
LISP routine by typing drawbox in the command bar.    

Using ADS applications 
To write AutoCAD applications in C or C++, Autodesk uses the ADS (AutoCAD 
Development System). This is an API (applications programming interface) that pro-
vides a library to access AutoCAD-specific functions and drawing data. 

The equivalent in IntelliCAD is called SDS™, the Solutions Development System™. 
SDS is a C/C++ language interface compatible with the ADS interface in AutoCAD. 
Like scripts and AutoLISP, you can run your existing ADS applications in 
IntelliCAD. Simply recompile the source code using the SDS libraries provided on 
the IntelliCAD CD-ROM, or, if you use an AutoCAD program written by a third-
party vendor, contact that vendor for the IntelliCAD version.

IntelliCAD provides the Sds.H file, which redefines ADS function names to their 
SDS equivalents. SDS supports the AutoCAD dialog control language (DCL), which 
is used by ADS to define the look of a dialog box. You can use all DCL files unmod-
ified within SDS. 
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Understanding ADS compatibility
The primary difference between ADS and SDS is that all SDS functions have an sds_ 
prefix, and ADS functions have a variety of prefixes, such as ads_, acad_, and acrx_. 
The exception is dialog-related SDS functions, which have a dlg_ prefix. IntelliCAD 
accepts either prefix. Other differences include the additional SDS functions listed in 
the following table. 

Some ADS functions are not supported in SDS, including: ads__msize, ads_ssgetx, 
ads_ssnamex, ads_tablet, ads_ssGetKwordCallbackPtr, 
ads_ssGetOtherCallbackPtr, and adsw_acadDocWnd. 

For more information
• Read the online documentation for SDS functions. 
• See the \IntelliCAD2001\Api\Sds folder, which contains the SDS include, header, 

and library files.

• See the \IntelliCAD2001\Api\Dcl folder, which contains the core DCL files.

Using DCL with IntelliCAD
IntelliCAD completely supports the AutoCAD DCL (dialog control language). DCL 
is used by AutoLISP functions to define the look of dialog boxes. You can use all 
DCL files unmodified within IntelliCAD.

   

SDS functions with no ADS equivalent
SDS function name Description
sds_grclear Clears all graphics from the drawing window; similar to the LISP 

(grclear) function.

sds_name_clear Clears the entity name or selection set.

sds_name_equal Verifies whether two entity names or selection sets are equal.

sds_name_nil Verifies whether the entity name or selection set has been 
cleared. 

sds_name_set Copies one entity name or selection set to another drawing.

sds_pmtssget Similar to the ads_ssget function, but allows you to display a 
prompt appropriate for the specific command, rather than the 
generic “Select object” prompt.

sds_point_set Copies a point from one variable to another.

sds_progresspercent Displays the percentage done in a progress bar.

sds_progressstart Starts the progress bar.

sds_progressstop Ends the progress bar.

sds_readaliasfile Loads the PGP file into IntelliCAD.

sds_sendmessage Sends a message to the IntelliCAD command line.

sds_swapscreen Flips the off-screen device context to the display.
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Using a digitizer tablet

IntelliCAD supports tablets compatible with the TabletWorks driver and has its own 
tablet overlay. For instructions on installing the tablet driver and using the buttons on 
your pointing device, refer to your hardware documentation. 

Three options are available with the Tablet command: 

• Configure Maps the tablet overlay to the tablet itself. Configure the tablet if you 
plan to select IntelliCAD tools from the tablet overlay.

• Calibrate Maps points on the tablet, in absolute coordinates, to points on a draw-
ing. Calibrate the tablet if you intend to digitize points. This process is convenient 
for tracing paper drawings.

• Tablet ON/OFF Turns tablet calibration (digitizer mode) on and off. Use this to 
switch between tool selection and digitizer input. To use the tablet for tool selec-
tion, tablet mode must be turned off. 

Configuring the tablet
Before you begin to configure the tablet, slip the tablet overlay underneath the tab-
let’s plastic cover, and align it in accordance with the directions for your tablet. If 
your tablet does not have a plastic cover, align the overlay holes with the pegs on 
your tablet. 

IntelliCAD provides a default configuration for tablets measuring 12" by 12". If you 
choose to accept the default, be sure to verify that the commands in the grid are acti-
vated correctly. If the default alignment does not work for your tablet, you’ll need to 
begin the configuration process again and align the tablet yourself.
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To configure the tablet for menu input
1 Do one of the following:

• Choose Settings > Tablet > Configure.

• Type tablet, choose Configure, and then press Enter.

2 In response to the prompt to align the tablet, do one of the following:
• If your tablet is 12" by 12", choose No to accept the default alignment and 

conclude the configuration process. 

• To align the tablet yourself, choose Yes, and then continue with step 3.

3 Click the tablet pointer on the upper left alignment point of the overlay ( ). 
4 Click the tablet pointer on the lower left alignment point of the overlay ( ).
5 Click the tablet pointer on the lower right alignment point of the overlay ( ).
6 Click the tablet pointer on the lower left alignment point of the Workspace area of 

the overlay ( ).
7 Click the tablet pointer on the upper right alignment of the Workspace area of the 

overlay ( ).

To turn tablet mode on or off
1 Do one of the following:

• Choose Settings > Tablet > Tablet On (or Tablet Off).

• Type tablet, choose On or Off, and then press Enter.

• Press the F4 key to toggle tablet mode on or off.

• On the status bar, double-click TABLET to turn tablet mode on or off. 

Click points in the order shown to configure your tablet for menu input.

5

1

2

4

3
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Calibrating the tablet
You must specify at least two points for tablet calibration. However, the more points 
you specify, the more accurate the transformation between the tablet and the screen 
points. Specifying additional points is particularly useful if you plan to trace a paper 
drawing that is not orthogonal, such as an aerial photograph. 

Understanding transformation types
Depending on the number of points specified, you have a choice of transformation 
types to use, along with the type recommended for IntelliCAD. 

Transformation refers to the calculation of the points on the screen that correspond to 
points you digitize on the tablet.

• Orthogonal Preserves all angles between lines, preserves all relative distances, 
and, in general, preserves shapes. If you specify only two points, an orthogonal 
transformation is automatically generated. The orthogonal transformation type 
yields the most precise mapping between the digitized points on the tablet and the 
corresponding points on the screen.

• Affine Preserves parallel lines, but not necessarily the angles between intersecting 
lines. If you specified three points, IntelliCAD can no longer represent this map-
ping as an exact orthogonal transformation. Therefore, you have a choice of an 
exact affine transformation or a “best fit” orthogonal transformation.

• Projective Does not preserve parallel lines or angles. If you specify exactly four 
points, you have a choice of an exact projective transformation or a “best fit” 
orthogonal or affine transformation. 

Recommended and “best fit” transformation types

Number of points specified
Transformation type 
recommended “Best fit” (approximate)

2 Orthogonal None

3 Affine Orthogonal

4 Projective Orthogonal, Affine

5-10 None Orthogonal, Affine
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Choose the recommended type unless you know it will not be appropriate for what 
you are digitizing. The most appropriate type is not always the one with the least 
error; for example, you might digitize three points and select the orthogonal transfor-
mation, even though the affine transformation would yield a closer representation of 
your calibration entries.    

Digitizing by selecting points (1, 2, 3, and 4) on the tablet. Corresponding screen coordinates:
1 Coordinate specification X0, Y0, Z0
2 Coordinate specification X0, Y5, Z0
3 Coordinate specification X5, Y5, Z0
4 Coordinate specification X5, Y0, Z0

Screen result of orthogonal transformation after 
tracing polyline on tablet.

Screen result of affine transformation  
after tracing polyline on tablet.

Screen result of projective transformation after 
tracing polyline on tablet.

2

1 4

3

3

4

2

1
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To calibrate your tablet for digitizing points
1 Do one of the following:

• Choose Settings > Tablet > Calibrate.

• Type tablet, choose Calibrate, and then press Enter.

2 Click a point on the tablet to define as the first calibration point.
3 Specify a point within the IntelliCAD drawing window to correspond to the point 

you digitized on the tablet, or enter coordinate values in the command bar. 
4 Click a point on the tablet to define as the second calibration point.

Specify a point within the IntelliCAD drawing window to correspond to the point 
you digitized on the tablet, or enter coordinate values in the command bar. To 
specify more than the two points required, click a point on the tablet to define as 
the third calibration point. You can enter up to 10 points.

5 Choose the transformation type, and then press Enter.

Customizing the tablet interface
You can customize the digitizer tablet interface by using the LISP commands 
integrated with IntelliCAD, even if you are not familiar with LISP. For instructions, 
see “Customizing the Tablet Interface” in the IntelliCAD online Help.
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Appendix

Understanding AutoCAD compatibility

IntelliCAD® was designed to interface with AutoCAD as seamlessly as possible. 
There are, however, some differences for which those accustomed to working in 
AutoCAD may need to adjust. This appendix provides information specifically for 
that audience. 

Topics in this chapter
Comparing system requirements...................................................................... 416
Using enhanced AutoCAD commands in IntelliCAD ........................................ 417
Using additional selection sets ......................................................................... 418
Using additional IntelliCAD commands............................................................. 419
Recognizing subtle command differences ........................................................ 422
Identifying unsupported commands.................................................................. 423
Identifying what does not display...................................................................... 424
Supporting AutoCAD customization ................................................................. 425
Understanding menu compatibility.................................................................... 426
Importing and exporting customization files...................................................... 427
Programming IntelliCAD ................................................................................... 428
IntelliCAD-AutoCAD list of terms ...................................................................... 430



416   A P P E N D I X
Comparing system requirements

Following are the recommended system requirements for IntelliCAD and the 
corresponding system requirements for AutoCAD, which are listed in the AutoCAD 
Installation Guide.      

Comparing system requirements
Specification IntelliCAD 2001 AutoCAD Release 2002
Operating system Microsoft Windows 95, Windows 98, Windows NT 

4.0, Windows ME, Windows 2000, or Windows XP.
Microsoft Windows 4.0, Windows 98, Windows 
ME, Windows 2000, or Windows XP.

CPU Intel Pentium (or faster) processor 233 Pentium or better

RAM 32 megabytes (MB) of RAM (minimum); 
64 MB or greater (recommended)

96 megabytes (MB) of RAM (minimum); 
128 MB or greater (recommended)

Hard disk space 60 MB of free hard disk space for a full installation, 
including sample files, electronic documentation, and 
online Help

200 MB (minimum);  
64 MB disk swap space (minimum);
60 MB free disk space in System folder

CD-ROM drive Required for installation, if installing from a CD. Required for installation only.
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Using enhanced AutoCAD commands in IntelliCAD

IntelliCAD enhances several AutoCAD commands by providing more options. For 
example, if you hold down the Shift key, IntelliCAD is placed temporarily in orthog-
onal mode, which you will find to be a useful feature for drawing at right angles. The 
following table lists examples of other commands with enhanced options.    

Enhanced IntelliCAD commands

Command
Enhanced  
option name Explanation

circle Arc Converts an arc to a circle.

donut 2point Determines the outside diameter of a donut by 
two pick points.

donut 3point Determines the outside diameter of a donut by 
three pick points.

donut RadTanTan Determines the outside diameter of a donut by 
tangent points.

line Angle Types an angle, followed by a length.

line Length Types a length, followed by an angle.

msnapshot (mslide) and 
vsnapshot (vslide) 

EMF Saves and views screen images in enhanced 
metafile format.

msnapshot (mslide) and 
vsnapshot (vslide)

WMF Saves and views screen images in Windows 
metafile format.

parallel (offset) Both sides Copies an entity parallel on both sides.

parallel (offset) Wrap Follows a complex polyline path.

plane (solid) Rectangle Draws a rectangular solid at any angle.

plane (solid) Square Draws a square solid at any angle.

plane (solid) Triangle Draws an equilateral solid at any angle.

rectangle Square Draws a square rectangle.

rectangle Rotated Draws a rotated rectangle.
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Using additional selection sets

IntelliCAD has additional selection-set options not found in AutoCAD. In particular, 
in the circle selection set, the Crossing Circle (CC), Outside Circle (OC), and Win-
dow Circle (WC) options select all entities relative to the same distance (radius) of a 
central pick point.

The following table lists and describes the additional selection sets in IntelliCAD.    

Additional selection set options
Selection mode Description
CC Crossing Circle: Selects all entities within and crossing a circular area.

D Selection method: Displays the Drawing Settings dialog box.

O Outside Window: Selects all entities outside a rectangular area; this is the 
inverse of the Crossing Circle option.

OC Outside Circle: Selects all entities outside a circular area.

OP Outside Polygon: Selects all entities outside a polygonal area; this is the 
inverse of the CP (Crossing Polygon) and WP (Window Polygon) options. 

PRO Properties: Selects all entities with specific properties, such as area, color, 
and layer.

WC Window Circle: Selects all entities within a circular area.
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Using additional IntelliCAD commands 

Although you can use the AutoCAD command structure with IntelliCAD, the pro-
gram has its own set of commands. IntelliCAD has numerous command names not 
found in AutoCAD, although many of these commands have an equivalent function 
in AutoCAD. When you type the AutoCAD equivalent, the IntelliCAD alias system 
activates the correct command. 

For example, the AutoCAD offset command is mapped to the IntelliCAD parallel 
command. You can type either offset or parallel in the command bar, or you can 
choose Modify > Parallel.

The following table lists optional IntelliCAD command names that you can use in 
place of AutoCAD command names to perform the equivalent AutoCAD function.    

Command differences in IntelliCAD 
IntelliCAD 2001 AutoCAD 2000/R14 command AutoCAD R13 command Action in IntelliCAD
close No equivalent No equivalent Closes the current drawing.

cmdbar No equivalent No equivalent Positions the command window.

coordinate Ctrl+D or F6 Ctrl+D or F6 Changes the display of coordinates on the 
status line.

copyedata No equivalent No equivalent Copies extended entity data from one 
entity to another.

customize toolbar tbconfig Displays the Customize dialog box.

deledata No equivalent No equivalent Deletes extended entity data from an 
entity.

delete erase erase Removes entities from the drawing.

dimension dim dim Switches to dimension mode.

editedata No equivalent No equivalent Edits extended entity data found in an 
entity.

editlen lengthen lengthen Changes the length of open entities.

editpline pedit pedit Edits polylines and polymeshes.

entprop ddmodify and ddchprop ddmodify and ddchprop Displays the Entity Properties dialog box.

esnap -osnap osnap Sets entity snaps from the command line.

expblocks ddinsert ddinsert Displays the IntelliCAD Explorer - Blocks.

expdimstyles ddim ddim Displays the IntelliCAD Explorer - 
Dimension Styles.

expfonts style ddstyle Displays the IntelliCAD Explorer - Styles.

explayers layer ddlmodes Displays the IntelliCAD Explorer - Layers.

explorer ddrename ddrename Displays the IntelliCAD Explorer.

expltypes linetype ddltype Displays the IntelliCAD Explorer - 
Linetypes.
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expucs dducs dducs Displays the IntelliCAD Explorer - UCS.

expviews ddview ddview Displays the IntelliCAD Explorer - Views.

face 3dface 3dface Draws three-dimensional faces with three 
or four vertices.

flatten No equivalent No equivalent Sets thickness to zero at user-specified 
elevation.

font -style style Displays the Text Style dialog box.

freehand sketch sketch Allows freehand sketching.

idpoint id id Returns the x-, y-, and z-coordinates of a 
picked point.

infline xline xline Draws a line of infinite length.

join pedit join pedit join Joins lines and arcs.

mesh 3dmesh 3dmesh Draws a surface mesh.

moveedata No equivalent No equivalent Moves extended entity data from one 
entity to another.

msnapshot mslide mslide Makes an SLD, EMF, or WMF file of the 
current view.

orthogonal ortho ortho Toggles orthogonal mode.

parallel offset offset Copies an entity by a parallel offset 
distance.

plane solid solid Draws a two-dimensional solid plane.

pmthist F2 F2 Switches between the Prompt History 
window and the graphics screen.

polyline pline pline Draws a polyline.

ppreview preview No equivalent Previews the plot.

psetup config config Displays the Print/Plot dialog box.

qprint No equivalent No equivalent Quickly prints the current viewport 
(window) with no options.

reassocapp No equivalent No equivalent Reassociates extended entity data with an 
application.

recscript No equivalent No equivalent Starts the Script Recorder.

saveall No equivalent No equivalent Saves all currently open drawings.

setcolor ddcolor ddcolor Displays the Color dialog box.

setdim ddim ddim Displays the Dimension Settings dialog 
box.

setesnap osnap ddosnap Displays the Drawing Settings dialog box 
with the Coordinate Input tab displayed.

setlayer ai_molc No equivalent Sets the current layer based on the 
selected entity’s layer.

Command differences in IntelliCAD (continued)
IntelliCAD 2001 AutoCAD 2000/R14 command AutoCAD R13 command Action in IntelliCAD
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settings No equivalent No equivalent Displays the Drawing Settings dialog box.

setucs dducs dducs Displays the User Coordinate Systems 
dialog box.

setvpoint No equivalent No equivalent Displays the Preset Viewpoints dialog box.

stopscript No equivalent No equivalent Stops running the script.

tipofday No equivalent No equivalent Displays the Tip of the Day.

undelete oops oops Restores the last deleted entity.

vba vbaide No equivalent Opens the Microsoft Visual Basic 
Applications editor.

vbaload vbaload No equivalent Displays the VBA Add-In Manager dialog 
box.

vbarun vbarun No equivalent Runs a VBA application.

vbaunload vbaunload No equivalent Unloads one or more VBA applications.

viewctl ddvpoint ddvpoint Sets the three-dimensional viewing 
direction via an interactive dialog box.

viewpoint vpoint vpoint Sets the three-dimensional viewing 
direction via the command line.

vsnapshot vslide vslide Displays an SLD, EMF, or WMF file in the 
current viewport.

Command differences in IntelliCAD (continued)
IntelliCAD 2001 AutoCAD 2000/R14 command AutoCAD R13 command Action in IntelliCAD
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Recognizing subtle command differences

The commands listed in the following table function slightly differently in Intelli-
CAD than in AutoCAD.    

Command function differences
IntelliCAD 
command

AutoCAD 
command Function in IntelliCAD

box ai_box Draws a surface model box instead of a solid model box.

cal cal Displays the Windows calculator.

cone ai_cone Draws a surface model cone instead of solid model cone.

cylinder ai_cylinder Draws a surface model cylinder instead of solid model cylinder.

import dxfin, open Imports DWG and DXF files.

pan -pan Performs a vector pan instead of a real-time pan.

sphere ai_sphere Draws a surface model sphere instead of a solid model sphere.

torus ai_torus Draws a surface model torus instead of a solid model torus.

wedge ai_wedge Draws a surface model wedge instead of solid model wedge.

zoom -zoom Performs a stepped zoom instead of a real-time zoom.
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Identifying unsupported commands

A few AutoCAD commands are not supported in this release of IntelliCAD, as shown 
in the following table.  

AutoCAD commands not supported by IntelliCAD

2000 arctext, rtext, wipeout

R13 align, arx, audit, copylink, dsviewer, dxbin, edge, hatchedit, 
mline, mledit, recover, shape, treestat, wmfopts

Advanced AutoCAD 
modules

ACIS commands (solids modeling): acisin, acisout, ameconvert, 
extrude, interfere, intersect, region, revolve, section, slice, soldraw, 
solprof, solview, stlout, subtract, and union

ASE commands (AutoCAD SQL extension): aseadmin, aseexport, 
aselinks, aserows, aseselect, and asesqled

Image commands: image, imageadjust, imageclip, imageframe, and 
imagequality; imageattach functions

Internet commands: attachurl, browser, detachurl, dwfout, dwfoutd, 
inserturl, listurl, openurl, saveurl, and selecturl

Landscape commands: lsedit, lslib, and lsnew

PostScript commands: psdrag, psfill, psin, and psout

Render commands: fog, matlib, replay, saveimg, scene, setuv, 
showmat, stats, transparency, 3dsin, and 3dsout
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Identifying what does not display

When a drawing containing AutoCAD proxy entities is loaded into IntelliCAD, the 
program displays the following message: “This drawing contains one or more entities 
that will not display. These entities WILL be stored and saved back into the draw-
ing.” 

The following table identifies which AutoCAD objects are not displayed in 
IntelliCAD. 

AutoCAD objects not displayed in IntelliCAD
AutoCAD object Description

Proxy (zombie) Not displayed.

Images Do not display if inside blocks and externally referenced drawings (xrefs).

Arc aligned text Text that is aligned along the curve of an arc.

Read text Dynamically linked text that displays in a drawing but resides in an 
external file.

Wipeout masks Masks to cover parts of drawings that you don’t want plotted.
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Supporting AutoCAD customization

The following table lists and describes the ways IntelliCAD supports the AutoCAD 
customization files.  

IntelliCAD support of AutoCAD customization files
File extension Description
LIN Supported: Linetypes and complex linetypes with text and shapes.

MNU and MNS Supported: Toolbar and menu macros. 
Supported: ***POP0, ***POPn, and ***TOOLBAR sections. 
Not supported: ***TABLET, ***BUTTONS, ***SCREEN, ***AUX, and ***ICON 
sections.

MIN Not supported: The multiline definition file is used by the AutoCAD mline 
command.

PAT Supported: Hatch patterns.

PGP Supported: Command aliases. 
Not supported: External commands.

PSF Not supported: PostScript fill pattern file is used by the AutoCAD psfill 
command.

SHP and SHX Supported: Text fonts. 
Not supported: Shapes.

SLD Supported: Slide files.

UNT Supported: Unit translation file used by the LISP (cvunit) and SDS sds_cvunit 
functions to translate values from one unit of measurement to another.
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Understanding menu compatibility

MNU files are menu files created by all AutoCAD releases, and MNS files are 
included in AutoCAD Releases 13, 14, and 2000. IntelliCAD reads both file formats, 
even when menu macros include AutoLISP code. This feature allows you to continue 
using your existing AutoCAD menus. 

IntelliCAD support of specific sections in AutoCAD MNU and MNS files
Menu section Definition IntelliCAD support
***POP0 Cursor menu Supported

***POPn Pull-down menus Supported

***AUXn Auxiliary menus Not supported

***BUTTONn Button menus Not supported

***ICON Icon menus Not supported

***SCREEN Screen menus Not supported

***TABLETn Tablet menus Not supported
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Importing and exporting customization files

You can continue using aliases and menu files from AutoCAD by importing the 
appropriate file. You can import AutoCAD customization files and export IntelliCAD 
formats using the Customize dialog box. All of the files listed in the following table 
are in ASCII format, which means you can view and edit them with a text editor, such 
as Notepad. 

TIP You can manually add toolbar customizations to a MNU file. See the section in 
Chapter 17 on "Customizing toolbars" for more information.

Customizing files
Customization Import file formats Export file formats
Aliases PGP: AutoCAD aliases 

ICA: IntelliCAD aliases 
ICA: IntelliCAD aliases

PGP: AutoCAD aliases

Keyboard ICK: IntelliCAD keyboard ICK: IntelliCAD keyboard

Menus MNU: All AutoCAD menus 
MNS: AutoCAD R13, R14 and 2000 
menus 
ICM: IntelliCAD menu

ICM: IntelliCAD menu

Toolbars MNU: All AutoCAD menus None



428   A P P E N D I X
Programming IntelliCAD

IntelliCAD supports more AutoCAD application programming interfaces (APIs) than 
any other software, but not all of the AutoCAD APIs are available in IntelliCAD. The 
following table summarizes the AutoCAD APIs IntelliCAD supports.  

Understanding AutoLISP compatibility 
IntelliCAD adds LISP functionality that you will find useful. The following table lists 
functions that are unique to IntelliCAD LISP.  

IntelliCAD support of the AutoCAD programming interface
AutoCAD programming interface IntelliCAD support
Scripts (SCR files) Supported

AutoLISP (LSP files) Supported

Dialog Control Language (DCL files) Supported

AutoCAD Development System (ADS) Supported; source code must be 
recompiled

Visual Basic Applications (VBA) Supported, depending on your version 
of IntelliCAD

Direct Interactively Evaluated String Expression 
Language (Diesel)

Not supported

AutoCAD SQL Interface (ASI) Not supported

Autodesk Threaded Language Application System Toolkit 
(Atlast)

Not needed

AutoCAD Runtime Extension (ARx) Not supported

Additional IntelliCAD LISP functions
Unique LISP function Definition
(log10) Returns log base 10.

(lpad) Pads a text string with spaces to the left.

(rpad) Pads a text string with spaces to the right.

(tan) Returns the tangent.

(trim) Trims spaces from a string.
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Not all IntelliCAD LISP functions are completely compatible with AutoLISP func-
tions. The following table identifies IntelliCAD LISP functions that are partially 
compatible with AutoLISP functions.

Partially compatible LISP functions
LISP function Description

(menucmd) Supports P0 (cursor menu) and P1 through P16 (the pull-down 
menus), but does not support A (aux menus), B (button menus), I 
(icon menus), M (diesel expressions), S (screen menu), or T (tablet 
menus).

(osnap) Supports an additional entity snap, pla, for planview (two-dimensional 
intersection).

(print1) Does not support Unicode characters, such as \U+00B0 (the degree 
symbol) and M+Nxxxx (multibyte Unicode sequences).

(ssget) and (ssadd) Supports additional selection modes: 
CC = Crossing Circle 
O = Outside 
OC = Outside Circle 
OP = Outside Polygon 
PO = POint
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IntelliCAD-AutoCAD list of terms

  
List of terms

IntelliCAD term Meaning for AutoCAD users
command bar command prompt area

edit length lengthen

entity object

entity snap object snap

entity snap precision aperture

fixed attribute constant attribute

follow continue

freehand sketch

hidden attribute invisible attribute

infinite line XLine

insert draw

orthogonal ortho

parallel offset

plane solid (2D)

predefined attribute preset attribute

prompt box screen menu

Prompt History window text screen

reference grid grid

set point snap node snap

snapshot slide (SLD)

validate attribute verify attribute

workspace model or paper space, with viewports



Glossary

2D  Two-dimensional locations defined by x- and y-coordinates.

3D  Three-dimensional locations defined by x-, y-, and z-coordinates.

absolute coordinates  Coordinates defined in relation to the origin point of the current 
user coordinate system. See also coordinate system, coordinates, origin, relative 
coordinates, user coordinate system, and World Coordinate System.

ActiveX  A mechanism for exchanging information between different programs 
whereby a copy of a source document is embedded or a pointer to a source document 
is linked to a target document. See also embed and link.

acute angles  Angles of fewer than 90 degrees.

alias  An abbreviation or alternative word for an IntelliCAD® command.

aligned dimension  A dimension aligned parallel to an entity or measuring the distance 
between two points at any angle.

angle  The difference in direction between two nonparallel linear entities, measured in 
degrees or radians.

angular dimension  A dimension measuring the angle between two lines or subtended 
by an arc.

angular unit  The unit of measurement for angles. Angular units can be measured in 
decimal degrees, degrees/minutes/seconds, grads, and radians.

annotation  Any text, dimensions, tolerances, or notes added to a drawing.

ANSI  Acronym for American National Standards Institute. In the context of text, a 
standard character set defined by ANSI used in computer-aided drafting.

arc  A segment of a circle or ellipse.

area  Measurement of a planar region or the calculated space within an entity. 

array  Multiple copies of selected entities in a circular or rectangular pattern.

ASCII  Acronym for American Standard Code for Information Interchange, a com-
monly used system for assigning numbers to printable alphanumeric characters, 
punctuation, and symbols.
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attribute  A component of a block containing specific text or numeric information. 
You can copy the information contained in an attribute from the drawing to an exter-
nal database.

attribute definition  An entity composed of a name, prompt for information, display 
characteristics, and default text that, when incorporated into a block, creates an 
attribute when the block is inserted into a drawing.

attribute name  Text that identifies an attribute within a block.

attribute text  The text containing an attribute’s information within a block.

B-spline curve  See spline. 

base point  A point on an entity that serves as its reference or insertion point. A point 
of reference when specifying relative distances.    

baseline  The line on which text characters appear to sit. The descenders of individual 
characters drop below the baseline.

baseline dimension  Multiple parallel dimensions measured from the same baseline 
origin.

bind  To convert an externally referenced drawing into a standard block definition.

blips  Temporary screen markers displayed in a drawing when you select a point. 
Also called marker blips.

block  One or more entities grouped together to create a single entity. See also nested 
block.

block definition  The name, base point, and entities grouped together when creating a 
block.

boundary polyline  A selected area bounded by a single closed entity or by multiple 
entities that intersect.

BYBLOCK  A property whereby an entity inherits the color or linetype of any block 
that contains it.

BYLAYER  A property whereby an entity inherits the color or linetype of its associated 
layer. 

CAD  Acronym for computer-aided design.

Cartesian coordinates  Coordinates defined using three perpendicular axes (x, y, and 
z) to define locations in three-dimensional space. See also cylindrical coordinates, 
polar coordinates, and spherical coordinates.

center line  A line used to indicate the center of a circle or an arc, usually consisting of 
a center mark and lines extending slightly beyond the diameter of the circle or the arc.

center mark  A cross marking the center of a circle or an arc.



   433
chamfer  A beveled edge between two lines.

chord  A line connecting two points on a circle or an arc.

circumference  The measurement of the distance around a circle.

closed  A condition whereby the start point and endpoint of an entity are the same.

comma-delimited  Data that is separated by a comma to represent the end of a field.

command bar  A dockable window in which you type IntelliCAD commands and view 
prompts and other program messages.

cone  A three-dimensional entity where a vertex exists above or below the circular 
shape and where a surface has been applied between the vertex and the circular shape.

contiguous  Connected, unbroken, or uninterrupted. Entities that share the same end-
point.

continued dimension  A dimension measured from the previous extension line of an 
existing dimension, resulting in two or more dimensions positioned end to end. 

control point  A point used to define a spline.

Coons patch  A surface interpolated among three or four boundary curves.

coordinate filter  A function that extracts individual x-, y-, and z-coordinate values 
from different points to create a new composite point.

coordinate system  A system of points that represents the drawing space in relation to 
an origin (0,0,0) and a set of axes that intersect at the origin. In two dimensions, the x- 
and y-axes represent horizontal and vertical directions, respectively. In three dimen-
sions, the z-axis represents locations above and below the two-dimensional xy plane. 
Locations in the drawing can be represented using two-dimensional and three-dimen-
sional rectangular (Cartesian) coordinates, two-dimensional polar coordinates, three-
dimensional polar (cylindrical) coordinates, and three-dimensional spherical coordi-
nates. See also polar coordinates, relative coordinates, spherical coordinates, 
user coordinate system, and World Coordinate System.

coordinates  A set of values that determines a location in two-dimensional or three-
dimensional space. See also absolute coordinates, Cartesian coordinates, polar 
coordinates, relative coordinates, and spherical coordinates.

coplanar  Lying within the same plane.

crosshairs  A cursor that consists of two or three lines that intersect at the cursor loca-
tion.

crosshatch  To fill an area with a pattern of evenly spaced perpendicular lines. See 
also hatch.

crossing circle  An entity-selection method that selects entities contained within or 
crossing the boundary of a circular selection window. 
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crossing polygon  An entity-selection method that selects entities contained within or 
crossing the boundary of a polygon selection window. 

crossing window  An entity-selection method that selects entities contained within or 
crossing the boundary of a rectangular selection window. 

cube  A boxed, three-dimensional, geometric shape where length, width, and height 
are equal.

cursor  The insertion-point symbol on the screen. The appearance of the cursor 
changes based on the current task.

curve  A smooth, continuous path made up of linear and arc segments. Curve types 
include arcs, splines, circles, and ellipses. 

cylindrical coordinates  Coordinates describing a point in three-dimensional space 
based on its distance from the origin, its angle in the xy plane, and its z-coordinate 
value. See also polar coordinates and spherical coordinates.

datum-line dimensioning  See ordinate dimension.

default  An initial or predefined setting.

detach  To remove an external reference from a drawing. See also external refer-
ence.  diameter  The distance across a circle or sphere.

digitizer tablet  A hardware input device that incorporates an electronic pad and a 
hand-held pointer similar to a mouse. A digitizer tablet serves two purposes: (1) You 
can select tools from paper representations attached to the pad (called an overlay), 
providing access to all tools at once while freeing your screen space; and (2) you can 
input digital points into the computer that correspond to points on a paper drawing, 
photograph, or blueprint attached to the pad.

dimension  A measurement, as in height or width. In the context of drafting, a set of 
lines, arrowheads, and text used to indicate a measurement. 

dimension style  A named group of dimension variable settings that determines the 
appearance of the dimension. You can save multiple dimension styles for reuse.

dimension text  The measurement value. Dimension text can include prefixes, suf-
fixes, tolerances, and other annotations.

dimension tolerance  A value specifying the allowed variation of a dimension (+ or – 
n).

dish  The lower half of a sphere. See also dome.

displacement point  The point to which a base, or reference, point will be relocated 
when moving or copying entities.

distance  The measure of space between two points.

dock  To position a toolbar or the command bar at the edge of the drawing window, 
where it locks into place. See also float.
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dome  The upper half of a sphere. See also dish.

donut  A filled circle or flat ring created as a polyline.       

drawing extents  See extents.

drawing limits  See limits.

drawing unit  The linear measurement system used in a drawing. The user determines 
what a drawing unit represents, such as one inch, one centimeter, one foot, or one 
meter.

.dwg  A standard format used by CAD programs to store drawing files.

DXF  Acronym for Drawing Exchange Format, a standard ASCII or binary file format 
for importing and exporting files between most CAD programs.

elevation  The z value measured from the xy plane. Positive values are above the xy 
plane; negative values are below the xy plane.

embed  A technique for exchanging information between different programs whereby 
a copy of the source document is stored in the target document. See also ActiveX and 
link.

EMF  Acronym for Enhanced Metafile, a file format with the type and extension of 
.emf. It is a native internal file format of Windows 95, Windows 98, and Windows 
NT. EMF supports both raster and vector information and 24-bit RGB color. Most 
Windows-based programs support this format.

endpoint  The point at which a line or curve ends.

entity  Any single basic item in a drawing. Entities include arcs, attributes, blocks, cir-
cles, dimensions, ellipses, elliptical arcs, infinite lines, lines, polylines, rays, and text.      

entity data  Any of a variety of additional information, such as text, numbers, and dis-
tances, that can be attached to drawing entities.

entity snap  A technique for accurately locating and specifying key geometric points 
on entities, such as endpoints and midpoints of lines, and center points and tangents 
of arcs and circles.

entity snap override  To disable or change an entity snap mode for a single input. See 
also entity snap and running entity snap.

Esnap  See entity snap.

explode  The conversion of a complex entity into its basic entities.

extension lines  Lines extending away from an entity being dimensioned so that you 
can place the dimension line away from the entity. Also called projection lines.

extents  The smallest rectangle that can contain all the entities in a drawing. Infinite 
lines and rays do not affect a drawing’s extents. See also limits.

external reference  A drawing that is linked to another drawing.
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extrude  The process of converting a two-dimensional entity into a three-dimensional 
entity by stretching (extruding) the two-dimensional entity along a straight path. 
Changing the thickness of a two-dimensional entity effectively extrudes it along its z-
axis. See also tabulated surface.

face  A planar surface defined by three or four points.

fence  An entity-selection method that selects entities crossing a multisegmented line.

fillet  An arc that smoothly connects the end of one line to another.

float  To position a toolbar or the command bar away from the edges of the drawing 
window where it can be moved independently. See also dock.

freeze  To suppress the display of, and ignore the entities on, a specified layer when 
regenerating a drawing, thus accelerating the display of the drawing. See also thaw.

grid  An adjustable, regularly spaced pattern of dots on the screen, used as an aid in 
drawing and aligning entities. The grid is not plotted.

grip  A small square displayed at key positions on an entity when the entity is selected 
that can be used to modify the entity by clicking and dragging.

halfwidth  The distance from the center of a wide polyline to its edge.

hatch  To fill a selected area either with lines, crosshatching, or a hatch pattern. See 
also crosshatch.

hatch pattern  A pattern, often representing a material such as steel, wood, or sand, for 
filling selected areas.

hidden-line removal  A visualization technique in which all lines that are hidden 
behind other entities or surfaces from your viewpoint are clipped or removed, giving 
the image the appearance of a solid object.

horizontal dimension  A linear dimension measuring a horizontal distance.

infinite line  A line extending infinitely in both directions.  

insertion point  The point where you place an entity into a particular space. A refer-
ence point by which an entity is inserted in a drawing. 

intersection  The point where two entities meet or cross.

isometric drawing  A drawing aligned with an isometric plane.

isometric plane  One of three planes representing the left, right, or top sides of an 
implied three-dimensional, orthogonal entity. Snap and grid points are aligned with 
the plane to constrain drawings.
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layer  The computer equivalent of overlays used in manual drafting. A tool by which 
drawing components can be organized into related sets, such as plumbing, framing, 
and electrical systems of a house, each being drawn on its own layer.

leader  A line leading from a feature of a drawing to an annotation.

limits  The user-defined boundary of a drawing, defined by its lower left and upper 
right corner coordinates. See also extents.

limits tolerance  Dimension text in which the measured dimension is replaced by the 
largest and smallest dimensions allowed, with the upper limit displayed above the 
lower limit. See also tolerance and variance tolerance.

linetype  The appearance of a line, defined as a solid (continuous) line or as a pattern 
of dashes, dots, and blank spaces.

link  A technique for exchanging information between different programs whereby 
the target document maintains a pointer to the original source document. Any 
changes to the source document are reflected in all target documents containing links 
to the source. See also ActiveX and embed.

LISP  Acronym for List Processing Language, a computer language invented in the 
late 1950s by John McCarthy for use in artificial intelligence. Because it is inter-
preted rather than compiled, and is relatively straightforward, it is a convenient lan-
guage for users to write routines to extend the set of commands and functionality of 
IntelliCAD.

lock  Prevents unauthorized access to drawing layers.

M direction  In a polygon mesh, the direction from the first to the second row. See also 
N direction.

macro  In menus and toolbars, several commands grouped together as one. Also 
Microsoft Visual Basic for Applications code.

major axis  The longest distance across an ellipse, from one end to the other. See also 
minor axis.

marker blips  Temporary screen markers displayed in a drawing when you select a 
point. Also called blips.

MDI  Acronym for multiple-document interface. See multiple-document interface.

mesh  A set of connected polygon faces approximating a curved surface.

minor axis  The shortest distance across an ellipse, from one side to the other. See also 
major axis.

mirror  To create a reverse-image copy of selected entities by reflecting the entities 
symmetrically about a line or plane.
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model space  The primary drawing workspace in which you create entities. See also 
paper space. 

multiple-document interface  The ability to view and work with different drawings 
simultaneously.

N direction  In a polygon mesh, the direction from the first to the second column. See 
also M direction.

named view  A saved view that can be recalled at a later time by specifying its name.

nested block  A block contained as part of the definition of another block. See also 
block.

nonassociative hatch  A hatch that is not associated with or linked to an entity.

oblique  Geometric lines or planes that are not parallel or perpendicular.

offset  See parallel.

OLE  Acronym for Object Linking and Embedding. See ActiveX.

ordinate dimension  A measurement of the horizontal (x-ordinate) or vertical (y-ordi-
nate) distance from an established reference base point or datum.

origin  The intersection point of the coordinate system axes. In a Cartesian coordinate 
system, the origin is the point at which the x-, y-, and z-axes intersect (the 0,0,0 coor-
dinate).

orthogonal  Having perpendicular slopes or tangents at the point of intersection.

orthogonal mode (ortho)  A drawing mode in which the entity creation is constrained 
to parallel the horizontal and vertical axes relative to the current snap angle.

orthographic projection  A drafting technique by which a three-dimensional item is 
described in two dimensions by showing it from various directions, most commonly 
front, top, and side views.

outside circle  An entity-selection method that selects entities falling completely out-
side a circular selection window. 

outside polygon  An entity-selection method that selects entities falling completely 
outside a polygon selection window. 

outside window  An entity-selection method that selects entities falling completely 
outside a rectangular selection window. 

pan  To shift the displayed view of a drawing without changing the magnification. 
See also zoom.

paper space  A two-dimensional workspace analogous to a sheet of paper, in which 
you can arrange different views of your drawing as floating model space viewports. 
See also model space.
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parallel  Two or more coplanar lines that never intersect one another.

parallel dimension  See baseline dimension.

perimeter  The distance around the boundary of an entity.

perpendicular  Entities at right angles to one another.

planar  Entities whose extents are situated entirely within a plane.

plane  Two-dimensional surface.

plan view  A view of the drawing from above, looking down the z-axis perpendicular 
to the xy plane of the current UCS.

point  A location in space specified by its x-, y-, and z-coordinates. A drawing entity 
consisting of a single x,y,z-coordinate location and represented by one of several 
symbols.        

point filter  See coordinate filter.

polar array  Multiple copies of selected entities in a circular pattern.

polar coordinates  Coordinates describing a two-dimensional point on a two-dimen-
sional plane based on the point’s distance from the origin and its angle in the plane. 
See also Cartesian coordinates, coordinates, cylindrical coordinates, relative 
coordinates, and spherical coordinates.

polygon  A closed single entity with three or more sides.  

polyline  A drawing entity composed of one or more connected line or arc segments 
treated as a single entity. 

projection lines  See extension lines.

prompt box  A list of options displayed when a command or tool provides several 
choices.

Prompt History window  A window containing a history of the most recent commands 
and prompts issued since you started the current session of IntelliCAD.

quadrant  One-fourth of a circle, arc, or ellipse entity. In the context of entity snaps, 
the option that snaps to points on a circle, arc, or ellipse at each quadrant.

radial dimension  A dimension that measures the radius of a circle or arc.

radian  A unit of angular measurement; 360 degrees equals 6.283185 or 2pi radians.

radius  The distance from the center of a circle or sphere to its periphery.

ray  A line that starts at a designated point and runs infinitely.

ray tracing  A visualization technique in which rays from imaginary light sources are 
traced as they refract off the surfaces of a model, determining where shadows fall and 
how reflections on shiny materials such as metal and glass appear.
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rectangle  A four-sided, closed entity whereby opposite sides are equal in length.

rectangular array  Multiple copies of selected entities in a rectangular pattern consist-
ing of a specified number of columns and rows.

redo  To reverse the effect of previous undo commands. See also undo.

redraw  To quickly update or refresh the drawing screen display. See also regenerate.

regenerate  To update or refresh the drawing screen display by recalculating the draw-
ing from its database. See also redraw. 

relative coordinates  Coordinates expressed in relation to a previous coordinate. See 
also absolute coordinates. 

revolve  Creating a three-dimensional surface entity by rotating a two-dimensional 
profile around an axis.

right-hand rule  A visual aid for remembering the relative directions of the positive x-, 
y-, and z-axes of a Cartesian coordinate system and the positive rotation direction 
about an axis.

rotate  To change the orientation of an entity, without modifying it, by repositioning it 
equidistant from, but at a new angle with respect to, a point or axis.

rotation angle  The angle by which an entity is displaced from its original location 
when rotating it about a point or axis.

rubber-band line  A ghosted image line that stretches dynamically on the screen with 
the movement of the cursor. The line extends between a fixed point and the cursor 
position to provide dynamic feedback.

ruled surface  A three-dimensional polygon mesh that approximates a smooth surface 
between two entities.

running entity snap  Setting an entity snap so that it continues for subsequent selec-
tions. See also entity snap and entity snap override.

scale  To resize an entity. To draw according to the proportions of an entity.

script  A set of commands stored in an ASCII script file and replayed in sequence by 
running the script.

SDS  Acronym for Solutions Development System, a C programming interface for 
developing specialized programs to run inside IntelliCAD.

segment  Any part of an entity bounded by two points.

selection set  One or more drawing entities selected on which one can operate as a sin-
gle unit.

shade  To fill planar entities with solid colors for easier visualization.

snap angle  The angle around which the snap grid is rotated.
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snap grid  An invisible grid that locks entity creation to a specified alignment and 
snap increment when Snap is enabled.

snap resolution  The spacing between points on the snap grid.

snapshot  A raster representation of the current view of one’s drawing.

spherical coordinates  Coordinates describing a point in three-dimensional space 
based on its distance from the origin, its angle in the xy plane, and its angle up from 
the xy plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, 
and polar coordinates.

spline  A curve generated along the path of three or more control points. The curve 
passes through the start point and endpoint, but does not necessarily pass through the 
intermediate control points. 

status bar  The bar at the bottom of the IntelliCAD window that displays information 
about the selected command or tool as well as the cursor coordinates, the name of the 
current layer, mode settings, and other information about drawing settings.

surface model  A three-dimensional model consisting of both edges and the surfaces 
between those edges. See also wire-frame model.

surface of revolution  A three-dimensional polygon mesh that approximates the sur-
face generated by rotating a two-dimensional profile around an axis.

system variable  A setting or value that stores operating environment and command 
information (such as the drawing limits or global linetype scale factor).

tabulated surface  A three-dimensional polygon mesh that approximates the surface 
generated by extruding a curve along a vector. See also extrude.

tangent  A line that passes through a single point on a curve.

template  A drawing with preset layers, linetypes, and other settings (and entities) that 
can be used as the basis for creating a new drawing.

text style  A named, saved collection of format settings that determines the appear-
ance of text.  

thaw  To redisplay a layer that was frozen. See also freeze.

thickness  An entity’s depth, as measured along its z-axis. The distance an entity is 
extruded above or below its elevation. See also elevation and extrude.

through point  In creating a parallel entity, a point through which the new entity 
passes.

tolerance  Dimension text indicating how much the actual dimension of a manufac-
tured component can vary from the specified dimension. See also limits tolerance 
and variance tolerance.

tolerance command  A command that creates a feature-control frame used in mechan-
ical geometric dimensioning and tolerancing.



toolbar  A collection of tools arranged on a palette that can be moved and resized any-
where on the screen.

torus  A donut-shaped, three-dimensional entity.

transparent command  A command started while another command is already active. 
You can use a command transparently by preceding it with an apostrophe.

UCS  Acronym for user coordinate system. See user coordinate system.

UCS icon  A user coordinate system icon that shows the orientation of the coordinate 
axes, the location of the coordinate system origin, and the viewing direction relative 
to the xy plane.

undo  To reverse the effect of previous commands. See also redo.

unit  See drawing unit.

unlock  Free access to layers in a drawing that would be otherwise locked, thus pro-
hibiting them from being viewed or edited by another user.

user coordinate system  A Cartesian coordinate system with origins and orientation 
defined by the user. See also World Coordinate System.

variance tolerance  Dimension text in which a plus/minus value is appended to the 
specified dimension to indicate how much the actual dimension of a manufactured 
component can vary from the specified dimension. See also limits tolerance and tol-
erance.

vector  A means of describing a displacement using magnitude and orientation. For 
example, you can create a line entity, or move an entity, by specifying an initial point, 
a direction, and a distance.

vertex  The point of intersection of the sides of an angle. The start points or endpoints 
of a line or arc segment in a polyline.

vertical dimension  A linear dimension measuring a vertical distance.

view  A representation of a drawing or portion of a drawing from a specific viewpoint 
in three-dimensional space.

viewpoint  A location in three-dimensional space for viewing one’s drafting.

viewport  A window that displays all or a portion of a drawing’s model space. See also 
model space and paper space.             

viewport configuration  A named arrangement of windows that can be saved and 
restored.

WCS  Acronym for World Coordinate System. See World Coordinate System.

wedge  A three-dimensional entity that resembles a box divided along one side from 
one corner to the opposite corner; for example, a doorstop or a ramp.
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window circle  An entity-selection method that selects entities contained entirely 
within a circular selection window. 

window inside  An entity-selection method that selects entities contained entirely 
within a rectangular selection window. 

window polygon  An entity-selection method that selects entities contained entirely 
within a polygon selection window. 

wire-frame model  A three-dimensional model consisting of lines and curves that 
define the edges of a three-dimensional entity. See also surface model.

WMF  Acronym for Windows metafile, a format containing vector and color informa-
tion to render entities.

workspace  A space for representing and working with drawing information; types of 
workspaces are model space and paper space.

World Coordinate System  The fixed Cartesian coordinate system used as the basis for 
defining other coordinate systems. See also user coordinate system.

xref  See external reference.

zoom  To increase or decrease the magnification of the display of a drawing. See also 
pan.   
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Index

- (hyphen characters) 112, 315

Symbols
$ (dollar signs) 112, 315
% (percent signs) 247
& (ampersand character) 382
, (commas) 127
. (period characters) 128
< (angle brackets) 124, 126, 127
@ (at symbols) 221
_ (underscore characters) 112, 315
± (plus or minus signs) 247
° (degree symbols) 247

Numerics
0 layer 142
2-dimensional drawings

2-dimensional coordinate systems 121
coordinate systems 118
defined 431
isometric drawings 47
point filters 128
polar coordinates 124

2-dimensional entities
See also 2-dimensional entity types; entities
arraying in columns or rows 209
extruding to create 3-dimensional entities 333–336

2-dimensional entity types
arcs 63
circles 61
donuts 77
ellipses 66
elliptical arcs 67
freehand sketches 73
infinite lines 71
lines 60
planes 89
point entities 68
polygons 80
polylines 74
rays 70
rectangles and squares 78
splines 84

3D Array command or tool (3darray) 352, 353

3D Mirror command or tool (mirror3d) 354
3D Rotate command or tool (rotate3d) 351
3-dimensional coordinate systems 126

defined 431
specifying locations with 125

3-dimensional drawings
compared to isometric 2-dimensional drawings 47
coordinate system icons 119
coordinate systems 118, 125
defined 431
point filters 129
setting viewpoints 330–333
snapping to entity intersections 55–56
user coordinate systems 130
wire-frame and surface models 333

3-dimensional entities
See also 3-dimensional entity types; entities
arraying copies of entities 352–354
editing 351–354
mirroring 354
rotating entities 351
thickness and elevation 333–337

3-dimensional entity types
boxes 340–341
cones 341
cylinders 343
dishes 345
domes 345
edge-defined Coons surface patch meshes 350
extruded surface meshes 347
face 337
polyface meshes 339
pyramids 342–343
rectangular meshes 338
revolved surface meshes 348–350
ruled surface meshes 347
spheres 344
tori 346
wedges 341

3-Point Arc tool 63

A
absolute coordinates
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See also coordinate systems; user coordinate sys-
tems (UCS); World Coordinate System (WCS)

defined 431
specifying locations with 121, 125

absolute size of point entities 68
access keys for commands 382
accuracy

drawing unit display 37
IntelliCAD compared to manual drafting 7–8
precise point locations with entity snaps 187

ActiveX
defined 431
dragging drawings into other applications 363–364
editing linked or embedded objects 360, 362
linking drawings to other applications 363
linking objects to drawings 359–360
sharing drawing information and data 12

acute angles 431
Add To Set selection method 194
adding

aliases for commands 401
areas of entities 184
commands to menus 378, 379, 382
entities to selection sets 198
keyboard shortcuts for commands 397
space between tools 389
tools to toolbars 388

ADS programs 2, 4, 405
advanced experience level

changing level 3, 18, 25, 370
choosing during installation 18, 25

aliases for commands
creating 401
defined 431
deleting 402
importing or exporting 402
redefining 402

Aligned command or tool (dimaligned) 258
aligned dimensions

creating 258
defined 431
illustrated 254

aligning coordinate systems
with current view 132
with entities 130

aligning marker blocks on entities 181, 182
aligning text

on dimension lines 276
options 272

alternate dimension units, controlling 285
alternate font

setting the default file 372
American National Standards Institute (ANSI) defined 

431
American Standard Code for Information Interchange 

(ASCII) defined 431
ampersand characters 382
angle brackets 124, 126, 127
angle drawing method

infinite lines 71
rays 70

angles
angle direction and base settings 37
calculating angle between points 187–188
defined 431
displaying instead of coordinates 120
drawing unit settings 37, 435
specifying for arcs 63, 64, 83
specifying for chamfering 233
specifying for dimension lines 261
specifying for grid 46
specifying for lines 60
specifying for rotated entities 210–212
specifying for text styles 156
specifying locations by 124
specifying text angle in text styles 159
spherical and cylindrical coordinates 126
zero angle settings 37

Angular command or tool (dimangular) 261
angular dimensions 261, 262

creating 261
defined 431
formatting dimension unit display 278

angular drawing units 431
angularity tolerance symbol 280
annotations

adding in paper space 310
creating as dimension text 265
defined 431

aperture for entity snaps 49
apostrophes 26
appending scripts 405
appload command 406, 407
Arc command (arc) 63
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Arc Start-Center-Angle tool 63
Arc Start-Center-End tool 64
architectural

drawing scale ratios 38
drawing units 36

arcs
adding lines to 60
angle dimensions for 261
center marks 255
converting donuts into arc entities 88
converting polyline segments to arcs 83
converting to circles 62
defined 431
diameter dimensions for 262
direction of 67
drawing methods 63
elliptical arcs 67
extending to boundaries 214
joining 221, 227–228
measuring and marking off intervals 180–183
moving with grips 210
polyline drawing methods 83
radius dimensions for 262

Area command or tool (area) 183, 431
calculating areas 183

arranging windows 110
See also views and viewports

Array command or tool (array) 209
arraying entities 207, 352–354, 431
arrows and arrowheads 255, 270–272
ASCII

AutoCAD files. See DXF files
defined 431
text files 299

assembling master drawings 301
assigning aliases to commands 401
at symbol 221
Attach Drawing tool (Blocks toolbar) 168, 172
attaching

attributes to blocks 298
external references 301

attachment points 241
See also insertion points

attributes
after exploding blocks 231
attaching to blocks 298
data in 288

defined 167, 432
definitions 295–297
editing definitions 297
extracting values 299–301
fixed or variable values 294
flags 295
invisible data 294
names 432
overview 294–296
snapping to insertion points 54
text 432
updating values for 298
visible or hidden 295

AutoCAD
alias files 402
command name compatibility 400
exporting IntelliCAD files as AutoCAD files 364–

365
font compatibility 157
importing toolbars from menu files 393
IntelliCAD compatibility 2, 415
loading menu files 378, 379, 384
script files 403

AutoCAD Development System programs (ADS) 2, 4, 
405

AutoLISP programs 2, 4, 406–407
automatically

loading menus 374
reloading external references 303
running scripts 405
saving drawings 370

automating IntelliCAD functions 370
AutoSave 370
axes

changing display color 376
in coordinate systems 118, 121
in ellipse drawing methods 66
in elliptical arc drawing methods 67
rotating entities around 351

B
background screen color 374
backward text 159, 243, 249
base points

See also origin points
defined 432
for copying entities 202
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for entities to be moved 209
for scaling entities 213
for stretching entities 212

baseline
of text 432
offset in dimensions 274
text alignment 246

Baseline command or tool (dimbaseline) 259
baseline dimensions

adding to linear dimensions 256
angular baseline dimensions 261
creating 259
defined 432
illustrated 254

basing drawings on templates 30
beginner experience level

changing level 3, 18, 25, 370
choosing during installation 3, 18, 25

best fit for dimension text and arrows 272–274
beveled edges on entities 232–235
binding external references 304–305, 432
bisect drawing method (infinite lines or rays) 70
BL notation in extracted attribute file fields 299
black-and-white

tool icons 389, 392
blipmode command 116
blips

defined 432
displaying current settings 189
marker blips 116, 437
turning on or off 116

block command 289, 293
Block command (IntelliCAD Explorer) 170
Block command or tool (ddinsert) 290
Block toolbar 168
blocks

See also External Reference command or tool (xref)
as interval markers 180
attributes 288–294
Blocks list in IntelliCAD Explorer 167
BYBLOCK property 33–35
copying to other drawings 136
creating 170, 288–290
definitions 295–297
deleting in IntelliCAD Explorer 137
editing definitions 297, 298
entity storage in files 301

exploding 231, 292–293, 294
external references 301–305
inserting 171, 290–293
inserting drawings as 171
insertion points 54, 169–171, 290–293
instances of 290, 293
listing 167
multiple instances of 288, 289
names in extracted attribute file fields 299
nesting 288
number of occurrences 169
overview 167, 288
redefining and updating 288, 293
reusing blocks and drawings 10
rotation angle and scale 292, 293
saving 288–290
saving as drawing files 174, 289
search path for files 372
snapping to insertion points 54

BMP files 392
borders on drawings 310
borders on viewports

as available in each view 8
setting as invisible 314

bottom-aligned text 246
boundaries

extending entities to 214–217
setting for paragraph text 241
trimming or clipping entities to 217–218
xref clipping 305

Box command or tool (box) 340
Break command or tool (break) 220
breaking entities into pieces

exploding blocks 294
exploding into components 231
splitting into two parts 220

B-Spline curves. See splines
buttons. See toolbars and tools
BYBLOCK property

after exploding 231
colors 33–34
creating blocks from entities on different layers 288
defined 432
linetypes 34–35, 148–150

BYLAYER property
colors 33, 145
creating blocks from entities on different layers 288
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defined 432
linetypes 34, 147–156

C
C character

closing entities 123
in extracted attribute file fields 299

CAD defined 432
calculating areas 183
calculations

area and perimeter 183
distances and angles 187–188
in IntelliCAD and manual drafting 11–12
scale factors and printed size 38–40

callout lines. See leaders in dimensions
Cartesian coordinates

See also cylindrical coordinates; polar coordinates; 
spherical coordinates

2-dimensional coordinate systems 121
3-dimensional coordinate systems 125
absolute and relative coordinates 122
defined 432
overview 7
understanding coordinate systems 118, 120

Cascade command 110, 139
CDF files 299
center command 52
center lines

defined 432
for circles and arcs 255

center marks
defined 432
for circles and arcs 255
formatting 274–276

center points of entities
arcs 83
circles 61
dishes 345
domes 345
ellipses 66
elliptical arcs 67
polygons 80
snapping to 49, 52
spheres 343

center points of views 107
Center Snap command (center) 52
center-aligned text 246

Center-Diameter circle method 61
Center-Radius circle method 61
chain dimensions. See continued dimensions
Chamfer command or tool (chamfer) 235
character string fields in extracted attribute file fields 299
chords in arcs 63, 83, 433
Circle Center-Radius tool 61
Circle command (circle) 61
circle diameter symbol 247
Circle Radius-Tangent tool 62
circles

See also donuts 435
center marks 255
creating from arcs 62
diameter dimensions 262
drawing 86
measuring and marking off intervals 180
moving with grips 210
radius dimensions 263

circular
arrays of entities. See polar arrays of entities
runout tolerance symbol 280

circularity tolerance symbol 280
circumferences, defined 433
Clear Entity Snaps command or tool (none) 50, 57
Clipboard

copying entities into other drawings 204
embedding objects into drawings 358
embedding objects into other applications 363
linking drawings into other applications 363

clipping entities 217
closed (entities), defined 433
closing

polylines 82, 226
prompt boxes 23
splines 86

coaxiality tolerance symbol 280
Color dialog box 33, 146
colors

changing in entity properties 200
creating blocks from entities on different layers 288
current settings 189
default layer color 141
dimension lines 274
dimension text 277
displaying information about entities 188
grip color 198
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layer settings 139, 145–147
overriding layer color 146
selecting entities by color 195
setting entity color 33
status bar information 23
text entity color 249

columns of entities. See arraying entities; rectangular ar-
rays of entities

combining entities
chamfering and filleting 232
finding area of combined entities 184–187
joining 221, 227
lines and arcs in polylines 82

combining zooming and panning actions 107
Comma Delimited Format files 299, 433
command bar

Command Bar command 22
defined 433
displaying or hiding 22
illustrated 20
moving 19, 22
starting commands with 25

command strings for keyboard shortcuts 398–399
commands

active commands 24
adding to menus 382
aliases 400–403
AutoCAD command name compatibility 400
deleting from menus 383
displaying shortcut menus 21
ending 24
experience levels 370, 383
information in status bar 23
keyboard shortcuts for 398–400
loading custom programs 407
nesting several commands 26
prompt boxes 23
renaming 382
repeating 26
Script Recorder 26
starting 25
tracking history 26, 374

commenting
scripts 403

company names on printouts 318
complex entities

See also types of entities (polylines; rectangles; do-
nuts; and so on)

defined 77
exploding into components 231

complex hatch patterns 94
complex linetypes (IntelliCAD Explorer) 152
composite tolerances 281–286
compressing or expanding text 243, 246
concentric entities. See donuts; tori
concentricity tolerance symbol 280
Cone command or tool (cone) 341
cones 341, 433
config command 371
configuring

IntelliCAD 369
viewports 310

connecting entities
chamfering and filleting 232
joining 221, 227

constraining drawing
to drawing limits 41
to right angles 48

construction lines. See infinite lines
construction planes. See user coordinate systems (UCS)
contiguous (entities), defined 433
Continue command or tool (dimcontinue) 260
continued dimensions

adding to linear dimensions 256
angular continued dimensions 261
creating 261
defined 433
illustrated 254

CONTINUOUS linetype 34, 148
control codes for text 247
control points 85, 433
converting

2-dimensional entities to three dimensions 333
donut sides to arc entities 88
entities into components 231
entities to other linetypes before deleting 137
entities to other text styles before deleting 137
entities to polylines 225
plane sides to line entities 90
polygon sides to line entities 81
polyline segments to curves 226–227
polyline segments to entities 83
rectangle sides to line entities 78
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converting arcs to circles 62
Coons Surface command or tool (edgesurf) 350
Coons surface patch meshes 350, 433
coordinate filters (point filters) 128, 433
coordinate systems

2-dimensional coordinate systems 121
3-dimensional coordinate systems 125
absolute and relative coordinates 122
Cartesian coordinates 7, 118, 121, 432
copying to use in other drawings 136
cylindrical coordinates 127, 434
defined 433
deleting in IntelliCAD Explorer 137
icons for 119
listing 160–162
point filters 128, 130
polar coordinates 120, 124, 439
preset user coordinate systems 131
right-hand rule 125
spherical coordinates 126, 441
user coordinate systems 119, 130, 132
World Coordinate System 119, 132, 160, 332, 443

Coordinate Systems list in IntelliCAD Explorer 131, 160
coordinates

See also coordinate systems
defined 433
displaying for entities 188
finding point coordinates 121
in ordinate dimensions 263
of drawing limits 41
viewpoints in three-dimensional drawings 330

coplanar (entities), defined 433
Copy command or tool (copy or copyclip) 203–205
Copy command or tool (IntelliCAD Explorer) 136–137
copyclip command 205
copying drawings

dragging into other applications 363–364
with external references for distribution 304

copying entities 202–209
arrays of entities 207, 352–354
mirroring entities 207, 354
parallel copies 205–207
to other drawings 108, 204

copying layers to other drawings 137
copying objects

embedding IntelliCAD data into other applications 
361–363, 365–??

embedding objects into drawings 357
linking drawings to other applications 363
linking objects to drawings 359

copying settings to other drawings 136
corner points

of planes 89
of rectangles 78

correcting mistakes 27
Create Block command or tool (block) 289, 293
Create Snapshot dialog box 356
creating a block 171
cropping entities (trimming) 217, 233–235
crosshairs

defined 433
entity snap target box 49

crosshatching 94, 433
See also hatch patterns and hatching

Crossing Circle selection method 195, 433
Crossing Polygon selection method 195, 212, 434
Crossing Window selection method 194, 196, 212, 434
cubes 340–341, 434
current editing session timer 190
current settings

layers 142
linetypes 149
text styles 160
three-dimensional elevation and thickness 335
tools 136
user coordinate systems 163

Current tool (IntelliCAD Explorer) 160, 163
cursors

coordinate information in status bar 23
current position in coordinate systems 120
defined 434
magnifying glass cursor 104

curves. See also arcs; circles; ellipses; splines
curving polyline segments 226
Customize command (customize)

customizing aliases 400–403
customizing keyboard shortcuts 397–400
customizing menus 378–??, 379–387
customizing toolbars and tools 388, 397

Customize dialog box
Aliases tab 400
Keyboard tab 397–400
Menus tab 378–??, 379–387
Toolbars tab 387–397
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customizing IntelliCAD 27
customizing IntelliCAD options

aliases 400–403
coordinate systems 130
hatch patterns 94
keyboard shortcuts 397–400
menus 378–??, 379–386
program settings 370–378, ??–379
running custom programs 405–407
scripts for 403, 405
templates 30
toolbars and tools 19, 388

Cut command or tool (cutclip) 204
cutting entities

moving to other drawings 108
pasting in other drawings 204

Cylinder command or tool (cylinder) 343
cylinders 225, 343
cylindrical coordinates 127, 434

See also polar coordinates; spherical coordinates 
121

D
data

attaching to blocks. See attributes
attaching to drawings 11–12

data fields for extracted attribute files 299–301
databases

for drawing data 102
using information in drawings 11

dates
date stamps on printouts 318
tracking time spent on drawings 190

ddattdef command 295
ddatte command 298
ddattext command 300
ddedit command 248, 251, 297
ddgrips command 198
ddinsert command 290
decimal

degrees in angular units 37
drawing units 37

decurving polyline segments 226
defaults

arc direction 67
colors 141
defined 434

elevation 333
entity colors 33
icad.dwg template 19
layers 137
linetypes 34, 141, 147
text styles 243
thickness 333
values for attributes 295

Define Attributes
command or tool (ddattdef) 295
dialog box 295

defining
complex linetypes 152–155
dimension styles 269
keyboard shortcuts 398
linetypes 151–156
text styles 157
user coordinate systems 130, 162

definition points 256
degree symbols 247
Delete command or tool (delete) 202
Delete command or tool (IntelliCAD Explorer) 138
deleting

aliases 402
clipping boundary 306
commands from menus 383
custom programs 406
dimension styles 270
elements in IntelliCAD Explorer 137–139
entities 202
external references 302
freehand sketches 74
keyboard shortcuts 399
segments of polylines 82

delta distances, calculating 187
density of mesh surfaces 347, 348, 349, 350
descenders on text characters 246
deselecting entities 198
detaching external references 302, 434

See also External References command or tool (xref)
Details tool (Block toolbar) 168
Diameter command or tool (dimdiameter) 262
diameter dimensions

creating 262
defined 434
illustrated 254

diameters
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circles 262
donuts 87

dimaligned command 258
dimangular command 261
dimbaseline command 259
dimcontinue command 260
dimdiameter command 262
dimedit command

obliquing dimensions 266
replacing dimension text with new text 268
restoring dimension text to home position 268
rotating dimension text 267

dimension lines 276
See also dimension text; dimensions and dimension 

styles; extension line
aligning text on 276
defined 254, 434

Dimension Settings command or tool (setdim)
arrows and arrowheads 270, 273
baseline dimension offset 259
creating, renaming, or deleting dimension styles 269
dimension line colors 274
formatting and positioning dimension text 272, 276
rounding off numbers 278

Dimension Settings dialog box
Arrows tab 270–272
Format tab 272
Lines tab 274
Text tab 276
Units tab 278–280

Dimension Styles (IntelliCAD Explorer) 174
dimension text

aligning on lines 276
defined 434
formatting and positioning text 266–268, 272–274, 

276–278
overview 255
replacing dimension text with new text 268
restoring dimension text to home position 268
rotating dimension text 266

dimension tolerance
controlling 283

dimension units, alternate 285
dimensions and dimension styles

See also dimension text
aligned dimensions 258
angular dimensions 261–262

arrows and arrowheads 270
baseline dimensions 259
creating dimensions 256–266
creating or deleting styles 269
diameter dimensions 262
dimension styles defined 254, 269–280
dimension variables 269, 434
dimensions defined 434
extension lines 255
leaders and annotations 255, 265
line colors 274
line formats 274
linear dimensions 256–261
obliquing 266
ordinate dimensions 263
overview 254–256
radius dimensions 263
renaming styles 269
types of dimensions 254
units and rounding 278–280

dimleader command 265
dimlinear command 257
dimordinate command 264
dimradius command 263
dimstyle command 269
dimtedit command 267
directory paths for files 372
disabling. See turning features on or off
Dish command or tool (dish) 345, 434
disk space requirements for IntelliCAD 18
displacement points

defined 434
for copying entities 202
for moving entities 209
for stretching entities 212

displaying
command bar 22
drawing information 188
embedded files as icons 358
entire drawings 107
layers 143–145
lists of text styles 245
memory-intensive display elements 113
multiple views of drawings. See also views and 

viewports 108
online Help 28
plan view of user coordinate systems 132
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point entities 68
Prompt History window 26
reference grid 43
shortcut menus 21
snapshots 357
text as boxes 113
toolbars 21
ToolTips 21

Distance command or tool (distance) 187
Distance-Angle chamfer method 233–234
Distance-Distance chamfer method 233
distances

calculating between points 187
defined 434
displaying instead of coordinates 120
specifying in chamfering 233
specifying locations by 124
spherical and cylindrical coordinates 125, 127

Divide command (divide) 180, 182
dividing display into multiple views. See views and view-

ports
dividing entities into equal segments 180
docking

defined 434
toolbars and command bar 19–23

dollar signs 112, 315
Dome command or tool (dome) 345, 435
Donut command or tool (donut) 87
donuts

3-dimensional donuts (tori) 346
converting sides to arc entities 88
defined 435
drawing 87
editing 225
filled or outlined 88

dots
in linetypes 151
point entities 68

doughnuts. See donuts 435
drafting manually compared to IntelliCAD 4–14
dragging

drawings into other applications 363–364
moving entities with grips 210
new tools to toolbars 388

Draw 2D toolbar 21
Draw Freehand tool 73
Draw Orthogonal tool 48

Draw Point command (point) 68
drawing entities

3-dimensional faces 337
arcs 63
boxes 340–341
circles 86
cylinders 343
dishes 345
domes 345
donuts 87
edge-defined Coons surface patch meshes 350
ellipses 66
elliptical arcs 67
extruded surface meshes 348
freehand sketching 73
hatching entities 94
lines 60
planes 89
point entities 68
polyface meshes 339
polygons 80
polylines 81
pyramids 342–343
rays 70
rectangles 78
rectangular meshes 338
revolved surface meshes 348
ruled surface meshes 347
shading 440
spheres 344
splines 84
squares 78
tori 346
wedges 341

Drawing Exchange Format files 299, 364–365, 435
Drawing Settings command or tool (settings)

Blips display 116
coordinate display in status bar 120
drawing limits 41–43
drawing units 36–38
elevation and thickness settings 335
entity color settings 33
entity snap target box 49
freehand sketch settings 73
grid rotation 46
grid settings 43–47
grip display options 198
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highlighting entities 194
highlighting settings 115
isometric snap and grid 47
linetype scale settings 35–36
linetype settings 34
mesh surface settings 347, 348
orthogonal setting 48
point entity display 68
Quick Text feature 114
snap angle settings 46
snap spacing settings 44
text height settings 40

Drawing Settings dialog box - 3D Settings tab
elevation and thickness settings 335
mesh surface settings 348

Drawing Settings dialog box - Coordinate Input tab
drawing limits 41
entity snap settings 50
entity snap target box 50
grid rotation 46
grid settings 43
isometric snap and grid 47
mesh surface settings 347
orthogonal setting 48
snap angle settings 46
snap spacing settings 44

Drawing Settings dialog box - Display tab
coordinate display in status bar 120
grip display options 198
highlighting entities 194
highlighting settings 115
Marker Blips display 116
Quick Text feature 115

Drawing Settings dialog box - Drawing Units tab 36
Drawing Settings dialog box - Entity Creation tab

entity color settings 33
freehand sketch settings 74
linetype scale settings 35
linetype settings 35
point entity display 68
text height settings 40–41

Drawing Settings dialog box - Entity Modification tab 
232–234

Drawing Status command (status) 189
drawing units

angular units 37–38
linear units 36

real-world units and 36
relationship to printed units 318
rounding in dimension display 278
scale factors and 38
text height and 40

drawings
See also 2-dimensional drawings; 3-dimensional 

drawings
3-dimensional and isometric drawings compared 47
annotations, borders, and title blocks 310
blocks 171, 174, 290–294
color settings 33
copying entities to other drawings 108, 204
copying settings to other drawings 136
creating new drawings 19, 30
default template 372
displaying entire drawings 107
displaying information about 188–191
drawing limits 39, 41, 107, 189, 435
drawing units 36
embedding or linking into other applications 361–

364
exporting 364
extents 70, 102, 107, 435
external references 10, 167, 172, 301, 435
grid settings 43–44
isometric snap and grid 47
layer settings 32
linetype settings 34
master and component drawings 301
moving around in 102
multiple drawings 3, 108
opening 30
orthogonal setting 48
preparing layouts for printing 314
printing 317
redrawing and regenerating 102
reusability 4, 8, 10, 136
saving 28
scale factors 38–40
search path for files 372
sending through e-mail 365
snap settings 49–51
tracking time spent on drawings 190
views 104
writing sketches into drawings 73

drivers for plotters 328
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dtext command
adding text to drawings 240
setting text style 244
specifying alignment 247

duplicating entities 202
DWG files

exporting IntelliCAD files as 364–365
IntelliCAD compatibility with 2

DXF files 299, 435
DXX files 299
dynamic

panning 104
zooming 105

Dynamic View Control
command or tool (viewctl) 331
dialog box 331

dynamically rotating viewpoints in 3-dimensional draw-
ings 331

E
edgesurf command 350
Edit Block Attributes

command or tool (ddatte) 298
dialog box 298

Edit Dimension Text command or tool (dimedit) 268
Edit Length command or tool (editlen) 219
Edit Polyline command or tool (editpline)

curving and decurving 227
joining 228
moving polyline vertices 229
opening and closing 226
tapering polyline segments 230
width and tapering 228

Edit Text command or tool (ddedit)
changing text properties 248
editing attribute definitions 297
editing text 248, 251

editing
linked or embedded objects 360
polylines 225–231
settings, single-click (IntelliCAD Explorer) 156

editing drawings
blocks 170
embedded IntelliCAD objects in other applications 

362
in model space with floating viewports 312, 315
IntelliCAD compared to manual drafting 11

keyboard shortcuts 398
layers 137, 138, 141, 142, 145
linetypes 147, 149, 151
linking objects to drawings 359
text styles 157–160, 243
user coordinate systems 162–164
views 165

editing entities
3-dimensional entities 351–354
arraying 207, 352, 353
attribute definitions 297
breaking and joining 220–221, 227
chamfering and filleting 232
changing properties 200
copying and pasting to other drawings 202
curving and decurving 226
cutting to Clipboard 204
deleting 202
dividing 182
editing length 218
elevation and thickness settings 336
exploding into components 231, 294
extending to boundaries 214
grouping 222–225
in model space with floating viewports 312, 315
measuring 180
mirroring 207, 354
moving 209
moving polyline vertices 229
parallel entities 206
polylines 225
rotating 210, 351
scaling 213
selecting before editing 194–198
stretching 212
tapering polyline segments 228, 230
trimming 217
vertices 229–231
width of polylines 228
with grips 199

editing text
alignment settings 246
changing text properties 248
editing attribute definitions 297
formatting 248, 251
moving dimension text 267
replacing dimension text with new text 268



I N D E X    457
restoring dimension text to home position 268
rotating dimension text 267
text style settings 243

editlen command 219
editpline command

curving and decurving 227
joining 228
moving polyline vertices 229
opening and closing 226
tapering polyline segments 228, 230
width 228

elapsed-time timer 190
electronically mailing files 365
elements pane in IntelliCAD Explorer 135
Elevation command or tool (elev) 334
elevation in 3-dimensional entities 333, 337

defined 435
entering coordinates 129
setting default elevation 334

Ellipse Axis-Axis tool 66
Ellipse command (ellipse) 66
ellipses

drawing methods 66
moving with grips 210

Elliptical Arc Axis-Axis tool 67
Elliptical Arc command (ellipse) 67
e-mailing files 365
embedding

See also ActiveX; linking
defined 435
editing embedded objects 361, 362
IntelliCAD objects into other applications 361
objects into IntelliCAD drawings 357–360

EMF files
defined 435
exporting IntelliCAD files as 364
snapshot files 356

enabling features. See turning features on or off
end arrows 270
ending

commands 24
points for moving entities. See displacement points
script recording 404

Endpoint Snap command (endpoint) 51
endpoints of entities

defined 435
line entities 60

methods of drawing arcs 63, 82
snapping to 49, 51

engineering drawing
scale ratios 38
units 37

Enhanced Metafiles. See EMF files
enlarging or reducing view of drawings 104
entities

See also types of entities (lines; rays; arcs; and so on) 
435

3-dimensional entities 333–350
area and perimeter 183
arraying copies of entities 207, 352–354
attributes 294–301
blocks 167, 170, 288–294
breaking and joining 220, 227
chamfering and filleting 232
color settings 33, 145
complex entities 77
copying or duplicating 202
defined 435
deleting 202
displaying information about 188
editing in viewports 312, 316, 317
elevation and thickness 333
embedding into other applications 361
grips 198–200
linetypes 147
measuring and marking off intervals 180
moving and rotating 209–212, 351
on deleted layers 137
polylines 225
properties 200
resizing 212–219
selecting 143, 194, 256, 257
simple entities 83
text as 241
viewing in 3D drawings 330–333

Entity Data defined 435
Entity Properties dialog box

changing entity properties 200
editing attribute definitions 297
elevation and thickness settings 335
overriding layer color 146
overriding layer linetype 147

entity selection methods 194–198
entity snap
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See also entity snap tools
angle and base point 46
aperture 49
controlling separately in multiple views 108
current settings 50, 189
defined 435
definition point locations 256
finding point coordinates with 121, 187
isometric snap and grid 47
Nearest snap tool 51
one-time entity snaps 49
origin 46
override 435
overview 7
positioning ordinate points 263
running entity snaps 49
snap resolution defined 441
spacing 44
status bar information 23, 50
target box 49–50
turning off settings 57

entity snap tools
Center Snap 50, 52
Clear Entity Snaps 50, 57
Endpoint Snap 50, 51
fly-over snapping 57, 377
illustrated 50
Insertion Point Snap 50, 54
Intersection Snap 50, 55
Midpoint Snap 50, 52
Nearest Snap 50
overview 49
Perpendicular Snap 50, 53
Plan View Intersection Snap 50, 56
Point Snap 50, 55
Quadrant Snap 50, 54
Quick Snap 56
Tangent Snap 50, 53

entprop command
changing entity properties 200
setting elevation and thickness 335

erase command. See Delete command or tool (delete)
erasing

eraser tool 74
freehand sketches 74
segments of polylines 82

ESNAP setting in status bar 50

Esnap. See entity snap
exiting IntelliCAD 28
expanding or compressing text 243
expblocks command

creating and saving blocks 170
inserting blocks 171
inserting drawings as blocks 171
inserting external references 172
listing blocks 168
saving blocks as separate drawings 174

experience level 370
experience levels

changing level 3, 18, 25, 370
choosing during installation 3, 18, 25
setting for menus or commands 370, 383
setting for toolbars 391

expfonts command
See also Explore Text Styles command or tool 441
creating new text styles 157, 243
current text style 160
editing text styles 159

explayers command
copying and pasting layers to other drawings 137
creating and naming layers 141
current layer settings 32, 142
deleting layers 138
displaying list of layers 139
hiding or freezing layers 143
layer color settings 146
layer linetype settings 147
locking and unlocking layers 145

Explode command or tool (explode)
converting donut sides to arc entities 88
converting plane sides to line entities 90
converting polygon sides to line entities 81
converting polyline segments to entities 83
converting rectangle sides to line entities 78
exploding blocks 294
exploding entities into components 231

exploded hatching 97
Explore Blocks command or tool (expblocks)

creating and saving blocks 170
inserting blocks 171
inserting drawings as blocks 172
inserting external references 172
listing blocks 169
saving blocks as separate drawings 174
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Explore Coordinate Systems command or tool (expucs) 
161

Explore Layers command or tool (explayers) 134
copying layers to other drawings 137
creating and naming layers 141
current layer settings 32, 142
deleting layers 138
displaying list of layers 140
hiding or freezing layers 143
layer color settings 146
layer linetype settings 147
locking and unlocking layers 145
opening IntelliCAD Explorer 134

Explore Linetypes command or tool (expltypes)
creating new linetypes 151, 152
current linetype 149
listing linetypes 148
renaming linetypes 155

Explore Text Styles command or tool (expstyles)
creating new styles 244
creating new text styles 158
current text style 160
editing text styles 159
listing text styles 157

Explore Views command or tool (expviews)
listing views 164
saving and naming views 165

expltypes command
creating new complex linetypes 152
creating new linetypes 151
current linetype 149
listing linetypes 148
loading additional linetypes 150
renaming linetypes 155

Export To File command or tool (export) 365
exporting drawings 364
expstyles command 156

See also Explore Text Styles command or tool
expucs command 161

See also Explore Coordinate Systems command or 
tool

expviews command 164, 165
See also Explore Views command or tool

Extend command or tool (extend)
extending to boundaries 214, 248, 251
extending to implied boundaries 215, 248, 251

extending

dimensions 274
entities to meet boundaries 214

extension lines
adding dimensions by selecting origins 256, 257
adding dimensions by specifying lines 256
arrows and arrowheads 270
defined 255, 435
formatting 274
obliquing 266

extents
See also limits
defined 435
displaying entire drawings 107
rays and 70
scroll bar indicators 102

External Reference command or tool (xref)
clipping 305

External Reference command or tool (xref) 301, 302
See also blocks
attaching files to drawings 172
attaching or detaching external references 302
binding external references 304
changing file paths 304
defined 167, 435
inserting drawings as 172
inserting external references as blocks 304
nesting 301
overlaying 303
overview 301
reloading or updating 303
reusing entire blocks and drawings 10

Extract Attributes command or tool (ddattext) 300
extracting attribute data 294, 299–301
Extruded Surface command or tool (tabsurf) 348
extruded surface meshes 347
extruding 3-dimensional entities 333–336, 436

F
Face command or tool (face) 337
faces 337, 436
feature control frames 280
fence

defined 436
extending entities with 216
illustrated 197
trimming or clipping entities with 218

Fence selection method 195
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fields in extracted attribute files 299
file formats of IntelliCAD and AutoCAD files 2
file paths for external references 304
file size

blocks and 288
external references and 301
linked and embedded objects and 359, 363

files
aliases 400, 402
basing on templates 30
embedding into drawings 358
embedding into other applications 361, 363
exiting 28
exporting 364
external references 172, 301
extracted attribute data 294, 299
fonts 157
inserting as blocks 290
keyboard shortcuts 399
linking drawings into other applications 363
menus 384
opening 30
previewing before printing 318
printing drawings 319
saving 28
saving blocks as drawings 289
scripts 403
search paths 372
sending through e-mail 365

Fill command or tool (fill)
filled or outlined lines on entities 78, 81, 83, 88
turning fill display on or off 113

Fillet command or tool (fillet) 235
filleting

defined 232, 436
methods 235

filling entities
displaying current settings 189
donut lines 88
hatching 94
planes 89
polygon lines 81
polyline lines 83
rectangle lines 78
turning off display to improve performance 113

finding point coordinates 121
Fit Tolerance values for splines 85

fitting
text and arrowheads on dimensions 272
viewports to screen 314

fixed
attribute values 294
coordinate systems 119

flatness tolerance symbols 280
flipping entities (creating mirror images) 207, 354
floating toolbars and command bar 19, 24, 436
floating viewports

copying or changing size 315
creating 314
defined 311
disappearing in model space 313
editing in model space 316, 317
invisible borders on 314
model space with 312
paper space views 311
saving configuration 315
scale factor 316

flyouts on tools 25, 390–391
font map

setting the default file 372
fonts 156

AutoCAD fonts 157
defined 157
font files 243
in paragraphs 241
in text styles 244
search path for files 372

footers on printouts 318
forcing text to fit 246, 272
form tolerance symbols 280–281
formatting lines in dimensions 274
formatting text

dimension text 276–278
text styles 243, 244

fractional drawing units 36
Freehand command (freehand) 73
freehand sketches

drawing and inserting 73
erasing 74
setting as polylines or lines 74

Freeze/Thaw tool (IntelliCAD Explorer) 141, 144
freezing layers 139, 141, 144, 436
full-size drawings 38
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G
gaps in linetypes 151
Geometric Tolerance dialog box 282
geometric tolerances 280
geometry, overlaying reference geometry 303
global linetype scale 36
greeking text (Quick Text feature) 114
grid settings

changing settings 43
controlling separately in multiple views 108
displaying current settings 189
grid defined 436
GRID setting in status bar 43
isometric snap and grid 44, 47
rotating grid 44, 46

grips
color and size 198
editing entities with 199
moving entities with 210
resizing dimensions with 266
resizing entities with 212
scaling entities with 213–214
selecting entities with 198
stretching entities with 212
turning on or off 198

grouped entities. See blocks
grouping entities 222–225

H
hand cursor (Pan tool) 103
hand method to determine coordinates 125
handles (entity grips). See grips
hardware requirements for IntelliCAD 18
hatch boundaries 94
Hatch command or tool (hatch) 94
hatch patterns and hatching

adding to entities 94
IntelliCAD compatibility with AutoCAD files 2
search path for files 372

headers and footers on printouts 318
height of named views 164
height of text. See text height
Help

assistance for IntelliCAD 14
displaying online Help 28
search path for files 372

hidden

attributes 294
edges on 3-dimensional polyface meshes 339

hidden-line removal, defined 436
hiding

command bar 22
layers 143
Prompt History window 26
reference grid 43
toolbars 21
ToolTips 21

highlight command 115
highlighting entities

turning highlighting on or off 194
when selected 115

horizontal
grid spacing 43–44
text orientation 243

horizontal dimensions
creating 256
defined 436
illustrated 254

horizontal drawing method
infinite lines 71
rays 70

hyperlink command 366
hyphens 112, 315

I
ica files (IntelliCAD aliases) 402
icad.dwg template 19, 30
icad.fnt font 243
icad.lin file 150
icad.pat library file 94
icadload.dfs files 406
icm files (IntelliCAD menu files) 379, 384
icons

coordinate system 119
display options for tool icons 389
displaying embedded files as 358
large tools 390, 392

ID Coordinates command or tool (idpoint) 121
idpoint command 121
Images tool (Block toolbar) 168
implied boundaries

extending entities to 215
trimming or clipping entities with 217

improving performance
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hatch pattern memory requirements 97
memory-intensive display elements 113

included angles in arcs 63, 64, 83
Infinite Line command or tool (infline) 71
infinite lines

defined 436
drawing 71
filleting entities 237

infline command 71
Inquiry toolbar tools

coordinates 121
distances 187
drawing status 189
listing entity info 188
time variables 191

Insert Block dialog box 172, 291–293
Insert External file Blocks tool (Block toolbar) 168, 172
Insert Object dialog box 358, 360
Insert tool (Block toolbar) 168, 172
inserting

blocks 290
hatch patterns 94
menu items 381
menu sub-items 382
objects 358, 360
text 240
tolerances 282

inserting dimensions
aligned 258
angular 261
baseline 259
continued 260
diameter 262
horizontal or vertical 257
leaders on 265
obliqued 266
ordinate 263
radius 263

inserting drawings into other drawings. See External Ref-
erence command or tool (xref)

insertion command 54
Insertion Point Snap command (insertion) 54
insertion points

attachment points 241, 248, 251
base points for drawings 189
for blocks 170, 171, 288, 291–293
for external references 172, 302, 303

for text 240, 241, 244, 248, 251
in attribute definitions 295, 296, 297
in extracted attribute file fields 299
snapping to 54

insertobj command 358, 360
installing IntelliCAD 18
IntelliCAD Explorer

Blocks list 167–174
Coordinate Systems element 131, 160–164
copying elements to other drawings 136
deleting elements 137
Dimension Styles 174–177
Layers element 139
overview 134–136
purge tool 139
single-click editing 156
Styles element (text styles) 156–160
tools 136
Views element 164–167

IntelliCAD Explorer command or tool (explayers) 134
intermediate experience level

changing 3, 18, 25, 383
choosing during installation 3, 18, 25

Internet publishing 367
intersection command 55
intersection of 3-dimensional entities

defined 436
snapping to 55

Intersection Snap command (intersection) 55
intersections of 3-dimensional entities

defined 436
intervals on entities, marking off 180
invisible data. See attributes
invisible edges

on 3-dimensional faces 337
on 3-dimensional polyface meshes 339

invisible layers 139, 140, 143
isometric drawings

defined 436
enabling snap and grid settings 44

isometric planes
defined 436
illustrated 47
setting current plane 44

J
join command or tool (join) 221
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joining
entities 221, 227, 232
two views 112

justification
attribute text 296
dimension line text 277
text settings 249

K
keyboard shortcuts

adding or deleting 398
customizing 397

L
Last Entity In Drawing selection method 194
latitude lines

dishes 345
domes 345
spheres 344

Layer On/Off tool (IntelliCAD Explorer) 141
layers

blocks with entities from different layers 288
BYLAYER property 33–34
changing for text entities 248, 251
colors and linetypes 33–35, 140, 145–148
copying to other drawings 136–137
creating and naming 141, 142
current layer settings 32, 142, 189
defined 437
deleting in IntelliCAD Explorer 137
displaying layer information 188
freezing and thawing 140, 144
hidden and visible 139, 140, 143
in entity properties 200
in external reference files 301
Layer toolbar in IntelliCAD Explorer 140
Layers dialog box 146, 147
Layers element in IntelliCAD Explorer 137, 139
locking and unlocking 140, 145
overview 6–7, 139–175
printing and nonprinting 139, 143
renaming 142
selecting entities by layer 195
status bar information 23
transparent overlays 6

layouts 317
Leader command or tool (dimleader) 265

leaders in dimensions
allowing text without leader 273
creating 265
defined 255, 437

leading zeros in dimensions 279
least material condition (LMC) 281
left-aligned text 246
length of lines

in freehand sketches 73
specifying before drawing 60

lengthening or shortening entities. See resizing entities
levels of entities in arrays 352
levels of precision. See accuracy
libraries

of hatch patterns 94
of linetype 148, 150

limits
See also extents
defined 437
displaying entire drawings 107
displaying limits for drawings 189
setting 39, 41

limits tolerance. See tolerances
lin files (linetype libraries) 150
Line command or tool (line) 60
Linear command or tool (dimlinear) 257
linear dimensions

aligned 258
baseline 259
continued 260
creating 256
formatting dimension unit display 279
illustrated 254
rounding in 278

linear drawing units 36–37
lines

adding to arcs 60
colors in dimensions 274
converting complex entity sides to 78, 81, 83, 90
dimensioning angles between lines 262
drawing lines 60
extending to boundaries 214
filled or outlined on complex entities 78, 81, 83
formats in dimensions 274
freehand sketches as 74
in hatching 94, 124
in polylines 81
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infinite lines 71
joining 221, 227
measuring and marking off intervals 180
moving with grips 210
of text See text entities
profile tolerance symbols 280
width 79

linetype scale
changing global 36
setting current 35

linetypes
changing in entity properties 200
compatibility with AutoCAD files 2
copying to other drawings 136
creating new linetypes 151
current settings 34, 189
default linetypes 141
defined 437
deleting in IntelliCAD Explorer 137
displaying information about entities 188
drawing scale factor and 38
global scale settings 36
in external reference files 301
layer settings 139, 147
library files 150
linetype scale settings 35
loading additional linetypes 150
overriding for entities 147, 149
overview 148–149
status bar information 23

Linetypes element (IntelliCAD Explorer) 150, 151
linking

See also ActiveX; embedding
defined 437
drawings into other applications 363
editing linked objects 360
external reference files 301–305
objects into drawings 359–360

LISP programs
calculating coordinates in rectangular meshes 338
defined 437
IntelliCAD compatibility 4
running programs 406–407

List Entity Info command or tool (list) 188
List Processing Language. See LISP Programs
listing

blocks and external references 168

fonts and text styles 156, 175, 245
hatch patterns 95, 96
layers 140
linetypes 148
named views 164
user coordinate systems 161

LMC (least material condition) 281
Load Application Files dialog box 406
load command 378
load command 406
Load LISP or SDS Application command (appload) 406, 

407
loading

additional linetypes 150
alias files 403
keyboard shortcut files 400
LISP programs 406
menu files 374, 384

location tolerance symbols 280
locations in drawings

absolute and relative coordinates 122, 126
coordinate systems 118
displaying entity coordinates 188
finding point coordinates 121
moving and rotating entities 210–212
obtaining precise point locations 187

Lock/Unlock command tool (IntelliCAD Explorer) 145
locking layers 140, 145, 437
log file

setting the default file 372

M
M or N direction

defined 437, 438
in rectangular meshes 338
in surface meshes 347, 348, 350

macros 408, 437
See also scripts

magnification of drawings
See also scale factors
magnifying views 5
methods 104
zooming and panning in 3-dimensional drawings 

332
magnifying glass cursor 104
major axes 437
Make Oblique command or tool (dimedit) 266
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Make Snapshot command or tool (msnapshot) 356
manual drafting compared to IntelliCAD 4
MAPI protocol 365
margins on drawings. See extents; limits
marker blips. See blips
marker blocks 180
marking off interval on entities 180
master drawings from component drawings 301
material condition symbols 281
maximum material condition (MMC) 281
MDI (multiple-document interface) 3, 108, 437
Measure command or tool (measure) 180, 181
measurement lines. See dimensions and dimension styles
measuring and marking entities 180
memory requirements

for IntelliCAD 18
hatch pattern requirements 97
memory-intensive display elements 113

menu files
customizing menus 378–??, 379–387
IntelliCAD compatibility with AutoCAD files 2
loading 384
saving 384

Menu Item command 381
Menu Sub-Item command 382
menus

adding commands 382
automatically loading 374
changing experience levels 3, 18, 25, 370, 383
creating new menus 381
customizing 379
deleting commands from 383
menu bar illustrated 21
renaming commands 382
search path for files 372
starting commands with 25

Mesh command or tool (mesh) 338
mesh surfaces. See surface meshes
Messaging Application Program Interface (MAPI) 365
Microsoft Visual Basic for Applications 4
middle-aligned text 246
Midpoint Snap command (midpoint) 52
midpoints of entities 49, 52
minor axes 437
mirror command or tool (mirror) 207
mirror3D command 354
mirroring entities 207, 354, 437

mistakes, correcting 27
MMC (maximum material condition) 281
mns files (AutoCAD menu files) 379, 384, 393
mnu files (AutoCAD menu files) 379, 384, 393
MODEL indicator in status bar 312
model space

See also paper space
defined 438
disappearing viewports in 313
displaying current space mode 188
editing entities in floating viewports 312, 316, 317
overview 8, 310
status bar information 23
switching to 312, 313
switching to paper space 312
viewport scale factor 316
with floating viewports 310, 316, 317
with tiled viewports 313

Modify toolbar 21
modifying. See editing
Move command or tool (move) 209
moving

around in drawings 102
external reference files 304
prompt boxes 23
toolbars and command bar 19

moving entities
dimension text 267
move command 209–210
to other drawings 108
to other layers before layer deletion 138
vertices in polylines 229
with grips 199

msnapshot command 356
mtext command 241, 251
MText dialog box 241
multiple commands

nesting several commands 26
repeating commands 26
using while commands are active 25

multiple copies
of entities 204
of external references 301

multiple drawings 3, 108
multiple views

See views and viewports
multiple-document interface (MDI) 3, 108, 438
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mview command
creating floating viewports 314

N
N direction. See M or N direction
N symbol in extracted attribute file fields 299
named text styles 243

See also text styles
named views 164, 315, 438

See also views and viewports
Nearest Snap command (nearest) 51
negative coordinate locations 118
nested

blocks 288, 438
commands 26
external reference files 301

nested blocks
See also blocks

New command (newwiz) 30
new drawings 30
new features 14
New Item tool 131, 136
newwiz command 30
node command 55
nonassociative hatches 438
none command 57

See also Clear Entity Snaps command or tool
numbers, rounding 278–280
numeric fields in extracted attribute file fields 299

O
Object command (insertobj) 358, 360
object linking and embedding. See Active X
oblique angle

in dimension lines 266
in text styles 157, 159, 243, 248, 251

offset copies of entities. See parallel entities
offsetting

baseline dimensions 259
text on dimension lines 277

OLE. See Active X
On/Off tool (IntelliCAD Explorer) 141, 143
online Help 14, 28
onweb command 367
oops command 289
Open command or tool (open) 30
Open Drawing dialog box 31

opening
existing drawings 30
files sent through e-mail 365
IntelliCAD 19
polylines 226

Options command (config) 371, 372, 373, 375, 376, 377
Options dialog box 371
options, setting or changing 370
Ordinate command or tool (dimordinate) 264
ordinate dimensions

creating 264
defined 438
illustrated 254

organizing information
on layers 6, 139
with blocks 288

orientation
of page 328
of text 156
of view 108, 111
tolerance symbols 280–286

origin points
adding dimensions by selecting origins 256, 257
compared to viewpoints in 3-dimensional drawings 

330–333
defined 438
displaying distances in ordinate dimensions 264
of coordinate systems 130, 161
of extension lines 256
of print areas 318
of snap and grid 46
specifying locations by 123

ORTHO setting in status bar 48
orthogonal mode

defined 438
displaying current settings 189
overview 7
status bar information 23
turning on 44, 48

orthogonal projection 438
osnap command. See entity snap
outlined elements in IntelliCAD Explorer 135
outlining

donut lines 88
planes 90
polygon lines 81
polyline lines 83
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rectangle lines 78
turning off fill display to improve performance 114
wire-frame models 333

output files of extracted attribute data 300
Outside Circle selection method 195, 438
Outside Polygon selection method 195, 438
Outside Window selection method 194, 438
overlaying external references 303
overlays. See layers
overscoring text 247

P
Pan command or tool (pan) 103
panning

See also zooming in or out
defined 438
in 3-dimensional drawings 332
in viewports 312
viewing drawings by 5

panning methods 103
PAPER indicator in status bar 312
paper space

See also model space
copying or resizing viewports. See model space
defined 438
displaying current space mode 188
editing method 312
floating viewports 314
overview 8, 310
printing from 311
saving viewport configuration 315
status bar information 23
switching to 312
switching to model space 312, 313

Paper Space Views command or tool (mview) 314
paragraph text

aligning 247
creating 241

parallel
dimensions. See baseline dimensions
drawing method, infinite lines and rays 70

Parallel command or tool (parallel) 206
parallel entities

defined 439
filleting parallel lines 237
parallel copies of entities 205

parallelism tolerance symbols 280

partial coordinates 128
Paste command or tool

IntelliCAD Explorer 136
pasteclip command 205

Paste command or tool (IntelliCAD Explorer) 136
Paste Special command and dialog box 360
pasting

embedded objects into drawings 358
entities into other drawings 108, 205
layers into other drawings 137
linked objects into drawings 360
settings into other drawings 136
text 241

patch meshes 350
paths

external reference files 304
paths for files 372
patterned

lines. See linetypes
pencil tool 73
percent signs 247
performance issues. See improving performance
perimeters 439

calculating areas 183
perpendicular distances from origin points 263
perpendicular entities

defined 439
infinite lines 71
rays 70
snapping to 49, 53

Perpendicular Snap command (perpendicular) 53
perpendicularity tolerance symbols 280
pface command 339
pgp files (AutoCAD aliases) 402
plan view

coordinate system icons 119
defined 439
displaying 3-dimensional drawings 332
snapping to intersecting entities 56

Plan View command or tool (plan) 332
Plan View Intersection Snap command (planviewint) 56
planar entities

converting to 3D 334
defined 439

planar tops for pyramids 343
Plane command or tool (plane) 89
planes



468   I N D E X
3-dimensional faces 337
converting sides to lines 90
defined 439
drawing 89
isometric planes 47

planviewint command 56
playing scripts 403–405
pline command. See Polyline command or tool (polyline) 

439
plotter drivers 328
plotting drawings

paper size and orientation 317
paper space 8
plotter drivers 328
preparing layouts for printing 314
previewing drawings before printing 318
printing and nonprinting layers 139, 143
printing drawings 317
scale factors 38, 318

plus or minus signs 247
pmspace command 312, 313, 317
point command 68
point filters (coordinate filters) 128, 433
Point Selection method 195
Point Snap command (node) 55
Point tool 68
points

See also base points; displacement points; endpoints 
of entities; insertion points; midpoints of entities; 
origin points; start points of entities

changing point entity appearance 68
defined 439
drawing point entities 68
finding point coordinates 121
interval marker point entities 180
parallel copies passing through points 206
point locations in coordinate systems 118
snapping to point entities 55

polar
arrays of entities 208, 352–354, 439
coordinates 121, 124

See also coordinate systems 124
Polyface Mesh command or tool (pface) 339
polyface meshes 339
Polygon command (polygon) 80
polygon meshes

edge-defined Coons surface patch meshes 350
extruded surface meshes 347
revolved surface meshes 348
ruled surface meshes 347

Polygon, Center-Side tool 81
Polygon, Center-Vertex tool 80
polygons

See also polygon meshes 439
calculating area and perimeter 183
converting sides to lines 81
defined 439
drawing 80
editing 225
using as selection windows 197

Polyline command or tool (polyline) 81
polylines

chamfering 234
converting entities to polylines 225
converting segments to entities 83
curving and decurving 226
defined 439
donuts 87
drawing 81
editing 225
editing vertices 229
extending to boundaries 214
filleting entities 235
freehand sketches as 73
joining 227
measuring and marking off intervals 180
opening and closing 82, 226
polygons 80
rectangles 78
tapering 81, 216
width 81, 228

position tolerance symbols 280
positioning

drawings on paper 318
text on dimension lines 276

positioning dimensions
aligned dimensions 258
angular dimensions 261
baseline dimensions 259
diameter dimensions 262
dimension text 267
horizontal or vertical dimensions 257
leaders and annotations 265
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radius dimensions 263
text and arrowhead positioning 272

positioning entities 209
See also insertion points
blocks 290
moving entities 199

positive coordinate locations 118
ppreview command 318
precision. See accuracy
preferences command. See config command
prefixes on dimension text 277
preparing layouts for printing 319
presentations 356
Preset Viewpoints

command or tool (setvpoint) 330
dialog box 331

previewing
block images 168
files before opening 31
print jobs 318

Previous Selection selection method 194
print area 317
Print command or tool (print) 319
print dialog boxes 319
Print Preview command or tool (ppreview) 318
printed units 318
printing only to drawing limits 322
printing. See plotting drawings
profile tolerance symbols 280
profiles for revolved surface meshes 348–350
programming IntelliCAD 405–408
projected tolerances 281–286
projection lines. See extension lines
prompt boxes

choosing command options 23
defined 439
turning off 24, 374

Prompt History window
defined 439
displaying drawing information 188
tracking history 26, 374

prompts in status bar 295
Properties command or tool (entprop)

changing entity properties 200
IntelliCAD Explorer 136, 146, 147, 159
setting elevation and thickness 336

publishing drawings to the Internet 367

pull-down menus 381
purge tool 139
Pyramid command or tool (pyramid) 342, 343
pyramids

drawing 342–343
editing 225

Q
qtext command 114
quadrant points of entities 54, 439
Quadrant Snap command (quadrant) 54
quadrilateral filled planes 89
quick command 56
Quick Snap command (quick) 56
Quick Text feature 114
quitting IntelliCAD 28

R
radial dimensions 254, 255
radians 439
radii of entities

arc 63
arcs 83
circles 61
cylinders 343
defined 439
dishes 345
domes 345
filleting entities 232, 235
spheres 344
tori 346

Radius command or tool (dimradius) 263
radius dimensions 263, 439
Radius-Tangent-Tangent circle method 61
RAM requirements. See memory requirements
Ray command or tool (ray) 70
ray tracing

defined 439
rays

defined 439
drawing 70
extending to boundaries 214
filleting 237

read-only files 31
Record Script command or tool (recscript) 404, 405
recording scripts 26, 403
Rectangle command or tool (rectangle) 78
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rectangles
converting sides to lines 78
defined 440
drawing 78
editing 225
squares 78

rectangular
arrays of entities 208, 352, 440
boxes 340–341
filled planes 89

Redo tool 27
redoing actions 27, 440

See also undoing actions
redrawing screen 102, 440

See also regenerating drawings 102
reducing or enlarging view of drawings 104
reference

angles for rotation 351
geometry 303
grid. See grid settings

Reference Grid tool 43
refreshing screen 102
regardless of feature size (RFS) condition 281
Regen command or tool (regen) 102, 114
regenall command 102
regenerating drawings

See also redrawing screen 440
after editing text styles 158
after enabling Quick Text 114
compared to redrawing 102
defined 440

relative coordinates
See also absolute coordinates; user coordinate sys-

tems (UCS); World Coordinate System (WCS) 
440

3-dimensional coordinate systems 125
defined 440
point filters 128
polar coordinates 124
spherical and cylindrical coordinates 126

relinking external reference files 304
reloading

external reference drawings 172, 301, 303
removing. See deleting
Rename Command (IntelliCAD Explorer) 142
renaming

attribute definitions 297

blocks 170
commands in menus 379, 382
dimension styles 269
layers 142
linetypes 155
toolbars 390

repeating commands 26
replacing dimension text with new text 268
Reposition Dimension Text command or tool (dimedit) 

267
resetting timer 190
resizing

toolbars 21
viewports 315

resizing entities
arrowheads 271
changing length 218
extending to boundaries 214
scaling 213
stretching 212–213
trimming or clipping 217

Restore Text Position command or tool (dimedit) 268
restoring

aliases to unchanged condition 401
changed blocks to originals 293
deleted entities 202
dimension text to home position 268
menus to unchanged condition 379
named views 166–167
previous user coordinate system 132
previous view of drawing 106, 112
toolbars to unchanged condition 387

restricting. See constraining drawing
reusing information 4

copying settings into other drawings 136
IntelliCAD compared to manual drafting 8
reusing entire blocks and drawings 10

reversed text 159
Revolved Surface command or tool (revsurf) 349
revolved surface meshes 348, 440
RFS (regardless of feature size condition) 281
right-aligned text 247
right-click menus 21
right-hand rule to determine coordinates 125, 440
Rotate command or tool (rotate) 210
Rotate Dimension Text command or tool (dimedit) 267
rotate3D command 351
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rotating
3-dimensional entities 351
angles in attribute text 296
angles in elliptical arc drawing methods 67
blocks 170, 171, 290–293
coordinate systems 130
creating 3D arrays 353
dimension text 266–267
dimensions. See aligned dimensions
entities 210, 351, 440
external references 172, 302, 303
grid 46
paragraph text 241
text 240, 245, 248, 251
viewpoints in 3-dimensional drawings 331
visualizing rotation direction 125

rotation points
defined 440
specifying 210

rounding corners on entities. See filleting
rounding numbers in dimension display 278
roundness tolerance symbols 280
rows and columns of entities. See rectangular arrays of 

entities
rubber-band lines 440
Ruled Surface command or tool (rulesurf) 347
ruled surface meshes 347, 440
running

entity snaps 49, 440
IntelliCAD 19

runout tolerance symbols 280

S
Save Block dialog box 174
Save Block to Disk

command or tool (wblock) 289
tool (Block toolbar) 168

Save command or tool (save) 28
Save/Restore View command or tool (view) 165
saving

attributes 295
blocks 170
blocks as drawing files 289
blocks as separate drawing files 174
drawings 28
in other formats 364
named views 165–166

new complex linetypes 152–155
new linetypes 151–155
sketches as part of drawings 73
snapshots 356
tracking last save time 190
user coordinate system 119, 130, 131
viewport configuration 112

Scale command or tool (scale) 213
scale factors

blocks 170, 171, 290
drawing to scale 5
drawing units 36
external references 172, 302, 303
floating viewports 316
hatching 94
in dimensions 279
linetype scale 35
magnifying view by precise scale factor 106
printing to scale 318
scaling entities 213
understanding drawing scale factors 38

scaling. See resizing entities; scale factors
scientific drawing units 37
screen display

magnifying 5
redrawing and regenerating 102
turning off memory-intensive display elements 113

screenshots (snapshots) 356
Script Recorder 26
scripts defined 440
scroll bars 102
sdf files (Space Delineated Format) 299
SDS programs 4, 27, 440
search path for files 372
segmented dimension lines. See continued dimensions
segments

converting polyline segments into curves 226
defined 440
editing in polylines 81
measuring and marking off intervals on entities 180

Select All Entities selection method 194
Select Colors command 146
Select File to Attach dialog box 172
Select File to Overlay dialog box 303
Select Font dialog box 244
Select Layer by Entity command or tool (setlayer) 143
Select Toolbars dialog box 21–22
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selecting entities
adding or removing entities from sets 198
highlighting 115, 194
matching specific properties 195
selection methods 194
to copy or duplicate 203
to delete 202

selection
sets 194, 440
windows 194

semicolon 403
setdim command 175

arrows and arrowheads 270, 272, 276
baseline dimension offset 259
blocks and external references 134
creating dimension styles 269
deleting dimension styles 270
dimension line colors 274
formatting dimension text 276
renaming dimension styles 269
rounding off numbers 278
text positioning 273, 276

settings
arrows and arrowheads 270
blips display 116
blocks and external references 168, 169, 171, 174
colors 145
coordinate systems 134, 160
dimension styles 269
distances and angles display 120
elevation and thickness 333–337
entity snap 49
fills 113
grip display options 198
highlighting 194
layers 32, 136–147
linetypes 136
mesh surfaces 347
Quick Text display 114
setting layers by selecting entities 143
text styles 134, 156, 243
user coordinate systems 130
views 134, 164, 165

settings command
dimension styles 278
drawing limits 41
drawing units 37

elevation and thickness 334–336
entity color 33
entity snap target box 49
freehand sketches 74
grid settings 43, 46
highlighting 194
isometric snap and grid 47
linetype scale 35
linetypes 35
orthogonal mode 48
point entity display 68
snap angles 46
snap spacing 44
text height 40

Settings pane in IntelliCAD Explorer 134
setucs command 131, 132
setvpoint command 330
shading surfaces of 3-dimensional entities 440
shape command 378
shape files 378
shortcuts

adding access keys to commands 382
customizing keyboard shortcuts 397
displaying shortcut menus 21
entity snaps menu 50

shortening or lengthening entities. See resizing entities
shp files (fonts) 157
shx files (fonts) 157
sides of entities

editing polygons 81
editing polylines 83
editing rectangles 78
maximum number for polygons 80
specifying to draw polygons 81

simple entities 59
See also types of entities (lines; rays; arcs; and so on)

simulating
3-dimensional drawings 47
paper output on screen. See paper space

size
of files. See file size
of grips 198
of printed drawings 39–40
of text. See text height

size of entities
displaying size information 188
point entities 68
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resizing. See resizing entities
sketch command. See freehand command 73
sketching freehand entities 73
slanted

dimensions. See aligned dimensions
text. See obliquing angle

sld files (snapshots) 356
slide

files 356
shows 356

small tool icons 390, 392–393
snap

angle 440
grids 441
resolution 441
settings. See entity snap
tool 45

SNAP setting in status bar 45
snapshots

defined 441
saving 356

solid
filled planes 89
fills 113

See also shading surfaces
Solutions Development System (SDS) 4, 27, 406, 440
Space Delimited Format files 299
spacers

in menus 379
in toolbars 389

spacing
for entity snap 44
in reference grid 43

special characters 247
speed of processing. See improving performance
Sphere command or tool (sphere) 344
spheres, drawing 344
spherical coordinates 126, 441

See also coordinates
Spline command or tool (spline) 84
splines

closing entities 86
drawing 84
fit tolerance 85

splitting entities 220
squares 79

stacking entities in arrays 352
standard

dimension style 269
text style 156, 243

Standard toolbar 21
start arrows 270
start points of entities

line entities 60
methods of drawing arcs 63, 82

starting
direction of arcs 63
IntelliCAD 19
new drawings with templates 19, 30
points for moving entities. See base points
script recording 403

starting commands
from command bar 25
from menus 25
from toolbars 25

status bar
assistance with IntelliCAD functions 14
displaying cursor position 120
illustrated 21, 23
prompts for commands 379
prompts for tools 387
workspace indicators 312

status command 189
status of drawings, displaying 189
Stop Recording command or tool (stopscript) 404
straightening curves in polylines 226
straightness tolerance symbols 280
Stretch command or tool (stretch) 212
stretching

entities 199, 212
text 246

style command (IntelliCAD Explorer) 158
styles

dimension styles 269
text styles 243

Styles dialog box 244
Styles element in IntelliCAD Explorer 156
Sub-items in menus 379
subtended angles 261
Subtract From Set selection method 194
subtracting areas of combined entities 185–187
suffixes on dimension text 277
surface
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of revolution 441
profile tolerance symbols 280

surface meshes
density 347, 348, 349, 350
edge-defined Coons surface patch meshes 350
extruded mesh surfaces 347
polyface meshes 339
rectangular meshes 338
revolved surface meshes 348
ruled surface meshes 347

surface models
See also wire-frame models
defined 333

switching between model space and paper space 312
symbols

datum reference letters 282
material condition symbols 281, 282
special characters in text 247
symmetry tolerance 280
tolerance 280, 282

system requirements for IntelliCAD 18
system variables 441

T
tabsurf command 348
tabulated surfaces 441
Tangent Arc tool 65
tangent command 53
tangent entities 441

drawing arcs tangent to an arc or line 65
drawing circles tangent to entities 62
drawing donuts tangent to entities 88
snapping to 49, 53

tangent points on splines 84
Tangent Snap command (tangent) 53
tapered polylines 82, 230

after joining 227
changing width 228
results of extending 216

target box for entity snaps 49
tbconfig command 390
templates

basing new drawings on 30
default icad.dwg template 19
for extracted attribute files 299–301
opening new drawings with 19
setting default template 372

terrain models 338
tetrahedrons 342
text annotations 265
Text command or tool (dtext)

adding text entities 240
setting text style 244
specifying alignment 246

text entities
See also text height; text in attributes; text on dimen-

sion lines
adding text to drawings 240
alignment 246
attachment points 245, 248, 251
backward or upside-down text 243
changing properties 248
color 248, 251
compressing or expanding 246
control codes and special characters 247
editing text 248, 251
fitting between two points 246
insertion points 54, 240, 244
layer settings 248, 251
obliquing 243
paragraph text 241
Quick Text feature 114
rotation angle 240
short lines of text 240
text styles 243
turning off display to improve performance 115
width 243

text files
script files 403
templates for extracted attribute files 299

text height
calculating for different scale factors 39
changing height 159
drawing scale factor and 38
in dimension styles 277
printed drawings and 39
short lines of text 240
specifying 40, 245, 248, 251
text styles 243

text in attributes 296, 297
text on dimension lines

colors 277
formatting and positioning 272–274, 276
illustrated 254
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moving text 267
prefixes or suffixes 277
replacing with new text 268
restoring to home position 268
rotating 266
specifying text styles in dimension styles 277

text size. See text height
text styles

applying 245
attribute text 296
changing styles 248, 251
compatibility with AutoCAD files 2
copying to other drawings 136
creating new styles 157, 243
current text style 160
deleting in IntelliCAD Explorer 137
editing attribute definitions 297
editing styles 157
in external reference files 301
listing available styles 245
overview 156
vertical, upside-down, or backward text 157

text-based data. See attributes
thawing layers 140, 144, 441
Thickness command or tool (thickness) 333
thickness in 3-dimensional entities 441

See also elevation in 3-dimensional entities
changing in entity properties 200
default thickness 333

three-dimensional drawings. See 3-dimensional drawings
three-dimensional entities. See 3-dimensional entities
three-point

arc method 63
through points 206, 441
thumbnails of blocks 168
tick marks on dimension lines 270
tiers of dimensions. See baseline dimensions
Tile Horizontally command 110
tile mode information in status bar 312
Tile Vertically command 110
tiled viewports

defined 310
illustrated 310
model space with tiled viewports 312

tilemode command 314
tiling windows 110
tilting. See obliquing angle

time stamps on printouts 318
Time Variables command or tool (time) 191
timers

for AutoSave 370
tracking drawing sessions 190

Tip of the Day 19
title blocks

adding in paper space 310
as available in each view 8

toggling features on or off. See turning features on or off
Tolerance command or tool (tolerance) 282
tolerances

adding geometric tolerances to drawings 280
composite tolerances 281
datum reference letters 282–283
defined 441
in Geometric Tolerances dialog box 282
limits tolerance 441
material condition symbols 281–286
projected tolerances 281
symbols, defined 280
tolerance commands 441
variance tolerance 441

toolbars and tools
compared to manual drafting 5
creating new toolbars 388
customizing tools and toolbars 19, 388
defined 442
displaying and hiding toolbars 21
docking or floating toolbars 21
entity snaps tools 50
experience levels for toolbars 370, 391
flyouts 25, 390
illustrated 21
IntelliCAD Explorer tools 136
large tool icons 390, 392
Layer toolbar 140
naming new toolbars 390
size and color of tools 21
spacing in toolbars 389
starting commands from 25
toolbars command (tbconfig) 390
Toolbars tab (Custom dialog box) 387
triangles on tools 390

ToolTips
adding to tools 388
assistance with IntelliCAD tools 14
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turning on or off 21, 389
top-aligned text 246
tori 346, 442
total runout tolerance symbols 280
tracking

command history 26, 374
last files used 31
number of entities 167

trailing zeros in dimensions 279
transferring drawings to other people 304
transparent

commands 442
overlays. See layers

triangles on tools 390
triangular filled planes 89
Trim command or tool (trim) 217
trimming entities

chamfering 233
filleting 235

troubleshooting
disappearing viewports in model space 313
drawing disappears from paper space 312
setting viewport borders as invisible 314

turning features on or off
automatically loading menus 374
AutoSave 370
blips 116
entity snaps 57
extension line options 275
grips 198
highlighting 115, 194
orthogonal setting 48
prompt boxes 23, 374
reference grid 43
snap settings 45
solid fill display 113
text display 114
Tip of the Day 19
ToolTips 389

two-dimensional
drawings. See 2-dimensional drawings 121
entities. See 2-dimensional entities 121

two-point circle method 61
typing commands

aliases 400
entity snap commands 49
in command bar 25

to load custom programs 407

U
UCS. See user coordinate systems (UCS) 130
undelete command (undelete) 202, 289
underscore characters 112, 315
underscoring text 247
undoing actions 27

See also redoing actions
Unicode characters 252
uniform width for polylines 228
unique numbers for colors 33
units. See drawing units
unloading custom programs 406
unlocking layers 145, 442
updating

all instances of blocks 288, 293
attribute values 298
block definitions 293
drawings inserted as blocks 172
external references 173, 301, 303
file paths for external references 304

upside-down text 159, 243, 248
user coordinate systems (UCS)

See also coordinates, World Coordinate System 
(WCS)

command (IntelliCAD Explorer) 131, 162
command or tool (setucs) 130
current UCS 163
defined 119, 442
defining systems 130, 162
dialog box 130
icon 20
listing 160
plan views of drawings 332
preset user coordinate systems 131

user levels. See experience levels

V
validated attribute values 296
values

editing attribute values 298
extracting attribute values 299
variable attribute values 294

variables
dimension variables 269
system variables 441
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variance tolerance
See also tolerances

variations in geometry. See tolerances
VBA programs 4
vectors 442
vertical

drawing method (infinite lines) 71
drawing method (rays) 70
grid spacing 43
orientation for text 243
text orientation 159

vertical dimensions
creating 257–258
defined 442
illustrated 254

vertices
chamfering 234
defined 442
drawing polygons 80
editing polyline vertices 229
filleting 236–237

View command (IntelliCAD Explorer) 165
View Snapshot

command or tool (vsnapshot) 357
dialog box 357
snapshots 357

viewing
See also views and viewports; windows 442
3-dimensional drawings 330
command bar 22
dynamic view controls 331
locked layers 145
panning drawings 103
plan view 332
preset viewpoints 330
redrawing screen 102
regenerating drawings 102
thawed layers 144
ToolTips 21
turning layers on 143
viewpoints in 3-dimensional drawings 330
zooming 104

viewpoints in 3-dimensional drawings 442
Viewports command or tool (vports or viewports) 315
views and viewports

See also model space; paper space 442
arranging windows 110

changing properties 166
copying views to other drawings 136
deleting views in IntelliCAD Explorer 137
displaying entire drawings 107
editing entities in viewport 312, 316, 317
floating viewports 311, 312
height and width of views 164
invisible borders on viewports 314
joining two views 112
listing named views 164–165
model space with floating viewports 312
model space with tiled viewports 313, 317
moving around in viewports 102
multiple views 108
orientation of viewports 111
paperspace in viewports 314
printing views 319
restoring named views 166
restoring previous view of drawing 106
saving view configuration 112, 165, 315
scale factor 316
size of viewports 316, 317
switching between model and paper space 312
tiled viewports 310, 313, 317
viewport configuration defined 442
viewports defined 442
views defined 442
zooming and panning 312

views and viewports. See model space; paper space
Views list in IntelliCAD Explorer 164
visibility of layers 139, 140, 143
visible

attributes 294
grid. See grid settings

Visual Basic for Applications (VBA) 4, 408
visualizing coordinate systems 125
vmlout command 367
vports command 315

W
wblock command 289
WCS. See Word Coordinate System (WCS)
Wedge command or tool (wedge) 341
wedges 341, 442
what’s new 14
width

after exploding 231
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after joining 227
changing the polyline width 228
of donuts 87
of fields in extracted attribute files 299
of lines 79, 328
of polylines 81, 230
of printed lines 328

width of text
in text styles 157, 159, 243
specifying 248, 251

Window Circle selection method 195
Window Polygon selection method 195, 197
Window-Inside selection method 194, 196
Windows

metafiles. See WMF files
windows

See also views and viewports 442
arranging 110
cascading 110
displaying entire drawings 107
joining two views 112
listing and saving named views 164
main IntelliCAD window 21
model space and paper space defined 310
moving around in 102
multiple views 108
opening new windows 108
saving arrangements 112
selection windows 194
tiling 110
unique numbers 110

Windows Clipboard
See Clipboard
embedding objects into drawings 357
embedding objects into other applications 361, 365
linking drawings into other applications 363

wire-frame models
See also surface models
defined 333, 443

witness lines. See extension lines
WMF files

defined 443
exporting IntelliCAD files as 364
snapshots 356

Workspace
command or tool (pmspace) 312
dialog box 313

workspaces
See also model space; paper space; views and view-

ports
displaying current space mode 188
model space and paper space defined 310
overview 8
status bar information 312

World Coordinate System (WCS)
defined 443
overview 119
plan views of drawings 332
selecting 132
working with coordinate systems 160

World tool (IntelliCAD Explorer) 136
Write, Then Resume option (freehand command) 73
writing sketches into drawings 73

X
x-axis

color 376
in coordinate systems 118

xclip command 306
xclipframe command 307
Xlines 71

See also infinite lines
x-ordinate dimensions 263
xref command

See also External Reference command or tool (xref)
attaching external references 302
binding external path names 305
detaching external references 302
inserting external references as blocks 304
moving or changing the path name 304
overlaying external references 303
reloading or uploading external references 303

Xrefs
search path for files 372

xrefs
clipping 305

Y
y-axis

color 376
in coordinate systems 118

y-ordinate dimensions 263
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Z
z-axis

in coordinate systems 118
z-coordinates in elevation 333, 336
zero angle settings 37
Zoom All tool 107
Zoom Center tool 107
Zoom command (zoom) 104, 316
Zoom Extents tool 107
Zoom In command or tool (zoom) 104, 106
Zoom Left tool 107
Zoom Out tool 104
Zoom Previous tool 106
zooming in or out

changing viewport scale factor 316
defined 443
in 3-dimensional drawings 332
in print preview window 319
in viewports 312
overview 104
viewing drawings 5

zooming methods 104
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